1 apt (0.5.6) unstable; urgency=low
3 * Adam Heath <doogie@debian.org>
4 - Fix segfault when handling /etc/apt/preferences. Closes: #192409.
5 * Matt Zimmerman <mdz@debian.org>
6 - Clean up some string handling, patch from Peter Lundkvist
7 <p.lundkvist@telia.com> (Closes: #192225)
8 - Don't fall off the end of the buffer when comparing versions.
9 Patch from Koblinger Egmont <egmont@uhulinux.hu> (Closes: #194327)
10 - Minor fixes to apt-ftparchive(1) (Closes: #118156)
11 - Fix typo in apt-ftparchive help text (Closes: #119072)
12 - More typos in apt-ftparchive help text (Closes: #190936)
13 - Update config.guess, config.sub to latest versions
14 - Modify the description for apt-utils to reflect the fact that it is not
15 (any longer) infrequently used (Closes: #138045)
16 - Make setup script for dselect method more explicit about
17 overwriting sources.list (Closes: #151727)
18 - Fix typo in apt-cache(8) (Closes: #161243)
19 - Remove duplicate 'showpkg' from synopsis on apt-cache(8)
21 - Document in apt-get(8) the meaning of the '*' in ShowList, which is that
22 the package is being purged (Closes: #182369)
23 - Fix extra "/" character in apt.conf(5) (Closes: #185545)
24 - Fix typo in tar error message (Closes: #191424)
25 - Clarify description of 'search' on apt-cache(8) (Closes: #192216)
26 - Fix incorrect path for 'partial' directory on apt-get(8)
28 - Fixes to pt_BR translation from Andre Luis Lopes <andrelop@ig.com.br>
33 apt (0.5.5.1) unstable; urgency=low
35 * Move the target of the example docs from doc to binary. Closes:
37 * Fix api breakage that broke apt-ftparchive and apt-cache dumpavail, by
38 backing out change that incorretly attempted to handle Package sections
39 larger than 32k. Closes: #192373
40 * Fix never-ending loop with apt-get install -V. Closes: #192355.
42 -- Adam Heath <doogie@debian.org> Mon, 19 May 2003 12:30:16 -0500
44 apt (0.5.5) unstable; urgency=low
46 * New deb version compare function, that has no integer limits, and
47 supports pre-versions using ~. Code ported from dpkg.
48 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
49 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
50 * "apt-get --arch-only build-dep" to install only architecture-
51 dependent build dependencies. Bump minor shared lib number to reflect
52 small change in BuildDepend API.
53 * APT::Build-Essential configuration option (defaults to "build-essential")
54 so that "apt-get build-dep" will ensure build essential packages are
55 installed prior to installing other build-dependencies. Closes: #148879
56 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
57 * /usr/doc reference in postinst. Closes: #126189
58 * Doc updates. Closes: #120689
59 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
61 * Print special message for EAI_AGAIN. Closes: #131397
62 * libapt-pkg-dev needs to bring in the apt-inst library if linking
63 is to work. Closes: #133943
64 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
65 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
66 #139994, #142955, #151654, #151834, #147611, #154268, #173971
67 * Fix possibility for tag file parsing to fail in some unlikely situations.
69 * Use std C++ names for some header files. Closes: #128741
70 * Do not check for free space if --no-download. Closes: #117856
71 * Actually implement or group handling for 'upgrade'. Closes: #133950
72 * "Internal Error, Couldn't configure pre-depend" is not actually an
73 internal error, it is a packaging error and now it says so, and
74 pinpoints the problem dependency. Closes: #155621
75 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
76 * Use usr/share/doc for dhelp. Closes: #115701
77 * --print-uris works with 'update'. Closes: #57070
78 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
80 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
82 * Allow an uninstalled package to be marked for removal on an install
83 line (meaning not to automatically install it), also fix some dodgy
84 handling of protected packages. Closes: #92287, #116011
85 * Fix errant prefix matching in version selection. Closes: #105968
86 * Ensure that all files needed to run APT as a user are readable and
87 ignore roots umask for these files. Closes: #108801
88 * Support larger config spaces. Closes: #111914
89 * 'apt-get update' no longer does 'Building Dependency Tree'.
90 * When matching regexs allways print a message. Change regex activation
91 charset. Closes: #147817
92 * Don't die if lines in sources.list are too long. Closes: #146846
93 * Show file name on apt-extracttemplate error messges. Closes: #151835
94 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
95 * Some highly unlikely memory faults. Closes: #155842
96 * C++ stuff for G++3.2. Closes: #162617, #165515,
97 * apt-config dumps sends to stdout not stderr now. Closes: #146294
98 * Fix segfault in FindAny when /i is used, and there is no default.
100 * Add s390x to archtable. Closese: #160992.
101 * Update config.sub/config.guess in cvs, and add support to debian/rules
102 to update them from /usr/share/misc if they exist. Closes: #155014
103 * Remove 'Sorry' from messages. Closes: #148824.
104 * Change wording of 'additional disk space usage' message. Closes:
106 * apt-extracttemplates now prepends the package name when extracting
107 files. Closes: #132776
108 * Add -n synonym for --names-only for apt-cache. Closes: #130689
109 * Display both current version and new version in apt-get -s. Closes:
111 * Add an options and timeout config item to ssh/rsh. Closes: #90654
112 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
113 * Change verbose logging output of apt-ftparchive to go to stderr,
114 instead of stdout. Also, errors that occur no longer go to stdout,
115 but stderr. Closes: #161592
116 * Test for timegm in configure. Closes: #165516.
117 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
118 support compliation on platforms where st_mtime is a macro. Closes:
120 * Check the currently mounted cdrom, to see if it's the one we are
121 interested in. Closes: #154602
122 * Refer to reportbug instead of bug in the man pages. Closes: #173745
123 * Link apt-inst to apt-pkg. Closes: #175055
124 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
126 * Fix > 300 col screen segfault. Closes: #176052
127 * Rebuild with gcc-3.2. Closes: #177752, #178008.
128 * Fix build-dep handling of | dependencies.
129 Closes: #98640, #145997, #158896, #172901
130 * Double default value of APT::Cache-Limit, until such time as it
131 can be made more dynamic. Closes: #178623.
132 * Report uris with '.gz' when there are errors. Closes: #178435.
133 * When installing build-deps, make sure the new version will
134 satisfy build requirements. Closes: #178121
135 * Split offline and guide documentation into apt-doc. This was done so
136 that binary-arch builds do not require documention deps. Note, that
137 apt-doc is not installed on upgrades.
138 * Use doc-base, instead of dhelp directly. Closes: #110389
139 * Change http message 'Waiting for file' to 'Waiting for headers'.
141 * Remove trailing lines on package lists in apt-get. Closes: #178736.
142 * Fix origin pins for file:// uris. Closes: #189014.
143 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
145 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
147 * Fix some typos in the apt-get manual. Closes: #163932.
148 * Apply patch from bug, to change frozen to testing, and then do it
149 everywhere else. Closes: #165085.
150 * Update es.po. Closes: #183111.
151 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
153 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
154 * Add option to apt-get to show versions of packages being
156 * Be quiet in apt.post{inst,rm}. Closes: #70685.
157 * apt-get now prints out suggested and recommended packages. Closes:
159 * Insert some newlines in the cdrom change media message. Closes:
161 * Add a rdepends command to apt-cache. Closes: #159864.
162 * When building the dpkg command line, allow for 8192 chars to be used,
163 instead of only 1024.
164 * APT::Immediate-Configure had inverted semantics(false meant it was
165 enabled). Closes: #173619.
166 * Fix status file parser so that if a record is larger than 32k, the
167 buffer size will be doubled, and the read attempted again. Closes:
170 -- Adam Heath <doogie@debian.org> Sun, 27 Apr 2003 01:23:12 -0500
172 apt (0.5.4) unstable; urgency=low
174 * M68k config.guess patch. Closes: #88913
175 * Bi-yearly test on OpenBSD and Solaris
176 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
177 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
179 * Various cosmetic code updates. Closes: #89066, #89066, #89152
180 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
182 * More patches from Alfredo for Vendors and more SHA-1 stuff
183 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
184 similar situations. Closes: #56708, #59432
185 * no_proxy and ftp. Closes: #89671
186 * Philippe Batailler's man page patches.
187 * Fix for display bug. Closes: #92033, #93652, #98468
188 * Use more than 16bits for the dep ID. Some people ran out..
189 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
190 #106911, #107395, #108968
191 * Reordered some things to make dante and FTP happier. Closes: #92757
192 * James R. Van Zandt's guide.sgml updates. Closes: #90027
193 * apt-ftparchive copes with no uncompressed package files + contents.
194 * French man pages from philippe batailler - well sort of. They
196 * run-parts. Closes: #94286
197 * 'apt-cache policy' preferences debug tool.
198 * Whatever. Closes: #89762
199 * libstdc++ and HURD. Closes: #92025
200 * More apt-utils verbage. Closes: #86954
201 * Fliped comparision operator. Closes: #94618
202 * Used the right copyright file. Closes: #65691
203 * Randolph's G++3 patches.
204 * Fixed no_proxy tokanizing. Closes: #100046
205 * Strip Config-Version when copying status to available. Closes: #97520
206 * Segfault with missing source files. Closes: #100325
207 * EINTR check. Closes: #102293
208 * Various changes to the locking metholodgy for --print-uris.
210 * Lame LD_LIBRARY_PATH thing. Closes: #98928
211 * apt-cache search searchs provide names too now. Closes: #98695
212 * Checksum and long lines problem. Closes: #106591
213 * .aptignr and empty files are just a warning. Closes: #97364
215 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
217 apt (0.5.3) unstable; urgency=low
219 * JoeyH's dpkg::preconfig not working. Closes: #88675
220 * Fixed apt override disparity
221 * Alfredo's SHA-1 and related patches
223 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
225 apt (0.5.2) unstable; urgency=low
227 * Fixed mention of /usr/doc in the long description
228 * JoeyH's downgrade bug -- don't use 0.5.1
229 * Doc bug. Closes: #88538
230 * Fault in building release strings. Closes: #88533
232 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
234 apt (0.5.1) unstable; urgency=low
236 * Fixed #82894 again, or should be and.
237 * Process the option string right. Closes: #86921
238 * Don't eat the last command for pipes. Closes: #86923
239 * Ignore .* for configuration directory processing. Closes: #86923
240 * Alfredo's no_proxy patch
241 * Documentation fixes. Closes: #87091
242 * JoeyH's double slash bug. Closes: #87266
243 * Unintitialized buffer and apt-ftparchive contents generation.
245 * Build-deps on virtual packages. Closes: #87639
246 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
247 libstdc++ version info in the library soname and in the package
248 provides. Closes: #87426
249 * Updated soname version to 0.3.2
250 * apt-extracttemplates moved from debconf into apt-utils
251 * s390 archtable entry. Closes: #88232
253 * Some instances where the status file can source a package in a
254 non-sensical way. Closes: #87390
255 * Work better if there are duplicate sources.list entries.
256 * Fixed the resetting of Dir with "dir {};". Closes: #87323
258 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
260 apt (0.5.0) unstable; urgency=low
262 * Fixed an obscure bug with missing final double new lines in
264 * Changed the apt-cdrom index copy routine to use the new section
266 * Added a package file sorter, apt-sortpkgs
267 * Parse obsolete Optional dependencies.
268 * Added Ben's rsh method. Closes: #57794
269 * Added IPv6 FTP support and better DNS rotation support.
270 * Include the server IP in error messages when using a DNS rotation.
272 * Made most of the byte counters into doubles to prevent 32bit overflow.
274 * HTTP Authorization. Closes: #61158
275 * Ability to parse and return source index build depends from Randolph.
276 * new 'apt-get build-dep' command from Randolph. Closes: #63982
277 * Added apt-ftparchive the all dancing all singing FTP archive
279 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
281 * Removed useless internal cruft including the xstatus file.
282 * Fixed config parser bugs. Closes: #67848, #71108
283 * Brain Damanged apt-get config options changed, does not change the command
284 line interface, except to allow --enable-* to undo a configuration
287 No-Download -> Download
288 No-Upgrade -> Upgrade
289 * Made this fix configable (DSelect::CheckDir) and default to disabled:
290 * No remove prompt if the archives dir has not changed. Closes: #55709
291 Because it is stupid in the case where no files were downloaded due to
292 a resumed-aborted install, or a full cache! Closes: #65952
293 * Obscure divide by zero problem. Closes: #64394
294 * Update sizetable for mips. Closes: #62288
295 * Fixed a bug with passive FTP connections
296 * Has sizetable entry for sparc64. Closes: #64869
297 * Escape special characters in the ::Label section of the cdroms.lst
298 * Created apt-utils and python-apt packages
299 * Due to the new policy engine, the available file may contain entries
300 from the status file. These are generated if the package is not obsolete
301 but the policy engine prohibits using the version from the package files.
302 They can be identified by the lack of a Filename field.
303 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
304 #36223, #33468, #22551
305 * Fixed deb-src line for non-us. Closes: #71501, #71601
306 * Fixes for G++ 2.96, s/friend/friend class/
307 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
308 * Confirmed fix for missing new line problem. Closes: #69386
309 * Fixed up dhelp files. Closes: #71312
310 * Added some notes about dselect and offline usage. Closes: #66473, #38316
311 * Lock files on read only file systems are ignored w/ warning.
313 * apt-get update foo now gives an error! Closes: #42891
314 * Added test for shlibs on hurd. Closes: #71499
315 * Clarified apt-cache document. Closes: #71934
316 * DocBook SGML man pages and some improvements in the text..
317 * sigwinch thing. Closes: #72382
318 * Caching can be turned off by setting the cache file names blank.
319 * Ignores arches it does not know about when autocleaning. Closes: #72862
320 * New function in apt-config to return dirs, files, bools and integers.
321 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
322 complex cases involving OR groups and provides.
323 68754 describes confusing messages which are the result of this..
324 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
325 * Speeling mistake and return code for the 'wicked' resolver error
326 Closes: #72621, #75226, #77464
327 * Solved unable to upgrade libc6 from potato to woody due to 3 package
328 libc6 dependency loop problem.
329 * Leading sources.list spaces. Closes: #76010
330 * Removed a possible infinite loop while processing installations.
331 * Man page updates. Closes: #75411, #75560, #64292, #78469
332 * ReduceSourceList bug. Closes: #76027
333 * --only-source option. Closes: #76320
334 * Typos. Closes: #77812, #77999
335 * Different status messages. Closes: #76652, #78353
336 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
337 * OS detection an support for the new pseduo standard of os-arch for the
338 Architecture string. Also uses regexing.. Closes: #39227, #72349
339 * Various i18n stuff. Note that this still needs some i18n wizard
340 to do the last gettextization right. Closes: #62386
341 * Fixed a problem with some odd http servers/proxies that did not return
342 the content size in the header. Closes: #79878, #44379
343 * Little acquire bugs. Closes: #77029, #55820
344 * _POSIX_THREADS may not be defined to anything, just defined..
346 * Spelling of Ignore-Hold correctly. Closes: #78042
347 * Unlock the dpkg db if in download only mode. Closes: #84851
348 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
349 * Patch from BenC. Closes: #80810
350 * Single output of some names in lists. Closes: #80498, #43286
351 * Nice message for people who can't read syserror output. Closes: #84734
352 * OR search function. Closes: #82894
353 * User's guide updates. Closes: #82469
354 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
355 * Various CD bugs, again thanks to Greenbush
356 Closes: #80946, #76547, #71810, #70049, #69482
357 * Using potato debhelper. Closes: #57977
358 * I cannot self-terminate. Closes: #74928
360 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
362 apt (0.3.19) frozen unstable; urgency=low
364 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
366 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
367 * Fixed hardcoded path. Closes: #59743
368 * Fixed Jay's relative path bug
369 * Allowed source only CDs. Closes: #58952
370 * Space check is supressed if --print-uris is given. Closes: #58965
371 * Clarified the documenation examples for non-us. Closes: #58646
372 * Typo in the package description. Closes: #60230
373 * Man Page typo. Closes: #60347
374 * Typo in Algorithms.cc. Closes: #63577
375 * Evil dotty function in apt-cache for generating dependency graphs
376 with the as-yet-unpackaged GraphVis.
377 * Appears to have been fixed in Janurary.. Closes: #57981
378 * New config.guess/sub for the new archs. Closes: #60874
379 * Fixed error reporting for certain kinds of resolution failures.
381 * Made autoclean respect 'q' settings. Closes: #63023
382 * Fixed up the example sources.list. Closes: #63676
383 * Added DPkg::FlushSTDIN to control the flushing of stdin before
384 forking dpkg. Closes: #63991
386 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
388 apt (0.3.18) frozen unstable; urgency=low
390 * Changes in the postinst script. Closes: #56855, #57237
391 * Fixed bashism. Closes: #57216, #57335
392 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
394 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
396 apt (0.3.17) unstable; urgency=low
398 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
399 * Fixed the configuration parser to not blow up if ; is in the config
401 * Applied visual patch to dselect install script . Closes #55214
402 * Included the configure-index example
404 * Library soname has increased
405 * Fixed default sources.list to have correct URLs for potato when it
407 * Added a message about erasing sources.list to dselect setup script
409 * No remove prompt if the archives dir has not changed. Closes: #55709
410 * Fixed inclusion of 2nd sample config file. Closes: #55374
411 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
414 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
416 apt (0.3.16) unstable; urgency=low
418 * Made --no-download work. Closes: #52993
419 * Now compiles on OpenBSD, Solaris and HP-UX
420 * Clarify segfault errors
421 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
422 * Fix for Joel's discovery of glibc removal behavoir.
423 * Fix for Ben Collins file: uri from slink upgrade.
424 * Fixed resume code in FTP. Closes: #54323
425 * Take more precautions to prevent the corruption Joey Hess saw.
426 * Fixed --no-list-cleanup
427 * RFC 2732 URI parsing ([] for hostnames).
428 * Typo in apt-cache man page. Closes: #54949
430 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
432 apt (0.3.15) unstable; urgency=low
434 * Added DSelect::WaitAfterDownload Closes: #49549
435 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
436 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
437 * Made -s and clean not do anything. Closes: #50238
438 * Problem with Protected packages and the new OR code.
439 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
440 * Remove doesn't require a package to be installable. Closes: #51175
441 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
443 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
445 apt (0.3.14) unstable; urgency=low
447 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
448 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
449 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
450 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
451 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
452 Closes: #45034, #45695, #46537
453 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
454 * Added APT::Clean-Installed option. Closes: #45973
455 * Moves the free space check to after the calculated size is printed.
456 Closes: #46639, #47498
457 * mipsel arch Closes: #47614
458 * Beautified URI printing to not include passwords Closes: #46857
459 * Fixed little problem with --no-download Closes: #47557
460 * Tweaked Dselect 'update' script to re-gen the avail file even in the
461 event of a failure Closes: #47112
462 * Retries for source archives too Closes: #47529
463 * Unmounts CDROMs iff it mounted them Closes: #45299
464 * Checks for the partial directories before doing downloads Closes: #47392
465 * no_proxy environment variable (http only!) Closes: #43476
466 * apt-cache showsrc Closes: #45799
467 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
468 * Regexs for install. Closes: #35304, #38835
469 * Dependency reports now show OR group relations
470 * Re-Install feature. Cloes: #46961, #37393, #38919
471 * Locks archive directory on clean (woops)
472 * Remove is not 'sticky'. Closes: #48392
473 * Slightly more accurate 'can not find package' message. Closes: #48311
474 * --trivial-only and --no-remove. Closes: #48518
475 * Increased the cache size. Closes: #47648
476 * Comment woopsie. Closes: #48789
477 * Removes existing links when linking sources. Closes: #48775
478 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
479 * Clearer usage message about 'source' Closes: #48858
480 * Immediate configure internal error Closes: #49062, #48884
482 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
484 apt (0.3.13) unstable; urgency=low
486 * Fix timestamp miss in FTP. Closes: #44363
487 * Fix sorting of Kept packages. Closes: #44377
488 * Fix Segfault for dselect-upgrade. Closes: #44436
489 * Fix handling of '/' for the dist name. Closes #43830
490 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
491 * Add commented-out deb-src URI to default sources.list file.
493 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
495 apt (0.3.12) unstable; urgency=low
497 * Fix for typo in the dhelp index. Closes: #40377
498 * Multiple media swap support
499 * Purge support. Closes: #33291, #40694
500 * Better handling of - remove notation. Closes: #41024
501 * Purge support. Closes: #33291, #40694
502 * Error code on failed update. Closes: #41053
503 * apt-cdrom adds entries for source directories. Closes: #41231
504 * Sorts the output of any list. Closes: #41107
505 * Fixes the looping problem. Closes: #41784, #42414, #44022
506 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
507 * More checks to keep the display sane. Particularly when fail-over is
508 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
509 * PThread lockup problem on certain sparc/m68k. Closes: #40628
510 * apt-cdrom understands .gz Package files too. Closes: #42779
511 * Spelling error in dselect method description. Closes: #43251
512 * Added security to the default source list. Closes: #43356
514 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
516 apt (0.3.11) unstable; urgency=low
518 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
519 * Fix for properly upgrading the system from perl 5.004 to 5.005
521 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
523 apt (0.3.9) unstable; urgency=low
525 * Spelling error in cachefile.cc. Closes: #39885
526 * Trailing slash in dselect install if you try to use the
527 default config file. Closes: #40011
528 * Simulate works for autoclean. Closes: #39141
529 * Fixed spelling errors. Closes: #39673
530 * Changed url parsing a bit. Closes: #40070, #40069
531 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
533 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
535 apt (0.3.7) unstable; urgency=low
537 * Fixed missing text in the apt-get(8) page. Closes: #37596
538 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
539 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
540 * Fixed handling of the -q option with not-entirely integer arguments
542 * Man page typo Closes: #37762
543 * Fixed parsing of the Source: line. Closes: #37679
544 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
545 * Added a check for an empty cache directory. Closes: #37963
546 * Return a failure code if -d is given and packages fail to download.
548 * Arranged for an ftp proxy specifing an http server to work. See the
549 important note in the sources.list man page.
550 * Accounted for resumed files in the cps calculation. Closes: #36787
551 * Deal with duplicate same version different packages. Closes: #30237
552 * Added --no-download. Closes: #38095
553 * Order of apt-cdrom dist detection. Closes: #38139
554 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
556 * Suggests dpkg-dev for apt-get source. Closes: #38158
557 * Fixed typo in apt-get help. Closes: #38712
558 * Improved the error message in the case of broken held package. Closes: #38777
559 * Fixed handling of MD5 failures
560 * Documented list notation Closes: #39008
561 * Change the 'b' to 'B'. Closes: #39007
563 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
565 apt (0.3.6) unstable; urgency=low
567 * Note that 0.3.5 never made it out the door..
568 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
569 * Made APT print numbers in decimal. Closes: #35617, #37319
570 * Buffer munching fix for FTP. Closes: #35868
571 * Typo in sample config file. Closes: #35907
572 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
573 * Changed installed size counter to only count unpacked packages.
575 * apt-get source support. Closes: #23934, #27190
576 * Renames .debs that fail MD5 checking, provides automatic corruption
577 recovery. Closes: #35931
578 * Fixed autoconf verison. Closes: #37305
579 * Random Segfaulting. Closes: #37312, #37530
580 * Fixed apt-cache man page. Closes: #36904
581 * Added a newline to apt-cache showpkg. Closes: #36903
583 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
585 apt (0.3.4) unstable; urgency=low
587 * Release for Ben while he is out of town.
588 * Checked the size of partial files. Closes: #33705
589 * apt-get should not print progress on non-tty. Closes: #34944
590 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
591 * Applied cdrom patches from Torsten. Closes: #35140, #35141
592 * smbmounted cdrom fix. Closes: #35470
593 * Changed ie to eg. Closes: #35196
595 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
597 apt (0.3.3) unstable; urgency=low
599 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
601 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
603 apt (0.3.2) unstable; urgency=low
605 * Major release into unstable of v3
606 * These bugs have been fixed, explanations are in the bug system, read
607 the man pages as well..
608 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
609 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
610 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
611 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
612 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
613 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
614 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
615 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
617 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
619 apt (0.3.1) experimental; urgency=low
621 * Minor release of cvs version.
622 * Added virtual package libapt-pkgx.x
624 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
626 apt (0.3.0) experimental; urgency=low
628 * New experimental version.
630 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
632 apt (0.1.9) frozen unstable; urgency=low
634 * Return to the wacky numbering for when we build 0.1.8 for hamm
635 * Important bug related to APT on the Alpha fixed
636 * apt-get dist-upgrade problems fixed
637 * tiny patch for http method to fix an endless loop
638 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
639 libtool and add proper shared lib dependancies
640 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
641 in case an old libpkg is installed while building APT to prevent
642 spurious dependancies
644 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
646 apt (0.1.7) unstable; urgency=low
648 * New build with libstdc++2.9.
649 * Various fixes; read the Changelog.
651 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
653 apt (0.1.6) unstable; urgency=low
655 * Various fixes in the FTP method for error checking. Fixes: #26188.
656 * Spelling corrections in dselect method. Fixes: #25884
657 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
658 * No more bo releases: we're using a normal numbering system now.
660 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
662 apt (0.1.5) unstable; urgency=low
664 * Changed sources.list to point to 'unstable' by default, as
665 'frozen' no longer exists!
667 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
669 apt (0.1.3) unstable; urgency=low
671 * New upstreamish version.
672 * ftp method rewritten in C. Removes dependancies on all perl/perl
673 related modules. This fixes many of the ftp method bugs.
675 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
677 apt (0.1.1) unstable; urgency=low
679 * Release for unstable.
681 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
683 apt (0.1) unstable; urgency=low
685 * Kludge to fix problem in libnet-perl with illegal anonymous
687 * Moved to unstable; apt is in a useable state now.
688 * Fixed version numbering. From now on, numbering will be:
689 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
690 0.1.1 (release for unstable). Thanks, Manoj.
692 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
694 apt (0.0.17-1) experimental; urgency=low
696 * Fixed problem with libc6 version compare
697 * Scott's away for a while, so I'll be packaging apt for the time
700 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
702 apt (0.0.16-1) experimental; urgency=low
704 * Modifications to make apt-get more friendly when backgrounded.
705 * Updated documentation.
706 * Updates to graphic widgets
708 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
710 apt (0.0.15-0.2bo) experimental; urgency=low
713 * Bob Hilliards crash
715 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
717 apt (0.0.15-0.1bo) experimental; urgency=low
722 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
724 apt (0.0.15) experimental; urgency=low
726 * Clean up source tarball (no user-visible changes)
728 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
730 apt (0.0.14) experimental; urgency=low
732 * Updates in ordering code to make sure certain upgrades work correctly.
733 * Made dselect/setup understand ftp as well as http
735 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
737 apt (0.0.13-bo1) experimental; urgency=low
741 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
743 apt (0.0.13) experimental; urgency=low
745 * Remove hardcoded egcc from debian/rules (#21575)
746 * Fixes for ordering logic when system has a number of unpacked
747 but unconfigured packages installed.
748 * Spelling fix in dselect install method (#22556)
750 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
752 apt (0.0.12) experimental; urgency=low
754 * Fixed problems with package cache corruption.
755 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
757 * Interface and documentation improvements.
759 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
761 apt (0.0.11) experimental; urgency=low
763 * Change dependancies to pre-depends since breaking your packaging tools
764 in the middle of an installation isn't very good.
765 * Bug fixes to ftp method and general apt-get code
767 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
769 apt (0.0.10) experimental; urgency=low
771 * Run "dpkg --configure -a" after an aborted dselect install
772 * Fixed problem with install looping
773 * Support for authenticating proxys: (note this isn't terribly secure)
774 http_proxy="http://user:pass@firewall:port/"
775 * Substitute $ARCH in sources.list
776 * Fixes in the resumption code for ftp
778 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
780 apt (0.0.9) experimental; urgency=low
783 * Various other less visible bug fixes.
784 * Fixed problem with segfault when apt-get invoked in a non-existant
785 directory (Bug #21863)
786 * Bumped policy to 2.4.1
788 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
790 apt (0.0.8) experimental; urgency=low
792 * Fixed generated available file (Bug #21836)
793 * Added download ETA (Bug #21774).
794 * Fixed hardcoded ARCH (Bug #21751).
795 * Fixed check on http_proxy (Bug #21795).
796 * Added download speed indicator.
798 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
800 apt (0.0.7) experimental; urgency=low
802 * Remove libdeity and apt from package for now, since only apt-get and
803 apt-cache are actually useful right now.
804 * Clean up handling of package installation errors.
805 * Added timeout to http transfers (#21269)
806 * Updated setup for dselect/apt method.
808 * Long options (added in 0.0.6)
810 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
812 apt (0.0.6) experimental; urgency=low
815 * Revamped download status display.
816 * Call apt-get clean after successful install in dselect.
817 * Added "apt-get clean" which deletes package files from /var/cache/apt
819 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
821 apt (0.0.5) experimental; urgency=low
823 * Ignore signals while dpkg is running so we don't leave dpkg running in
824 the background (#20804)
825 * Check Packages as well as Packages.gz for file URIs (#20784)
826 * Spelling cleanup (#20800)
827 * Added -m option to permit upgrade to go on in the case of a bad mirror.
828 This option may result in incomplete upgrades when used with -f.
830 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
832 apt (0.0.4) experimental; urgency=low
835 * Various documentation updates and cleanup.
836 * Added '-f' option to apt-get attempt to fix broken dependancies.
838 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
840 apt (0.0.3) experimental; urgency=low
842 * Added a shlibs.local file to prevent apt from depending on itself.
843 * Updates to how apt-get handles bad states in installed packages.
844 * Updated rules to make sure build works from a freshly checked out source
845 archive. Building from CVS needs libtool/automake/autoconf, builds from
846 the distributed source package should have no such dependancy.
848 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
850 apt (0.0.2) unstable; urgency=low
852 * Updates to apt-get and http binding for dselect method (apt).
853 * Updating version number from 0.0.1, which was released only on IRC.
855 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
857 apt (0.0.1) unstable; urgency=low
861 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500