]> git.saurik.com Git - wxWidgets.git/blob - wxMotif.spec
merged some message catlogues from 2.2 that were missing from 2.3
[wxWidgets.git] / wxMotif.spec
1 # RPM .spec file for wxMotif. Based on the .spec file for wxGTK
2 # (c) by Robert Roebling. Modifications (c) 2000/03 by Robert Fendt.
3
4 # Note that this is NOT a relocatable package
5 %define pref /usr
6 %define ver 2.3.2
7 %define ver2 2.3
8 %define rel 1
9
10 Summary: The Motif/Lesstif port of the wxWindows library
11 Name: wxMOTIF
12 Version: %{ver}
13 Release: %{rel}
14 Copyright: wxWindows Licence
15 Group: X11/Libraries
16 Source: wxMOTIF-%{ver}.tar.bz2
17 URL: http://www.wxwindows.org
18 Packager: Robert Fendt <rfendt@myokay.net>
19 BuildRoot: /tmp/wxmotif_root
20
21 # all packages providing an implementation of wxWindows library (regardless of
22 # the toolkit used) should provide the (virtual) wxwin package, this makes it
23 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
24 Provides: wxwin
25
26 %description
27 wxWindows is a free C++ library for cross-platform GUI development.
28 With wxWindows, you can create applications for different GUIs (GTK+,
29 Motif/LessTif, MS Windows, Mac) from the same source code.
30
31 %package devel
32 Summary: The Motif/Lesstif port of the wxWindows library
33 Group: X11/Libraries
34 Requires: wxMotif
35
36 %description devel
37 Header files for wxMotif, the Motif/Lesstif port of the wxWindows library.
38
39 %package gl
40 Summary: The Motif/Lesstif port of the wxWindows library, OpenGl add-on.
41 Group: X11/Libraries
42 Requires: wxMotif
43
44 %description gl
45 OpenGl add-on library for wxMotif, the Motif/Lesstif port of the wxWindows library.
46
47 %prep
48 %setup
49 ./configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl --with-motif
50
51 %build
52 if [ "$SMP" != "" ]; then
53 export MAKE="make -j$SMP"
54 else
55 export MAKE="make"
56 fi
57 $MAKE
58 (cd locale ; make allmo)
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 make prefix=$RPM_BUILD_ROOT%{pref} install
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 /sbin/ldconfig
69
70 %postun
71 /sbin/ldconfig
72
73 %post gl
74 /sbin/ldconfig
75
76 %postun gl
77 /sbin/ldconfig
78
79 %post devel
80 # Install wx-config if there isn't any
81 if test ! -f %{_bindir}/wx-config ; then
82 ln -sf wxmotif-%{ver2}-config %{_bindir}/wx-config
83 fi
84
85 %preun devel
86 # Remove wx-config if it points to this package
87 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
88 SUM1=`md5sum %{_bindir}/wxmotif-%{ver2}-config | cut -c 0-32`
89 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
90 if test "x$SUM1" = "x$SUM2" ; then
91 rm -f %{_bindir}/wx-config
92 fi
93 fi
94
95
96 %files
97 %defattr (-,root,root)
98 %doc COPYING.LIB *.txt
99 %dir %{_datadir}/wx
100 %{_datadir}/wx/*
101 %{_datadir}/locale/*/*/*.mo
102 %{_libdir}/libwx_motif-%{ver2}*.so.*
103
104 %files devel
105 %defattr (-,root,root)
106 %{_libdir}/libwx_motif-%{ver2}*.so
107 %dir %{_includedir}/wx
108 %{_includedir}/wx/*
109 %dir %{_libdir}/wx
110 %{_libdir}/wx/*
111 %{_bindir}/wxmotif-%{ver2}-config
112
113 %files gl
114 %defattr(-,root,root)
115 %{_libdir}/libwx_motif_gl*