]> git.saurik.com Git - apt.git/blobdiff - debian/tests/run-tests
support Signed-By in Release files as a sort of HPKP
[apt.git] / debian / tests / run-tests
index 6ea5035688b194634abcea6ebca02f915518a907..f858adf5f138beedbe38422c83071f5bf24ef856 100644 (file)
@@ -2,6 +2,21 @@
 
 set -e
 
-make
-make test
-test/integration/run-tests
+# we need the buildin webserver for the tests
+if [ ! -e environment.mak ]; then
+    make startup
+fi
+make -C test/interactive-helper/
+
+# run tests against the installed apt, use "env -i" to ensure
+# the host env does not pollute our environment
+env -i \
+APT_INTEGRATION_TESTS_SOURCE_DIR=$(pwd) \
+APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR=$(pwd)/build/bin \
+APT_INTEGRATION_TESTS_METHODS_DIR=/usr/lib/apt/methods \
+APT_INTEGRATION_TESTS_LIBEXEC_DIR=/usr/lib/apt/ \
+APT_INTEGRATION_TESTS_INTERNAL_SOLVER=/usr/lib/apt/solvers/apt \
+APT_INTEGRATION_TESTS_DUMP_SOLVER=/usr/lib/apt/solvers/dump \
+APT_INTEGRATION_TESTS_BUILD_DIR=/usr/bin \
+APT_INTEGRATION_TESTS_LIBRARY_PATH=/dev/null/does/not/exist \
+./test/integration/run-tests -q