]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
Release 1.3.1
[apt.git] / debian / changelog
index e45998abadb21bd27c72d4481c3c3578085d2c19..8c31be6d753a9c6c5a47c4101450359dc4fa51c6 100644 (file)
@@ -1,3 +1,533 @@
+apt (1.3.1) unstable; urgency=medium
+
+  [ Julian Andres Klode ]
+  * Do not read stderr from proxy autodetection scripts
+  * travis: Move codecov from after_success to after_script
+
+  [ victory ]
+  * Japanese manpages translation update
+
+  [ Mert Dirik ]
+  * Turkish program translation update (Closes: #838731)
+
+ -- Julian Andres Klode <jak@debian.org>  Tue, 04 Oct 2016 19:43:35 +0200
+
+apt (1.3) unstable; urgency=medium
+
+  [ David Kalnischkies ]
+  * abort connection on '.' target replies in SRV
+  * edsp: try 2 to read responses even if writing failed
+
+  [ Julian Andres Klode ]
+  * test: Always install dpkg into our tests, regardless of MA
+  * CMake: Add coverage build type
+  * Coverage: Do not print messages from gcov
+  * VersionHash: Do not skip too long dependency lines
+
+ -- Julian Andres Klode <jak@debian.org>  Tue, 20 Sep 2016 23:53:51 +0200
+
+apt (1.3~rc4) unstable; urgency=medium
+
+  [ Julian Andres Klode ]
+  * Fix segfault and out-of-bounds read in Binary fields
+  * TagFile: Fix off-by-one errors in comment stripping
+  * Base256ToNum: Fix uninitialized value
+  * test-apt-cdrom: Fix for gnupg 2.1.15
+  * CMake: test/libapt: Use a prebuilt GTest library if available
+  * CMake: apt-pkg: Use correct ICONV_INCLUDE_DIRS variable
+  * acquire: Use priority queues and a 3 stage pipeline design
+    => faster updates with better progress reporting
+  * debian: Move bugscript to old location for overlayfs xdev issue
+  * debian: Pass -O to make to get readable build logs
+
+  [ David Kalnischkies ]
+  * try not to call memcpy with length 0 in hash calculations
+  * re-add apt breaks/replaces apt-utils (<< 1.3~exp2~) (Closes: #836220)
+  * support long keyid and fingerprint in gpgv's GOODSIG
+
+ -- Julian Andres Klode <jak@debian.org>  Fri, 02 Sep 2016 20:26:36 +0200
+
+apt (1.3~rc3) unstable; urgency=medium
+
+  [ Julian Andres Klode ]
+  * Ignore SIGINT and SIGQUIT for Pre-Install hooks
+    This basically fixes Bug #832593, as long as your /bin/sh
+    is not dash, as dash is evil.
+  * prepare-release: Use equivs and gdebi-core for travis deps
+  * install-progress: Call the real ::fork() in our fork() method
+  * Packaging cleanup:
+    - debian: Install etc/apt if present (e.g., on Ubuntu)
+    - tests/control: Handle the gpg1/gpg2 mess a bit better
+    - debian: Make better use of the tree installed by CMake
+    - debian: Switch to debhelper 10
+    - debian: Add more lintian overrides
+    - debian: Drop outdated stuff
+    - debian: Run wrap-and-sort
+    - Add new symbols to symbols file
+  * Build system fixes, including:
+   - CMake: Translations: Don't rebuild .mo for line number changes
+   - CMake: Translations: Pass --previous to msgmerge.
+     Thanks to Guillem Jover for the suggestion.
+   - CMake: Do not add po/ if USE_NLS is OFF
+   - CMake: Install config and logging directories
+   - CMake: Translations: Build byproduct before output
+   - CMake: Add Large File Support (Closes: #834767)
+  * Several portability fixes (full test suite passes on FreeBSD), including:
+   - CMake: Discover docbook stylesheet in other locations
+   - Add missing includes and external definitions
+   - Use C locale instead of C.UTF-8 for protocol strings
+   - Make directory paths configurable
+   - Lower-case uname -r output in kernel autoremove helper
+   - Make root group configurable via ROOT_GROUP
+  * Accept --autoremove as alias for --auto-remove
+  * apt-inst: debfile: Pass comp. Name to ExtractTar, not Binary
+  * changelog: Respect Dir setting for local changelog getting
+  * init: Add Dir::Bin::planners default entry
+  * Switch documentation from httpredir.d.o to deb.d.o
+
+  [ Zhou Mo ]
+  * zh_CN.po: update simplified Chinese translation
+
+  [ David Kalnischkies ]
+  * do dpkg --configure before --remove/--purge --pending (Closes: 835094)
+  * prevent C++ locale number formatting in text APIs (try 3) (LP: 1611010)
+  * do fail on weakhash/loop earlier in acquire (Closes: 835195)
+  * do not restore selections for already purged packages
+  * apt-key: warn instead of fail on unreadable keyrings
+  * show apt-key warnings in apt update (Closes: 834973)
+  * treat .ddeb files like .deb, especially for dpkg (LP: #1616909)
+  * randomize acquire order for same type index files
+  * don't loop on pinning pkgs from absolute debs by regex (Closes: 835818)
+
+ -- Julian Andres Klode <jak@debian.org>  Tue, 30 Aug 2016 22:20:28 +0200
+
+apt (1.3~rc2) unstable; urgency=medium
+
+  [ Julian Andres Klode ]
+  * debian/NEWS: Get rid of 1.3~pre3+cmake1 entry.
+    Thanks to Axel Beckert for reporting
+  * CMake: Use COPYONLY instead of @ONLY
+  * fileutl: empty file support: Avoid fstat() on -1 fd and check result
+  * Change anonscm.d.o links to /git/apt/apt.git and https
+
+  [ David Kalnischkies ]
+  * don't perform int<float in progress bar drawing
+  * ensure a good clock() value for usage and tests
+  * drop incorrect const attribute from DirectoryExists (LP: 1473674)
+  * http(s): allow empty values for header fields (Closes: 834048)
+  * don't sent Range requests if we know its not accepted
+  * don't try pipelining if server closes connections (Closes: #832113)
+  * log with the failed item description, not with next try
+  * retry without same redirection mirror on 404 errors
+  * support getting only-uncompressed files via by-hash
+  * support compression and by-hash for .diff/Index files (Closes: #824926)
+  * default to Dir=/ in dpkg/status file finding magic
+  * add the gpg-classic variant to the gpgv/gnupg or-group
+  * allow spaces in fingerprints for 'apt-key del'
+  * add --with-source option and Packages/Sources support
+  * don't count each Type as an individual deb822-sources stanza
+  * methods: read config in most to least specific order (Closes: 834642)
+
+ -- Julian Andres Klode <jak@debian.org>  Wed, 17 Aug 2016 23:31:07 +0200
+
+apt (1.3~rc1) unstable; urgency=medium
+
+  * Summary: CMake branch merged, socks5h (and tor) support, and fancy
+    installation ordering changes.
+
+  [ Julian Andres Klode ]
+  * Handle interrupt when running Pre-Install hooks (Closes: #832593)
+  * CMake: po: Add mirror method
+  * CMake: Translations: Add support for shell scripts
+  * debian: make autopkgtest run with CMake build dir
+  * CMake: Bump minimum required version to 3.4.0
+  * CMake: Check for ptsname_r() again (Closes: #833674)
+  * CMake: Rewrite existing Documentation support and add doxygen
+  * apt-private: Do not include apti18n.h in headers
+  * Get rid of the old buildsystem
+  * Fix some indentation issues in README.md
+
+  [ David Kalnischkies ]
+  * pass --force-remove-essential to dpkg only if needed
+  * use dpkg --unpack --recursive to avoid long cmdlines
+  * save and restore selection states before/after calling dpkg
+  * select remove/purge packages early on for dpkg
+  * call dpkg with --no-triggers by default (Closes: #626599)
+  * don't purge directly, but remove and do purge at the end
+  * ensure all configures are reported to hook scripts
+  * ensure all removes are reported to hook scripts
+  * support all socks-proxy known to curl in https method
+  * suggest transport-packages based on established namescheme
+  * fail on unsupported http/https proxy settings (Closes: #623443)
+  * detect redirection loops in acquire instead of workers
+  * use the same redirection handling for http and https
+  * implement generic config fallback for methods
+  * implement socks5h proxy support for http method (Closes: 744934)
+  * allow methods to be disabled and redirected via config
+  * allow user@host (aka: no password) in URI parsing
+  * try to avoid removal of crossgraded packages
+  * simulate all package manager actions explicitly
+  * disable explicit configuration of all packages at the end
+  * block direct connections to .onion domains (RFC7687)
+  * http: auto-configure for local Tor proxy if called as 'tor'
+
+ -- Julian Andres Klode <jak@debian.org>  Thu, 11 Aug 2016 14:10:22 +0200
+
+apt (1.3~pre3+cmake2) experimental; urgency=medium
+
+  * Build-depend on pkg-config
+
+ -- Julian Andres Klode <jak@debian.org>  Sat, 06 Aug 2016 23:18:37 +0200
+
+apt (1.3~pre3+cmake1) experimental; urgency=medium
+
+  [ Julian Andres Klode ]
+  * configure.ac: Re-enable pthread support for thread-local _error
+  * CMake: Add basic CMake build system
+  * CMake: Add support for building and installing .mo files
+  * CMake: Add initial support for documentation building
+  * CMake: Switch integration tests and travis over
+  * CMake: debian: Switch packaging over to CMake and dh 9
+
+  [ Jason Travis ]
+  * doc: update path to periodic options script
+
+ -- Julian Andres Klode <jak@debian.org>  Sat, 06 Aug 2016 22:37:30 +0200
+
+apt (1.3~pre3) unstable; urgency=medium
+
+  [ Julian Andres Klode ]
+  * ExecGPGV: Fork in all cases
+  * ExecGPGV: Pass current config state to apt-key via temp file (LP: #1607283)
+
+  [ David Kalnischkies ]
+  * tests: activate dpkg multi-arch even if test is single arch
+  * ensure Cnf::FindFile doesn't return files below /dev/null
+  * don't hardcode /var/lib/dpkg/status as dir::state::status
+  * allow arch=all to override No-Support-for-Architecture-all
+  * support "install ./foo.changes"
+  * clean up default-stanzas from extended_states on write
+  * report warnings&errors consistently in edit-sources
+  * create non-existent files in edit-sources with 644 instead of 640
+  * report progress for removing while purging pkgs
+  * use a configurable location for apport report storage
+  * report progress for triggered actions
+  * call flush on the wrapped writebuffered FileFd
+  * verify hash of input file in rred
+  * use proper warning for automatic pipeline disable
+  * http: skip requesting if pipeline is full
+  * rred: truncate result file before writing to it (Closes: #831762)
+  * eipp: avoid producing file warnings in simulation (Closes: 832614)
+  * if the FileFd failed already following calls should fail, too
+  * edsp: try to read responses even if writing failed
+  * prevent C++ locale number formatting in text APIs (try 2) (Closes: 832044)
+  * apt-key: kill gpg-agent explicitly in cleanup
+
+  [ Mert Dirik ]
+  * Turkish program translation update (Closes: 832039)
+
+ -- Julian Andres Klode <jak@debian.org>  Thu, 04 Aug 2016 10:23:49 +0200
+
+apt (1.3~pre2) unstable; urgency=medium
+
+  [ Andrew Patterson ]
+  * Add kernels with "+" in the package name to APT::NeverAutoRemove
+    (Closes: #830159)
+
+  [ David Kalnischkies ]
+  * add Testsuite-Triggers to tagfile-order
+  * tests: fix external solver/planner directory setup
+
+ -- Julian Andres Klode <jak@debian.org>  Fri, 08 Jul 2016 14:28:57 +0200
+
+apt (1.3~pre1) unstable; urgency=medium
+
+  Upload to unstable from the pub because Niels wanted it
+
+  [ David Kalnischkies ]
+  * show right binary name in simulation notice (Closes: 825216)
+  * imbue datetime parsing with C.UTF-8 locale (Closes: 828011)
+  * imbue .diff/Index parsing with C.UTF-8 as well
+  * close server if parsing of header field failed
+  * add myself to Uploaders
+  * eipp: implement version 0.1 of the protocol
+  * eipp: provide the internal planer as an external one
+  * eipp: make no difference between remove & purge
+  * eipp: properly handle arch-specific provides
+  * eipp: implement Immediate-Configuration flag
+  * eipp: add Allow-Temporary-Remove-of-Essentials
+  * eipp: rename stanza 'Install' to 'Unpack'
+  * eipp: enable xz-compressed scenario logging
+  * if conf unset, don't read / as conf/pref/sources dir
+  * don't do atomic overrides with failed files (Closes: 828908)
+  * if reading of autobit state failed, let write fail
+  * write auto-bits before calling dpkg & again after if needed
+  * protect only the latest same-source providers from autoremove
+  * reinstalling local deb file is no downgrade
+  * do not treat same-version local debs as downgrade
+  * alias apt-key list to finger (Closes: 829232)
+  * warn if apt-key is used in scripts/its output parsed
+  * deprecate 'apt-key update' and no-op it in Debian
+  * use +0000 instead of UTC by default as timezone in output
+  * avoid 416 response teardown binding to null pointer
+  * report write errors in EDSP/EIPP properly back to caller
+  * EIPP/EDSP log can't be written is a warning, not an error
+  * don't change owner/perms/times through file:// symlinks
+  * report all instead of first error up the acquire chain
+  * keep trying with next if connection to a SRV host failed
+
+  [ Zhou Mo ]
+  * zh_CN.po: update simplified chinese translation
+
+  [ Julian Andres Klode ]
+  * methods/ftp: Cope with weird PASV responses.
+    Thanks to Lukasz Stelmach for the initial patch (Closes: #420940)
+  * Fix buffer overflow in debListParser::VersionHash() (Closes: #828812)
+  * cache: Bump minor version to 6
+  * indextargets: Check that cache could be built before using it
+    (Closes: #829651)
+
+  [ Nicolas Le Cam ]
+  * Use the ConditionACPower feature of systemd in the apt-daily service
+    (Closes: #827930)
+  * Add a apt suggests powermgmt-base
+
+ -- Julian Andres Klode <jak@debian.org>  Thu, 07 Jul 2016 20:25:18 +0200
+
+apt (1.3~exp3) experimental; urgency=medium
+
+  [ Petter Reinholdtsen ]
+  * Norwegian Bokmål program translation update (Closes: 827067)
+
+  [ David Kalnischkies ]
+  * apt-key: don't search PATH if command is a path already
+  * don't use FindFile for external Dir::Bin commands
+  * http: don't hang on redirect with length + connection close
+  * merge sources.list lines based on Release filename (Closes: 826944)
+  * avoid std::get_time usage to sidestep libstdc++6 bug (LP: 1593583)
+  * do not error if auto-detect-proxy cmd has no output (Closes: 827713)
+  * implement and document DIRECT for auto-detect-proxy
+  * run update post-invokes even on (partial) failures
+  * handle weak-security repositories as unauthenticated (Closes: 827364)
+  * generalize secure->insecure downgrade protection
+  * forbid insecure repositories by default expect in apt-get (Closes: 808367)
+  * source: if download is skipped, don't try to unpack
+  * better error message for insufficient hashsums (Closes: 827758)
+  * add [weak] tag to hash errors to indicate insufficiency
+  * ensure filesize of deb is included in the hashes list
+  * add insecure (and weak) allow-options for sources.list
+
+  [ Dominic Benson ]
+  * Reinstate caching of file hashes in apt-ftparchive (Closes: #806924)
+
+  [ Zhou Mo ]
+  * zh_CN.po: update simplified chinese translation
+
+ -- Julian Andres Klode <jak@debian.org>  Wed, 22 Jun 2016 14:50:12 +0200
+
+apt (1.3~exp2) experimental; urgency=medium
+
+  [ Johannes 'josch' Schauer ]
+  * edsp: document unique package identifiers
+
+  [ David Kalnischkies ]
+  * edsp: warn if unexpected stanzas appear in the solution
+  * show globalerrors before asking for confirmation
+  * show final solution in --no-download --fix-missing mode
+  * document --no- as --show-upgraded is the default (Closes: 824456)
+  * fail instead of segfault on unreadable config files (Closes: 824503)
+  * convert EDSP to be based on FileFd instead of FILE*
+  * edsp: dump: support dumping into compressed file
+  * edsp: add Forbid-{New-Install,Remove} and Upgrade-All
+  * update symbols file
+  * no-change bump of Standards-Version to 3.9.8
+  * override lintian on doxygens embedded-javascript-library
+  * fix and document on the fly compressor config
+  * prevent C++ locale number formatting in text APIs (Closes: #825396)
+  * accept only the expected UTC timezones in date parsing (Closes: 819697)
+  * avoid changing the global LC_TIME for Release writing
+  * use de-localed std::put_time instead rolling our own
+  * use std::locale::global instead of setlocale
+  * look into the right textdomain for apt-utils again
+  * try to detect sudo spawned root-shell in prefixing (Closes: 825742)
+  * ignore std::locale exception on non-existent "" locale
+  * apt-key: change to / before find to satisfy its CWD needs.
+    Thanks to Samuel Thibault for 'finding' the culprit! (Closes: 826043)
+  * edsp: use an ID mapping for the internal solver
+  * edsp: use a stanza based interface for solution writing
+  * edsp: optionally store a compressed copy of the last scenario
+  * move 'dump' solver from apt-utils to apt package
+  * edsp: if internal is used, keep this decision
+  * edsp: if logging is requested, do it for internal, too
+  * edsp: drop privileges before executing solvers
+  * don't explicitly configure the last round of packages
+  * drop Dpkg::MaxArgs in favor of Dpkg::MaxArgsBytes
+  * do not hang on piped input in PipedFileFdPrivate
+  * don't leak an FD in lz4 (de)compression
+  * don't leak EDSP solver output fd
+  * don't leak FD in AutoProxyDetect command return parsing
+
+  [ Julian Andres Klode ]
+  * Provide complete apt bash completion.
+    Thanks to Elias Fröhner and Svyatoslav Gryaznov for the initial work
+    (LP: #1573547)
+  * apt.systemd.daily: Put opening brace of check_power on extra line
+    (LP: #1581985)
+  * Add conflicting Signed-By values to error message
+  * Normalize Signed-By values by removing trailing commas everywhere
+  * Pass -fvisibility-inlines-hidden to g++
+
+  [ Zhou Mo ]
+  * zh_CN.po: update simplified Chinese translation.
+
+  [ Yuri Kozlov ]
+  * Russian program translation update (Closes: 824702)
+
+  [ Takuma Yamada ]
+  * Japanese program translation update (Closes: 826291)
+
+ -- Julian Andres Klode <jak@debian.org>  Sat, 11 Jun 2016 17:23:19 +0200
+
+apt (1.3~exp1) experimental; urgency=medium
+
+  [ David Kalnischkies ]
+  * make random acquire queues work less random
+  * add dep11 files to default Release patterns
+  * don't ask server if we have entire file in partial/
+  * properly format multiline error messages
+  * format multiline errors properly in acquire progress
+  * show more details for "Hash Sum mismatch" errors
+  * show more details for "Writing more data" errors, too
+  * use the same redirection mirror for all index files
+  * edsp: ask policy engine for the pin of the version directly
+  * give rc-status packages a pin of -1
+  * respect user pinning in M-A:same version (un)screwing
+  * deprecate confusing Pkg.CandVersion() method
+  * factor out Pkg/DepIterator prettyprinters into own header
+  * gpgv: use EXPKEYSIG instead of KEYEXPIRED
+  * gpgv: handle expired sig as worthless
+  * don't show NO_PUBKEY warning if repo is signed by another key
+    (Closes: 618445)
+  * support multiple fingerprints in signed-by
+  * support Signed-By in Release files as a sort of HPKP
+  * bugscript: include all configuration fragment files (Closes: 820861)
+  * move gnupg|gnupg2 from apt Depends to Recommends
+  * warn if apt-key is run unconditionally in maintainerscript
+  * remove 100-levels config nesting limit
+  * let DPKG_COLORS default to our APT::Color setting
+  * allow redirection for items without a space in the desc again
+  * delay progress until Release files are downloaded
+  * download arch:all also for NATIVE_ARCHITECTURE indextargets
+  * implement Fallback-Of for IndexTargets
+  * implement Identifier field for IndexTargets
+  * gpgv: show always webportal error on NODATA (Closes: 823746)
+  * don't sent uninstallable rc-only versions via EDSP
+  * edsp: support generic and solver-specific configs (Closes: 823918)
+
+  [ Julian Andres Klode ]
+  * policy: Get rid of old (pre-1.1) GetCandidateVer algorithm
+  * private-show: Get rid of old policy support code
+  * ftparchive: Support writing Signed-By fields
+  * Strip trailing commas for created signed-by fingerprint lists
+  * update: Run Post-Invoke-Success if not all sources failed
+
+  [ Patrick Cable ]
+  * refactored no_proxy code to work regardless of where https proxy is set
+
+  [ James McCoy ]
+  * deb822: Restore support for <multivalue>-{Add,Remove}
+
+  [ Zhou Mo ]
+  * zh_TW.po: remove several fuzzy tags after review
+
+  [ Adrian Wielgosik ]
+  * Don't copy strings in Startswith, Endswith
+  * Speed up GetLocalitySortedVersionSet.
+
+  [ Frans Spiesschaert ]
+  * Dutch program translation update (Closes: 823976)
+
+ -- Julian Andres Klode <jak@debian.org>  Wed, 11 May 2016 10:48:27 +0200
+
+apt (1.2.11) unstable; urgency=medium
+
+  [ David Kalnischkies ]
+  * ensure transaction states are changed only once
+  * stop handling items in doomed transactions.
+    Thanks to Barr Detwix & Vincent Lefevre for log files (Closes: 817240)
+  * do not require non-broken systems in 'upgrade'
+  * detect compressed status files on extension again
+  * recheck Pre-Depends satisfaction in SmartConfigure (LP: #1569099)
+  * fix Alt-Filename handling of file method
+  * allow uncompressed files to be empty in store again
+  * silently skip acquire of empty index files
+  * ensure outdated files are dropped without lists-cleanup
+
+  [ Kelemen Gábor ]
+  * Hungarian program translation update (Closes: 820638)
+
+ -- Julian Andres Klode <jak@debian.org>  Mon, 25 Apr 2016 15:23:49 +0200
+
+apt (1.2.10) unstable; urgency=medium
+
+  [ Zhou Mo ]
+  * zh_CN.po: update simplified Chinese translation. (100%)
+
+  [ Julian Andres Klode ]
+  * test-apt-download-progress: Use a larger file for testing
+  * Allow lowering trust level of a hash via config
+
+  [ Michael Vogt ]
+  * Use systemd.timer instead of a cron job (Closes: #600262, #709675, #663290)
+    (LP: #246381, #727685)
+
+  [ David Kalnischkies ]
+  * use buffered writing for InRelease splitting
+
+  [ Takuma Yamada ]
+  * Japanese program translation update (Closes: 819938)
+
+ -- Michael Vogt <mvo@debian.org>  Tue, 05 Apr 2016 20:23:47 +0200
+
+apt (1.2.9) unstable; urgency=high
+
+  [ David Kalnischkies ]
+  * drop confusing comma from no strong hash message
+
+  [ Julian Andres Klode ]
+  * Do not mark packages for keep that we want to remove (LP: #1562402)
+    (This fixes some upgrades involving renames where the old package
+     is removed)
+
+ -- Julian Andres Klode <jak@debian.org>  Sun, 27 Mar 2016 01:26:51 +0100
+
+apt (1.2.8) unstable; urgency=medium
+
+  [ Michael Vogt ]
+  * Get accurate progress reporting in apt update again
+
+  [ Julian Andres Klode ]
+  * Report non-transient errors as errors, not as warnings
+  * methods/gpgv: Rewrite error handling and message.
+    Thanks to Ron Lee for wording suggestions
+  * Use descriptive URIs in 104 Warning messages
+  * cachefile: Only set members that were initialized successfully
+    (Closes: #818628)
+  * Update symbols file
+
+  [ David Kalnischkies ]
+  * do not strip epochs from state version strings (Closes: 818162)
+  * properly check for "all good sigs are weak" (Closes: 818910)
+  * handle gpgv's weak-digests ERRSIG
+
+  [ Zhou Mo ]
+  * zh_CN.po: update simplified Chinese translation. (Closes: #818639)
+
+  [ Takuma Yamada ]
+  * Japanese manpage translation update (Closes: 818950)
+
+ -- Julian Andres Klode <jak@debian.org>  Thu, 24 Mar 2016 19:31:24 +0100
+
 apt (1.2.7) unstable; urgency=medium
 
   "Caesar is dead"