]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* merged with apt--mvo--0
[apt.git] / debian / rules
index d6ae540ee0cc31289eb8b13f13231e91f1ba6137..94e3e2216a9c548fd675fe92ee115132bf64d7e8 100755 (executable)
@@ -209,7 +209,7 @@ apt: build debian/shlibs.local
 
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
 
-       cp share/*.gpg debian/$@/usr/share/$@
+       cp share/debian-archive.gpg debian/$@/usr/share/$@
 
 #      head -n 500 ChangeLog > debian/ChangeLog
 
@@ -269,6 +269,7 @@ apt-utils: build debian/shlibs.local
 
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
        dh_installdocs -p$@
+       dh_installexamples -p$@
 
        # Install the man pages..
        dh_installman -p$@
@@ -336,4 +337,4 @@ arch-build:
        mkdir -p debian/arch-build/apt-$(APT_DEBVER)
        baz inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
        $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
-       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))
+       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)