]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Fix whitespace in French translation of "Yes, do as I say!".
[apt.git] / debian / rules
index 9f13f71243c61d653c4e62489f6a6b16186b5182..0ac423c92c9e17de3ee31cdd039e926c4a2633f0 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.54 2003/08/10 23:54:57 mdz Exp $
+# $Id: rules,v 1.62 2003/12/24 22:55:30 mdz Exp $
 
 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -30,7 +30,7 @@ endif
 # Default rule
 build:
 
-DEB_BUILD_PROG:=debuild -us -uc
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc
 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 
@@ -53,7 +53,7 @@ endif
 ifneq ($(APT_DEBVER),$(APT_CONFVER))
 .PHONY: configure.in
 configure.in:
-       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
+       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
 else
 configure.in:
 endif
@@ -99,14 +99,6 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-ifneq ($(wildcard /usr/share/misc/config.sub),)
-       cp -a /usr/share/misc/config.sub buildlib/config.sub
-       echo Updating buildlib/config.sub
-endif
-ifneq ($(wildcard /usr/share/misc/config.guess),)
-       cp -a /usr/share/misc/config.guess buildlib/config.guess
-       echo Updating buildlib/config.guess
-endif
        cd build && ../configure $(confflags)
        touch $@
 
@@ -316,7 +308,7 @@ binary: binary-indep binary-arch
 
 cvs-build:
        rm -rf debian/cvs-build
-       cvs update
+       cvs update -d
        $(MAKE) startup
        $(MAKE) doc
        tar c --exclude CVS --exclude cvs-build --exclude '.#*' . |\