]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
rename packageset into cacheset while it is not too late
[apt.git] / debian / changelog
index c1ee360f0fd17b41d4bf20d7d48b0e8233edb08c..6b9057ae3927dd2d8a44675372beb5e98ab10273 100644 (file)
@@ -10,8 +10,30 @@ apt (0.7.26~exp6) UNRELEASED; urgency=low
     - do the autoremove mark process also for required packages to handle
       these illegally depending on lower priority packages (Closes: #583517)
     - try harder to find the other pseudo versions for autoremove multiarch
+  * apt-pkg/aptconfiguration.cc:
+    - remove duplicate architectures in getArchitectures()
+  * apt-pkg/indexrecords.{cc,h}:
+    - add a constant Exists check for MetaKeys
+  * apt-pkg/acquire-item.cc:
+    - do not try PDiff if it is not listed in the Meta file
+  * apt-pkg/cacheiterator.h:
+    - let pkgCache::Iterator inherent std::iterator
+  * apt-pkg/depcache.cc:
+    - correct "Dangerous iterator usage." pointed out by cppcheck
+  * ftparchive/writer.h:
+    - add a virtual destructor to FTWScanner class (for cppcheck)
+  * apt-pkg/cacheset.h:
+    - add a simple wrapper around std::set for packages with it
+    - move regex magic from apt-get to new FromRegEx method
+    - move cmdline parsing from apt-cache to new FromCommandLine method
+  * apt-pkg/contrib/cmdline.cc:
+    - fix segfault in SaveInConfig caused by writing over char[] sizes
+  * apt-pkg/pkgcache.cc:
+    - get the best matching arch package from a group with FindPreferredPkg
+  * cmdline/apt-cache.cc:
+    - make the search multiarch compatible by using GrpIterator instead
 
- -- David Kalnischkies <kalnischkies@gmail.com>  Fri, 28 May 2010 19:03:30 +0200
+ -- David Kalnischkies <kalnischkies@gmail.com>  Mon, 31 May 2010 20:00:24 +0200
 
 apt (0.7.26~exp5) experimental; urgency=low