]> git.saurik.com Git - apt.git/blob - debian/rules
Add a vcg command to apt-cache, similiar to dotty.
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.48 2003/02/12 14:31:41 doogie Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DH_COMPAT=2
18
19 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
20 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
21
22 # FOR AUTOCONF 2.52 AND NEWER ONLY
23 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
24 confflags += --build $(DEB_HOST_GNU_TYPE)
25 else
26 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
27 endif
28
29 # See below
30 -include build/environment.mak
31
32 # Default rule
33 build:
34
35 DEB_BUILD_PROG:=debuild -us -uc
36 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
37 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
38
39 # Determine the build directory to use
40 BASE=.
41 ifdef BUILD
42 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
43 else
44 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
45 endif
46 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
47 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
48 override BLD := $(BUILDX)
49
50 ifeq ($(words $(BLD)),0)
51 override BLD := ./build
52 endif
53
54 # Rebuild configure.in to have the correct version from the change log
55 ifneq ($(APT_DEBVER),$(APT_CONFVER))
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
59 else
60 configure.in:
61 endif
62
63 # APT Programs in apt-utils
64 APT_UTILS=ftparchive sortpkgs extracttemplates
65
66 # Uncomment this to turn on verbose mode.
67 #export DH_VERBOSE=1
68
69 # Find the libapt-pkg major version for use in other control files
70 export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
71 export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
72
73 # Determine which package we should provide in the control files
74 LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
75 LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
76
77 debian/shlibs.local: apt-pkg/makefile
78 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
79 # one for the rest of the packages. This ensures that each package gets
80 # the right overrides..
81 rm -rf $@ $@.apt $@.apt-utils
82 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
83
84 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
85 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
86
87 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
88 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
89
90 build: build/build-stamp
91 build-doc: build/build-doc-stamp
92
93 # Note that this is unconditionally done first as part of loading environment.mak
94 # The true is needed to force make to reload environment.mak after running
95 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
96 build/environment.mak: build/configure-stamp
97 @true
98
99 configure: configure.in
100 build/configure-stamp: configure
101 dh_testdir
102 -mkdir build
103 cp COPYING debian/copyright
104 ifneq ($(wildcard /usr/share/misc/config.sub),)
105 cp -a /usr/share/misc/config.sub buildlib/config.sub
106 echo Updating buildlib/config.sub
107 endif
108 ifneq ($(wildcard /usr/share/misc/config.guess),)
109 cp -a /usr/share/misc/config.guess buildlib/config.guess
110 echo Updating buildlib/config.guess
111 endif
112 cd build && ../configure $(confflags)
113 touch $@
114
115 build/build-stamp: build/configure-stamp
116 # Add here commands to compile the package.
117 $(MAKE) binary
118 touch $@
119
120 build/build-doc-stamp: build/configure-stamp
121 # Add here commands to compile the package.
122 $(MAKE) doc
123 touch $@
124
125 clean:
126 dh_testdir
127 # dh_testroot
128 -$(MAKE) clean
129 -$(MAKE) distclean
130
131 rm -rf build
132
133 # Add here commands to clean up after the build process.
134 dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
135
136 binary-indep: apt-doc libapt-pkg-doc
137 # Build architecture-independent files here.
138 libapt-pkg-doc: build-doc debian/shlibs.local
139 dh_testdir -p$@
140 dh_testroot -p$@
141 dh_clean -p$@ -k
142 dh_installdirs -p$@
143 #
144 # libapt-pkg-doc install
145 #
146 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
147 $(BLD)/docs/files* $(BLD)/docs/method* \
148 doc/libapt-pkg2_to_3.txt doc/style.txt
149 dh_installexamples -p$@
150 # dh_installmenu -p$@
151 # dh_installinit -p$@
152 # dh_installcron -p$@
153 # dh_installmanpages -p$@
154
155 # dh_undocumented -p$@
156 dh_installchangelogs -p$@
157 dh_strip -p$@
158 dh_compress -p$@
159 dh_fixperms -p$@
160 # dh_suidregister -p$@
161 dh_installdeb -p$@
162 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
163 dh_md5sums -p$@
164 dh_builddeb -p$@
165
166 apt-doc: build-doc
167 dh_testdir -p$@
168 dh_testroot -p$@
169 dh_clean -p$@ -k
170 #
171 # apt-doc install
172 #
173 # Copy the guides
174 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
175 $(BLD)/docs/offline.text $(BLD)/docs/offline.html
176 dh_installchangelogs -p$@
177 dh_compress -p$@
178 dh_fixperms -p$@
179 dh_installdeb -p$@
180 dh_gencontrol -p$@
181 dh_md5sums -p$@
182 dh_builddeb -p$@
183
184
185
186 # Build architecture-dependent files here.
187
188 binary-arch: apt libapt-pkg-dev apt-utils
189 apt: build debian/shlibs.local
190 dh_testdir -p$@
191 dh_testroot -p$@
192 dh_clean -p$@ -k
193 dh_installdirs -p$@ /usr/share
194 #
195 # apt install
196 #
197 cp $(BLD)/bin/apt-* debian/apt/usr/bin/
198
199 # Remove the bits that are in apt-utils
200 rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
201
202 # install the shared libs
203 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
204 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
205
206 cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
207
208 cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
209 cp -r $(BLD)/locale debian/apt/usr/share/
210
211 # head -n 500 ChangeLog > debian/ChangeLog
212
213 dh_installexamples -p$@ $(BLD)/docs/examples/*
214 dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1 apt-extracttemplates.1
215
216 dh_installchangelogs -p$@
217 dh_strip -p$@
218 dh_compress -p$@
219 dh_fixperms -p$@
220 dh_installdeb -p$@
221 dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
222 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
223 dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
224 dh_md5sums -p$@
225 dh_builddeb -p$@
226
227 libapt-pkg-dev: build debian/shlibs.local
228 dh_testdir -p$@
229 dh_testroot -p$@
230 dh_clean -p$@ -k
231 dh_installdirs -p$@
232 #
233 # libapt-pkg-dev install
234 #
235 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
236 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
237 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
238 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
239
240 dh_installdocs -p$@
241 # dh_installmenu -p$@
242 # dh_installinit -p$@
243 # dh_installcron -p$@
244 # dh_installmanpages -p$@
245
246 dh_installchangelogs -p$@
247 dh_strip -p$@
248 dh_compress -p$@
249 dh_fixperms -p$@
250 # dh_suidregister -p$@
251 dh_installdeb -p$@
252 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
253 dh_md5sums -p$@
254 dh_builddeb -p$@
255
256 apt-utils: build debian/shlibs.local
257 dh_testdir -p$@
258 dh_testroot -p$@
259 dh_clean -p$@ -k
260 dh_installdirs -p$@
261
262 # install the shared libs
263 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
264 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
265
266 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
267 dh_installdocs -p$@
268
269 # Install the man pages..
270 mkdir -p debian/$@/usr/share/man/man1
271 -cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 doc/apt-extracttemplates.1 debian/$@/usr/share/man/man1/
272
273 dh_installchangelogs -p$@
274 dh_strip -p$@
275 dh_compress -p$@
276 dh_fixperms -p$@
277 dh_installdeb -p$@
278 LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
279 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
280 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
281 dh_md5sums -p$@
282 dh_builddeb -p$@
283
284 source diff:
285 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
286
287 # Update from CVS
288 l33ch: really-clean
289 cvs update
290 buildlib/mkChangeLog
291
292 # Update from CVS and then configure for build
293 super-l33ch: l33ch Makefile.in
294
295 configure:
296 $(MAKE) configure
297
298 l33ch-stamp: super-l33ch
299 touch $@
300
301 really-clean: clean
302 -find -name Makefile.in -print0 | xargs -0r rm -f
303 find -name ChangeLog | xargs rm -f
304 rm -f l33ch-stamp
305
306 binary: binary-indep binary-arch
307 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
308
309
310 # Done by the uploader.
311 #cvs update..
312 #edit debian/changelog
313 # configure.in has the version automatically updated now.
314 # edit configure.in
315 # debian/rules cvs-build
316
317 cvs-build:
318 rm -rf debian/cvs-build
319 cvs update
320 $(MAKE) startup
321 $(MAKE) doc
322 tar c --exclude CVS --exclude cvs-build . |\
323 (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
324 (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
325
326 cvs-mkul:
327 -mkdir -p ../upload-$(APT_DEBVER)
328 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)