]> git.saurik.com Git - apt.git/blob - debian/changelog
Add a vcg command to apt-cache, similiar to dotty.
[apt.git] / debian / changelog
1 apt (0.5.4.9) unstable; urgency=low
2
3 * New deb version compare function, that has no integer limits, and
4 supports pre-versions using ~. Code ported from dpkg.
5 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
6 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
7 * "apt-get --arch-only build-dep" to install only architecture-
8 dependent build dependencies. Bump minor shared lib number to reflect
9 small change in BuildDepend API.
10 * APT::Build-Essential configuration option (defaults to "build-essential")
11 so that "apt-get build-dep" will ensure build essential packages are
12 installed prior to installing other build-dependencies. Closes: #148879
13 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
14 * /usr/doc reference in postinst. Closes: #126189
15 * Doc updates. Closes: #120689
16 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
17 #131062, #136749
18 * Print special message for EAI_AGAIN. Closes: #131397
19 * libapt-pkg-dev needs to bring in the apt-inst library if linking
20 is to work. Closes: #133943
21 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
22 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
23 #139994, #142955, #151654, #151834, #147611, #154268, #173971
24 * Fix possibility for tag file parsing to fail in some unlikely situations.
25 Closes: #139328
26 * Use std C++ names for some header files. Closes: #128741
27 * Do not check for free space if --no-download. Closes: #117856
28 * Actually implement or group handling for 'upgrade'. Closes: #133950
29 * "Internal Error, Couldn't configure pre-depend" is not actually an
30 internal error, it is a packaging error and now it says so, and
31 pinpoints the problem dependency. Closes: #155621
32 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
33 * Use usr/share/doc for dhelp. Closes: #115701
34 * --print-uris works with 'update'. Closes: #57070
35 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
36 command line.
37 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
38 #142298
39 * Allow an uninstalled package to be marked for removal on an install
40 line (meaning not to automatically install it), also fix some dodgy
41 handling of protected packages. Closes: #92287, #116011
42 * Fix errant prefix matching in version selection. Closes: #105968
43 * Ensure that all files needed to run APT as a user are readable and
44 ignore roots umask for these files. Closes: #108801
45 * Support larger config spaces. Closes: #111914
46 * 'apt-get update' no longer does 'Building Dependency Tree'.
47 * When matching regexs allways print a message. Change regex activation
48 charset. Closes: #147817
49 * Don't die if lines in sources.list are too long. Closes: #146846
50 * Show file name on apt-extracttemplate error messges. Closes: #151835
51 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
52 * Some highly unlikely memory faults. Closes: #155842
53 * C++ stuff for G++3.2. Closes: #162617, #165515,
54 * apt-config dumps sends to stdout not stderr now. Closes: #146294
55 * Fix segfault in FindAny when /i is used, and there is no default.
56 Closes: #165891
57 * Add s390x to archtable. Closese: #160992.
58 * Update config.sub/config.guess in cvs, and add support to debian/rules
59 to update them from /usr/share/misc if they exist. Closes: #155014
60 * Remove 'Sorry' from messages. Closes: #148824.
61 * Change wording of 'additional disk space usage' message. Closes:
62 #135021.
63 * apt-extracttemplates now prepends the package name when extracting
64 files. Closes: #132776
65 * Add -n synonym for --names-only for apt-cache. Closes: #130689
66 * Display both current version and new version in apt-get -s. Closes:
67 #92358
68 * Add an options and timeout config item to ssh/rsh. Closes: #90654
69 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
70 * Change verbose logging output of apt-ftparchive to go to stderr,
71 instead of stdout. Also, errors that occur no longer go to stdout,
72 but stderr. Closes: #161592
73 * Test for timegm in configure. Closes: #165516.
74 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
75 support compliation on platforms where st_mtime is a macro. Closes:
76 #165518
77 * Check the currently mounted cdrom, to see if it's the one we are
78 interested in. Closes: #154602
79 * Refer to reportbug instead of bug in the man pages. Closes: #173745
80 * Link apt-inst to apt-pkg. Closes: #175055
81 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
82 and others.
83 * Fix > 300 col screen segfault. Closes: #176052
84 * Rebuild with gcc-3.2. Closes: #177752, #178008.
85 * Fix build-dep handling of | dependencies.
86 Closes: #98640, #145997, #158896, #172901
87 * Double default value of APT::Cache-Limit, until such time as it
88 can be made more dynamic. Closes: #178623.
89 * Report uris with '.gz' when there are errors. Closes: #178435.
90 * When installing build-deps, make sure the new version will
91 satisfy build requirements. Closes: #178121
92 * Split offline and guide documentation into apt-doc. This was done so
93 that binary-arch builds do not require documention deps. Note, that
94 apt-doc is not installed on upgrades.
95 * Use doc-base, instead of dhelp directly. Closes: #110389
96 * Change http message 'Waiting for file' to 'Waiting for headers'.
97 Closes: #178537
98 * Remove trailing lines on package lists in apt-get. Closes: #178736.
99 * Fix origin pins for file:// uris. Closes: #189014.
100 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
101 #155194
102 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
103 Closes: #153734.
104 * Fix some typos in the apt-get manual. Closes: #163932.
105 * Apply patch from bug, to change frozen to testing, and then do it
106 everywhere else. Closes: #165085.
107 * Update es.po. Closes: #183111.
108 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
109 Closes: #183904.
110 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
111
112 -- Adam Heath <doogie@debian.org> Sun, 02 Feb 2003 02:54:45 -0600
113
114 apt (0.5.4) unstable; urgency=low
115
116 * M68k config.guess patch. Closes: #88913
117 * Bi-yearly test on OpenBSD and Solaris
118 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
119 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
120 #105606, #105377
121 * Various cosmetic code updates. Closes: #89066, #89066, #89152
122 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
123 update).
124 * More patches from Alfredo for Vendors and more SHA-1 stuff
125 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
126 similar situations. Closes: #56708, #59432
127 * no_proxy and ftp. Closes: #89671
128 * Philippe Batailler's man page patches.
129 * Fix for display bug. Closes: #92033, #93652, #98468
130 * Use more than 16bits for the dep ID. Some people ran out..
131 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
132 #106911, #107395, #108968
133 * Reordered some things to make dante and FTP happier. Closes: #92757
134 * James R. Van Zandt's guide.sgml updates. Closes: #90027
135 * apt-ftparchive copes with no uncompressed package files + contents.
136 * French man pages from philippe batailler - well sort of. They
137 don't build yet..
138 * run-parts. Closes: #94286
139 * 'apt-cache policy' preferences debug tool.
140 * Whatever. Closes: #89762
141 * libstdc++ and HURD. Closes: #92025
142 * More apt-utils verbage. Closes: #86954
143 * Fliped comparision operator. Closes: #94618
144 * Used the right copyright file. Closes: #65691
145 * Randolph's G++3 patches.
146 * Fixed no_proxy tokanizing. Closes: #100046
147 * Strip Config-Version when copying status to available. Closes: #97520
148 * Segfault with missing source files. Closes: #100325
149 * EINTR check. Closes: #102293
150 * Various changes to the locking metholodgy for --print-uris.
151 Closes: #100590
152 * Lame LD_LIBRARY_PATH thing. Closes: #98928
153 * apt-cache search searchs provide names too now. Closes: #98695
154 * Checksum and long lines problem. Closes: #106591
155 * .aptignr and empty files are just a warning. Closes: #97364
156
157 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
158
159 apt (0.5.3) unstable; urgency=low
160
161 * JoeyH's dpkg::preconfig not working. Closes: #88675
162 * Fixed apt override disparity
163 * Alfredo's SHA-1 and related patches
164
165 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
166
167 apt (0.5.2) unstable; urgency=low
168
169 * Fixed mention of /usr/doc in the long description
170 * JoeyH's downgrade bug -- don't use 0.5.1
171 * Doc bug. Closes: #88538
172 * Fault in building release strings. Closes: #88533
173
174 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
175
176 apt (0.5.1) unstable; urgency=low
177
178 * Fixed #82894 again, or should be and.
179 * Process the option string right. Closes: #86921
180 * Don't eat the last command for pipes. Closes: #86923
181 * Ignore .* for configuration directory processing. Closes: #86923
182 * Alfredo's no_proxy patch
183 * Documentation fixes. Closes: #87091
184 * JoeyH's double slash bug. Closes: #87266
185 * Unintitialized buffer and apt-ftparchive contents generation.
186 Closes: #87612
187 * Build-deps on virtual packages. Closes: #87639
188 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
189 libstdc++ version info in the library soname and in the package
190 provides. Closes: #87426
191 * Updated soname version to 0.3.2
192 * apt-extracttemplates moved from debconf into apt-utils
193 * s390 archtable entry. Closes: #88232
194 * Dan's segfault
195 * Some instances where the status file can source a package in a
196 non-sensical way. Closes: #87390
197 * Work better if there are duplicate sources.list entries.
198 * Fixed the resetting of Dir with "dir {};". Closes: #87323
199
200 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
201
202 apt (0.5.0) unstable; urgency=low
203
204 * Fixed an obscure bug with missing final double new lines in
205 package files
206 * Changed the apt-cdrom index copy routine to use the new section
207 rewriter
208 * Added a package file sorter, apt-sortpkgs
209 * Parse obsolete Optional dependencies.
210 * Added Ben's rsh method. Closes: #57794
211 * Added IPv6 FTP support and better DNS rotation support.
212 * Include the server IP in error messages when using a DNS rotation.
213 Closes: #64895
214 * Made most of the byte counters into doubles to prevent 32bit overflow.
215 Closes: #65349
216 * HTTP Authorization. Closes: #61158
217 * Ability to parse and return source index build depends from Randolph.
218 * new 'apt-get build-dep' command from Randolph. Closes: #63982
219 * Added apt-ftparchive the all dancing all singing FTP archive
220 maintinance program
221 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
222 in apt-get.
223 * Removed useless internal cruft including the xstatus file.
224 * Fixed config parser bugs. Closes: #67848, #71108
225 * Brain Damanged apt-get config options changed, does not change the command
226 line interface, except to allow --enable-* to undo a configuration
227 option:
228 No-Remove -> Remove
229 No-Download -> Download
230 No-Upgrade -> Upgrade
231 * Made this fix configable (DSelect::CheckDir) and default to disabled:
232 * No remove prompt if the archives dir has not changed. Closes: #55709
233 Because it is stupid in the case where no files were downloaded due to
234 a resumed-aborted install, or a full cache! Closes: #65952
235 * Obscure divide by zero problem. Closes: #64394
236 * Update sizetable for mips. Closes: #62288
237 * Fixed a bug with passive FTP connections
238 * Has sizetable entry for sparc64. Closes: #64869
239 * Escape special characters in the ::Label section of the cdroms.lst
240 * Created apt-utils and python-apt packages
241 * Due to the new policy engine, the available file may contain entries
242 from the status file. These are generated if the package is not obsolete
243 but the policy engine prohibits using the version from the package files.
244 They can be identified by the lack of a Filename field.
245 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
246 #36223, #33468, #22551
247 * Fixed deb-src line for non-us. Closes: #71501, #71601
248 * Fixes for G++ 2.96, s/friend/friend class/
249 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
250 * Confirmed fix for missing new line problem. Closes: #69386
251 * Fixed up dhelp files. Closes: #71312
252 * Added some notes about dselect and offline usage. Closes: #66473, #38316
253 * Lock files on read only file systems are ignored w/ warning.
254 Closes: #61701
255 * apt-get update foo now gives an error! Closes: #42891
256 * Added test for shlibs on hurd. Closes: #71499
257 * Clarified apt-cache document. Closes: #71934
258 * DocBook SGML man pages and some improvements in the text..
259 * sigwinch thing. Closes: #72382
260 * Caching can be turned off by setting the cache file names blank.
261 * Ignores arches it does not know about when autocleaning. Closes: #72862
262 * New function in apt-config to return dirs, files, bools and integers.
263 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
264 complex cases involving OR groups and provides.
265 68754 describes confusing messages which are the result of this..
266 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
267 * Speeling mistake and return code for the 'wicked' resolver error
268 Closes: #72621, #75226, #77464
269 * Solved unable to upgrade libc6 from potato to woody due to 3 package
270 libc6 dependency loop problem.
271 * Leading sources.list spaces. Closes: #76010
272 * Removed a possible infinite loop while processing installations.
273 * Man page updates. Closes: #75411, #75560, #64292, #78469
274 * ReduceSourceList bug. Closes: #76027
275 * --only-source option. Closes: #76320
276 * Typos. Closes: #77812, #77999
277 * Different status messages. Closes: #76652, #78353
278 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
279 * OS detection an support for the new pseduo standard of os-arch for the
280 Architecture string. Also uses regexing.. Closes: #39227, #72349
281 * Various i18n stuff. Note that this still needs some i18n wizard
282 to do the last gettextization right. Closes: #62386
283 * Fixed a problem with some odd http servers/proxies that did not return
284 the content size in the header. Closes: #79878, #44379
285 * Little acquire bugs. Closes: #77029, #55820
286 * _POSIX_THREADS may not be defined to anything, just defined..
287 Closes: #78996
288 * Spelling of Ignore-Hold correctly. Closes: #78042
289 * Unlock the dpkg db if in download only mode. Closes: #84851
290 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
291 * Patch from BenC. Closes: #80810
292 * Single output of some names in lists. Closes: #80498, #43286
293 * Nice message for people who can't read syserror output. Closes: #84734
294 * OR search function. Closes: #82894
295 * User's guide updates. Closes: #82469
296 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
297 * Various CD bugs, again thanks to Greenbush
298 Closes: #80946, #76547, #71810, #70049, #69482
299 * Using potato debhelper. Closes: #57977
300 * I cannot self-terminate. Closes: #74928
301
302 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
303
304 apt (0.3.19) frozen unstable; urgency=low
305
306 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
307 Paul Wade.
308 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
309 * Fixed hardcoded path. Closes: #59743
310 * Fixed Jay's relative path bug
311 * Allowed source only CDs. Closes: #58952
312 * Space check is supressed if --print-uris is given. Closes: #58965
313 * Clarified the documenation examples for non-us. Closes: #58646
314 * Typo in the package description. Closes: #60230
315 * Man Page typo. Closes: #60347
316 * Typo in Algorithms.cc. Closes: #63577
317 * Evil dotty function in apt-cache for generating dependency graphs
318 with the as-yet-unpackaged GraphVis.
319 * Appears to have been fixed in Janurary.. Closes: #57981
320 * New config.guess/sub for the new archs. Closes: #60874
321 * Fixed error reporting for certain kinds of resolution failures.
322 Closes: #61327
323 * Made autoclean respect 'q' settings. Closes: #63023
324 * Fixed up the example sources.list. Closes: #63676
325 * Added DPkg::FlushSTDIN to control the flushing of stdin before
326 forking dpkg. Closes: #63991
327
328 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
329
330 apt (0.3.18) frozen unstable; urgency=low
331
332 * Changes in the postinst script. Closes: #56855, #57237
333 * Fixed bashism. Closes: #57216, #57335
334 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
335
336 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
337
338 apt (0.3.17) unstable; urgency=low
339
340 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
341 * Fixed the configuration parser to not blow up if ; is in the config
342 string
343 * Applied visual patch to dselect install script . Closes #55214
344 * Included the configure-index example
345 * Minimal CD swaps
346 * Library soname has increased
347 * Fixed default sources.list to have correct URLs for potato when it
348 becomes stable
349 * Added a message about erasing sources.list to dselect setup script
350 Closes: #55755
351 * No remove prompt if the archives dir has not changed. Closes: #55709
352 * Fixed inclusion of 2nd sample config file. Closes: #55374
353 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
354 Closes: #55991
355
356 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
357
358 apt (0.3.16) unstable; urgency=low
359
360 * Made --no-download work. Closes: #52993
361 * Now compiles on OpenBSD, Solaris and HP-UX
362 * Clarify segfault errors
363 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
364 * Fix for Joel's discovery of glibc removal behavoir.
365 * Fix for Ben Collins file: uri from slink upgrade.
366 * Fixed resume code in FTP. Closes: #54323
367 * Take more precautions to prevent the corruption Joey Hess saw.
368 * Fixed --no-list-cleanup
369 * RFC 2732 URI parsing ([] for hostnames).
370 * Typo in apt-cache man page. Closes: #54949
371
372 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
373
374 apt (0.3.15) unstable; urgency=low
375
376 * Added DSelect::WaitAfterDownload Closes: #49549
377 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
378 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
379 * Made -s and clean not do anything. Closes: #50238
380 * Problem with Protected packages and the new OR code.
381 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
382 * Remove doesn't require a package to be installable. Closes: #51175
383 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
384
385 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
386
387 apt (0.3.14) unstable; urgency=low
388
389 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
390 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
391 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
392 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
393 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
394 Closes: #45034, #45695, #46537
395 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
396 * Added APT::Clean-Installed option. Closes: #45973
397 * Moves the free space check to after the calculated size is printed.
398 Closes: #46639, #47498
399 * mipsel arch Closes: #47614
400 * Beautified URI printing to not include passwords Closes: #46857
401 * Fixed little problem with --no-download Closes: #47557
402 * Tweaked Dselect 'update' script to re-gen the avail file even in the
403 event of a failure Closes: #47112
404 * Retries for source archives too Closes: #47529
405 * Unmounts CDROMs iff it mounted them Closes: #45299
406 * Checks for the partial directories before doing downloads Closes: #47392
407 * no_proxy environment variable (http only!) Closes: #43476
408 * apt-cache showsrc Closes: #45799
409 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
410 * Regexs for install. Closes: #35304, #38835
411 * Dependency reports now show OR group relations
412 * Re-Install feature. Cloes: #46961, #37393, #38919
413 * Locks archive directory on clean (woops)
414 * Remove is not 'sticky'. Closes: #48392
415 * Slightly more accurate 'can not find package' message. Closes: #48311
416 * --trivial-only and --no-remove. Closes: #48518
417 * Increased the cache size. Closes: #47648
418 * Comment woopsie. Closes: #48789
419 * Removes existing links when linking sources. Closes: #48775
420 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
421 * Clearer usage message about 'source' Closes: #48858
422 * Immediate configure internal error Closes: #49062, #48884
423
424 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
425
426 apt (0.3.13) unstable; urgency=low
427
428 * Fix timestamp miss in FTP. Closes: #44363
429 * Fix sorting of Kept packages. Closes: #44377
430 * Fix Segfault for dselect-upgrade. Closes: #44436
431 * Fix handling of '/' for the dist name. Closes #43830
432 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
433 * Add commented-out deb-src URI to default sources.list file.
434
435 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
436
437 apt (0.3.12) unstable; urgency=low
438
439 * Fix for typo in the dhelp index. Closes: #40377
440 * Multiple media swap support
441 * Purge support. Closes: #33291, #40694
442 * Better handling of - remove notation. Closes: #41024
443 * Purge support. Closes: #33291, #40694
444 * Error code on failed update. Closes: #41053
445 * apt-cdrom adds entries for source directories. Closes: #41231
446 * Sorts the output of any list. Closes: #41107
447 * Fixes the looping problem. Closes: #41784, #42414, #44022
448 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
449 * More checks to keep the display sane. Particularly when fail-over is
450 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
451 * PThread lockup problem on certain sparc/m68k. Closes: #40628
452 * apt-cdrom understands .gz Package files too. Closes: #42779
453 * Spelling error in dselect method description. Closes: #43251
454 * Added security to the default source list. Closes: #43356
455
456 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
457
458 apt (0.3.11) unstable; urgency=low
459
460 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
461 * Fix for properly upgrading the system from perl 5.004 to 5.005
462
463 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
464
465 apt (0.3.9) unstable; urgency=low
466
467 * Spelling error in cachefile.cc. Closes: #39885
468 * Trailing slash in dselect install if you try to use the
469 default config file. Closes: #40011
470 * Simulate works for autoclean. Closes: #39141
471 * Fixed spelling errors. Closes: #39673
472 * Changed url parsing a bit. Closes: #40070, #40069
473 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
474
475 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
476
477 apt (0.3.7) unstable; urgency=low
478
479 * Fixed missing text in the apt-get(8) page. Closes: #37596
480 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
481 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
482 * Fixed handling of the -q option with not-entirely integer arguments
483 Closes: #37499
484 * Man page typo Closes: #37762
485 * Fixed parsing of the Source: line. Closes: #37679
486 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
487 * Added a check for an empty cache directory. Closes: #37963
488 * Return a failure code if -d is given and packages fail to download.
489 Closes: #38127
490 * Arranged for an ftp proxy specifing an http server to work. See the
491 important note in the sources.list man page.
492 * Accounted for resumed files in the cps calculation. Closes: #36787
493 * Deal with duplicate same version different packages. Closes: #30237
494 * Added --no-download. Closes: #38095
495 * Order of apt-cdrom dist detection. Closes: #38139
496 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
497 * IPv6 http support
498 * Suggests dpkg-dev for apt-get source. Closes: #38158
499 * Fixed typo in apt-get help. Closes: #38712
500 * Improved the error message in the case of broken held package. Closes: #38777
501 * Fixed handling of MD5 failures
502 * Documented list notation Closes: #39008
503 * Change the 'b' to 'B'. Closes: #39007
504
505 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
506
507 apt (0.3.6) unstable; urgency=low
508
509 * Note that 0.3.5 never made it out the door..
510 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
511 * Made APT print numbers in decimal. Closes: #35617, #37319
512 * Buffer munching fix for FTP. Closes: #35868
513 * Typo in sample config file. Closes: #35907
514 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
515 * Changed installed size counter to only count unpacked packages.
516 Closes: #36201
517 * apt-get source support. Closes: #23934, #27190
518 * Renames .debs that fail MD5 checking, provides automatic corruption
519 recovery. Closes: #35931
520 * Fixed autoconf verison. Closes: #37305
521 * Random Segfaulting. Closes: #37312, #37530
522 * Fixed apt-cache man page. Closes: #36904
523 * Added a newline to apt-cache showpkg. Closes: #36903
524
525 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
526
527 apt (0.3.4) unstable; urgency=low
528
529 * Release for Ben while he is out of town.
530 * Checked the size of partial files. Closes: #33705
531 * apt-get should not print progress on non-tty. Closes: #34944
532 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
533 * Applied cdrom patches from Torsten. Closes: #35140, #35141
534 * smbmounted cdrom fix. Closes: #35470
535 * Changed ie to eg. Closes: #35196
536
537 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
538
539 apt (0.3.3) unstable; urgency=low
540
541 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
542
543 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
544
545 apt (0.3.2) unstable; urgency=low
546
547 * Major release into unstable of v3
548 * These bugs have been fixed, explanations are in the bug system, read
549 the man pages as well..
550 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
551 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
552 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
553 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
554 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
555 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
556 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
557 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
558
559 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
560
561 apt (0.3.1) experimental; urgency=low
562
563 * Minor release of cvs version.
564 * Added virtual package libapt-pkgx.x
565
566 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
567
568 apt (0.3.0) experimental; urgency=low
569
570 * New experimental version.
571
572 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
573
574 apt (0.1.9) frozen unstable; urgency=low
575
576 * Return to the wacky numbering for when we build 0.1.8 for hamm
577 * Important bug related to APT on the Alpha fixed
578 * apt-get dist-upgrade problems fixed
579 * tiny patch for http method to fix an endless loop
580 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
581 libtool and add proper shared lib dependancies
582 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
583 in case an old libpkg is installed while building APT to prevent
584 spurious dependancies
585
586 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
587
588 apt (0.1.7) unstable; urgency=low
589
590 * New build with libstdc++2.9.
591 * Various fixes; read the Changelog.
592
593 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
594
595 apt (0.1.6) unstable; urgency=low
596
597 * Various fixes in the FTP method for error checking. Fixes: #26188.
598 * Spelling corrections in dselect method. Fixes: #25884
599 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
600 * No more bo releases: we're using a normal numbering system now.
601
602 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
603
604 apt (0.1.5) unstable; urgency=low
605
606 * Changed sources.list to point to 'unstable' by default, as
607 'frozen' no longer exists!
608
609 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
610
611 apt (0.1.3) unstable; urgency=low
612
613 * New upstreamish version.
614 * ftp method rewritten in C. Removes dependancies on all perl/perl
615 related modules. This fixes many of the ftp method bugs.
616
617 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
618
619 apt (0.1.1) unstable; urgency=low
620
621 * Release for unstable.
622
623 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
624
625 apt (0.1) unstable; urgency=low
626
627 * Kludge to fix problem in libnet-perl with illegal anonymous
628 FTP passwords.
629 * Moved to unstable; apt is in a useable state now.
630 * Fixed version numbering. From now on, numbering will be:
631 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
632 0.1.1 (release for unstable). Thanks, Manoj.
633
634 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
635
636 apt (0.0.17-1) experimental; urgency=low
637
638 * Fixed problem with libc6 version compare
639 * Scott's away for a while, so I'll be packaging apt for the time
640 being.
641
642 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
643
644 apt (0.0.16-1) experimental; urgency=low
645
646 * Modifications to make apt-get more friendly when backgrounded.
647 * Updated documentation.
648 * Updates to graphic widgets
649
650 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
651
652 apt (0.0.15-0.2bo) experimental; urgency=low
653
654 * Bo compilation
655 * Bob Hilliards crash
656
657 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
658
659 apt (0.0.15-0.1bo) experimental; urgency=low
660
661 * Bo compilation
662 * libstdc++272 patch
663
664 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
665
666 apt (0.0.15) experimental; urgency=low
667
668 * Clean up source tarball (no user-visible changes)
669
670 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
671
672 apt (0.0.14) experimental; urgency=low
673
674 * Updates in ordering code to make sure certain upgrades work correctly.
675 * Made dselect/setup understand ftp as well as http
676
677 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
678
679 apt (0.0.13-bo1) experimental; urgency=low
680
681 * Bo compilation
682
683 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
684
685 apt (0.0.13) experimental; urgency=low
686
687 * Remove hardcoded egcc from debian/rules (#21575)
688 * Fixes for ordering logic when system has a number of unpacked
689 but unconfigured packages installed.
690 * Spelling fix in dselect install method (#22556)
691
692 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
693
694 apt (0.0.12) experimental; urgency=low
695
696 * Fixed problems with package cache corruption.
697 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
698 earlier versions.
699 * Interface and documentation improvements.
700
701 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
702
703 apt (0.0.11) experimental; urgency=low
704
705 * Change dependancies to pre-depends since breaking your packaging tools
706 in the middle of an installation isn't very good.
707 * Bug fixes to ftp method and general apt-get code
708
709 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
710
711 apt (0.0.10) experimental; urgency=low
712
713 * Run "dpkg --configure -a" after an aborted dselect install
714 * Fixed problem with install looping
715 * Support for authenticating proxys: (note this isn't terribly secure)
716 http_proxy="http://user:pass@firewall:port/"
717 * Substitute $ARCH in sources.list
718 * Fixes in the resumption code for ftp
719
720 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
721
722 apt (0.0.9) experimental; urgency=low
723
724 * Added ftp support.
725 * Various other less visible bug fixes.
726 * Fixed problem with segfault when apt-get invoked in a non-existant
727 directory (Bug #21863)
728 * Bumped policy to 2.4.1
729
730 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
731
732 apt (0.0.8) experimental; urgency=low
733
734 * Fixed generated available file (Bug #21836)
735 * Added download ETA (Bug #21774).
736 * Fixed hardcoded ARCH (Bug #21751).
737 * Fixed check on http_proxy (Bug #21795).
738 * Added download speed indicator.
739
740 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
741
742 apt (0.0.7) experimental; urgency=low
743
744 * Remove libdeity and apt from package for now, since only apt-get and
745 apt-cache are actually useful right now.
746 * Clean up handling of package installation errors.
747 * Added timeout to http transfers (#21269)
748 * Updated setup for dselect/apt method.
749 * Updated man pages
750 * Long options (added in 0.0.6)
751
752 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
753
754 apt (0.0.6) experimental; urgency=low
755
756 * Spelling changes.
757 * Revamped download status display.
758 * Call apt-get clean after successful install in dselect.
759 * Added "apt-get clean" which deletes package files from /var/cache/apt
760
761 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
762
763 apt (0.0.5) experimental; urgency=low
764
765 * Ignore signals while dpkg is running so we don't leave dpkg running in
766 the background (#20804)
767 * Check Packages as well as Packages.gz for file URIs (#20784)
768 * Spelling cleanup (#20800)
769 * Added -m option to permit upgrade to go on in the case of a bad mirror.
770 This option may result in incomplete upgrades when used with -f.
771
772 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
773
774 apt (0.0.4) experimental; urgency=low
775
776 * New usage guide.
777 * Various documentation updates and cleanup.
778 * Added '-f' option to apt-get attempt to fix broken dependancies.
779
780 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
781
782 apt (0.0.3) experimental; urgency=low
783
784 * Added a shlibs.local file to prevent apt from depending on itself.
785 * Updates to how apt-get handles bad states in installed packages.
786 * Updated rules to make sure build works from a freshly checked out source
787 archive. Building from CVS needs libtool/automake/autoconf, builds from
788 the distributed source package should have no such dependancy.
789
790 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
791
792 apt (0.0.2) unstable; urgency=low
793
794 * Updates to apt-get and http binding for dselect method (apt).
795 * Updating version number from 0.0.1, which was released only on IRC.
796
797 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
798
799 apt (0.0.1) unstable; urgency=low
800
801 * Initial Release.
802
803 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500
804