2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
6 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
7 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
9 # FOR AUTOCONF 2.52 AND NEWER ONLY
10 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
11 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
13 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
17 -include build
/environment.mak
19 ifneq (,$(shell which dpkg-buildflags
))
20 export CXXFLAGS
= $(shell dpkg-buildflags
--get CXXFLAGS
)
22 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
23 export CXXFLAGS
= -O0
-g
-Wall
25 export CXXFLAGS
= -O2
-g
-Wall
33 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
--preserve-envvar CCACHE_DIR
-us
-uc
$(DEB_BUILD_PROG_OPTS
)
34 APT_DEBVER
=$(shell dpkg-parsechangelog |sed
-n
-e
'/^Version:/s/^Version: //p' | sed
-e
's/\+.*$$//')
35 APT_CONFVER
=$(shell sed
-n
-e
's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in
)
36 APT_CVSTAG
=$(shell echo
"$(APT_DEBVER)" | sed
-e
's/^/v/' -e
's/\./_/g')
38 # Determine the build directory to use
41 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
43 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
--machine
) $(BASE
)/build
45 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
46 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
47 override BLD
:= $(BUILDX
)
49 ifeq ($(words $(BLD
)),0)
50 override BLD
:= .
/build
53 # Rebuild configure.in to have the correct version from the change log
54 ifneq ($(APT_DEBVER
),$(APT_CONFVER
))
55 ifneq ($(APT_DEBVER
),)
58 sed
-e
's/$(APT_CONFVER)/$(APT_DEBVER)/' $@
> $@.
$$$$ && mv
$@.
$$$$ $@
64 # APT Programs in apt-utils
65 APT_UTILS
=ftparchive sortpkgs extracttemplates
67 # Uncomment this to turn on verbose mode.
70 # Find the libapt-pkg major version for use in other control files
71 include buildlib
/libversion.mak
73 # do not fail as we are just experimenting with symbol files for now
74 export DPKG_GENSYMBOLS_CHECK_LEVEL
=0
76 build
: build
/build-stamp
77 build-doc
: build
/build-doc-stamp
79 # Note that this is unconditionally done first as part of loading environment.mak
80 # The true is needed to force make to reload environment.mak after running
81 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
82 build
/environment.mak
: build
/configure-stamp
85 configure
: configure.in
86 build
/configure-stamp
: configure
89 cp COPYING debian
/copyright
90 cd build
&& CXXFLAGS
="$(CXXFLAGS)" ..
/configure
$(confflags
)
93 build
/build-stamp
: build
/configure-stamp
94 # Add here commands to compile the package.
98 build
/build-doc-stamp
: build
/configure-stamp
99 # Add here commands to compile the package.
106 [ ! -f Makefile
] ||
$(MAKE
) clean distclean
109 binary-indep
: apt-doc libapt-pkg-doc
110 # Build architecture-independent files here.
111 libapt-pkg-doc
: build-doc
117 # libapt-pkg-doc install
119 # remove doxygen's embedded jquery as we don't use it anyway (#622147)
120 rm -f
$(BLD
)/doc
/doxygen
/html
/jquery.js
122 dh_installdocs
-p
$@
$(BLD
)/docs
/design
* \
123 $(BLD
)/docs
/dpkg-tech
* \
125 $(BLD
)/docs
/method
* \
126 doc
/libapt-pkg2_to_3.txt \
128 $(BLD
)/doc
/doxygen
/html
129 dh_installexamples
-p
$@
131 dh_installchangelogs
-p
$@
148 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text \
149 $(BLD
)/docs
/guide
*.html \
150 $(BLD
)/docs
/offline
*.text \
151 $(BLD
)/docs
/offline
*.html
152 dh_installchangelogs
-p
$@
162 # Build architecture-dependent files here.
164 binary-arch
: libapt-pkg4.10 libapt-inst1.2 apt libapt-pkg-dev apt-utils apt-transport-https
165 apt_MANPAGES
= apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
174 cp debian
/apt.conf.autoremove debian
/$@
/etc
/apt
/apt.conf.d
/01autoremove
176 # make rosetta happy and remove pot files in po/ (but leave stuff
177 # in po/domains/* untouched) and cp *.po into each domain dir
181 dh_install
-p
$@
--sourcedir
=$(BLD
)
183 # Remove the bits that are in apt-utils
184 rm $(addprefix debian
/$@
/usr
/bin
/apt-
,$(APT_UTILS
))
186 # https has its own package
187 rm debian
/$@
/usr
/lib
/apt
/methods
/https
189 # move the mirror failure script in place
190 #mv debian/$@/usr/bin/apt-report-mirror-failure \
191 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
195 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
196 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/%.
[158],$(apt_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt_MANPAGES
)))
199 dh_installchangelogs
-p
$@
200 dh_installlogrotate
-p
$@
205 dh_shlibdeps
-p
$@
-l
$(CURDIR
)/debian
/libapt-inst2.1
/usr
/lib
:$(CURDIR
)/debian
/libapt-pkg4.10
/usr
/lib
210 libapt-pkg-dev
: build
216 # libapt-pkg-dev install
218 dh_install
-p
$@
--sourcedir
=$(BLD
)
220 dh_installchangelogs
-p
$@
229 apt-utils_MANPAGES
= apt-sortpkgs apt-ftparchive apt-extracttemplates
236 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
238 dh_install
-p
$@
--sourcedir
=$(BLD
)
240 dh_installexamples
-p
$@
242 # Install the man pages..
243 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/%.
[158],$(apt-utils_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt-utils_MANPAGES
)))
245 dh_installchangelogs
-p
$@
251 dh_shlibdeps
-p
$@
-l
$(CURDIR
)/debian
/libapt-inst2.1
/usr
/lib
:$(CURDIR
)/debian
/libapt-pkg4.10
/usr
/lib
256 libapt-pkg4.10
: build
262 dh_install
-p
$@
--sourcedir
=$(BLD
)
263 dh_installchangelogs
-p
$@
274 libapt-inst1.2
: build
280 dh_install
-p
$@
--sourcedir
=$(BLD
)
281 dh_installchangelogs
-p
$@
287 dh_shlibdeps
-p
$@
-l
$(CURDIR
)/debian
/libapt-pkg4.10
/usr
/lib
292 apt-transport-https
: build libapt-pkg-dev
298 dh_install
-p
$@
--sourcedir
=$(BLD
)
299 dh_installdocs
-p
$@ debian
/apt-transport-https.README
300 dh_installexamples
-p
$@
302 # Install the man pages..
305 dh_installchangelogs
-p
$@
310 dh_shlibdeps
-p
$@
-l
$(CURDIR
)/debian
/apt
/usr
/lib
:$(CURDIR
)/debian
/$@
/usr
/lib
319 -find .
-name Makefile.in
-print0 | xargs
--null
--no-run-if-empty
-- rm -f
320 find
-name ChangeLog | xargs
rm -f
323 binary
: binary-indep binary-arch
324 .PHONY
: build
clean binary-indep binary-arch binary