]> git.saurik.com Git - apt.git/blob - debian/rules
do not include libapt-pkg* in apt itself, add missing dh_makeshlibs calls
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
8
9 # FOR AUTOCONF 2.52 AND NEWER ONLY
10 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
11 confflags += --build $(DEB_HOST_GNU_TYPE)
12 else
13 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
14 endif
15
16 # See below
17 -include build/environment.mak
18
19 ifneq (,$(shell which dpkg-buildflags))
20 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
21 else
22 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 export CXXFLAGS = -O0 -g -Wall
24 else
25 export CXXFLAGS = -O2 -g -Wall
26 endif
27 endif
28
29 # Default rule
30 build:
31
32 PKG=apt
33 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
34 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
35 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
36 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
37
38 # Determine the build directory to use
39 BASE=.
40 ifdef BUILD
41 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
42 else
43 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
44 endif
45 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
46 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
47 override BLD := $(BUILDX)
48
49 ifeq ($(words $(BLD)),0)
50 override BLD := ./build
51 endif
52
53 # Rebuild configure.in to have the correct version from the change log
54 ifneq ($(APT_DEBVER),$(APT_CONFVER))
55 ifneq ($(APT_DEBVER),)
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
59 endif
60 else
61 configure.in:
62 endif
63
64 # APT Programs in apt-utils
65 APT_UTILS=ftparchive sortpkgs extracttemplates
66
67 # Uncomment this to turn on verbose mode.
68 #export DH_VERBOSE=1
69
70 # Find the libapt-pkg major version for use in other control files
71 include buildlib/libversion.mak
72
73 # do not fail as we are just experimenting with symbol files for now
74 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
75
76 build: build/build-stamp
77 build-doc: build/build-doc-stamp
78
79 # Note that this is unconditionally done first as part of loading environment.mak
80 # The true is needed to force make to reload environment.mak after running
81 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
82 build/environment.mak: build/configure-stamp
83 @true
84
85 configure: configure.in
86 build/configure-stamp: configure
87 dh_testdir
88 -mkdir build
89 cp COPYING debian/copyright
90 cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
91 touch $@
92
93 build/build-stamp: build/configure-stamp
94 # Add here commands to compile the package.
95 $(MAKE) binary
96 touch $@
97
98 build/build-doc-stamp: build/configure-stamp
99 # Add here commands to compile the package.
100 $(MAKE) doc
101 touch $@
102
103 clean:
104 dh_testdir
105
106 [ ! -f Makefile ] || $(MAKE) clean distclean
107 rm -rf build
108
109 binary-indep: apt-doc libapt-pkg-doc
110 # Build architecture-independent files here.
111 libapt-pkg-doc: build-doc
112 dh_testdir -p$@
113 dh_testroot -p$@
114 dh_prep -p$@
115 dh_installdirs -p$@
116 #
117 # libapt-pkg-doc install
118 #
119 # remove doxygen's embedded jquery as we don't use it anyway (#622147)
120 rm -f $(BLD)/doc/doxygen/html/jquery.js
121
122 dh_installdocs -p$@ $(BLD)/docs/design* \
123 $(BLD)/docs/dpkg-tech* \
124 $(BLD)/docs/files* \
125 $(BLD)/docs/method* \
126 doc/libapt-pkg2_to_3.txt \
127 doc/style.txt \
128 $(BLD)/doc/doxygen/html
129 dh_installexamples -p$@
130
131 dh_installchangelogs -p$@
132 dh_strip -p$@
133 dh_compress -p$@
134 dh_fixperms -p$@
135 dh_installdeb -p$@
136 dh_gencontrol -p$@
137 dh_md5sums -p$@
138 dh_builddeb -p$@
139
140 apt-doc: build-doc
141 dh_testdir -p$@
142 dh_testroot -p$@
143 dh_prep -p$@
144 #
145 # apt-doc install
146 #
147 # Copy the guides
148 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
149 $(BLD)/docs/guide*.html \
150 $(BLD)/docs/offline*.text \
151 $(BLD)/docs/offline*.html
152 dh_installchangelogs -p$@
153 dh_compress -p$@
154 dh_fixperms -p$@
155 dh_installdeb -p$@
156 dh_gencontrol -p$@
157 dh_md5sums -p$@
158 dh_builddeb -p$@
159
160
161
162 # Build architecture-dependent files here.
163
164 binary-arch: libapt-pkg4.10 libapt-inst1.2 apt libapt-pkg-dev apt-utils apt-transport-https
165 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
166 apt: build build-doc
167 dh_testdir -p$@
168 dh_testroot -p$@
169 dh_prep -p$@
170 dh_installdirs -p$@
171 #
172 # apt install
173 #
174 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
175
176 # make rosetta happy and remove pot files in po/ (but leave stuff
177 # in po/domains/* untouched) and cp *.po into each domain dir
178 rm -f build/po/*.pot
179 rm -f po/*.pot
180
181 dh_install -p$@ --sourcedir=$(BLD)
182
183 # Remove the bits that are in apt-utils
184 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
185
186 # https has its own package
187 rm debian/$@/usr/lib/apt/methods/https
188
189 # move the mirror failure script in place
190 #mv debian/$@/usr/bin/apt-report-mirror-failure \
191 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
192
193 dh_bugfiles -p$@
194 dh_lintian -p$@
195 dh_installexamples -p$@ $(BLD)/docs/examples/*
196 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
197 dh_installcron -p$@
198 dh_installdocs -p$@
199 dh_installchangelogs -p$@
200 dh_installlogrotate -p$@
201 dh_strip -p$@
202 dh_compress -p$@
203 dh_fixperms -p$@
204 dh_installdeb -p$@
205 dh_shlibdeps -p$@ -l$(CURDIR)/debian/libapt-inst2.1/usr/lib:$(CURDIR)/debian/libapt-pkg4.10/usr/lib
206 dh_gencontrol -p$@
207 dh_md5sums -p$@
208 dh_builddeb -p$@
209
210 libapt-pkg-dev: build
211 dh_testdir -p$@
212 dh_testroot -p$@
213 dh_prep -p$@
214 dh_installdirs -p$@
215 #
216 # libapt-pkg-dev install
217 #
218 dh_install -p$@ --sourcedir=$(BLD)
219 dh_installdocs -p$@
220 dh_installchangelogs -p$@
221 dh_strip -p$@
222 dh_compress -p$@
223 dh_fixperms -p$@
224 dh_installdeb -p$@
225 dh_gencontrol -p$@
226 dh_md5sums -p$@
227 dh_builddeb -p$@
228
229 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
230 apt-utils: build
231 dh_testdir -p$@
232 dh_testroot -p$@
233 dh_prep -p$@
234 dh_installdirs -p$@
235
236 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
237
238 dh_install -p$@ --sourcedir=$(BLD)
239 dh_installdocs -p$@
240 dh_installexamples -p$@
241
242 # Install the man pages..
243 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
244
245 dh_installchangelogs -p$@
246 dh_strip -p$@
247 dh_compress -p$@
248 dh_fixperms -p$@
249 dh_makeshlibs -p$@
250 dh_installdeb -p$@
251 dh_shlibdeps -p$@ -l$(CURDIR)/debian/libapt-inst2.1/usr/lib:$(CURDIR)/debian/libapt-pkg4.10/usr/lib
252 dh_gencontrol -p$@
253 dh_md5sums -p$@
254 dh_builddeb -p$@
255
256 libapt-pkg4.10: build
257 dh_testdir -p$@
258 dh_testroot -p$@
259 dh_prep -p$@
260 dh_installdirs -p$@
261
262 dh_install -p$@ --sourcedir=$(BLD)
263 dh_installchangelogs -p$@
264 dh_strip -p$@
265 dh_compress -p$@
266 dh_fixperms -p$@
267 dh_installdeb -p$@
268 dh_makeshlibs -p$@
269 dh_shlibdeps -p$@
270 dh_gencontrol -p$@
271 dh_md5sums -p$@
272 dh_builddeb -p$@
273
274 libapt-inst1.2: build
275 dh_testdir -p$@
276 dh_testroot -p$@
277 dh_prep -p$@
278 dh_installdirs -p$@
279
280 dh_install -p$@ --sourcedir=$(BLD)
281 dh_installchangelogs -p$@
282 dh_strip -p$@
283 dh_compress -p$@
284 dh_fixperms -p$@
285 dh_installdeb -p$@
286 dh_makeshlibs -p$@
287 dh_shlibdeps -p$@ -l$(CURDIR)/debian/libapt-pkg4.10/usr/lib
288 dh_gencontrol -p$@
289 dh_md5sums -p$@
290 dh_builddeb -p$@
291
292 apt-transport-https: build libapt-pkg-dev
293 dh_testdir -p$@
294 dh_testroot -p$@
295 dh_prep -p$@
296 dh_installdirs -p$@
297
298 dh_install -p$@ --sourcedir=$(BLD)
299 dh_installdocs -p$@ debian/apt-transport-https.README
300 dh_installexamples -p$@
301
302 # Install the man pages..
303 dh_installman -p$@
304
305 dh_installchangelogs -p$@
306 dh_strip -p$@
307 dh_compress -p$@
308 dh_fixperms -p$@
309 dh_installdeb -p$@
310 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
311 dh_gencontrol -p$@
312 dh_md5sums -p$@
313 dh_builddeb -p$@
314
315 configure:
316 $(MAKE) configure
317
318 really-clean: clean
319 -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
320 find -name ChangeLog | xargs rm -f
321 rm -f l33ch-stamp
322
323 binary: binary-indep binary-arch
324 .PHONY: build clean binary-indep binary-arch binary