2 # Copyright (C) 2009, 2016 Julian Andres Klode <jak@debian.org>
4 # Free Software, licensed under the GPL-2 or (at your option) any later version.
5 export DEB_LDFLAGS_MAINT_APPEND
:= -Wl
,--as-needed
6 export DEB_BUILD_MAINT_OPTIONS
:= hardening
=+all
8 # do not fail as we are just experimenting with symbol files for now
9 export DPKG_GENSYMBOLS_CHECK_LEVEL
=0
11 export CTEST_OUTPUT_ON_FAILURE
=1
14 dh
$@
--with systemd
--parallel
--buildsystem
=cmake
16 override_dh_install-indep
:
18 dh_install
--list-missing
20 override_dh_install-arch
:
22 if
[ -e debian
/tmp
/etc
/apt
]; then dh_install
-papt etc
/apt
/* etc
/apt
; fi
23 dh_install
--list-missing
24 install -m
644 debian
/apt.conf.autoremove debian
/apt
/etc
/apt
/apt.conf.d
/01autoremove
25 install -m
755 debian
/apt.auto-removal.sh debian
/apt
/etc
/kernel
/postinst.d
/apt-auto-removal
27 override_dh_gencontrol
:
28 dh_gencontrol
-- -Vapt
:keyring
="$(shell ./vendor/getinfo keyring-package)"
30 override_dh_installcron
:
31 dh_installcron
--name
=apt-compat
34 override_dh_auto_configure-arch
: flags
=-DWITH_DOC
=OFF
35 override_dh_auto_configure-indep
: flags
=-DWITH_DOC
=ON
36 override_dh_auto_configure-arch override_dh_auto_configure-indep
:
37 dh_auto_configure
-- $(flags
)