]> git.saurik.com Git - apt.git/blob - debian/changelog
Add a rdepends command to apt-cache.
[apt.git] / debian / changelog
1 apt (0.5.4.9) unstable; urgency=low
2
3 * New deb version compare function, that has no integer limits, and
4 supports pre-versions using ~. Code ported from dpkg.
5 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
6 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
7 * "apt-get --arch-only build-dep" to install only architecture-
8 dependent build dependencies. Bump minor shared lib number to reflect
9 small change in BuildDepend API.
10 * APT::Build-Essential configuration option (defaults to "build-essential")
11 so that "apt-get build-dep" will ensure build essential packages are
12 installed prior to installing other build-dependencies. Closes: #148879
13 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
14 * /usr/doc reference in postinst. Closes: #126189
15 * Doc updates. Closes: #120689
16 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
17 #131062, #136749
18 * Print special message for EAI_AGAIN. Closes: #131397
19 * libapt-pkg-dev needs to bring in the apt-inst library if linking
20 is to work. Closes: #133943
21 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
22 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
23 #139994, #142955, #151654, #151834, #147611, #154268, #173971
24 * Fix possibility for tag file parsing to fail in some unlikely situations.
25 Closes: #139328
26 * Use std C++ names for some header files. Closes: #128741
27 * Do not check for free space if --no-download. Closes: #117856
28 * Actually implement or group handling for 'upgrade'. Closes: #133950
29 * "Internal Error, Couldn't configure pre-depend" is not actually an
30 internal error, it is a packaging error and now it says so, and
31 pinpoints the problem dependency. Closes: #155621
32 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
33 * Use usr/share/doc for dhelp. Closes: #115701
34 * --print-uris works with 'update'. Closes: #57070
35 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
36 command line.
37 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
38 #142298
39 * Allow an uninstalled package to be marked for removal on an install
40 line (meaning not to automatically install it), also fix some dodgy
41 handling of protected packages. Closes: #92287, #116011
42 * Fix errant prefix matching in version selection. Closes: #105968
43 * Ensure that all files needed to run APT as a user are readable and
44 ignore roots umask for these files. Closes: #108801
45 * Support larger config spaces. Closes: #111914
46 * 'apt-get update' no longer does 'Building Dependency Tree'.
47 * When matching regexs allways print a message. Change regex activation
48 charset. Closes: #147817
49 * Don't die if lines in sources.list are too long. Closes: #146846
50 * Show file name on apt-extracttemplate error messges. Closes: #151835
51 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
52 * Some highly unlikely memory faults. Closes: #155842
53 * C++ stuff for G++3.2. Closes: #162617, #165515,
54 * apt-config dumps sends to stdout not stderr now. Closes: #146294
55 * Fix segfault in FindAny when /i is used, and there is no default.
56 Closes: #165891
57 * Add s390x to archtable. Closese: #160992.
58 * Update config.sub/config.guess in cvs, and add support to debian/rules
59 to update them from /usr/share/misc if they exist. Closes: #155014
60 * Remove 'Sorry' from messages. Closes: #148824.
61 * Change wording of 'additional disk space usage' message. Closes:
62 #135021.
63 * apt-extracttemplates now prepends the package name when extracting
64 files. Closes: #132776
65 * Add -n synonym for --names-only for apt-cache. Closes: #130689
66 * Display both current version and new version in apt-get -s. Closes:
67 #92358
68 * Add an options and timeout config item to ssh/rsh. Closes: #90654
69 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
70 * Change verbose logging output of apt-ftparchive to go to stderr,
71 instead of stdout. Also, errors that occur no longer go to stdout,
72 but stderr. Closes: #161592
73 * Test for timegm in configure. Closes: #165516.
74 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
75 support compliation on platforms where st_mtime is a macro. Closes:
76 #165518
77 * Check the currently mounted cdrom, to see if it's the one we are
78 interested in. Closes: #154602
79 * Refer to reportbug instead of bug in the man pages. Closes: #173745
80 * Link apt-inst to apt-pkg. Closes: #175055
81 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
82 and others.
83 * Fix > 300 col screen segfault. Closes: #176052
84 * Rebuild with gcc-3.2. Closes: #177752, #178008.
85 * Fix build-dep handling of | dependencies.
86 Closes: #98640, #145997, #158896, #172901
87 * Double default value of APT::Cache-Limit, until such time as it
88 can be made more dynamic. Closes: #178623.
89 * Report uris with '.gz' when there are errors. Closes: #178435.
90 * When installing build-deps, make sure the new version will
91 satisfy build requirements. Closes: #178121
92 * Split offline and guide documentation into apt-doc. This was done so
93 that binary-arch builds do not require documention deps. Note, that
94 apt-doc is not installed on upgrades.
95 * Use doc-base, instead of dhelp directly. Closes: #110389
96 * Change http message 'Waiting for file' to 'Waiting for headers'.
97 Closes: #178537
98 * Remove trailing lines on package lists in apt-get. Closes: #178736.
99 * Fix origin pins for file:// uris. Closes: #189014.
100 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
101 #155194
102 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
103 Closes: #153734.
104 * Fix some typos in the apt-get manual. Closes: #163932.
105 * Apply patch from bug, to change frozen to testing, and then do it
106 everywhere else. Closes: #165085.
107 * Update es.po. Closes: #183111.
108 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
109 Closes: #183904.
110 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
111 * Add option to apt-get to show versions of packages being
112 upgraded/installed.
113 * Be quiet in apt.post{inst,rm}. Closes: #70685.
114 * apt-get now prints out suggested and recommended packages. Closes:
115 #54982.
116 * Insert some newlines in the cdrom change media message. Closes:
117 #154601.
118 * Add a rdepends command to apt-cache. Closes: #159864.
119
120 -- Adam Heath <doogie@debian.org> Sun, 02 Feb 2003 02:54:45 -0600
121
122 apt (0.5.4) unstable; urgency=low
123
124 * M68k config.guess patch. Closes: #88913
125 * Bi-yearly test on OpenBSD and Solaris
126 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
127 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
128 #105606, #105377
129 * Various cosmetic code updates. Closes: #89066, #89066, #89152
130 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
131 update).
132 * More patches from Alfredo for Vendors and more SHA-1 stuff
133 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
134 similar situations. Closes: #56708, #59432
135 * no_proxy and ftp. Closes: #89671
136 * Philippe Batailler's man page patches.
137 * Fix for display bug. Closes: #92033, #93652, #98468
138 * Use more than 16bits for the dep ID. Some people ran out..
139 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
140 #106911, #107395, #108968
141 * Reordered some things to make dante and FTP happier. Closes: #92757
142 * James R. Van Zandt's guide.sgml updates. Closes: #90027
143 * apt-ftparchive copes with no uncompressed package files + contents.
144 * French man pages from philippe batailler - well sort of. They
145 don't build yet..
146 * run-parts. Closes: #94286
147 * 'apt-cache policy' preferences debug tool.
148 * Whatever. Closes: #89762
149 * libstdc++ and HURD. Closes: #92025
150 * More apt-utils verbage. Closes: #86954
151 * Fliped comparision operator. Closes: #94618
152 * Used the right copyright file. Closes: #65691
153 * Randolph's G++3 patches.
154 * Fixed no_proxy tokanizing. Closes: #100046
155 * Strip Config-Version when copying status to available. Closes: #97520
156 * Segfault with missing source files. Closes: #100325
157 * EINTR check. Closes: #102293
158 * Various changes to the locking metholodgy for --print-uris.
159 Closes: #100590
160 * Lame LD_LIBRARY_PATH thing. Closes: #98928
161 * apt-cache search searchs provide names too now. Closes: #98695
162 * Checksum and long lines problem. Closes: #106591
163 * .aptignr and empty files are just a warning. Closes: #97364
164
165 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
166
167 apt (0.5.3) unstable; urgency=low
168
169 * JoeyH's dpkg::preconfig not working. Closes: #88675
170 * Fixed apt override disparity
171 * Alfredo's SHA-1 and related patches
172
173 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
174
175 apt (0.5.2) unstable; urgency=low
176
177 * Fixed mention of /usr/doc in the long description
178 * JoeyH's downgrade bug -- don't use 0.5.1
179 * Doc bug. Closes: #88538
180 * Fault in building release strings. Closes: #88533
181
182 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
183
184 apt (0.5.1) unstable; urgency=low
185
186 * Fixed #82894 again, or should be and.
187 * Process the option string right. Closes: #86921
188 * Don't eat the last command for pipes. Closes: #86923
189 * Ignore .* for configuration directory processing. Closes: #86923
190 * Alfredo's no_proxy patch
191 * Documentation fixes. Closes: #87091
192 * JoeyH's double slash bug. Closes: #87266
193 * Unintitialized buffer and apt-ftparchive contents generation.
194 Closes: #87612
195 * Build-deps on virtual packages. Closes: #87639
196 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
197 libstdc++ version info in the library soname and in the package
198 provides. Closes: #87426
199 * Updated soname version to 0.3.2
200 * apt-extracttemplates moved from debconf into apt-utils
201 * s390 archtable entry. Closes: #88232
202 * Dan's segfault
203 * Some instances where the status file can source a package in a
204 non-sensical way. Closes: #87390
205 * Work better if there are duplicate sources.list entries.
206 * Fixed the resetting of Dir with "dir {};". Closes: #87323
207
208 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
209
210 apt (0.5.0) unstable; urgency=low
211
212 * Fixed an obscure bug with missing final double new lines in
213 package files
214 * Changed the apt-cdrom index copy routine to use the new section
215 rewriter
216 * Added a package file sorter, apt-sortpkgs
217 * Parse obsolete Optional dependencies.
218 * Added Ben's rsh method. Closes: #57794
219 * Added IPv6 FTP support and better DNS rotation support.
220 * Include the server IP in error messages when using a DNS rotation.
221 Closes: #64895
222 * Made most of the byte counters into doubles to prevent 32bit overflow.
223 Closes: #65349
224 * HTTP Authorization. Closes: #61158
225 * Ability to parse and return source index build depends from Randolph.
226 * new 'apt-get build-dep' command from Randolph. Closes: #63982
227 * Added apt-ftparchive the all dancing all singing FTP archive
228 maintinance program
229 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
230 in apt-get.
231 * Removed useless internal cruft including the xstatus file.
232 * Fixed config parser bugs. Closes: #67848, #71108
233 * Brain Damanged apt-get config options changed, does not change the command
234 line interface, except to allow --enable-* to undo a configuration
235 option:
236 No-Remove -> Remove
237 No-Download -> Download
238 No-Upgrade -> Upgrade
239 * Made this fix configable (DSelect::CheckDir) and default to disabled:
240 * No remove prompt if the archives dir has not changed. Closes: #55709
241 Because it is stupid in the case where no files were downloaded due to
242 a resumed-aborted install, or a full cache! Closes: #65952
243 * Obscure divide by zero problem. Closes: #64394
244 * Update sizetable for mips. Closes: #62288
245 * Fixed a bug with passive FTP connections
246 * Has sizetable entry for sparc64. Closes: #64869
247 * Escape special characters in the ::Label section of the cdroms.lst
248 * Created apt-utils and python-apt packages
249 * Due to the new policy engine, the available file may contain entries
250 from the status file. These are generated if the package is not obsolete
251 but the policy engine prohibits using the version from the package files.
252 They can be identified by the lack of a Filename field.
253 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
254 #36223, #33468, #22551
255 * Fixed deb-src line for non-us. Closes: #71501, #71601
256 * Fixes for G++ 2.96, s/friend/friend class/
257 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
258 * Confirmed fix for missing new line problem. Closes: #69386
259 * Fixed up dhelp files. Closes: #71312
260 * Added some notes about dselect and offline usage. Closes: #66473, #38316
261 * Lock files on read only file systems are ignored w/ warning.
262 Closes: #61701
263 * apt-get update foo now gives an error! Closes: #42891
264 * Added test for shlibs on hurd. Closes: #71499
265 * Clarified apt-cache document. Closes: #71934
266 * DocBook SGML man pages and some improvements in the text..
267 * sigwinch thing. Closes: #72382
268 * Caching can be turned off by setting the cache file names blank.
269 * Ignores arches it does not know about when autocleaning. Closes: #72862
270 * New function in apt-config to return dirs, files, bools and integers.
271 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
272 complex cases involving OR groups and provides.
273 68754 describes confusing messages which are the result of this..
274 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
275 * Speeling mistake and return code for the 'wicked' resolver error
276 Closes: #72621, #75226, #77464
277 * Solved unable to upgrade libc6 from potato to woody due to 3 package
278 libc6 dependency loop problem.
279 * Leading sources.list spaces. Closes: #76010
280 * Removed a possible infinite loop while processing installations.
281 * Man page updates. Closes: #75411, #75560, #64292, #78469
282 * ReduceSourceList bug. Closes: #76027
283 * --only-source option. Closes: #76320
284 * Typos. Closes: #77812, #77999
285 * Different status messages. Closes: #76652, #78353
286 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
287 * OS detection an support for the new pseduo standard of os-arch for the
288 Architecture string. Also uses regexing.. Closes: #39227, #72349
289 * Various i18n stuff. Note that this still needs some i18n wizard
290 to do the last gettextization right. Closes: #62386
291 * Fixed a problem with some odd http servers/proxies that did not return
292 the content size in the header. Closes: #79878, #44379
293 * Little acquire bugs. Closes: #77029, #55820
294 * _POSIX_THREADS may not be defined to anything, just defined..
295 Closes: #78996
296 * Spelling of Ignore-Hold correctly. Closes: #78042
297 * Unlock the dpkg db if in download only mode. Closes: #84851
298 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
299 * Patch from BenC. Closes: #80810
300 * Single output of some names in lists. Closes: #80498, #43286
301 * Nice message for people who can't read syserror output. Closes: #84734
302 * OR search function. Closes: #82894
303 * User's guide updates. Closes: #82469
304 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
305 * Various CD bugs, again thanks to Greenbush
306 Closes: #80946, #76547, #71810, #70049, #69482
307 * Using potato debhelper. Closes: #57977
308 * I cannot self-terminate. Closes: #74928
309
310 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
311
312 apt (0.3.19) frozen unstable; urgency=low
313
314 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
315 Paul Wade.
316 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
317 * Fixed hardcoded path. Closes: #59743
318 * Fixed Jay's relative path bug
319 * Allowed source only CDs. Closes: #58952
320 * Space check is supressed if --print-uris is given. Closes: #58965
321 * Clarified the documenation examples for non-us. Closes: #58646
322 * Typo in the package description. Closes: #60230
323 * Man Page typo. Closes: #60347
324 * Typo in Algorithms.cc. Closes: #63577
325 * Evil dotty function in apt-cache for generating dependency graphs
326 with the as-yet-unpackaged GraphVis.
327 * Appears to have been fixed in Janurary.. Closes: #57981
328 * New config.guess/sub for the new archs. Closes: #60874
329 * Fixed error reporting for certain kinds of resolution failures.
330 Closes: #61327
331 * Made autoclean respect 'q' settings. Closes: #63023
332 * Fixed up the example sources.list. Closes: #63676
333 * Added DPkg::FlushSTDIN to control the flushing of stdin before
334 forking dpkg. Closes: #63991
335
336 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
337
338 apt (0.3.18) frozen unstable; urgency=low
339
340 * Changes in the postinst script. Closes: #56855, #57237
341 * Fixed bashism. Closes: #57216, #57335
342 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
343
344 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
345
346 apt (0.3.17) unstable; urgency=low
347
348 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
349 * Fixed the configuration parser to not blow up if ; is in the config
350 string
351 * Applied visual patch to dselect install script . Closes #55214
352 * Included the configure-index example
353 * Minimal CD swaps
354 * Library soname has increased
355 * Fixed default sources.list to have correct URLs for potato when it
356 becomes stable
357 * Added a message about erasing sources.list to dselect setup script
358 Closes: #55755
359 * No remove prompt if the archives dir has not changed. Closes: #55709
360 * Fixed inclusion of 2nd sample config file. Closes: #55374
361 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
362 Closes: #55991
363
364 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
365
366 apt (0.3.16) unstable; urgency=low
367
368 * Made --no-download work. Closes: #52993
369 * Now compiles on OpenBSD, Solaris and HP-UX
370 * Clarify segfault errors
371 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
372 * Fix for Joel's discovery of glibc removal behavoir.
373 * Fix for Ben Collins file: uri from slink upgrade.
374 * Fixed resume code in FTP. Closes: #54323
375 * Take more precautions to prevent the corruption Joey Hess saw.
376 * Fixed --no-list-cleanup
377 * RFC 2732 URI parsing ([] for hostnames).
378 * Typo in apt-cache man page. Closes: #54949
379
380 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
381
382 apt (0.3.15) unstable; urgency=low
383
384 * Added DSelect::WaitAfterDownload Closes: #49549
385 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
386 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
387 * Made -s and clean not do anything. Closes: #50238
388 * Problem with Protected packages and the new OR code.
389 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
390 * Remove doesn't require a package to be installable. Closes: #51175
391 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
392
393 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
394
395 apt (0.3.14) unstable; urgency=low
396
397 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
398 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
399 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
400 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
401 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
402 Closes: #45034, #45695, #46537
403 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
404 * Added APT::Clean-Installed option. Closes: #45973
405 * Moves the free space check to after the calculated size is printed.
406 Closes: #46639, #47498
407 * mipsel arch Closes: #47614
408 * Beautified URI printing to not include passwords Closes: #46857
409 * Fixed little problem with --no-download Closes: #47557
410 * Tweaked Dselect 'update' script to re-gen the avail file even in the
411 event of a failure Closes: #47112
412 * Retries for source archives too Closes: #47529
413 * Unmounts CDROMs iff it mounted them Closes: #45299
414 * Checks for the partial directories before doing downloads Closes: #47392
415 * no_proxy environment variable (http only!) Closes: #43476
416 * apt-cache showsrc Closes: #45799
417 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
418 * Regexs for install. Closes: #35304, #38835
419 * Dependency reports now show OR group relations
420 * Re-Install feature. Cloes: #46961, #37393, #38919
421 * Locks archive directory on clean (woops)
422 * Remove is not 'sticky'. Closes: #48392
423 * Slightly more accurate 'can not find package' message. Closes: #48311
424 * --trivial-only and --no-remove. Closes: #48518
425 * Increased the cache size. Closes: #47648
426 * Comment woopsie. Closes: #48789
427 * Removes existing links when linking sources. Closes: #48775
428 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
429 * Clearer usage message about 'source' Closes: #48858
430 * Immediate configure internal error Closes: #49062, #48884
431
432 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
433
434 apt (0.3.13) unstable; urgency=low
435
436 * Fix timestamp miss in FTP. Closes: #44363
437 * Fix sorting of Kept packages. Closes: #44377
438 * Fix Segfault for dselect-upgrade. Closes: #44436
439 * Fix handling of '/' for the dist name. Closes #43830
440 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
441 * Add commented-out deb-src URI to default sources.list file.
442
443 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
444
445 apt (0.3.12) unstable; urgency=low
446
447 * Fix for typo in the dhelp index. Closes: #40377
448 * Multiple media swap support
449 * Purge support. Closes: #33291, #40694
450 * Better handling of - remove notation. Closes: #41024
451 * Purge support. Closes: #33291, #40694
452 * Error code on failed update. Closes: #41053
453 * apt-cdrom adds entries for source directories. Closes: #41231
454 * Sorts the output of any list. Closes: #41107
455 * Fixes the looping problem. Closes: #41784, #42414, #44022
456 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
457 * More checks to keep the display sane. Particularly when fail-over is
458 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
459 * PThread lockup problem on certain sparc/m68k. Closes: #40628
460 * apt-cdrom understands .gz Package files too. Closes: #42779
461 * Spelling error in dselect method description. Closes: #43251
462 * Added security to the default source list. Closes: #43356
463
464 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
465
466 apt (0.3.11) unstable; urgency=low
467
468 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
469 * Fix for properly upgrading the system from perl 5.004 to 5.005
470
471 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
472
473 apt (0.3.9) unstable; urgency=low
474
475 * Spelling error in cachefile.cc. Closes: #39885
476 * Trailing slash in dselect install if you try to use the
477 default config file. Closes: #40011
478 * Simulate works for autoclean. Closes: #39141
479 * Fixed spelling errors. Closes: #39673
480 * Changed url parsing a bit. Closes: #40070, #40069
481 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
482
483 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
484
485 apt (0.3.7) unstable; urgency=low
486
487 * Fixed missing text in the apt-get(8) page. Closes: #37596
488 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
489 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
490 * Fixed handling of the -q option with not-entirely integer arguments
491 Closes: #37499
492 * Man page typo Closes: #37762
493 * Fixed parsing of the Source: line. Closes: #37679
494 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
495 * Added a check for an empty cache directory. Closes: #37963
496 * Return a failure code if -d is given and packages fail to download.
497 Closes: #38127
498 * Arranged for an ftp proxy specifing an http server to work. See the
499 important note in the sources.list man page.
500 * Accounted for resumed files in the cps calculation. Closes: #36787
501 * Deal with duplicate same version different packages. Closes: #30237
502 * Added --no-download. Closes: #38095
503 * Order of apt-cdrom dist detection. Closes: #38139
504 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
505 * IPv6 http support
506 * Suggests dpkg-dev for apt-get source. Closes: #38158
507 * Fixed typo in apt-get help. Closes: #38712
508 * Improved the error message in the case of broken held package. Closes: #38777
509 * Fixed handling of MD5 failures
510 * Documented list notation Closes: #39008
511 * Change the 'b' to 'B'. Closes: #39007
512
513 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
514
515 apt (0.3.6) unstable; urgency=low
516
517 * Note that 0.3.5 never made it out the door..
518 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
519 * Made APT print numbers in decimal. Closes: #35617, #37319
520 * Buffer munching fix for FTP. Closes: #35868
521 * Typo in sample config file. Closes: #35907
522 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
523 * Changed installed size counter to only count unpacked packages.
524 Closes: #36201
525 * apt-get source support. Closes: #23934, #27190
526 * Renames .debs that fail MD5 checking, provides automatic corruption
527 recovery. Closes: #35931
528 * Fixed autoconf verison. Closes: #37305
529 * Random Segfaulting. Closes: #37312, #37530
530 * Fixed apt-cache man page. Closes: #36904
531 * Added a newline to apt-cache showpkg. Closes: #36903
532
533 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
534
535 apt (0.3.4) unstable; urgency=low
536
537 * Release for Ben while he is out of town.
538 * Checked the size of partial files. Closes: #33705
539 * apt-get should not print progress on non-tty. Closes: #34944
540 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
541 * Applied cdrom patches from Torsten. Closes: #35140, #35141
542 * smbmounted cdrom fix. Closes: #35470
543 * Changed ie to eg. Closes: #35196
544
545 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
546
547 apt (0.3.3) unstable; urgency=low
548
549 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
550
551 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
552
553 apt (0.3.2) unstable; urgency=low
554
555 * Major release into unstable of v3
556 * These bugs have been fixed, explanations are in the bug system, read
557 the man pages as well..
558 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
559 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
560 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
561 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
562 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
563 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
564 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
565 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
566
567 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
568
569 apt (0.3.1) experimental; urgency=low
570
571 * Minor release of cvs version.
572 * Added virtual package libapt-pkgx.x
573
574 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
575
576 apt (0.3.0) experimental; urgency=low
577
578 * New experimental version.
579
580 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
581
582 apt (0.1.9) frozen unstable; urgency=low
583
584 * Return to the wacky numbering for when we build 0.1.8 for hamm
585 * Important bug related to APT on the Alpha fixed
586 * apt-get dist-upgrade problems fixed
587 * tiny patch for http method to fix an endless loop
588 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
589 libtool and add proper shared lib dependancies
590 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
591 in case an old libpkg is installed while building APT to prevent
592 spurious dependancies
593
594 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
595
596 apt (0.1.7) unstable; urgency=low
597
598 * New build with libstdc++2.9.
599 * Various fixes; read the Changelog.
600
601 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
602
603 apt (0.1.6) unstable; urgency=low
604
605 * Various fixes in the FTP method for error checking. Fixes: #26188.
606 * Spelling corrections in dselect method. Fixes: #25884
607 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
608 * No more bo releases: we're using a normal numbering system now.
609
610 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
611
612 apt (0.1.5) unstable; urgency=low
613
614 * Changed sources.list to point to 'unstable' by default, as
615 'frozen' no longer exists!
616
617 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
618
619 apt (0.1.3) unstable; urgency=low
620
621 * New upstreamish version.
622 * ftp method rewritten in C. Removes dependancies on all perl/perl
623 related modules. This fixes many of the ftp method bugs.
624
625 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
626
627 apt (0.1.1) unstable; urgency=low
628
629 * Release for unstable.
630
631 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
632
633 apt (0.1) unstable; urgency=low
634
635 * Kludge to fix problem in libnet-perl with illegal anonymous
636 FTP passwords.
637 * Moved to unstable; apt is in a useable state now.
638 * Fixed version numbering. From now on, numbering will be:
639 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
640 0.1.1 (release for unstable). Thanks, Manoj.
641
642 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
643
644 apt (0.0.17-1) experimental; urgency=low
645
646 * Fixed problem with libc6 version compare
647 * Scott's away for a while, so I'll be packaging apt for the time
648 being.
649
650 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
651
652 apt (0.0.16-1) experimental; urgency=low
653
654 * Modifications to make apt-get more friendly when backgrounded.
655 * Updated documentation.
656 * Updates to graphic widgets
657
658 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
659
660 apt (0.0.15-0.2bo) experimental; urgency=low
661
662 * Bo compilation
663 * Bob Hilliards crash
664
665 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
666
667 apt (0.0.15-0.1bo) experimental; urgency=low
668
669 * Bo compilation
670 * libstdc++272 patch
671
672 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
673
674 apt (0.0.15) experimental; urgency=low
675
676 * Clean up source tarball (no user-visible changes)
677
678 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
679
680 apt (0.0.14) experimental; urgency=low
681
682 * Updates in ordering code to make sure certain upgrades work correctly.
683 * Made dselect/setup understand ftp as well as http
684
685 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
686
687 apt (0.0.13-bo1) experimental; urgency=low
688
689 * Bo compilation
690
691 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
692
693 apt (0.0.13) experimental; urgency=low
694
695 * Remove hardcoded egcc from debian/rules (#21575)
696 * Fixes for ordering logic when system has a number of unpacked
697 but unconfigured packages installed.
698 * Spelling fix in dselect install method (#22556)
699
700 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
701
702 apt (0.0.12) experimental; urgency=low
703
704 * Fixed problems with package cache corruption.
705 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
706 earlier versions.
707 * Interface and documentation improvements.
708
709 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
710
711 apt (0.0.11) experimental; urgency=low
712
713 * Change dependancies to pre-depends since breaking your packaging tools
714 in the middle of an installation isn't very good.
715 * Bug fixes to ftp method and general apt-get code
716
717 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
718
719 apt (0.0.10) experimental; urgency=low
720
721 * Run "dpkg --configure -a" after an aborted dselect install
722 * Fixed problem with install looping
723 * Support for authenticating proxys: (note this isn't terribly secure)
724 http_proxy="http://user:pass@firewall:port/"
725 * Substitute $ARCH in sources.list
726 * Fixes in the resumption code for ftp
727
728 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
729
730 apt (0.0.9) experimental; urgency=low
731
732 * Added ftp support.
733 * Various other less visible bug fixes.
734 * Fixed problem with segfault when apt-get invoked in a non-existant
735 directory (Bug #21863)
736 * Bumped policy to 2.4.1
737
738 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
739
740 apt (0.0.8) experimental; urgency=low
741
742 * Fixed generated available file (Bug #21836)
743 * Added download ETA (Bug #21774).
744 * Fixed hardcoded ARCH (Bug #21751).
745 * Fixed check on http_proxy (Bug #21795).
746 * Added download speed indicator.
747
748 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
749
750 apt (0.0.7) experimental; urgency=low
751
752 * Remove libdeity and apt from package for now, since only apt-get and
753 apt-cache are actually useful right now.
754 * Clean up handling of package installation errors.
755 * Added timeout to http transfers (#21269)
756 * Updated setup for dselect/apt method.
757 * Updated man pages
758 * Long options (added in 0.0.6)
759
760 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
761
762 apt (0.0.6) experimental; urgency=low
763
764 * Spelling changes.
765 * Revamped download status display.
766 * Call apt-get clean after successful install in dselect.
767 * Added "apt-get clean" which deletes package files from /var/cache/apt
768
769 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
770
771 apt (0.0.5) experimental; urgency=low
772
773 * Ignore signals while dpkg is running so we don't leave dpkg running in
774 the background (#20804)
775 * Check Packages as well as Packages.gz for file URIs (#20784)
776 * Spelling cleanup (#20800)
777 * Added -m option to permit upgrade to go on in the case of a bad mirror.
778 This option may result in incomplete upgrades when used with -f.
779
780 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
781
782 apt (0.0.4) experimental; urgency=low
783
784 * New usage guide.
785 * Various documentation updates and cleanup.
786 * Added '-f' option to apt-get attempt to fix broken dependancies.
787
788 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
789
790 apt (0.0.3) experimental; urgency=low
791
792 * Added a shlibs.local file to prevent apt from depending on itself.
793 * Updates to how apt-get handles bad states in installed packages.
794 * Updated rules to make sure build works from a freshly checked out source
795 archive. Building from CVS needs libtool/automake/autoconf, builds from
796 the distributed source package should have no such dependancy.
797
798 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
799
800 apt (0.0.2) unstable; urgency=low
801
802 * Updates to apt-get and http binding for dselect method (apt).
803 * Updating version number from 0.0.1, which was released only on IRC.
804
805 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
806
807 apt (0.0.1) unstable; urgency=low
808
809 * Initial Release.
810
811 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500
812