]> git.saurik.com Git - apt.git/blob - debian/rules
Display both current version and new version in apt-get -s.
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.41 2002/11/09 20:21:54 doogie Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DH_COMPAT=2
18
19 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
20 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
21
22 # FOR AUTOCONF 2.52 AND NEWER ONLY
23 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
24 confflags += --build $(DEB_HOST_GNU_TYPE)
25 else
26 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
27 endif
28
29 # See below
30 -include build/environment.mak
31
32 # Default rule
33 build:
34
35 DEB_BUILD_PROG:=debuild -us -uc
36 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
37 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
38
39 # Determine the build directory to use
40 BASE=.
41 ifdef BUILD
42 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
43 else
44 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
45 endif
46 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
47 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
48 override BLD := $(BUILDX)
49
50 ifeq ($(words $(BLD)),0)
51 override BLD := ./build
52 endif
53
54 # Rebuild configure.in to have the correct version from the change log
55 ifneq ($(APT_DEBVER),$(APT_CONFVER))
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
59 else
60 configure.in:
61 endif
62
63 # APT Programs in apt-utils
64 APT_UTILS=ftparchive sortpkgs extracttemplates
65
66 # Uncomment this to turn on verbose mode.
67 #export DH_VERBOSE=1
68
69 # Find the libapt-pkg major version for use in other control files
70 export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
71 export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
72
73 # Determine which package we should provide in the control files
74 LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
75 LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
76
77 debian/shlibs.local: apt-pkg/makefile
78 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
79 # one for the rest of the packages. This ensures that each package gets
80 # the right overrides..
81 rm -rf $@ $@.apt $@.apt-utils
82 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
83
84 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
85 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
86
87 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
88 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
89
90 build: build/build-stamp
91
92 # Note that this is unconditionally done first as part of loading environment.mak
93 # The true is needed to force make to reload environment.mak after running
94 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
95 build/environment.mak: build/configure-stamp
96 @true
97
98 configure: configure.in
99 build/configure-stamp: configure
100 dh_testdir
101 -mkdir build
102 cp COPYING debian/copyright
103 ifneq ($(wildcard /usr/share/misc/config.sub),)
104 cp -a /usr/share/misc/config.sub buildlib/config.sub
105 echo Updating buildlib/config.sub
106 endif
107 ifneq ($(wildcard /usr/share/misc/config.guess),)
108 cp -a /usr/share/misc/config.guess buildlib/config.guess
109 echo Updating buildlib/config.guess
110 endif
111 (cd build; ../configure $(confflags))
112 touch $@
113
114 build/build-stamp: build/configure-stamp
115 # Add here commands to compile the package.
116 $(MAKE) -s
117 touch $@
118
119 clean:
120 dh_testdir
121 # dh_testroot
122 rm -f build-stamp debian/shlibs.local
123 rm -rf build
124 rm -f debian/shlibs.local.apt debian/shlibs.local.apt-utils
125
126 # Add here commands to clean up after the build process.
127 -$(MAKE) clean
128 -$(MAKE) distclean
129 dh_clean debian/copyright
130
131 binary-indep: libapt-pkg-doc
132 # Build architecture-independent files here.
133 libapt-pkg-doc: build debian/shlibs.local
134 dh_testdir -p$@
135 dh_testroot -p$@
136 dh_clean -p$@ -k
137 dh_installdirs -p$@
138 #
139 # libapt-pkg-doc install
140 #
141 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
142 $(BLD)/docs/files* $(BLD)/docs/method* \
143 doc/libapt-pkg2_to_3.txt doc/style.txt
144
145 -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
146 -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
147
148 dh_installexamples -p$@
149 # dh_installmenu -p$@
150 # dh_installinit -p$@
151 # dh_installcron -p$@
152 # dh_installmanpages -p$@
153
154 # dh_undocumented -p$@
155 dh_installchangelogs -p$@
156 dh_strip -p$@
157 dh_compress -p$@
158 dh_fixperms -p$@
159 # dh_suidregister -p$@
160 dh_installdeb -p$@
161 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
162 dh_md5sums -p$@
163 dh_builddeb -p$@
164
165
166 # Build architecture-dependent files here.
167
168 binary-arch: apt libapt-pkg-dev apt-utils
169 apt: build debian/shlibs.local
170 dh_testdir -p$@
171 dh_testroot -p$@
172 dh_clean -p$@ -k
173 dh_installdirs -p$@
174 #
175 # apt install
176 #
177 cp $(BLD)/bin/apt-* debian/apt/usr/bin/
178
179 # Remove the bits that are in apt-utils
180 rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
181
182 # install the shared libs
183 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
184 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
185
186 cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
187
188 cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
189 cp -r $(BLD)/locale debian/apt/usr/
190
191 # Copy the guides
192 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
193 $(BLD)/docs/offline.text $(BLD)/docs/offline.html
194
195 # One or the other..
196 -cp -a debian/dhelp debian/apt/usr/doc/apt/.dhelp
197 -cp -a debian/dhelp debian/apt/usr/share/doc/apt/.dhelp
198
199 # head -n 500 ChangeLog > debian/ChangeLog
200
201 dh_installexamples -p$@ $(BLD)/docs/examples/*
202 dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1 apt-extracttemplates.1
203
204 dh_installchangelogs -p$@
205 dh_strip -p$@
206 dh_compress -p$@
207 dh_fixperms -p$@
208 dh_installdeb -p$@
209 dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
210 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
211 dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
212 dh_md5sums -p$@
213 dh_builddeb -p$@
214
215 libapt-pkg-dev: build debian/shlibs.local
216 dh_testdir -p$@
217 dh_testroot -p$@
218 dh_clean -p$@ -k
219 dh_installdirs -p$@
220 #
221 # libapt-pkg-dev install
222 #
223 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
224 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
225 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
226 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
227
228 dh_installdocs -p$@
229 # dh_installmenu -p$@
230 # dh_installinit -p$@
231 # dh_installcron -p$@
232 # dh_installmanpages -p$@
233
234 dh_installchangelogs -p$@
235 dh_strip -p$@
236 dh_compress -p$@
237 dh_fixperms -p$@
238 # dh_suidregister -p$@
239 dh_installdeb -p$@
240 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
241 dh_md5sums -p$@
242 dh_builddeb -p$@
243
244 apt-utils: build debian/shlibs.local
245 dh_testdir -p$@
246 dh_testroot -p$@
247 dh_clean -p$@ -k
248 dh_installdirs -p$@
249
250 # install the shared libs
251 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
252 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
253
254 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
255 dh_installdocs -p$@
256
257 # Install the man pages..
258 mkdir -p debian/$@/usr/share/man/man1
259 -cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 doc/apt-extracttemplates.1 debian/$@/usr/share/man/man1/
260
261 dh_installchangelogs -p$@
262 dh_strip -p$@
263 dh_compress -p$@
264 dh_fixperms -p$@
265 dh_installdeb -p$@
266 LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
267 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
268 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
269 dh_md5sums -p$@
270 dh_builddeb -p$@
271
272 source diff:
273 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
274
275 # Update from CVS
276 l33ch: really-clean
277 cvs update
278 buildlib/mkChangeLog
279
280 # Update from CVS and then configure for build
281 super-l33ch: l33ch Makefile.in
282
283 configure:
284 $(MAKE) configure
285
286 l33ch-stamp: super-l33ch
287 touch $@
288
289 really-clean: clean
290 -find -name Makefile.in -print0 | xargs -0r rm -f
291 find -name ChangeLog | xargs rm -f
292 rm -f l33ch-stamp
293
294 binary: binary-indep binary-arch
295 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
296
297
298 # Done by the uploader.
299 #cvs update..
300 #edit debian/changelog
301 # configure.in has the version automatically updated now.
302 # edit configure.in
303 # debian/rules cvs-build
304
305 cvs-build:
306 rm -rf debian/cvs-build
307 cvs update
308 $(MAKE) startup
309 $(MAKE) doc
310 tar c --exclude CVS --exclude cvs-build . |\
311 (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
312 (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
313
314 cvs-mkul:
315 -mkdir -p ../upload-$(APT_DEBVER)
316 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)