1 apt (0.5.6) unstable; urgency=low
3 * Adam Heath <doogie@debian.org>
4 - Fix segfault when handling /etc/apt/preferences. Closes: #192409.
5 * Matt Zimmerman <mdz@debian.org>
6 - Clean up some string handling, patch from Peter Lundkvist
7 <p.lundkvist@telia.com> (Closes: #192225)
8 - Don't fall off the end of the buffer when comparing versions.
9 Patch from Koblinger Egmont <egmont@uhulinux.hu> (Closes: #194327)
10 - Minor fixes to apt-ftparchive(1) (Closes: #118156)
11 - Fix typo in apt-ftparchive help text (Closes: #119072)
12 - More typos in apt-ftparchive help text (Closes: #190936)
13 - Update config.guess, config.sub to latest versions
14 - Modify the description for apt-utils to reflect the fact that it is not
15 (any longer) infrequently used (Closes: #138045)
16 - Make setup script for dselect method more explicit about
17 overwriting sources.list (Closes: #151727)
18 - Fix typo in apt-cache(8) (Closes: #161243)
19 - Remove duplicate 'showpkg' from synopsis on apt-cache(8)
21 - Document in apt-get(8) the meaning of the '*' in ShowList, which is that
22 the package is being purged (Closes: #182369)
23 - Fix extra "/" character in apt.conf(5) (Closes: #185545)
24 - Fix typo in tar error message (Closes: #191424)
25 - Clarify description of 'search' on apt-cache(8) (Closes: #192216)
26 - Fix incorrect path for 'partial' directory on apt-get(8)
28 - Fixes to pt_BR translation from Andre Luis Lopes <andrelop@ig.com.br>
30 - Updated apt_preferences(5) man page with many corrections and
31 clarifications from Thomas Hood <jdthood@yahoo.co.uk>
33 - Fix SGML validation errors in apt-cache.8.sgml introduced in 0.5.5 or so
37 apt (0.5.5.1) unstable; urgency=low
39 * Move the target of the example docs from doc to binary. Closes:
41 * Fix api breakage that broke apt-ftparchive and apt-cache dumpavail, by
42 backing out change that incorretly attempted to handle Package sections
43 larger than 32k. Closes: #192373
44 * Fix never-ending loop with apt-get install -V. Closes: #192355.
46 -- Adam Heath <doogie@debian.org> Mon, 19 May 2003 12:30:16 -0500
48 apt (0.5.5) unstable; urgency=low
50 * New deb version compare function, that has no integer limits, and
51 supports pre-versions using ~. Code ported from dpkg.
52 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
53 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
54 * "apt-get --arch-only build-dep" to install only architecture-
55 dependent build dependencies. Bump minor shared lib number to reflect
56 small change in BuildDepend API.
57 * APT::Build-Essential configuration option (defaults to "build-essential")
58 so that "apt-get build-dep" will ensure build essential packages are
59 installed prior to installing other build-dependencies. Closes: #148879
60 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
61 * /usr/doc reference in postinst. Closes: #126189
62 * Doc updates. Closes: #120689
63 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
65 * Print special message for EAI_AGAIN. Closes: #131397
66 * libapt-pkg-dev needs to bring in the apt-inst library if linking
67 is to work. Closes: #133943
68 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
69 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
70 #139994, #142955, #151654, #151834, #147611, #154268, #173971
71 * Fix possibility for tag file parsing to fail in some unlikely situations.
73 * Use std C++ names for some header files. Closes: #128741
74 * Do not check for free space if --no-download. Closes: #117856
75 * Actually implement or group handling for 'upgrade'. Closes: #133950
76 * "Internal Error, Couldn't configure pre-depend" is not actually an
77 internal error, it is a packaging error and now it says so, and
78 pinpoints the problem dependency. Closes: #155621
79 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
80 * Use usr/share/doc for dhelp. Closes: #115701
81 * --print-uris works with 'update'. Closes: #57070
82 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
84 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
86 * Allow an uninstalled package to be marked for removal on an install
87 line (meaning not to automatically install it), also fix some dodgy
88 handling of protected packages. Closes: #92287, #116011
89 * Fix errant prefix matching in version selection. Closes: #105968
90 * Ensure that all files needed to run APT as a user are readable and
91 ignore roots umask for these files. Closes: #108801
92 * Support larger config spaces. Closes: #111914
93 * 'apt-get update' no longer does 'Building Dependency Tree'.
94 * When matching regexs allways print a message. Change regex activation
95 charset. Closes: #147817
96 * Don't die if lines in sources.list are too long. Closes: #146846
97 * Show file name on apt-extracttemplate error messges. Closes: #151835
98 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
99 * Some highly unlikely memory faults. Closes: #155842
100 * C++ stuff for G++3.2. Closes: #162617, #165515,
101 * apt-config dumps sends to stdout not stderr now. Closes: #146294
102 * Fix segfault in FindAny when /i is used, and there is no default.
104 * Add s390x to archtable. Closese: #160992.
105 * Update config.sub/config.guess in cvs, and add support to debian/rules
106 to update them from /usr/share/misc if they exist. Closes: #155014
107 * Remove 'Sorry' from messages. Closes: #148824.
108 * Change wording of 'additional disk space usage' message. Closes:
110 * apt-extracttemplates now prepends the package name when extracting
111 files. Closes: #132776
112 * Add -n synonym for --names-only for apt-cache. Closes: #130689
113 * Display both current version and new version in apt-get -s. Closes:
115 * Add an options and timeout config item to ssh/rsh. Closes: #90654
116 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
117 * Change verbose logging output of apt-ftparchive to go to stderr,
118 instead of stdout. Also, errors that occur no longer go to stdout,
119 but stderr. Closes: #161592
120 * Test for timegm in configure. Closes: #165516.
121 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
122 support compliation on platforms where st_mtime is a macro. Closes:
124 * Check the currently mounted cdrom, to see if it's the one we are
125 interested in. Closes: #154602
126 * Refer to reportbug instead of bug in the man pages. Closes: #173745
127 * Link apt-inst to apt-pkg. Closes: #175055
128 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
130 * Fix > 300 col screen segfault. Closes: #176052
131 * Rebuild with gcc-3.2. Closes: #177752, #178008.
132 * Fix build-dep handling of | dependencies.
133 Closes: #98640, #145997, #158896, #172901
134 * Double default value of APT::Cache-Limit, until such time as it
135 can be made more dynamic. Closes: #178623.
136 * Report uris with '.gz' when there are errors. Closes: #178435.
137 * When installing build-deps, make sure the new version will
138 satisfy build requirements. Closes: #178121
139 * Split offline and guide documentation into apt-doc. This was done so
140 that binary-arch builds do not require documention deps. Note, that
141 apt-doc is not installed on upgrades.
142 * Use doc-base, instead of dhelp directly. Closes: #110389
143 * Change http message 'Waiting for file' to 'Waiting for headers'.
145 * Remove trailing lines on package lists in apt-get. Closes: #178736.
146 * Fix origin pins for file:// uris. Closes: #189014.
147 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
149 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
151 * Fix some typos in the apt-get manual. Closes: #163932.
152 * Apply patch from bug, to change frozen to testing, and then do it
153 everywhere else. Closes: #165085.
154 * Update es.po. Closes: #183111.
155 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
157 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
158 * Add option to apt-get to show versions of packages being
160 * Be quiet in apt.post{inst,rm}. Closes: #70685.
161 * apt-get now prints out suggested and recommended packages. Closes:
163 * Insert some newlines in the cdrom change media message. Closes:
165 * Add a rdepends command to apt-cache. Closes: #159864.
166 * When building the dpkg command line, allow for 8192 chars to be used,
167 instead of only 1024.
168 * APT::Immediate-Configure had inverted semantics(false meant it was
169 enabled). Closes: #173619.
170 * Fix status file parser so that if a record is larger than 32k, the
171 buffer size will be doubled, and the read attempted again. Closes:
174 -- Adam Heath <doogie@debian.org> Sun, 27 Apr 2003 01:23:12 -0500
176 apt (0.5.4) unstable; urgency=low
178 * M68k config.guess patch. Closes: #88913
179 * Bi-yearly test on OpenBSD and Solaris
180 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
181 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
183 * Various cosmetic code updates. Closes: #89066, #89066, #89152
184 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
186 * More patches from Alfredo for Vendors and more SHA-1 stuff
187 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
188 similar situations. Closes: #56708, #59432
189 * no_proxy and ftp. Closes: #89671
190 * Philippe Batailler's man page patches.
191 * Fix for display bug. Closes: #92033, #93652, #98468
192 * Use more than 16bits for the dep ID. Some people ran out..
193 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
194 #106911, #107395, #108968
195 * Reordered some things to make dante and FTP happier. Closes: #92757
196 * James R. Van Zandt's guide.sgml updates. Closes: #90027
197 * apt-ftparchive copes with no uncompressed package files + contents.
198 * French man pages from philippe batailler - well sort of. They
200 * run-parts. Closes: #94286
201 * 'apt-cache policy' preferences debug tool.
202 * Whatever. Closes: #89762
203 * libstdc++ and HURD. Closes: #92025
204 * More apt-utils verbage. Closes: #86954
205 * Fliped comparision operator. Closes: #94618
206 * Used the right copyright file. Closes: #65691
207 * Randolph's G++3 patches.
208 * Fixed no_proxy tokanizing. Closes: #100046
209 * Strip Config-Version when copying status to available. Closes: #97520
210 * Segfault with missing source files. Closes: #100325
211 * EINTR check. Closes: #102293
212 * Various changes to the locking metholodgy for --print-uris.
214 * Lame LD_LIBRARY_PATH thing. Closes: #98928
215 * apt-cache search searchs provide names too now. Closes: #98695
216 * Checksum and long lines problem. Closes: #106591
217 * .aptignr and empty files are just a warning. Closes: #97364
219 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
221 apt (0.5.3) unstable; urgency=low
223 * JoeyH's dpkg::preconfig not working. Closes: #88675
224 * Fixed apt override disparity
225 * Alfredo's SHA-1 and related patches
227 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
229 apt (0.5.2) unstable; urgency=low
231 * Fixed mention of /usr/doc in the long description
232 * JoeyH's downgrade bug -- don't use 0.5.1
233 * Doc bug. Closes: #88538
234 * Fault in building release strings. Closes: #88533
236 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
238 apt (0.5.1) unstable; urgency=low
240 * Fixed #82894 again, or should be and.
241 * Process the option string right. Closes: #86921
242 * Don't eat the last command for pipes. Closes: #86923
243 * Ignore .* for configuration directory processing. Closes: #86923
244 * Alfredo's no_proxy patch
245 * Documentation fixes. Closes: #87091
246 * JoeyH's double slash bug. Closes: #87266
247 * Unintitialized buffer and apt-ftparchive contents generation.
249 * Build-deps on virtual packages. Closes: #87639
250 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
251 libstdc++ version info in the library soname and in the package
252 provides. Closes: #87426
253 * Updated soname version to 0.3.2
254 * apt-extracttemplates moved from debconf into apt-utils
255 * s390 archtable entry. Closes: #88232
257 * Some instances where the status file can source a package in a
258 non-sensical way. Closes: #87390
259 * Work better if there are duplicate sources.list entries.
260 * Fixed the resetting of Dir with "dir {};". Closes: #87323
262 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
264 apt (0.5.0) unstable; urgency=low
266 * Fixed an obscure bug with missing final double new lines in
268 * Changed the apt-cdrom index copy routine to use the new section
270 * Added a package file sorter, apt-sortpkgs
271 * Parse obsolete Optional dependencies.
272 * Added Ben's rsh method. Closes: #57794
273 * Added IPv6 FTP support and better DNS rotation support.
274 * Include the server IP in error messages when using a DNS rotation.
276 * Made most of the byte counters into doubles to prevent 32bit overflow.
278 * HTTP Authorization. Closes: #61158
279 * Ability to parse and return source index build depends from Randolph.
280 * new 'apt-get build-dep' command from Randolph. Closes: #63982
281 * Added apt-ftparchive the all dancing all singing FTP archive
283 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
285 * Removed useless internal cruft including the xstatus file.
286 * Fixed config parser bugs. Closes: #67848, #71108
287 * Brain Damanged apt-get config options changed, does not change the command
288 line interface, except to allow --enable-* to undo a configuration
291 No-Download -> Download
292 No-Upgrade -> Upgrade
293 * Made this fix configable (DSelect::CheckDir) and default to disabled:
294 * No remove prompt if the archives dir has not changed. Closes: #55709
295 Because it is stupid in the case where no files were downloaded due to
296 a resumed-aborted install, or a full cache! Closes: #65952
297 * Obscure divide by zero problem. Closes: #64394
298 * Update sizetable for mips. Closes: #62288
299 * Fixed a bug with passive FTP connections
300 * Has sizetable entry for sparc64. Closes: #64869
301 * Escape special characters in the ::Label section of the cdroms.lst
302 * Created apt-utils and python-apt packages
303 * Due to the new policy engine, the available file may contain entries
304 from the status file. These are generated if the package is not obsolete
305 but the policy engine prohibits using the version from the package files.
306 They can be identified by the lack of a Filename field.
307 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
308 #36223, #33468, #22551
309 * Fixed deb-src line for non-us. Closes: #71501, #71601
310 * Fixes for G++ 2.96, s/friend/friend class/
311 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
312 * Confirmed fix for missing new line problem. Closes: #69386
313 * Fixed up dhelp files. Closes: #71312
314 * Added some notes about dselect and offline usage. Closes: #66473, #38316
315 * Lock files on read only file systems are ignored w/ warning.
317 * apt-get update foo now gives an error! Closes: #42891
318 * Added test for shlibs on hurd. Closes: #71499
319 * Clarified apt-cache document. Closes: #71934
320 * DocBook SGML man pages and some improvements in the text..
321 * sigwinch thing. Closes: #72382
322 * Caching can be turned off by setting the cache file names blank.
323 * Ignores arches it does not know about when autocleaning. Closes: #72862
324 * New function in apt-config to return dirs, files, bools and integers.
325 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
326 complex cases involving OR groups and provides.
327 68754 describes confusing messages which are the result of this..
328 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
329 * Speeling mistake and return code for the 'wicked' resolver error
330 Closes: #72621, #75226, #77464
331 * Solved unable to upgrade libc6 from potato to woody due to 3 package
332 libc6 dependency loop problem.
333 * Leading sources.list spaces. Closes: #76010
334 * Removed a possible infinite loop while processing installations.
335 * Man page updates. Closes: #75411, #75560, #64292, #78469
336 * ReduceSourceList bug. Closes: #76027
337 * --only-source option. Closes: #76320
338 * Typos. Closes: #77812, #77999
339 * Different status messages. Closes: #76652, #78353
340 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
341 * OS detection an support for the new pseduo standard of os-arch for the
342 Architecture string. Also uses regexing.. Closes: #39227, #72349
343 * Various i18n stuff. Note that this still needs some i18n wizard
344 to do the last gettextization right. Closes: #62386
345 * Fixed a problem with some odd http servers/proxies that did not return
346 the content size in the header. Closes: #79878, #44379
347 * Little acquire bugs. Closes: #77029, #55820
348 * _POSIX_THREADS may not be defined to anything, just defined..
350 * Spelling of Ignore-Hold correctly. Closes: #78042
351 * Unlock the dpkg db if in download only mode. Closes: #84851
352 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
353 * Patch from BenC. Closes: #80810
354 * Single output of some names in lists. Closes: #80498, #43286
355 * Nice message for people who can't read syserror output. Closes: #84734
356 * OR search function. Closes: #82894
357 * User's guide updates. Closes: #82469
358 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
359 * Various CD bugs, again thanks to Greenbush
360 Closes: #80946, #76547, #71810, #70049, #69482
361 * Using potato debhelper. Closes: #57977
362 * I cannot self-terminate. Closes: #74928
364 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
366 apt (0.3.19) frozen unstable; urgency=low
368 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
370 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
371 * Fixed hardcoded path. Closes: #59743
372 * Fixed Jay's relative path bug
373 * Allowed source only CDs. Closes: #58952
374 * Space check is supressed if --print-uris is given. Closes: #58965
375 * Clarified the documenation examples for non-us. Closes: #58646
376 * Typo in the package description. Closes: #60230
377 * Man Page typo. Closes: #60347
378 * Typo in Algorithms.cc. Closes: #63577
379 * Evil dotty function in apt-cache for generating dependency graphs
380 with the as-yet-unpackaged GraphVis.
381 * Appears to have been fixed in Janurary.. Closes: #57981
382 * New config.guess/sub for the new archs. Closes: #60874
383 * Fixed error reporting for certain kinds of resolution failures.
385 * Made autoclean respect 'q' settings. Closes: #63023
386 * Fixed up the example sources.list. Closes: #63676
387 * Added DPkg::FlushSTDIN to control the flushing of stdin before
388 forking dpkg. Closes: #63991
390 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
392 apt (0.3.18) frozen unstable; urgency=low
394 * Changes in the postinst script. Closes: #56855, #57237
395 * Fixed bashism. Closes: #57216, #57335
396 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
398 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
400 apt (0.3.17) unstable; urgency=low
402 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
403 * Fixed the configuration parser to not blow up if ; is in the config
405 * Applied visual patch to dselect install script . Closes #55214
406 * Included the configure-index example
408 * Library soname has increased
409 * Fixed default sources.list to have correct URLs for potato when it
411 * Added a message about erasing sources.list to dselect setup script
413 * No remove prompt if the archives dir has not changed. Closes: #55709
414 * Fixed inclusion of 2nd sample config file. Closes: #55374
415 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
418 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
420 apt (0.3.16) unstable; urgency=low
422 * Made --no-download work. Closes: #52993
423 * Now compiles on OpenBSD, Solaris and HP-UX
424 * Clarify segfault errors
425 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
426 * Fix for Joel's discovery of glibc removal behavoir.
427 * Fix for Ben Collins file: uri from slink upgrade.
428 * Fixed resume code in FTP. Closes: #54323
429 * Take more precautions to prevent the corruption Joey Hess saw.
430 * Fixed --no-list-cleanup
431 * RFC 2732 URI parsing ([] for hostnames).
432 * Typo in apt-cache man page. Closes: #54949
434 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
436 apt (0.3.15) unstable; urgency=low
438 * Added DSelect::WaitAfterDownload Closes: #49549
439 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
440 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
441 * Made -s and clean not do anything. Closes: #50238
442 * Problem with Protected packages and the new OR code.
443 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
444 * Remove doesn't require a package to be installable. Closes: #51175
445 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
447 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
449 apt (0.3.14) unstable; urgency=low
451 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
452 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
453 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
454 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
455 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
456 Closes: #45034, #45695, #46537
457 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
458 * Added APT::Clean-Installed option. Closes: #45973
459 * Moves the free space check to after the calculated size is printed.
460 Closes: #46639, #47498
461 * mipsel arch Closes: #47614
462 * Beautified URI printing to not include passwords Closes: #46857
463 * Fixed little problem with --no-download Closes: #47557
464 * Tweaked Dselect 'update' script to re-gen the avail file even in the
465 event of a failure Closes: #47112
466 * Retries for source archives too Closes: #47529
467 * Unmounts CDROMs iff it mounted them Closes: #45299
468 * Checks for the partial directories before doing downloads Closes: #47392
469 * no_proxy environment variable (http only!) Closes: #43476
470 * apt-cache showsrc Closes: #45799
471 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
472 * Regexs for install. Closes: #35304, #38835
473 * Dependency reports now show OR group relations
474 * Re-Install feature. Cloes: #46961, #37393, #38919
475 * Locks archive directory on clean (woops)
476 * Remove is not 'sticky'. Closes: #48392
477 * Slightly more accurate 'can not find package' message. Closes: #48311
478 * --trivial-only and --no-remove. Closes: #48518
479 * Increased the cache size. Closes: #47648
480 * Comment woopsie. Closes: #48789
481 * Removes existing links when linking sources. Closes: #48775
482 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
483 * Clearer usage message about 'source' Closes: #48858
484 * Immediate configure internal error Closes: #49062, #48884
486 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
488 apt (0.3.13) unstable; urgency=low
490 * Fix timestamp miss in FTP. Closes: #44363
491 * Fix sorting of Kept packages. Closes: #44377
492 * Fix Segfault for dselect-upgrade. Closes: #44436
493 * Fix handling of '/' for the dist name. Closes #43830
494 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
495 * Add commented-out deb-src URI to default sources.list file.
497 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
499 apt (0.3.12) unstable; urgency=low
501 * Fix for typo in the dhelp index. Closes: #40377
502 * Multiple media swap support
503 * Purge support. Closes: #33291, #40694
504 * Better handling of - remove notation. Closes: #41024
505 * Purge support. Closes: #33291, #40694
506 * Error code on failed update. Closes: #41053
507 * apt-cdrom adds entries for source directories. Closes: #41231
508 * Sorts the output of any list. Closes: #41107
509 * Fixes the looping problem. Closes: #41784, #42414, #44022
510 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
511 * More checks to keep the display sane. Particularly when fail-over is
512 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
513 * PThread lockup problem on certain sparc/m68k. Closes: #40628
514 * apt-cdrom understands .gz Package files too. Closes: #42779
515 * Spelling error in dselect method description. Closes: #43251
516 * Added security to the default source list. Closes: #43356
518 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
520 apt (0.3.11) unstable; urgency=low
522 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
523 * Fix for properly upgrading the system from perl 5.004 to 5.005
525 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
527 apt (0.3.9) unstable; urgency=low
529 * Spelling error in cachefile.cc. Closes: #39885
530 * Trailing slash in dselect install if you try to use the
531 default config file. Closes: #40011
532 * Simulate works for autoclean. Closes: #39141
533 * Fixed spelling errors. Closes: #39673
534 * Changed url parsing a bit. Closes: #40070, #40069
535 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
537 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
539 apt (0.3.7) unstable; urgency=low
541 * Fixed missing text in the apt-get(8) page. Closes: #37596
542 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
543 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
544 * Fixed handling of the -q option with not-entirely integer arguments
546 * Man page typo Closes: #37762
547 * Fixed parsing of the Source: line. Closes: #37679
548 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
549 * Added a check for an empty cache directory. Closes: #37963
550 * Return a failure code if -d is given and packages fail to download.
552 * Arranged for an ftp proxy specifing an http server to work. See the
553 important note in the sources.list man page.
554 * Accounted for resumed files in the cps calculation. Closes: #36787
555 * Deal with duplicate same version different packages. Closes: #30237
556 * Added --no-download. Closes: #38095
557 * Order of apt-cdrom dist detection. Closes: #38139
558 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
560 * Suggests dpkg-dev for apt-get source. Closes: #38158
561 * Fixed typo in apt-get help. Closes: #38712
562 * Improved the error message in the case of broken held package. Closes: #38777
563 * Fixed handling of MD5 failures
564 * Documented list notation Closes: #39008
565 * Change the 'b' to 'B'. Closes: #39007
567 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
569 apt (0.3.6) unstable; urgency=low
571 * Note that 0.3.5 never made it out the door..
572 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
573 * Made APT print numbers in decimal. Closes: #35617, #37319
574 * Buffer munching fix for FTP. Closes: #35868
575 * Typo in sample config file. Closes: #35907
576 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
577 * Changed installed size counter to only count unpacked packages.
579 * apt-get source support. Closes: #23934, #27190
580 * Renames .debs that fail MD5 checking, provides automatic corruption
581 recovery. Closes: #35931
582 * Fixed autoconf verison. Closes: #37305
583 * Random Segfaulting. Closes: #37312, #37530
584 * Fixed apt-cache man page. Closes: #36904
585 * Added a newline to apt-cache showpkg. Closes: #36903
587 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
589 apt (0.3.4) unstable; urgency=low
591 * Release for Ben while he is out of town.
592 * Checked the size of partial files. Closes: #33705
593 * apt-get should not print progress on non-tty. Closes: #34944
594 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
595 * Applied cdrom patches from Torsten. Closes: #35140, #35141
596 * smbmounted cdrom fix. Closes: #35470
597 * Changed ie to eg. Closes: #35196
599 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
601 apt (0.3.3) unstable; urgency=low
603 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
605 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
607 apt (0.3.2) unstable; urgency=low
609 * Major release into unstable of v3
610 * These bugs have been fixed, explanations are in the bug system, read
611 the man pages as well..
612 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
613 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
614 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
615 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
616 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
617 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
618 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
619 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
621 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
623 apt (0.3.1) experimental; urgency=low
625 * Minor release of cvs version.
626 * Added virtual package libapt-pkgx.x
628 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
630 apt (0.3.0) experimental; urgency=low
632 * New experimental version.
634 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
636 apt (0.1.9) frozen unstable; urgency=low
638 * Return to the wacky numbering for when we build 0.1.8 for hamm
639 * Important bug related to APT on the Alpha fixed
640 * apt-get dist-upgrade problems fixed
641 * tiny patch for http method to fix an endless loop
642 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
643 libtool and add proper shared lib dependancies
644 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
645 in case an old libpkg is installed while building APT to prevent
646 spurious dependancies
648 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
650 apt (0.1.7) unstable; urgency=low
652 * New build with libstdc++2.9.
653 * Various fixes; read the Changelog.
655 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
657 apt (0.1.6) unstable; urgency=low
659 * Various fixes in the FTP method for error checking. Fixes: #26188.
660 * Spelling corrections in dselect method. Fixes: #25884
661 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
662 * No more bo releases: we're using a normal numbering system now.
664 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
666 apt (0.1.5) unstable; urgency=low
668 * Changed sources.list to point to 'unstable' by default, as
669 'frozen' no longer exists!
671 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
673 apt (0.1.3) unstable; urgency=low
675 * New upstreamish version.
676 * ftp method rewritten in C. Removes dependancies on all perl/perl
677 related modules. This fixes many of the ftp method bugs.
679 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
681 apt (0.1.1) unstable; urgency=low
683 * Release for unstable.
685 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
687 apt (0.1) unstable; urgency=low
689 * Kludge to fix problem in libnet-perl with illegal anonymous
691 * Moved to unstable; apt is in a useable state now.
692 * Fixed version numbering. From now on, numbering will be:
693 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
694 0.1.1 (release for unstable). Thanks, Manoj.
696 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
698 apt (0.0.17-1) experimental; urgency=low
700 * Fixed problem with libc6 version compare
701 * Scott's away for a while, so I'll be packaging apt for the time
704 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
706 apt (0.0.16-1) experimental; urgency=low
708 * Modifications to make apt-get more friendly when backgrounded.
709 * Updated documentation.
710 * Updates to graphic widgets
712 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
714 apt (0.0.15-0.2bo) experimental; urgency=low
717 * Bob Hilliards crash
719 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
721 apt (0.0.15-0.1bo) experimental; urgency=low
726 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
728 apt (0.0.15) experimental; urgency=low
730 * Clean up source tarball (no user-visible changes)
732 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
734 apt (0.0.14) experimental; urgency=low
736 * Updates in ordering code to make sure certain upgrades work correctly.
737 * Made dselect/setup understand ftp as well as http
739 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
741 apt (0.0.13-bo1) experimental; urgency=low
745 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
747 apt (0.0.13) experimental; urgency=low
749 * Remove hardcoded egcc from debian/rules (#21575)
750 * Fixes for ordering logic when system has a number of unpacked
751 but unconfigured packages installed.
752 * Spelling fix in dselect install method (#22556)
754 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
756 apt (0.0.12) experimental; urgency=low
758 * Fixed problems with package cache corruption.
759 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
761 * Interface and documentation improvements.
763 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
765 apt (0.0.11) experimental; urgency=low
767 * Change dependancies to pre-depends since breaking your packaging tools
768 in the middle of an installation isn't very good.
769 * Bug fixes to ftp method and general apt-get code
771 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
773 apt (0.0.10) experimental; urgency=low
775 * Run "dpkg --configure -a" after an aborted dselect install
776 * Fixed problem with install looping
777 * Support for authenticating proxys: (note this isn't terribly secure)
778 http_proxy="http://user:pass@firewall:port/"
779 * Substitute $ARCH in sources.list
780 * Fixes in the resumption code for ftp
782 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
784 apt (0.0.9) experimental; urgency=low
787 * Various other less visible bug fixes.
788 * Fixed problem with segfault when apt-get invoked in a non-existant
789 directory (Bug #21863)
790 * Bumped policy to 2.4.1
792 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
794 apt (0.0.8) experimental; urgency=low
796 * Fixed generated available file (Bug #21836)
797 * Added download ETA (Bug #21774).
798 * Fixed hardcoded ARCH (Bug #21751).
799 * Fixed check on http_proxy (Bug #21795).
800 * Added download speed indicator.
802 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
804 apt (0.0.7) experimental; urgency=low
806 * Remove libdeity and apt from package for now, since only apt-get and
807 apt-cache are actually useful right now.
808 * Clean up handling of package installation errors.
809 * Added timeout to http transfers (#21269)
810 * Updated setup for dselect/apt method.
812 * Long options (added in 0.0.6)
814 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
816 apt (0.0.6) experimental; urgency=low
819 * Revamped download status display.
820 * Call apt-get clean after successful install in dselect.
821 * Added "apt-get clean" which deletes package files from /var/cache/apt
823 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
825 apt (0.0.5) experimental; urgency=low
827 * Ignore signals while dpkg is running so we don't leave dpkg running in
828 the background (#20804)
829 * Check Packages as well as Packages.gz for file URIs (#20784)
830 * Spelling cleanup (#20800)
831 * Added -m option to permit upgrade to go on in the case of a bad mirror.
832 This option may result in incomplete upgrades when used with -f.
834 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
836 apt (0.0.4) experimental; urgency=low
839 * Various documentation updates and cleanup.
840 * Added '-f' option to apt-get attempt to fix broken dependancies.
842 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
844 apt (0.0.3) experimental; urgency=low
846 * Added a shlibs.local file to prevent apt from depending on itself.
847 * Updates to how apt-get handles bad states in installed packages.
848 * Updated rules to make sure build works from a freshly checked out source
849 archive. Building from CVS needs libtool/automake/autoconf, builds from
850 the distributed source package should have no such dependancy.
852 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
854 apt (0.0.2) unstable; urgency=low
856 * Updates to apt-get and http binding for dselect method (apt).
857 * Updating version number from 0.0.1, which was released only on IRC.
859 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
861 apt (0.0.1) unstable; urgency=low
865 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500