]> git.saurik.com Git - apt.git/blob - debian/rules
part revert, part redo 'which' replacement
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 # build in verbose mode by default to make it easy to diangose issues
7 export NOISY=1
8
9 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
10 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
11 export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
12 export PARALLEL = $(or $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))),1)
13
14 # FOR AUTOCONF 2.52 AND NEWER ONLY
15 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
16 confflags += --build $(DEB_HOST_GNU_TYPE)
17 else
18 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
19 endif
20
21 # Set the number of procs to be run in parallel from the options.
22 confflags += --with-procs=$(PARALLEL)
23
24 # See below
25 -include build/environment.mak
26
27 ifneq (,$(shell which dpkg-buildflags))
28 # make does not export to $(shell) so we need to workaround
29 # (http://savannah.gnu.org/bugs/?10593)
30 dpkg_buildflags = DEB_BUILD_MAINT_OPTIONS=hardening=+all dpkg-buildflags
31 export CXXFLAGS = $(shell $(dpkg_buildflags) --get CXXFLAGS)
32 export LDFLAGS = $(shell $(dpkg_buildflags) --get LDFLAGS)
33 export CPPFLAGS = $(shell $(dpkg_buildflags) --get CPPFLAGS)
34 else
35 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
36 export CXXFLAGS = -O0 -g -Wall
37 else
38 export CXXFLAGS = -O2 -g -Wall
39 endif
40 endif
41
42 # Default rule
43 build:
44
45 PKG=apt
46 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
47
48 # Determine the build directory to use
49 BASE=.
50 ifdef BUILD
51 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
52 else
53 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
54 endif
55 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
56 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
57 override BLD := $(BUILDX)
58
59 ifeq ($(words $(BLD)),0)
60 override BLD := ./build
61 endif
62
63 # APT Programs in apt-utils
64 APT_UTILS=ftparchive sortpkgs extracttemplates
65
66 # Uncomment this to turn on verbose mode.
67 #export DH_VERBOSE=1
68
69 # Find the libapt-pkg major version for use in other control files
70 include buildlib/libversion.mak
71
72 # Determine which library package names to use
73 LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
74 LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
75
76 # do not fail as we are just experimenting with symbol files for now
77 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
78
79 build-binary: build/build-binary-stamp
80 build-docbook: build/build-docbook-stamp
81 build-manpages: build/build-manpages-stamp
82
83 # Note that this is unconditionally done first as part of loading environment.mak
84 # The true is needed to force make to reload environment.mak after running
85 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
86 build/environment.mak: build/configure-stamp
87 @true
88
89 configure: configure.ac
90 build/configure-stamp: configure buildlib/config.sub buildlib/config.guess
91 dh_testdir
92 mkdir -p build
93 cp COPYING debian/copyright
94 cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
95 touch $@
96
97 build/build-binary-stamp: build/configure-stamp
98 # Add here commands to compile the package.
99 $(MAKE) binary
100 # compat symlink for the locale split
101 mkdir -p build/usr/share
102 cd build/usr/share && ln -f -s ../../locale .
103 # compile and run tests
104 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
105 $(MAKE) test
106 else
107 @echo "Tests DISABLED"
108 endif
109 touch $@
110
111 build/build-docbook-stamp: build/configure-stamp
112 # Add here commands to compile the package.
113 $(MAKE) docbook
114 touch $@
115
116 build/build-manpages-stamp: build/configure-stamp
117 # Add here commands to compile the package.
118 $(MAKE) manpages
119 touch $@
120
121 clean:
122 dh_testdir
123 dh_clean
124
125 [ ! -f Makefile ] || $(MAKE) clean distclean
126 rm -rf build
127 rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
128 debian/libapt-pkg-dev.install debian/apt.install
129 test ! -L buildlib/config.guess || rm -f buildlib/config.guess
130 test ! -L buildlib/config.sub || rm -f buildlib/config.sub
131
132 debian/%.install: debian/%.install.in
133 sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
134
135 # Build architecture-independent files here.
136 libapt-pkg-doc: build-docbook
137 dh_testdir -p$@
138 dh_testroot -p$@
139 dh_prep -p$@
140 dh_installdirs -p$@
141 #
142 # libapt-pkg-doc install
143 #
144 rm -f $(BLD)/doc/doxygen/html/*.map $(BLD)/doc/doxygen/html/*.md5
145 dh_installdocs -p$@ $(BLD)/docs/design* \
146 $(BLD)/docs/dpkg-tech* \
147 $(BLD)/docs/files* \
148 $(BLD)/docs/method* \
149 doc/libapt-pkg2_to_3.txt \
150 doc/style.txt \
151 $(BLD)/doc/doxygen/html
152 dh_installexamples -p$@
153
154 dh_installchangelogs -p$@
155 dh_strip -p$@
156 dh_compress -p$@ -X.xhtml
157 dh_fixperms -p$@
158 dh_installdeb -p$@
159 dh_gencontrol -p$@
160 dh_md5sums -p$@
161 dh_builddeb -p$@
162
163 apt-doc: build-docbook
164 dh_testdir -p$@
165 dh_testroot -p$@
166 dh_prep -p$@
167 #
168 # apt-doc install
169 #
170 # Copy the guides
171 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
172 $(BLD)/docs/guide*.html \
173 $(BLD)/docs/offline*.text \
174 $(BLD)/docs/offline*.html
175 dh_installchangelogs -p$@
176 dh_compress -p$@
177 dh_fixperms -p$@
178 dh_installdeb -p$@
179 dh_gencontrol -p$@
180 dh_md5sums -p$@
181 dh_builddeb -p$@
182
183
184
185 # Build architecture-dependent files here.
186
187 apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
188 apt: build-binary build-manpages debian/apt.install
189 dh_testdir -p$@
190 dh_testroot -p$@
191 dh_prep -p$@
192 dh_installdirs -p$@
193 #
194 # apt install
195 #
196 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
197 cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
198 chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
199 # install vendor specific apt confs
200 find -L vendor/current -name 'apt.conf-*' | while read conf; do cp "$${conf}" "debian/$@/etc/apt/apt.conf.d/$${conf#*-}"; done
201
202 # make rosetta happy and remove pot files in po/ (but leave stuff
203 # in po/domains/* untouched) and cp *.po into each domain dir
204 rm -f build/po/*.pot
205 rm -f po/*.pot
206
207 dh_install -p$@ --sourcedir=$(BLD)
208
209 # Remove the bits that are in apt-utils
210 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
211
212 # https has its own package
213 rm debian/$@/usr/lib/apt/methods/https
214
215 # move the mirror failure script in place
216 #mv debian/$@/usr/bin/apt-report-mirror-failure \
217 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
218
219 # move the apt-helper in place
220 mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper
221
222 dh_bugfiles -p$@
223 dh_lintian -p$@
224 dh_installexamples -p$@ $(BLD)/docs/examples/*
225 dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
226 dh_installcron -p$@
227 dh_installdocs -p$@
228 dh_installchangelogs -p$@
229 dh_installlogrotate -p$@
230 dh_strip -p$@
231 dh_compress -p$@
232 dh_fixperms -p$@
233 dh_makeshlibs -p$@
234 dh_installdeb -p$@
235 dh_shlibdeps -p$@
236 dh_gencontrol -p$@ -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
237 dh_md5sums -p$@
238 dh_builddeb -p$@
239
240 libapt-pkg-dev: build-binary debian/libapt-pkg-dev.install
241 dh_testdir -p$@
242 dh_testroot -p$@
243 dh_prep -p$@
244 dh_installdirs -p$@
245 #
246 # libapt-pkg-dev install
247 #
248 dh_install -p$@ --sourcedir=$(BLD)
249 dh_installdocs -p$@
250 dh_installchangelogs -p$@
251 dh_strip -p$@
252 dh_compress -p$@
253 dh_fixperms -p$@
254 dh_installdeb -p$@
255 dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
256 dh_md5sums -p$@
257 dh_builddeb -p$@
258
259 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
260 apt-utils: build-binary build-manpages
261 dh_testdir -p$@
262 dh_testroot -p$@
263 dh_prep -p$@
264 dh_installdirs -p$@
265
266 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
267 cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
268 cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
269
270 dh_install -p$@ --sourcedir=$(BLD)
271 dh_link -p$@
272 dh_installdocs -p$@
273 dh_installexamples -p$@
274
275 # Install the man pages..
276 dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
277
278 dh_installchangelogs -p$@
279 dh_strip -p$@
280 dh_compress -p$@
281 dh_fixperms -p$@
282 dh_makeshlibs -p$@
283 dh_installdeb -p$@
284 dh_shlibdeps -p$@
285 dh_gencontrol -p$@
286 dh_md5sums -p$@
287 dh_builddeb -p$@
288
289 $(LIBAPT_PKG): build-binary debian/$(LIBAPT_PKG).install
290 dh_testdir -p$@
291 dh_testroot -p$@
292 dh_prep -p$@
293 dh_installdirs -p$@
294
295 dh_install -p$@ --sourcedir=$(BLD)
296 dh_installdocs -p$@
297 dh_installchangelogs -p$@
298 dh_strip -p$@
299 dh_compress -p$@
300 dh_fixperms -p$@
301 dh_makeshlibs -p$@
302 dh_installdeb -p$@
303 dh_shlibdeps -p$@
304 dh_gencontrol -p$@
305 dh_md5sums -p$@
306 dh_builddeb -p$@
307
308 $(LIBAPT_INST): build-binary debian/$(LIBAPT_INST).install
309 dh_testdir -p$@
310 dh_testroot -p$@
311 dh_prep -p$@
312 dh_installdirs -p$@
313
314 dh_install -p$@ --sourcedir=$(BLD)
315 dh_installdocs -p$@
316 dh_installchangelogs -p$@
317 dh_strip -p$@
318 dh_compress -p$@
319 dh_fixperms -p$@
320 dh_makeshlibs -p$@
321 dh_installdeb -p$@
322 dh_shlibdeps -p$@
323 dh_gencontrol -p$@
324 dh_md5sums -p$@
325 dh_builddeb -p$@
326
327 apt-transport-https: build-binary libapt-pkg-dev
328 dh_testdir -p$@
329 dh_testroot -p$@
330 dh_prep -p$@
331 dh_installdirs -p$@
332
333 dh_install -p$@ --sourcedir=$(BLD)
334 dh_installdocs -p$@ debian/apt-transport-https.README
335 dh_installexamples -p$@
336
337 # Install the man pages..
338 dh_installman -p$@
339
340 dh_installchangelogs -p$@
341 dh_strip -p$@
342 dh_compress -p$@
343 dh_fixperms -p$@
344 dh_installdeb -p$@
345 dh_shlibdeps -p$@
346 dh_gencontrol -p$@
347 dh_md5sums -p$@
348 dh_builddeb -p$@
349
350 buildlib/config.guess buildlib/config.sub:
351 $(MAKE) "$@"
352
353 configure:
354 $(MAKE) configure
355
356 # translate targets to targets required by debian-policy
357 binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
358 binary-indep: apt-doc libapt-pkg-doc
359 binary: binary-indep binary-arch
360 build-arch: build-binary
361 build-indep: build-manpages build-docbook
362 build: build-indep build-arch
363
364 .PHONY: build clean binary-indep binary-arch binary