2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.60 2003/12/21 00:34:40 mdz Exp $
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
17 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
18 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
20 # FOR AUTOCONF 2.52 AND NEWER ONLY
21 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
22 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
24 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
28 -include build
/environment.mak
33 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
-us
-uc
34 APT_DEBVER
=$(shell dpkg-parsechangelog |sed
-n
-e
'/^Version:/s/^Version: //p')
35 APT_CONFVER
=$(shell sed
-n
-e
's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in
)
37 # Determine the build directory to use
40 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
42 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
-m
) $(BASE
)/build
44 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
45 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
46 override BLD
:= $(BUILDX
)
48 ifeq ($(words $(BLD
)),0)
49 override BLD
:= .
/build
52 # Rebuild configure.in to have the correct version from the change log
53 ifneq ($(APT_DEBVER
),$(APT_CONFVER
))
56 sed
-e
's/$(APT_CONFVER)/$(APT_DEBVER)/' $@
> $@.
$$$$;mv
$@.
$$$$ $@
61 # APT Programs in apt-utils
62 APT_UTILS
=ftparchive sortpkgs extracttemplates
64 # Uncomment this to turn on verbose mode.
67 # Find the libapt-pkg major version for use in other control files
68 export LIBAPTPKG_MAJOR
:=$(shell egrep
'^MAJOR=' apt-pkg
/makefile |cut
-d
'=' -f
2)
69 export LIBAPTINST_MAJOR
:=$(shell egrep
'^MAJOR=' apt-inst
/makefile |cut
-d
'=' -f
2)
71 # Determine which package we should provide in the control files
72 LIBAPTPKG_PROVIDE
=libapt-pkg
$(GLIBC_VER
)$(LIBSTDCPP_VER
)-$(LIBAPTPKG_MAJOR
)
73 LIBAPTINST_PROVIDE
=libapt-inst
$(GLIBC_VER
)$(LIBSTDCPP_VER
)-$(LIBAPTINST_MAJOR
)
75 debian
/shlibs.local
: apt-pkg
/makefile
76 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
77 # one for the rest of the packages. This ensures that each package gets
78 # the right overrides..
79 rm -rf
$@
$@.apt
$@.apt-utils
80 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
82 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
83 echo
"libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
85 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
86 echo
"libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
88 build
: build
/build-stamp
89 build-doc
: build
/build-doc-stamp
91 # Note that this is unconditionally done first as part of loading environment.mak
92 # The true is needed to force make to reload environment.mak after running
93 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
94 build
/environment.mak
: build
/configure-stamp
97 configure
: configure.in
98 build
/configure-stamp
: configure
101 cp COPYING debian
/copyright
102 cd build
&& ..
/configure
$(confflags
)
105 build
/build-stamp
: build
/configure-stamp
106 # Add here commands to compile the package.
110 build
/build-doc-stamp
: build
/configure-stamp
111 # Add here commands to compile the package.
123 # Add here commands to clean up after the build process.
124 dh_clean debian
/copyright debian
/shlibs.local debian
/shlibs.local.apt debian
/shlibs.local.apt-utils
126 binary-indep
: apt-doc libapt-pkg-doc
127 # Build architecture-independent files here.
128 libapt-pkg-doc
: build-doc debian
/shlibs.local
134 # libapt-pkg-doc install
136 dh_installdocs
-p
$@
$(BLD
)/docs
/cache
* $(BLD
)/docs
/design
* $(BLD
)/docs
/dpkg-tech
* \
137 $(BLD
)/docs
/files
* $(BLD
)/docs
/method
* \
138 doc
/libapt-pkg2_to_3.txt doc
/style.txt
139 dh_installexamples
-p
$@
140 # dh_installmenu -p$@
141 # dh_installinit -p$@
142 # dh_installcron -p$@
145 # dh_undocumented -p$@
146 dh_installchangelogs
-p
$@
150 # dh_suidregister -p$@
152 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
)
164 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text
$(BLD
)/docs
/guide
*.html \
165 $(BLD
)/docs
/offline.text
$(BLD
)/docs
/offline.html
166 dh_installchangelogs
-p
$@
176 # Build architecture-dependent files here.
178 binary-arch
: apt libapt-pkg-dev apt-utils
179 apt
: build debian
/shlibs.local
183 dh_installdirs
-p
$@
/usr
/share
/bug
/$@
187 cp
$(BLD
)/bin
/apt-
* debian
/apt
/usr
/bin
/
189 # Remove the bits that are in apt-utils
190 rm $(addprefix debian
/apt
/usr
/bin
/apt-
,$(APT_UTILS
))
192 # install the shared libs
193 find
$(BLD
)/bin
/ -type f
-name
"libapt-pkg*.so.*" -exec cp
-a
"{}" debian
/apt
/usr
/lib
/ \
;
194 find
$(BLD
)/bin
/ -type l
-name
"libapt-pkg*.so.*" -exec cp
-a
"{}" debian
/apt
/usr
/lib
/ \
;
196 cp
$(BLD
)/bin
/methods
/* debian
/apt
/usr
/lib
/apt
/methods
/
198 cp
$(BLD
)/scripts
/dselect
/* debian
/apt
/usr
/lib
/dpkg
/methods
/apt
/
199 cp
-r
$(BLD
)/locale debian
/apt
/usr
/share
/
201 cp debian
/bugscript debian
/apt
/usr
/share
/bug
/apt
/script
203 # head -n 500 ChangeLog > debian/ChangeLog
205 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
209 dh_installchangelogs
-p
$@
213 dh_makeshlibs
-m
$(LIBAPTPKG_MAJOR
) -V
'$(LIBAPTPKG_PROVIDE)' -papt
215 dh_shlibdeps
-papt
-l
`pwd`/debian
/apt
/usr
/lib
-- -Ldebian
/shlibs.local.apt
216 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
)
220 libapt-pkg-dev
: build debian
/shlibs.local
226 # libapt-pkg-dev install
228 cp
-a
$(BLD
)/bin
/libapt-pkg
*.so debian
/libapt-pkg-dev
/usr
/lib
/
229 cp
-a
$(BLD
)/bin
/libapt-inst
*.so debian
/libapt-pkg-dev
/usr
/lib
/
230 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
231 cp
$(BLD
)/include/apt-pkg
/*.h debian
/libapt-pkg-dev
/usr
/include/apt-pkg
/
234 # dh_installmenu -p$@
235 # dh_installinit -p$@
236 # dh_installcron -p$@
239 dh_installchangelogs
-p
$@
243 # dh_suidregister -p$@
245 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
) -Vlibapt-inst
:provides
=$(LIBAPTINST_PROVIDE
)
249 apt-utils
: build debian
/shlibs.local
255 # install the shared libs
256 find
$(BLD
)/bin
/ -type f
-name
"libapt-inst*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
257 find
$(BLD
)/bin
/ -type l
-name
"libapt-inst*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
259 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
262 # Install the man pages..
265 dh_installchangelogs
-p
$@
269 dh_makeshlibs
-m
$(LIBAPTINST_MAJOR
) -V
'$(LIBAPTINST_PROVIDE)' -p
$@
271 LD_LIBRARY_PATH
=$$LD_LIBRARY_PATH:`pwd`/debian
/apt
/usr
/lib
:`pwd`/debian
/$@
/usr
/lib dh_shlibdeps
-p
$@
-- -Ldebian
/shlibs.local.apt-utils
272 dh_gencontrol
-p
$@
-u
-Vlibapt-inst
:provides
=$(LIBAPTINST_PROVIDE
)
277 @echo
>&2 'source and diff are obsolete - use dpkg-source -b'; false
284 # Update from CVS and then configure for build
285 super-l33ch
: l33ch Makefile.in
290 l33ch-stamp
: super-l33ch
294 -find
-name Makefile.in
-print0 | xargs
-0r
rm -f
295 find
-name ChangeLog | xargs
rm -f
298 binary
: binary-indep binary-arch
299 .PHONY
: build
clean binary-indep binary-arch binary debian
/shlibs.local
302 # Done by the uploader.
304 #edit debian/changelog
305 # configure.in has the version automatically updated now.
307 # debian/rules cvs-build
310 rm -rf debian
/cvs-build
314 tar c
--exclude CVS
--exclude cvs-build
--exclude
'.#*' . |\
315 (mkdir
-p debian
/cvs-build
/apt-
$(APT_DEBVER
);cd debian
/cvs-build
/apt-
$(APT_DEBVER
);tar x
)
316 (cd debian
/cvs-build
/apt-
$(APT_DEBVER
);$(DEB_BUILD_PROG
))
319 -mkdir
-p ..
/upload-
$(APT_DEBVER
)
320 cp
`find debian/cvs-build -maxdepth 1 -type f` ..
/upload-
$(APT_DEBVER
)