2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
17 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
18 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
20 # FOR AUTOCONF 2.52 AND NEWER ONLY
21 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
22 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
24 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
28 -include build
/environment.mak
30 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
31 export CXXFLAGS
= -O0
-g
-Wall
33 export CXXFLAGS
= -O2
-g
-Wall
39 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
--preserve-envvar CCACHE_DIR
-us
-uc
$(DEB_BUILD_PROG_OPTS
)
40 APT_DEBVER
=$(shell dpkg-parsechangelog |sed
-n
-e
'/^Version:/s/^Version: //p')
41 APT_CONFVER
=$(shell sed
-n
-e
's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in
)
42 APT_CVSTAG
=$(shell echo
"$(APT_DEBVER)" | sed
-e
's/^/v/' -e
's/\./_/g')
44 # Determine the build directory to use
47 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
49 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
-m
) $(BASE
)/build
51 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
52 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
53 override BLD
:= $(BUILDX
)
55 ifeq ($(words $(BLD
)),0)
56 override BLD
:= .
/build
59 # Rebuild configure.in to have the correct version from the change log
60 ifneq ($(APT_DEBVER
),$(APT_CONFVER
))
61 ifneq ($(APT_DEBVER
),)
64 sed
-e
's/$(APT_CONFVER)/$(APT_DEBVER)/' $@
> $@.
$$$$ && mv
$@.
$$$$ $@
70 # APT Programs in apt-utils
71 APT_UTILS
=ftparchive sortpkgs extracttemplates
73 # Uncomment this to turn on verbose mode.
76 # Find the libapt-pkg major version for use in other control files
77 export LIBAPTPKG_MAJOR
:=$(shell egrep
'^MAJOR=' apt-pkg
/makefile |cut
-d
'=' -f
2)
78 export LIBAPTINST_MAJOR
:=$(shell egrep
'^MAJOR=' apt-inst
/makefile |cut
-d
'=' -f
2)
80 # Determine which package we should provide in the control files
81 LIBAPTPKG_PROVIDE
=libapt-pkg
$(GLIBC_VER
)$(LIBSTDCPP_VER
)-$(LIBAPTPKG_MAJOR
)
82 LIBAPTINST_PROVIDE
=libapt-inst
$(GLIBC_VER
)$(LIBSTDCPP_VER
)-$(LIBAPTINST_MAJOR
)
84 debian
/shlibs.local
: apt-pkg
/makefile
85 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
86 # one for the rest of the packages. This ensures that each package gets
87 # the right overrides..
88 rm -rf
$@
$@.apt
$@.apt-utils
89 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
91 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
92 echo
"libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
94 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
95 echo
"libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
97 build
: build
/build-stamp
98 build-doc
: build
/build-doc-stamp
100 # Note that this is unconditionally done first as part of loading environment.mak
101 # The true is needed to force make to reload environment.mak after running
102 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
103 build
/environment.mak
: build
/configure-stamp
106 configure
: configure.in
107 build
/configure-stamp
: configure
110 cp COPYING debian
/copyright
111 cd build
&& CXXFLAGS
="$(confcxxflags)" ..
/configure
$(confflags
)
114 build
/build-stamp
: build
/configure-stamp
115 # Add here commands to compile the package.
119 build
/build-doc-stamp
: build
/configure-stamp
120 # Add here commands to compile the package.
132 # Add here commands to clean up after the build process.
133 dh_clean debian
/copyright debian
/shlibs.local debian
/shlibs.local.apt debian
/shlibs.local.apt-utils
135 binary-indep
: apt-doc libapt-pkg-doc
136 # Build architecture-independent files here.
137 libapt-pkg-doc
: build-doc debian
/shlibs.local
143 # libapt-pkg-doc install
145 dh_installdocs
-p
$@
$(BLD
)/docs
/cache
* $(BLD
)/docs
/design
* $(BLD
)/docs
/dpkg-tech
* \
146 $(BLD
)/docs
/files
* $(BLD
)/docs
/method
* \
147 doc
/libapt-pkg2_to_3.txt doc
/style.txt
148 dh_installexamples
-p
$@
149 # dh_installmenu -p$@
150 # dh_installinit -p$@
151 # dh_installcron -p$@
154 # dh_undocumented -p$@
155 dh_installchangelogs
-p
$@
159 # dh_suidregister -p$@
161 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
)
173 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text
$(BLD
)/docs
/guide
*.html \
174 $(BLD
)/docs
/offline
*.text
$(BLD
)/docs
/offline
*.html
175 dh_installchangelogs
-p
$@
185 # Build architecture-dependent files here.
187 binary-arch
: apt libapt-pkg-dev apt-utils
188 apt
: build debian
/shlibs.local
192 dh_installdirs
-p
$@
/usr
/share
/bug
/$@
/usr
/share
/$@
196 cp
$(BLD
)/bin
/apt-
* debian
/$@
/usr
/bin
/
198 # Remove the bits that are in apt-utils
199 rm $(addprefix debian
/$@
/usr
/bin
/apt-
,$(APT_UTILS
))
201 # install the shared libs
202 find
$(BLD
)/bin
/ -type f
-name
"libapt-pkg*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
203 find
$(BLD
)/bin
/ -type l
-name
"libapt-pkg*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
205 cp
$(BLD
)/bin
/methods
/* debian
/$@
/usr
/lib
/apt
/methods
/
207 cp
$(BLD
)/scripts
/dselect
/* debian
/$@
/usr
/lib
/dpkg
/methods
/apt
/
208 cp
-r
$(BLD
)/locale debian
/$@
/usr
/share
/
210 cp debian
/bugscript debian
/$@
/usr
/share
/bug
/apt
/script
212 cp share
/ubuntu-archive.gpg debian
/$@
/usr
/share
/$@
214 # head -n 500 ChangeLog > debian/ChangeLog
216 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
220 dh_installchangelogs
-p
$@
224 dh_makeshlibs
-p
$@
-m
$(LIBAPTPKG_MAJOR
) -V
'$(LIBAPTPKG_PROVIDE)'
226 dh_shlibdeps
-p
$@
-l
`pwd`/debian
/apt
/usr
/lib
:`pwd`/debian
/$@
/usr
/lib
-- -Ldebian
/shlibs.local.apt
227 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
)
231 libapt-pkg-dev
: build debian
/shlibs.local
237 # libapt-pkg-dev install
239 cp
-a
$(BLD
)/bin
/libapt-pkg
*.so debian
/libapt-pkg-dev
/usr
/lib
/
240 cp
-a
$(BLD
)/bin
/libapt-inst
*.so debian
/libapt-pkg-dev
/usr
/lib
/
241 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
242 cp
$(BLD
)/include/apt-pkg
/*.h debian
/libapt-pkg-dev
/usr
/include/apt-pkg
/
245 # dh_installmenu -p$@
246 # dh_installinit -p$@
247 # dh_installcron -p$@
250 dh_installchangelogs
-p
$@
254 # dh_suidregister -p$@
256 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
) -Vlibapt-inst
:provides
=$(LIBAPTINST_PROVIDE
)
260 apt-utils
: build debian
/shlibs.local
266 # install the shared libs
267 find
$(BLD
)/bin
/ -type f
-name
"libapt-inst*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
268 find
$(BLD
)/bin
/ -type l
-name
"libapt-inst*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
270 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
273 # Install the man pages..
276 dh_installchangelogs
-p
$@
280 dh_makeshlibs
-m
$(LIBAPTINST_MAJOR
) -V
'$(LIBAPTINST_PROVIDE)' -p
$@
282 dh_shlibdeps
-p
$@
-l
`pwd`/debian
/apt
/usr
/lib
:`pwd`/debian
/$@
/usr
/lib
-- -Ldebian
/shlibs.local.apt-utils
283 dh_gencontrol
-p
$@
-u
-Vlibapt-inst
:provides
=$(LIBAPTINST_PROVIDE
)
288 @echo
>&2 'source and diff are obsolete - use dpkg-source -b'; false
295 # Update from CVS and then configure for build
296 super-l33ch
: l33ch Makefile.in
301 l33ch-stamp
: super-l33ch
305 -find
-name Makefile.in
-print0 | xargs
-0r
rm -f
306 find
-name ChangeLog | xargs
rm -f
309 binary
: binary-indep binary-arch
310 .PHONY
: build
clean binary-indep binary-arch binary debian
/shlibs.local
313 # Done by the uploader.
315 #edit debian/changelog
316 # configure.in has the version automatically updated now.
318 # debian/rules cvs-build
320 CVS_BUILDDIR
=apt-
$(APT_DEBVER
)
321 CVS_ROOT
=$(shell cat CVS
/Root
)
322 CVS_MODULE
=$(shell cat CVS
/Repository
)
324 rm -rf debian
/cvs-build
325 mkdir
-p debian
/cvs-build
326 (cd debian
/cvs-build
;cvs
-d
$(CVS_ROOT
) export -r
$(APT_CVSTAG
) -d apt-
$(APT_DEBVER
) $(CVS_MODULE
))
327 $(MAKE
) -C debian
/cvs-build
/$(CVS_BUILDDIR
) startup doc
328 (cd debian
/cvs-build
/$(CVS_BUILDDIR
);$(DEB_BUILD_PROG
))
331 -mkdir
-p ..
/upload-
$(APT_DEBVER
)
332 cp
`find debian/cvs-build -maxdepth 1 -type f` ..
/upload-
$(APT_DEBVER
)
335 rm -rf debian
/arch-build
336 mkdir
-p debian
/arch-build
/apt-
$(APT_DEBVER
)
337 baz inventory
-s | xargs cp
-a
--parents
--target
=debian
/arch-build
/apt-
$(APT_DEBVER
)
338 $(MAKE
) -C debian
/arch-build
/apt-
$(APT_DEBVER
) startup doc
339 (cd debian
/arch-build
/apt-
$(APT_DEBVER
); $(DEB_BUILD_PROG
); dpkg-genchanges
-S
> ..
/apt_
$(APT_DEBVER
)_source.changes
)