1 apt (0.5.6) unstable; urgency=low
3 * Adam Heath <doogie@debian.org>
4 - Fix segfault when handling /etc/apt/preferences. Closes: #192409.
5 * Matt Zimmerman <mdz@debian.org>
6 - Clean up some string handling, patch from Peter Lundkvist
7 <p.lundkvist@telia.com> (Closes: #192225)
8 - Don't fall off the end of the buffer when comparing versions.
9 Patch from Koblinger Egmont <egmont@uhulinux.hu> (Closes: #194327)
10 - Minor fixes to apt-ftparchive(1) (Closes: #118156)
11 - Fix typo in apt-ftparchive help text (Closes: #119072)
12 - Update config.guess, config.sub to latest versions
16 apt (0.5.5.1) unstable; urgency=low
18 * Move the target of the example docs from doc to binary. Closes:
20 * Fix api breakage that broke apt-ftparchive and apt-cache dumpavail, by
21 backing out change that incorretly attempted to handle Package sections
22 larger than 32k. Closes: #192373
23 * Fix never-ending loop with apt-get install -V. Closes: #192355.
25 -- Adam Heath <doogie@debian.org> Mon, 19 May 2003 12:30:16 -0500
27 apt (0.5.5) unstable; urgency=low
29 * New deb version compare function, that has no integer limits, and
30 supports pre-versions using ~. Code ported from dpkg.
31 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
32 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
33 * "apt-get --arch-only build-dep" to install only architecture-
34 dependent build dependencies. Bump minor shared lib number to reflect
35 small change in BuildDepend API.
36 * APT::Build-Essential configuration option (defaults to "build-essential")
37 so that "apt-get build-dep" will ensure build essential packages are
38 installed prior to installing other build-dependencies. Closes: #148879
39 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
40 * /usr/doc reference in postinst. Closes: #126189
41 * Doc updates. Closes: #120689
42 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
44 * Print special message for EAI_AGAIN. Closes: #131397
45 * libapt-pkg-dev needs to bring in the apt-inst library if linking
46 is to work. Closes: #133943
47 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
48 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
49 #139994, #142955, #151654, #151834, #147611, #154268, #173971
50 * Fix possibility for tag file parsing to fail in some unlikely situations.
52 * Use std C++ names for some header files. Closes: #128741
53 * Do not check for free space if --no-download. Closes: #117856
54 * Actually implement or group handling for 'upgrade'. Closes: #133950
55 * "Internal Error, Couldn't configure pre-depend" is not actually an
56 internal error, it is a packaging error and now it says so, and
57 pinpoints the problem dependency. Closes: #155621
58 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
59 * Use usr/share/doc for dhelp. Closes: #115701
60 * --print-uris works with 'update'. Closes: #57070
61 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
63 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
65 * Allow an uninstalled package to be marked for removal on an install
66 line (meaning not to automatically install it), also fix some dodgy
67 handling of protected packages. Closes: #92287, #116011
68 * Fix errant prefix matching in version selection. Closes: #105968
69 * Ensure that all files needed to run APT as a user are readable and
70 ignore roots umask for these files. Closes: #108801
71 * Support larger config spaces. Closes: #111914
72 * 'apt-get update' no longer does 'Building Dependency Tree'.
73 * When matching regexs allways print a message. Change regex activation
74 charset. Closes: #147817
75 * Don't die if lines in sources.list are too long. Closes: #146846
76 * Show file name on apt-extracttemplate error messges. Closes: #151835
77 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
78 * Some highly unlikely memory faults. Closes: #155842
79 * C++ stuff for G++3.2. Closes: #162617, #165515,
80 * apt-config dumps sends to stdout not stderr now. Closes: #146294
81 * Fix segfault in FindAny when /i is used, and there is no default.
83 * Add s390x to archtable. Closese: #160992.
84 * Update config.sub/config.guess in cvs, and add support to debian/rules
85 to update them from /usr/share/misc if they exist. Closes: #155014
86 * Remove 'Sorry' from messages. Closes: #148824.
87 * Change wording of 'additional disk space usage' message. Closes:
89 * apt-extracttemplates now prepends the package name when extracting
90 files. Closes: #132776
91 * Add -n synonym for --names-only for apt-cache. Closes: #130689
92 * Display both current version and new version in apt-get -s. Closes:
94 * Add an options and timeout config item to ssh/rsh. Closes: #90654
95 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
96 * Change verbose logging output of apt-ftparchive to go to stderr,
97 instead of stdout. Also, errors that occur no longer go to stdout,
98 but stderr. Closes: #161592
99 * Test for timegm in configure. Closes: #165516.
100 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
101 support compliation on platforms where st_mtime is a macro. Closes:
103 * Check the currently mounted cdrom, to see if it's the one we are
104 interested in. Closes: #154602
105 * Refer to reportbug instead of bug in the man pages. Closes: #173745
106 * Link apt-inst to apt-pkg. Closes: #175055
107 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
109 * Fix > 300 col screen segfault. Closes: #176052
110 * Rebuild with gcc-3.2. Closes: #177752, #178008.
111 * Fix build-dep handling of | dependencies.
112 Closes: #98640, #145997, #158896, #172901
113 * Double default value of APT::Cache-Limit, until such time as it
114 can be made more dynamic. Closes: #178623.
115 * Report uris with '.gz' when there are errors. Closes: #178435.
116 * When installing build-deps, make sure the new version will
117 satisfy build requirements. Closes: #178121
118 * Split offline and guide documentation into apt-doc. This was done so
119 that binary-arch builds do not require documention deps. Note, that
120 apt-doc is not installed on upgrades.
121 * Use doc-base, instead of dhelp directly. Closes: #110389
122 * Change http message 'Waiting for file' to 'Waiting for headers'.
124 * Remove trailing lines on package lists in apt-get. Closes: #178736.
125 * Fix origin pins for file:// uris. Closes: #189014.
126 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
128 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
130 * Fix some typos in the apt-get manual. Closes: #163932.
131 * Apply patch from bug, to change frozen to testing, and then do it
132 everywhere else. Closes: #165085.
133 * Update es.po. Closes: #183111.
134 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
136 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
137 * Add option to apt-get to show versions of packages being
139 * Be quiet in apt.post{inst,rm}. Closes: #70685.
140 * apt-get now prints out suggested and recommended packages. Closes:
142 * Insert some newlines in the cdrom change media message. Closes:
144 * Add a rdepends command to apt-cache. Closes: #159864.
145 * When building the dpkg command line, allow for 8192 chars to be used,
146 instead of only 1024.
147 * APT::Immediate-Configure had inverted semantics(false meant it was
148 enabled). Closes: #173619.
149 * Fix status file parser so that if a record is larger than 32k, the
150 buffer size will be doubled, and the read attempted again. Closes:
153 -- Adam Heath <doogie@debian.org> Sun, 27 Apr 2003 01:23:12 -0500
155 apt (0.5.4) unstable; urgency=low
157 * M68k config.guess patch. Closes: #88913
158 * Bi-yearly test on OpenBSD and Solaris
159 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
160 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
162 * Various cosmetic code updates. Closes: #89066, #89066, #89152
163 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
165 * More patches from Alfredo for Vendors and more SHA-1 stuff
166 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
167 similar situations. Closes: #56708, #59432
168 * no_proxy and ftp. Closes: #89671
169 * Philippe Batailler's man page patches.
170 * Fix for display bug. Closes: #92033, #93652, #98468
171 * Use more than 16bits for the dep ID. Some people ran out..
172 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
173 #106911, #107395, #108968
174 * Reordered some things to make dante and FTP happier. Closes: #92757
175 * James R. Van Zandt's guide.sgml updates. Closes: #90027
176 * apt-ftparchive copes with no uncompressed package files + contents.
177 * French man pages from philippe batailler - well sort of. They
179 * run-parts. Closes: #94286
180 * 'apt-cache policy' preferences debug tool.
181 * Whatever. Closes: #89762
182 * libstdc++ and HURD. Closes: #92025
183 * More apt-utils verbage. Closes: #86954
184 * Fliped comparision operator. Closes: #94618
185 * Used the right copyright file. Closes: #65691
186 * Randolph's G++3 patches.
187 * Fixed no_proxy tokanizing. Closes: #100046
188 * Strip Config-Version when copying status to available. Closes: #97520
189 * Segfault with missing source files. Closes: #100325
190 * EINTR check. Closes: #102293
191 * Various changes to the locking metholodgy for --print-uris.
193 * Lame LD_LIBRARY_PATH thing. Closes: #98928
194 * apt-cache search searchs provide names too now. Closes: #98695
195 * Checksum and long lines problem. Closes: #106591
196 * .aptignr and empty files are just a warning. Closes: #97364
198 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
200 apt (0.5.3) unstable; urgency=low
202 * JoeyH's dpkg::preconfig not working. Closes: #88675
203 * Fixed apt override disparity
204 * Alfredo's SHA-1 and related patches
206 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
208 apt (0.5.2) unstable; urgency=low
210 * Fixed mention of /usr/doc in the long description
211 * JoeyH's downgrade bug -- don't use 0.5.1
212 * Doc bug. Closes: #88538
213 * Fault in building release strings. Closes: #88533
215 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
217 apt (0.5.1) unstable; urgency=low
219 * Fixed #82894 again, or should be and.
220 * Process the option string right. Closes: #86921
221 * Don't eat the last command for pipes. Closes: #86923
222 * Ignore .* for configuration directory processing. Closes: #86923
223 * Alfredo's no_proxy patch
224 * Documentation fixes. Closes: #87091
225 * JoeyH's double slash bug. Closes: #87266
226 * Unintitialized buffer and apt-ftparchive contents generation.
228 * Build-deps on virtual packages. Closes: #87639
229 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
230 libstdc++ version info in the library soname and in the package
231 provides. Closes: #87426
232 * Updated soname version to 0.3.2
233 * apt-extracttemplates moved from debconf into apt-utils
234 * s390 archtable entry. Closes: #88232
236 * Some instances where the status file can source a package in a
237 non-sensical way. Closes: #87390
238 * Work better if there are duplicate sources.list entries.
239 * Fixed the resetting of Dir with "dir {};". Closes: #87323
241 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
243 apt (0.5.0) unstable; urgency=low
245 * Fixed an obscure bug with missing final double new lines in
247 * Changed the apt-cdrom index copy routine to use the new section
249 * Added a package file sorter, apt-sortpkgs
250 * Parse obsolete Optional dependencies.
251 * Added Ben's rsh method. Closes: #57794
252 * Added IPv6 FTP support and better DNS rotation support.
253 * Include the server IP in error messages when using a DNS rotation.
255 * Made most of the byte counters into doubles to prevent 32bit overflow.
257 * HTTP Authorization. Closes: #61158
258 * Ability to parse and return source index build depends from Randolph.
259 * new 'apt-get build-dep' command from Randolph. Closes: #63982
260 * Added apt-ftparchive the all dancing all singing FTP archive
262 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
264 * Removed useless internal cruft including the xstatus file.
265 * Fixed config parser bugs. Closes: #67848, #71108
266 * Brain Damanged apt-get config options changed, does not change the command
267 line interface, except to allow --enable-* to undo a configuration
270 No-Download -> Download
271 No-Upgrade -> Upgrade
272 * Made this fix configable (DSelect::CheckDir) and default to disabled:
273 * No remove prompt if the archives dir has not changed. Closes: #55709
274 Because it is stupid in the case where no files were downloaded due to
275 a resumed-aborted install, or a full cache! Closes: #65952
276 * Obscure divide by zero problem. Closes: #64394
277 * Update sizetable for mips. Closes: #62288
278 * Fixed a bug with passive FTP connections
279 * Has sizetable entry for sparc64. Closes: #64869
280 * Escape special characters in the ::Label section of the cdroms.lst
281 * Created apt-utils and python-apt packages
282 * Due to the new policy engine, the available file may contain entries
283 from the status file. These are generated if the package is not obsolete
284 but the policy engine prohibits using the version from the package files.
285 They can be identified by the lack of a Filename field.
286 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
287 #36223, #33468, #22551
288 * Fixed deb-src line for non-us. Closes: #71501, #71601
289 * Fixes for G++ 2.96, s/friend/friend class/
290 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
291 * Confirmed fix for missing new line problem. Closes: #69386
292 * Fixed up dhelp files. Closes: #71312
293 * Added some notes about dselect and offline usage. Closes: #66473, #38316
294 * Lock files on read only file systems are ignored w/ warning.
296 * apt-get update foo now gives an error! Closes: #42891
297 * Added test for shlibs on hurd. Closes: #71499
298 * Clarified apt-cache document. Closes: #71934
299 * DocBook SGML man pages and some improvements in the text..
300 * sigwinch thing. Closes: #72382
301 * Caching can be turned off by setting the cache file names blank.
302 * Ignores arches it does not know about when autocleaning. Closes: #72862
303 * New function in apt-config to return dirs, files, bools and integers.
304 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
305 complex cases involving OR groups and provides.
306 68754 describes confusing messages which are the result of this..
307 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
308 * Speeling mistake and return code for the 'wicked' resolver error
309 Closes: #72621, #75226, #77464
310 * Solved unable to upgrade libc6 from potato to woody due to 3 package
311 libc6 dependency loop problem.
312 * Leading sources.list spaces. Closes: #76010
313 * Removed a possible infinite loop while processing installations.
314 * Man page updates. Closes: #75411, #75560, #64292, #78469
315 * ReduceSourceList bug. Closes: #76027
316 * --only-source option. Closes: #76320
317 * Typos. Closes: #77812, #77999
318 * Different status messages. Closes: #76652, #78353
319 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
320 * OS detection an support for the new pseduo standard of os-arch for the
321 Architecture string. Also uses regexing.. Closes: #39227, #72349
322 * Various i18n stuff. Note that this still needs some i18n wizard
323 to do the last gettextization right. Closes: #62386
324 * Fixed a problem with some odd http servers/proxies that did not return
325 the content size in the header. Closes: #79878, #44379
326 * Little acquire bugs. Closes: #77029, #55820
327 * _POSIX_THREADS may not be defined to anything, just defined..
329 * Spelling of Ignore-Hold correctly. Closes: #78042
330 * Unlock the dpkg db if in download only mode. Closes: #84851
331 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
332 * Patch from BenC. Closes: #80810
333 * Single output of some names in lists. Closes: #80498, #43286
334 * Nice message for people who can't read syserror output. Closes: #84734
335 * OR search function. Closes: #82894
336 * User's guide updates. Closes: #82469
337 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
338 * Various CD bugs, again thanks to Greenbush
339 Closes: #80946, #76547, #71810, #70049, #69482
340 * Using potato debhelper. Closes: #57977
341 * I cannot self-terminate. Closes: #74928
343 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
345 apt (0.3.19) frozen unstable; urgency=low
347 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
349 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
350 * Fixed hardcoded path. Closes: #59743
351 * Fixed Jay's relative path bug
352 * Allowed source only CDs. Closes: #58952
353 * Space check is supressed if --print-uris is given. Closes: #58965
354 * Clarified the documenation examples for non-us. Closes: #58646
355 * Typo in the package description. Closes: #60230
356 * Man Page typo. Closes: #60347
357 * Typo in Algorithms.cc. Closes: #63577
358 * Evil dotty function in apt-cache for generating dependency graphs
359 with the as-yet-unpackaged GraphVis.
360 * Appears to have been fixed in Janurary.. Closes: #57981
361 * New config.guess/sub for the new archs. Closes: #60874
362 * Fixed error reporting for certain kinds of resolution failures.
364 * Made autoclean respect 'q' settings. Closes: #63023
365 * Fixed up the example sources.list. Closes: #63676
366 * Added DPkg::FlushSTDIN to control the flushing of stdin before
367 forking dpkg. Closes: #63991
369 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
371 apt (0.3.18) frozen unstable; urgency=low
373 * Changes in the postinst script. Closes: #56855, #57237
374 * Fixed bashism. Closes: #57216, #57335
375 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
377 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
379 apt (0.3.17) unstable; urgency=low
381 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
382 * Fixed the configuration parser to not blow up if ; is in the config
384 * Applied visual patch to dselect install script . Closes #55214
385 * Included the configure-index example
387 * Library soname has increased
388 * Fixed default sources.list to have correct URLs for potato when it
390 * Added a message about erasing sources.list to dselect setup script
392 * No remove prompt if the archives dir has not changed. Closes: #55709
393 * Fixed inclusion of 2nd sample config file. Closes: #55374
394 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
397 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
399 apt (0.3.16) unstable; urgency=low
401 * Made --no-download work. Closes: #52993
402 * Now compiles on OpenBSD, Solaris and HP-UX
403 * Clarify segfault errors
404 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
405 * Fix for Joel's discovery of glibc removal behavoir.
406 * Fix for Ben Collins file: uri from slink upgrade.
407 * Fixed resume code in FTP. Closes: #54323
408 * Take more precautions to prevent the corruption Joey Hess saw.
409 * Fixed --no-list-cleanup
410 * RFC 2732 URI parsing ([] for hostnames).
411 * Typo in apt-cache man page. Closes: #54949
413 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
415 apt (0.3.15) unstable; urgency=low
417 * Added DSelect::WaitAfterDownload Closes: #49549
418 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
419 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
420 * Made -s and clean not do anything. Closes: #50238
421 * Problem with Protected packages and the new OR code.
422 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
423 * Remove doesn't require a package to be installable. Closes: #51175
424 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
426 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
428 apt (0.3.14) unstable; urgency=low
430 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
431 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
432 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
433 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
434 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
435 Closes: #45034, #45695, #46537
436 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
437 * Added APT::Clean-Installed option. Closes: #45973
438 * Moves the free space check to after the calculated size is printed.
439 Closes: #46639, #47498
440 * mipsel arch Closes: #47614
441 * Beautified URI printing to not include passwords Closes: #46857
442 * Fixed little problem with --no-download Closes: #47557
443 * Tweaked Dselect 'update' script to re-gen the avail file even in the
444 event of a failure Closes: #47112
445 * Retries for source archives too Closes: #47529
446 * Unmounts CDROMs iff it mounted them Closes: #45299
447 * Checks for the partial directories before doing downloads Closes: #47392
448 * no_proxy environment variable (http only!) Closes: #43476
449 * apt-cache showsrc Closes: #45799
450 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
451 * Regexs for install. Closes: #35304, #38835
452 * Dependency reports now show OR group relations
453 * Re-Install feature. Cloes: #46961, #37393, #38919
454 * Locks archive directory on clean (woops)
455 * Remove is not 'sticky'. Closes: #48392
456 * Slightly more accurate 'can not find package' message. Closes: #48311
457 * --trivial-only and --no-remove. Closes: #48518
458 * Increased the cache size. Closes: #47648
459 * Comment woopsie. Closes: #48789
460 * Removes existing links when linking sources. Closes: #48775
461 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
462 * Clearer usage message about 'source' Closes: #48858
463 * Immediate configure internal error Closes: #49062, #48884
465 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
467 apt (0.3.13) unstable; urgency=low
469 * Fix timestamp miss in FTP. Closes: #44363
470 * Fix sorting of Kept packages. Closes: #44377
471 * Fix Segfault for dselect-upgrade. Closes: #44436
472 * Fix handling of '/' for the dist name. Closes #43830
473 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
474 * Add commented-out deb-src URI to default sources.list file.
476 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
478 apt (0.3.12) unstable; urgency=low
480 * Fix for typo in the dhelp index. Closes: #40377
481 * Multiple media swap support
482 * Purge support. Closes: #33291, #40694
483 * Better handling of - remove notation. Closes: #41024
484 * Purge support. Closes: #33291, #40694
485 * Error code on failed update. Closes: #41053
486 * apt-cdrom adds entries for source directories. Closes: #41231
487 * Sorts the output of any list. Closes: #41107
488 * Fixes the looping problem. Closes: #41784, #42414, #44022
489 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
490 * More checks to keep the display sane. Particularly when fail-over is
491 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
492 * PThread lockup problem on certain sparc/m68k. Closes: #40628
493 * apt-cdrom understands .gz Package files too. Closes: #42779
494 * Spelling error in dselect method description. Closes: #43251
495 * Added security to the default source list. Closes: #43356
497 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
499 apt (0.3.11) unstable; urgency=low
501 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
502 * Fix for properly upgrading the system from perl 5.004 to 5.005
504 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
506 apt (0.3.9) unstable; urgency=low
508 * Spelling error in cachefile.cc. Closes: #39885
509 * Trailing slash in dselect install if you try to use the
510 default config file. Closes: #40011
511 * Simulate works for autoclean. Closes: #39141
512 * Fixed spelling errors. Closes: #39673
513 * Changed url parsing a bit. Closes: #40070, #40069
514 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
516 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
518 apt (0.3.7) unstable; urgency=low
520 * Fixed missing text in the apt-get(8) page. Closes: #37596
521 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
522 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
523 * Fixed handling of the -q option with not-entirely integer arguments
525 * Man page typo Closes: #37762
526 * Fixed parsing of the Source: line. Closes: #37679
527 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
528 * Added a check for an empty cache directory. Closes: #37963
529 * Return a failure code if -d is given and packages fail to download.
531 * Arranged for an ftp proxy specifing an http server to work. See the
532 important note in the sources.list man page.
533 * Accounted for resumed files in the cps calculation. Closes: #36787
534 * Deal with duplicate same version different packages. Closes: #30237
535 * Added --no-download. Closes: #38095
536 * Order of apt-cdrom dist detection. Closes: #38139
537 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
539 * Suggests dpkg-dev for apt-get source. Closes: #38158
540 * Fixed typo in apt-get help. Closes: #38712
541 * Improved the error message in the case of broken held package. Closes: #38777
542 * Fixed handling of MD5 failures
543 * Documented list notation Closes: #39008
544 * Change the 'b' to 'B'. Closes: #39007
546 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
548 apt (0.3.6) unstable; urgency=low
550 * Note that 0.3.5 never made it out the door..
551 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
552 * Made APT print numbers in decimal. Closes: #35617, #37319
553 * Buffer munching fix for FTP. Closes: #35868
554 * Typo in sample config file. Closes: #35907
555 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
556 * Changed installed size counter to only count unpacked packages.
558 * apt-get source support. Closes: #23934, #27190
559 * Renames .debs that fail MD5 checking, provides automatic corruption
560 recovery. Closes: #35931
561 * Fixed autoconf verison. Closes: #37305
562 * Random Segfaulting. Closes: #37312, #37530
563 * Fixed apt-cache man page. Closes: #36904
564 * Added a newline to apt-cache showpkg. Closes: #36903
566 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
568 apt (0.3.4) unstable; urgency=low
570 * Release for Ben while he is out of town.
571 * Checked the size of partial files. Closes: #33705
572 * apt-get should not print progress on non-tty. Closes: #34944
573 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
574 * Applied cdrom patches from Torsten. Closes: #35140, #35141
575 * smbmounted cdrom fix. Closes: #35470
576 * Changed ie to eg. Closes: #35196
578 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
580 apt (0.3.3) unstable; urgency=low
582 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
584 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
586 apt (0.3.2) unstable; urgency=low
588 * Major release into unstable of v3
589 * These bugs have been fixed, explanations are in the bug system, read
590 the man pages as well..
591 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
592 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
593 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
594 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
595 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
596 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
597 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
598 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
600 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
602 apt (0.3.1) experimental; urgency=low
604 * Minor release of cvs version.
605 * Added virtual package libapt-pkgx.x
607 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
609 apt (0.3.0) experimental; urgency=low
611 * New experimental version.
613 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
615 apt (0.1.9) frozen unstable; urgency=low
617 * Return to the wacky numbering for when we build 0.1.8 for hamm
618 * Important bug related to APT on the Alpha fixed
619 * apt-get dist-upgrade problems fixed
620 * tiny patch for http method to fix an endless loop
621 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
622 libtool and add proper shared lib dependancies
623 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
624 in case an old libpkg is installed while building APT to prevent
625 spurious dependancies
627 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
629 apt (0.1.7) unstable; urgency=low
631 * New build with libstdc++2.9.
632 * Various fixes; read the Changelog.
634 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
636 apt (0.1.6) unstable; urgency=low
638 * Various fixes in the FTP method for error checking. Fixes: #26188.
639 * Spelling corrections in dselect method. Fixes: #25884
640 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
641 * No more bo releases: we're using a normal numbering system now.
643 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
645 apt (0.1.5) unstable; urgency=low
647 * Changed sources.list to point to 'unstable' by default, as
648 'frozen' no longer exists!
650 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
652 apt (0.1.3) unstable; urgency=low
654 * New upstreamish version.
655 * ftp method rewritten in C. Removes dependancies on all perl/perl
656 related modules. This fixes many of the ftp method bugs.
658 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
660 apt (0.1.1) unstable; urgency=low
662 * Release for unstable.
664 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
666 apt (0.1) unstable; urgency=low
668 * Kludge to fix problem in libnet-perl with illegal anonymous
670 * Moved to unstable; apt is in a useable state now.
671 * Fixed version numbering. From now on, numbering will be:
672 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
673 0.1.1 (release for unstable). Thanks, Manoj.
675 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
677 apt (0.0.17-1) experimental; urgency=low
679 * Fixed problem with libc6 version compare
680 * Scott's away for a while, so I'll be packaging apt for the time
683 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
685 apt (0.0.16-1) experimental; urgency=low
687 * Modifications to make apt-get more friendly when backgrounded.
688 * Updated documentation.
689 * Updates to graphic widgets
691 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
693 apt (0.0.15-0.2bo) experimental; urgency=low
696 * Bob Hilliards crash
698 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
700 apt (0.0.15-0.1bo) experimental; urgency=low
705 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
707 apt (0.0.15) experimental; urgency=low
709 * Clean up source tarball (no user-visible changes)
711 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
713 apt (0.0.14) experimental; urgency=low
715 * Updates in ordering code to make sure certain upgrades work correctly.
716 * Made dselect/setup understand ftp as well as http
718 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
720 apt (0.0.13-bo1) experimental; urgency=low
724 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
726 apt (0.0.13) experimental; urgency=low
728 * Remove hardcoded egcc from debian/rules (#21575)
729 * Fixes for ordering logic when system has a number of unpacked
730 but unconfigured packages installed.
731 * Spelling fix in dselect install method (#22556)
733 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
735 apt (0.0.12) experimental; urgency=low
737 * Fixed problems with package cache corruption.
738 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
740 * Interface and documentation improvements.
742 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
744 apt (0.0.11) experimental; urgency=low
746 * Change dependancies to pre-depends since breaking your packaging tools
747 in the middle of an installation isn't very good.
748 * Bug fixes to ftp method and general apt-get code
750 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
752 apt (0.0.10) experimental; urgency=low
754 * Run "dpkg --configure -a" after an aborted dselect install
755 * Fixed problem with install looping
756 * Support for authenticating proxys: (note this isn't terribly secure)
757 http_proxy="http://user:pass@firewall:port/"
758 * Substitute $ARCH in sources.list
759 * Fixes in the resumption code for ftp
761 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
763 apt (0.0.9) experimental; urgency=low
766 * Various other less visible bug fixes.
767 * Fixed problem with segfault when apt-get invoked in a non-existant
768 directory (Bug #21863)
769 * Bumped policy to 2.4.1
771 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
773 apt (0.0.8) experimental; urgency=low
775 * Fixed generated available file (Bug #21836)
776 * Added download ETA (Bug #21774).
777 * Fixed hardcoded ARCH (Bug #21751).
778 * Fixed check on http_proxy (Bug #21795).
779 * Added download speed indicator.
781 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
783 apt (0.0.7) experimental; urgency=low
785 * Remove libdeity and apt from package for now, since only apt-get and
786 apt-cache are actually useful right now.
787 * Clean up handling of package installation errors.
788 * Added timeout to http transfers (#21269)
789 * Updated setup for dselect/apt method.
791 * Long options (added in 0.0.6)
793 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
795 apt (0.0.6) experimental; urgency=low
798 * Revamped download status display.
799 * Call apt-get clean after successful install in dselect.
800 * Added "apt-get clean" which deletes package files from /var/cache/apt
802 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
804 apt (0.0.5) experimental; urgency=low
806 * Ignore signals while dpkg is running so we don't leave dpkg running in
807 the background (#20804)
808 * Check Packages as well as Packages.gz for file URIs (#20784)
809 * Spelling cleanup (#20800)
810 * Added -m option to permit upgrade to go on in the case of a bad mirror.
811 This option may result in incomplete upgrades when used with -f.
813 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
815 apt (0.0.4) experimental; urgency=low
818 * Various documentation updates and cleanup.
819 * Added '-f' option to apt-get attempt to fix broken dependancies.
821 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
823 apt (0.0.3) experimental; urgency=low
825 * Added a shlibs.local file to prevent apt from depending on itself.
826 * Updates to how apt-get handles bad states in installed packages.
827 * Updated rules to make sure build works from a freshly checked out source
828 archive. Building from CVS needs libtool/automake/autoconf, builds from
829 the distributed source package should have no such dependancy.
831 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
833 apt (0.0.2) unstable; urgency=low
835 * Updates to apt-get and http binding for dselect method (apt).
836 * Updating version number from 0.0.1, which was released only on IRC.
838 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
840 apt (0.0.1) unstable; urgency=low
844 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500