]> git.saurik.com Git - apt.git/blob - debian/rules
Dans segfault
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.27 2001/02/27 04:16:05 tausq Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/tmp/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/tmp/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 # See below
18 include build/environment.mak
19
20 # Default rule
21 build:
22
23 DEB_BUILD_PROG:=debuild -us -uc
24 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
25 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
26
27 # Determine the build directory to use
28 BASE=.
29 ifdef BUILD
30 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
31 else
32 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
33 endif
34 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
35 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
36 override BLD := $(BUILDX)
37
38 ifeq ($(words $(BLD)),0)
39 override BLD := ./build
40 endif
41
42 # Rebuild configure.in to have the correct version from the change log
43 ifneq ($(APT_DEBVER),$(APT_CONFVER))
44 .PHONY: configure.in
45 configure.in:
46 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
47 else
48 configure.in:
49 endif
50
51 # APT Programs in apt-utils
52 APT_UTILS=ftparchive sortpkgs extracttemplates
53
54 # Uncomment this to turn on verbose mode.
55 #export DH_VERBOSE=1
56
57 # Find the libapt-pkg major version for use in other control files
58 export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
59 export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
60
61 # Determine which package we should provide in the control files
62 LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
63 LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
64
65 debian/shlibs.local: apt-pkg/makefile
66 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
67 # one for the rest of the packages. This ensures that each package gets
68 # the right overrides..
69 rm -rf $@ $@.apt $@.apt-utils
70 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
71
72 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
73 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
74
75 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
76 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
77
78 build: build/build-stamp
79
80 # Note that this is unconditionally done first as part of loading environment.mak
81 # The true is needed to force make to reload environment.mak after running
82 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
83 build/environment.mak: build/configure-stamp
84 @true
85
86 configure: configure.in
87 build/configure-stamp: configure
88 dh_testdir
89 -mkdir build
90 (cd build; ../configure)
91 touch $@
92
93 build/build-stamp: build/configure-stamp
94 # Add here commands to compile the package.
95 $(MAKE) -s
96 touch $@
97
98 clean:
99 dh_testdir
100 # dh_testroot
101 rm -f build-stamp debian/shlibs.local
102 rm -rf build
103 rm -f debian/shlibs.local.apt debian/shlibs.local.apt-utils
104
105 # Add here commands to clean up after the build process.
106 -$(MAKE) clean
107 -$(MAKE) distclean
108 dh_clean
109
110 binary-indep: libapt-pkg-doc
111 # Build architecture-independent files here.
112 libapt-pkg-doc: build debian/shlibs.local
113 dh_testdir -p$@
114 dh_testroot -p$@
115 dh_clean -p$@ -k
116 dh_installdirs -p$@
117 #
118 # libapt-pkg-doc install
119 #
120 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
121 $(BLD)/docs/files* $(BLD)/docs/method* \
122 doc/libapt-pkg2_to_3.txt doc/style.txt
123
124 -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
125 -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
126
127 dh_installexamples -p$@
128 # dh_installmenu -p$@
129 # dh_installinit -p$@
130 # dh_installcron -p$@
131 # dh_installmanpages -p$@
132
133 # dh_undocumented -p$@
134 dh_installchangelogs -p$@
135 dh_strip -p$@
136 dh_compress -p$@
137 dh_fixperms -p$@
138 # dh_suidregister -p$@
139 dh_installdeb -p$@
140 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
141 dh_md5sums -p$@
142 dh_builddeb -p$@
143
144
145 # Build architecture-dependent files here.
146
147 binary-arch: apt libapt-pkg-dev apt-utils
148 apt: build debian/shlibs.local
149 dh_testdir -p$@
150 dh_testroot -p$@
151 dh_clean -p$@ -k
152 dh_installdirs -p$@
153 #
154 # apt install
155 #
156 cp $(BLD)/bin/apt-* debian/tmp/usr/bin/
157
158 # Remove the bits that are in apt-utils
159 rm $(addprefix debian/tmp/usr/bin/apt-,$(APT_UTILS))
160
161 # install the shared libs
162 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
163 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
164
165 cp $(BLD)/bin/methods/* debian/tmp/usr/lib/apt/methods/
166
167 cp $(BLD)/scripts/dselect/* debian/tmp/usr/lib/dpkg/methods/apt/
168
169 # Copy the guides
170 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
171 $(BLD)/docs/offline.text $(BLD)/docs/offline.html
172
173 # One or the other..
174 -cp -a debian/dhelp debian/tmp/usr/doc/apt/.dhelp
175 -cp -a debian/dhelp debian/tmp/usr/share/doc/apt/.dhelp
176
177 # head -n 500 ChangeLog > debian/ChangeLog
178
179 dh_installexamples -p$@ $(BLD)/docs/examples/*
180 dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1
181
182 dh_installchangelogs -p$@
183 dh_strip -p$@
184 dh_compress -p$@
185 dh_fixperms -p$@
186 dh_installdeb -p$@
187 dh_shlibdeps -papt -l`pwd`/debian/tmp/usr/lib -- -Ldebian/shlibs.local.apt
188 # LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib dh_shlibdeps -papt
189 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
190 dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
191 dh_md5sums -p$@
192 dh_builddeb -p$@
193
194 libapt-pkg-dev: build debian/shlibs.local
195 dh_testdir -p$@
196 dh_testroot -p$@
197 dh_clean -p$@ -k
198 dh_installdirs -p$@
199 #
200 # libapt-pkg-dev install
201 #
202 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
203 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
204 #ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
205 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
206
207 dh_installdocs -p$@
208 # dh_installmenu -p$@
209 # dh_installinit -p$@
210 # dh_installcron -p$@
211 # dh_installmanpages -p$@
212
213 dh_installchangelogs -p$@
214 dh_strip -p$@
215 dh_compress -p$@
216 dh_fixperms -p$@
217 # dh_suidregister -p$@
218 dh_installdeb -p$@
219 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
220 dh_md5sums -p$@
221 dh_builddeb -p$@
222
223 apt-utils: build debian/shlibs.local
224 dh_testdir -p$@
225 dh_testroot -p$@
226 dh_clean -p$@ -k
227 dh_installdirs -p$@
228
229 # install the shared libs
230 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
231 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
232
233 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
234 dh_installdocs -p$@
235
236 # Install the man pages..
237 mkdir -p debian/$@/usr/share/man/man1
238 -cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 debian/$@/usr/share/man/man1/
239
240 dh_installchangelogs -p$@
241 dh_strip -p$@
242 dh_compress -p$@
243 dh_fixperms -p$@
244 dh_installdeb -p$@
245 LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
246 dh_gencontrol -p$@ -u -Vlibapt-inst:major=$(LIBAPTINST_MAJOR)
247 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
248 dh_md5sums -p$@
249 dh_builddeb -p$@
250
251 source diff:
252 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
253
254 # Update from CVS
255 l33ch: really-clean
256 cvs update
257 buildlib/mkChangeLog
258
259 # Update from CVS and then configure for build
260 super-l33ch: l33ch Makefile.in
261
262 configure:
263 $(MAKE) configure
264
265 l33ch-stamp: super-l33ch
266 touch $@
267
268 really-clean: clean
269 -find -name Makefile.in -print0 | xargs -0r rm -f
270 find -name ChangeLog | xargs rm -f
271 rm -f l33ch-stamp
272
273 binary: binary-indep binary-arch
274 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
275
276
277 # Done by the uploader.
278 #cvs update..
279 #edit debian/changelog
280 # configure.in has the version automatically updated now.
281 # edit configure.in
282 # debian/rules cvs-build
283
284 cvs-build:
285 rm -rf debian/cvs-build
286 cvs update
287 #buildlib/mkChangeLog
288 $(MAKE) startup
289 $(MAKE) doc
290 tar c --exclude CVS --exclude cvs-build . |\
291 (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
292 # The next line isn't needed, as debuild will make the .tar.gz for us.
293 # (cd debian/cvs-build;tar zcf apt_$(APT_DEBVER).tar.gz apt-$(APT_DEBVER))
294 (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
295 #rm ChangeLog
296
297 cvs-mkul:
298 -mkdir -p ../upload-$(APT_DEBVER)
299 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)