1 apt (0.5.4.9) unstable; urgency=low
3 * New deb version compare function, that has no integer limits, and
4 supports pre-versions using ~. Code ported from dpkg.
5 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
6 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
7 * "apt-get --arch-only build-dep" to install only architecture-
8 dependent build dependencies. Bump minor shared lib number to reflect
9 small change in BuildDepend API.
10 * APT::Build-Essential configuration option (defaults to "build-essential")
11 so that "apt-get build-dep" will ensure build essential packages are
12 installed prior to installing other build-dependencies. Closes: #148879
13 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
14 * /usr/doc reference in postinst. Closes: #126189
15 * Doc updates. Closes: #120689
16 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
18 * Print special message for EAI_AGAIN. Closes: #131397
19 * libapt-pkg-dev needs to bring in the apt-inst library if linking
20 is to work. Closes: #133943
21 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
22 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
23 #139994, #142955, #151654, #151834, #147611, #154268, #173971
24 * Fix possibility for tag file parsing to fail in some unlikely situations.
26 * Use std C++ names for some header files. Closes: #128741
27 * Do not check for free space if --no-download. Closes: #117856
28 * Actually implement or group handling for 'upgrade'. Closes: #133950
29 * "Internal Error, Couldn't configure pre-depend" is not actually an
30 internal error, it is a packaging error and now it says so, and
31 pinpoints the problem dependency. Closes: #155621
32 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
33 * Use usr/share/doc for dhelp. Closes: #115701
34 * --print-uris works with 'update'. Closes: #57070
35 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
37 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
39 * Allow an uninstalled package to be marked for removal on an install
40 line (meaning not to automatically install it), also fix some dodgy
41 handling of protected packages. Closes: #92287, #116011
42 * Fix errant prefix matching in version selection. Closes: #105968
43 * Ensure that all files needed to run APT as a user are readable and
44 ignore roots umask for these files. Closes: #108801
45 * Support larger config spaces. Closes: #111914
46 * 'apt-get update' no longer does 'Building Dependency Tree'.
47 * When matching regexs allways print a message. Change regex activation
48 charset. Closes: #147817
49 * Don't die if lines in sources.list are too long. Closes: #146846
50 * Show file name on apt-extracttemplate error messges. Closes: #151835
51 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
52 * Some highly unlikely memory faults. Closes: #155842
53 * C++ stuff for G++3.2. Closes: #162617, #165515,
54 * apt-config dumps sends to stdout not stderr now. Closes: #146294
55 * Fix segfault in FindAny when /i is used, and there is no default.
57 * Add s390x to archtable. Closese: #160992.
58 * Update config.sub/config.guess in cvs, and add support to debian/rules
59 to update them from /usr/share/misc if they exist. Closes: #155014
60 * Remove 'Sorry' from messages. Closes: #148824.
61 * Change wording of 'additional disk space usage' message. Closes:
63 * apt-extracttemplates now prepends the package name when extracting
64 files. Closes: #132776
65 * Add -n synonym for --names-only for apt-cache. Closes: #130689
66 * Display both current version and new version in apt-get -s. Closes:
68 * Add an options and timeout config item to ssh/rsh. Closes: #90654
69 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
70 * Change verbose logging output of apt-ftparchive to go to stderr,
71 instead of stdout. Also, errors that occur no longer go to stdout,
72 but stderr. Closes: #161592
73 * Test for timegm in configure. Closes: #165516.
74 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
75 support compliation on platforms where st_mtime is a macro. Closes:
77 * Check the currently mounted cdrom, to see if it's the one we are
78 interested in. Closes: #154602
79 * Refer to reportbug instead of bug in the man pages. Closes: #173745
80 * Link apt-inst to apt-pkg. Closes: #175055
81 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
83 * Fix > 300 col screen segfault. Closes: #176052
84 * Rebuild with gcc-3.2. Closes: #177752, #178008.
85 * Fix build-dep handling of | dependencies.
86 Closes: #98640, #145997, #158896, #172901
87 * Double default value of APT::Cache-Limit, until such time as it
88 can be made more dynamic. Closes: #178623.
89 * Report uris with '.gz' when there are errors. Closes: #178435.
90 * When installing build-deps, make sure the new version will
91 satisfy build requirements. Closes: #178121
92 * Split offline and guide documentation into apt-doc. This was done so
93 that binary-arch builds do not require documention deps. Note, that
94 apt-doc is not installed on upgrades.
95 * Use doc-base, instead of dhelp directly. Closes: #110389
96 * Change http message 'Waiting for file' to 'Waiting for headers'.
98 * Remove trailing lines on package lists in apt-get. Closes: #178736.
99 * Fix origin pins for file:// uris. Closes: #189014.
100 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
103 -- Adam Heath <doogie@debian.org> Sun, 02 Feb 2003 02:54:45 -0600
105 apt (0.5.4) unstable; urgency=low
107 * M68k config.guess patch. Closes: #88913
108 * Bi-yearly test on OpenBSD and Solaris
109 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
110 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
112 * Various cosmetic code updates. Closes: #89066, #89066, #89152
113 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
115 * More patches from Alfredo for Vendors and more SHA-1 stuff
116 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
117 similar situations. Closes: #56708, #59432
118 * no_proxy and ftp. Closes: #89671
119 * Philippe Batailler's man page patches.
120 * Fix for display bug. Closes: #92033, #93652, #98468
121 * Use more than 16bits for the dep ID. Some people ran out..
122 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
123 #106911, #107395, #108968
124 * Reordered some things to make dante and FTP happier. Closes: #92757
125 * James R. Van Zandt's guide.sgml updates. Closes: #90027
126 * apt-ftparchive copes with no uncompressed package files + contents.
127 * French man pages from philippe batailler - well sort of. They
129 * run-parts. Closes: #94286
130 * 'apt-cache policy' preferences debug tool.
131 * Whatever. Closes: #89762
132 * libstdc++ and HURD. Closes: #92025
133 * More apt-utils verbage. Closes: #86954
134 * Fliped comparision operator. Closes: #94618
135 * Used the right copyright file. Closes: #65691
136 * Randolph's G++3 patches.
137 * Fixed no_proxy tokanizing. Closes: #100046
138 * Strip Config-Version when copying status to available. Closes: #97520
139 * Segfault with missing source files. Closes: #100325
140 * EINTR check. Closes: #102293
141 * Various changes to the locking metholodgy for --print-uris.
143 * Lame LD_LIBRARY_PATH thing. Closes: #98928
144 * apt-cache search searchs provide names too now. Closes: #98695
145 * Checksum and long lines problem. Closes: #106591
146 * .aptignr and empty files are just a warning. Closes: #97364
148 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
150 apt (0.5.3) unstable; urgency=low
152 * JoeyH's dpkg::preconfig not working. Closes: #88675
153 * Fixed apt override disparity
154 * Alfredo's SHA-1 and related patches
156 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
158 apt (0.5.2) unstable; urgency=low
160 * Fixed mention of /usr/doc in the long description
161 * JoeyH's downgrade bug -- don't use 0.5.1
162 * Doc bug. Closes: #88538
163 * Fault in building release strings. Closes: #88533
165 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
167 apt (0.5.1) unstable; urgency=low
169 * Fixed #82894 again, or should be and.
170 * Process the option string right. Closes: #86921
171 * Don't eat the last command for pipes. Closes: #86923
172 * Ignore .* for configuration directory processing. Closes: #86923
173 * Alfredo's no_proxy patch
174 * Documentation fixes. Closes: #87091
175 * JoeyH's double slash bug. Closes: #87266
176 * Unintitialized buffer and apt-ftparchive contents generation.
178 * Build-deps on virtual packages. Closes: #87639
179 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
180 libstdc++ version info in the library soname and in the package
181 provides. Closes: #87426
182 * Updated soname version to 0.3.2
183 * apt-extracttemplates moved from debconf into apt-utils
184 * s390 archtable entry. Closes: #88232
186 * Some instances where the status file can source a package in a
187 non-sensical way. Closes: #87390
188 * Work better if there are duplicate sources.list entries.
189 * Fixed the resetting of Dir with "dir {};". Closes: #87323
191 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
193 apt (0.5.0) unstable; urgency=low
195 * Fixed an obscure bug with missing final double new lines in
197 * Changed the apt-cdrom index copy routine to use the new section
199 * Added a package file sorter, apt-sortpkgs
200 * Parse obsolete Optional dependencies.
201 * Added Ben's rsh method. Closes: #57794
202 * Added IPv6 FTP support and better DNS rotation support.
203 * Include the server IP in error messages when using a DNS rotation.
205 * Made most of the byte counters into doubles to prevent 32bit overflow.
207 * HTTP Authorization. Closes: #61158
208 * Ability to parse and return source index build depends from Randolph.
209 * new 'apt-get build-dep' command from Randolph. Closes: #63982
210 * Added apt-ftparchive the all dancing all singing FTP archive
212 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
214 * Removed useless internal cruft including the xstatus file.
215 * Fixed config parser bugs. Closes: #67848, #71108
216 * Brain Damanged apt-get config options changed, does not change the command
217 line interface, except to allow --enable-* to undo a configuration
220 No-Download -> Download
221 No-Upgrade -> Upgrade
222 * Made this fix configable (DSelect::CheckDir) and default to disabled:
223 * No remove prompt if the archives dir has not changed. Closes: #55709
224 Because it is stupid in the case where no files were downloaded due to
225 a resumed-aborted install, or a full cache! Closes: #65952
226 * Obscure divide by zero problem. Closes: #64394
227 * Update sizetable for mips. Closes: #62288
228 * Fixed a bug with passive FTP connections
229 * Has sizetable entry for sparc64. Closes: #64869
230 * Escape special characters in the ::Label section of the cdroms.lst
231 * Created apt-utils and python-apt packages
232 * Due to the new policy engine, the available file may contain entries
233 from the status file. These are generated if the package is not obsolete
234 but the policy engine prohibits using the version from the package files.
235 They can be identified by the lack of a Filename field.
236 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
237 #36223, #33468, #22551
238 * Fixed deb-src line for non-us. Closes: #71501, #71601
239 * Fixes for G++ 2.96, s/friend/friend class/
240 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
241 * Confirmed fix for missing new line problem. Closes: #69386
242 * Fixed up dhelp files. Closes: #71312
243 * Added some notes about dselect and offline usage. Closes: #66473, #38316
244 * Lock files on read only file systems are ignored w/ warning.
246 * apt-get update foo now gives an error! Closes: #42891
247 * Added test for shlibs on hurd. Closes: #71499
248 * Clarified apt-cache document. Closes: #71934
249 * DocBook SGML man pages and some improvements in the text..
250 * sigwinch thing. Closes: #72382
251 * Caching can be turned off by setting the cache file names blank.
252 * Ignores arches it does not know about when autocleaning. Closes: #72862
253 * New function in apt-config to return dirs, files, bools and integers.
254 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
255 complex cases involving OR groups and provides.
256 68754 describes confusing messages which are the result of this..
257 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
258 * Speeling mistake and return code for the 'wicked' resolver error
259 Closes: #72621, #75226, #77464
260 * Solved unable to upgrade libc6 from potato to woody due to 3 package
261 libc6 dependency loop problem.
262 * Leading sources.list spaces. Closes: #76010
263 * Removed a possible infinite loop while processing installations.
264 * Man page updates. Closes: #75411, #75560, #64292, #78469
265 * ReduceSourceList bug. Closes: #76027
266 * --only-source option. Closes: #76320
267 * Typos. Closes: #77812, #77999
268 * Different status messages. Closes: #76652, #78353
269 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
270 * OS detection an support for the new pseduo standard of os-arch for the
271 Architecture string. Also uses regexing.. Closes: #39227, #72349
272 * Various i18n stuff. Note that this still needs some i18n wizard
273 to do the last gettextization right. Closes: #62386
274 * Fixed a problem with some odd http servers/proxies that did not return
275 the content size in the header. Closes: #79878, #44379
276 * Little acquire bugs. Closes: #77029, #55820
277 * _POSIX_THREADS may not be defined to anything, just defined..
279 * Spelling of Ignore-Hold correctly. Closes: #78042
280 * Unlock the dpkg db if in download only mode. Closes: #84851
281 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
282 * Patch from BenC. Closes: #80810
283 * Single output of some names in lists. Closes: #80498, #43286
284 * Nice message for people who can't read syserror output. Closes: #84734
285 * OR search function. Closes: #82894
286 * User's guide updates. Closes: #82469
287 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
288 * Various CD bugs, again thanks to Greenbush
289 Closes: #80946, #76547, #71810, #70049, #69482
290 * Using potato debhelper. Closes: #57977
291 * I cannot self-terminate. Closes: #74928
293 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
295 apt (0.3.19) frozen unstable; urgency=low
297 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
299 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
300 * Fixed hardcoded path. Closes: #59743
301 * Fixed Jay's relative path bug
302 * Allowed source only CDs. Closes: #58952
303 * Space check is supressed if --print-uris is given. Closes: #58965
304 * Clarified the documenation examples for non-us. Closes: #58646
305 * Typo in the package description. Closes: #60230
306 * Man Page typo. Closes: #60347
307 * Typo in Algorithms.cc. Closes: #63577
308 * Evil dotty function in apt-cache for generating dependency graphs
309 with the as-yet-unpackaged GraphVis.
310 * Appears to have been fixed in Janurary.. Closes: #57981
311 * New config.guess/sub for the new archs. Closes: #60874
312 * Fixed error reporting for certain kinds of resolution failures.
314 * Made autoclean respect 'q' settings. Closes: #63023
315 * Fixed up the example sources.list. Closes: #63676
316 * Added DPkg::FlushSTDIN to control the flushing of stdin before
317 forking dpkg. Closes: #63991
319 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
321 apt (0.3.18) frozen unstable; urgency=low
323 * Changes in the postinst script. Closes: #56855, #57237
324 * Fixed bashism. Closes: #57216, #57335
325 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
327 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
329 apt (0.3.17) unstable; urgency=low
331 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
332 * Fixed the configuration parser to not blow up if ; is in the config
334 * Applied visual patch to dselect install script . Closes #55214
335 * Included the configure-index example
337 * Library soname has increased
338 * Fixed default sources.list to have correct URLs for potato when it
340 * Added a message about erasing sources.list to dselect setup script
342 * No remove prompt if the archives dir has not changed. Closes: #55709
343 * Fixed inclusion of 2nd sample config file. Closes: #55374
344 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
347 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
349 apt (0.3.16) unstable; urgency=low
351 * Made --no-download work. Closes: #52993
352 * Now compiles on OpenBSD, Solaris and HP-UX
353 * Clarify segfault errors
354 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
355 * Fix for Joel's discovery of glibc removal behavoir.
356 * Fix for Ben Collins file: uri from slink upgrade.
357 * Fixed resume code in FTP. Closes: #54323
358 * Take more precautions to prevent the corruption Joey Hess saw.
359 * Fixed --no-list-cleanup
360 * RFC 2732 URI parsing ([] for hostnames).
361 * Typo in apt-cache man page. Closes: #54949
363 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
365 apt (0.3.15) unstable; urgency=low
367 * Added DSelect::WaitAfterDownload Closes: #49549
368 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
369 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
370 * Made -s and clean not do anything. Closes: #50238
371 * Problem with Protected packages and the new OR code.
372 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
373 * Remove doesn't require a package to be installable. Closes: #51175
374 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
376 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
378 apt (0.3.14) unstable; urgency=low
380 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
381 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
382 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
383 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
384 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
385 Closes: #45034, #45695, #46537
386 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
387 * Added APT::Clean-Installed option. Closes: #45973
388 * Moves the free space check to after the calculated size is printed.
389 Closes: #46639, #47498
390 * mipsel arch Closes: #47614
391 * Beautified URI printing to not include passwords Closes: #46857
392 * Fixed little problem with --no-download Closes: #47557
393 * Tweaked Dselect 'update' script to re-gen the avail file even in the
394 event of a failure Closes: #47112
395 * Retries for source archives too Closes: #47529
396 * Unmounts CDROMs iff it mounted them Closes: #45299
397 * Checks for the partial directories before doing downloads Closes: #47392
398 * no_proxy environment variable (http only!) Closes: #43476
399 * apt-cache showsrc Closes: #45799
400 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
401 * Regexs for install. Closes: #35304, #38835
402 * Dependency reports now show OR group relations
403 * Re-Install feature. Cloes: #46961, #37393, #38919
404 * Locks archive directory on clean (woops)
405 * Remove is not 'sticky'. Closes: #48392
406 * Slightly more accurate 'can not find package' message. Closes: #48311
407 * --trivial-only and --no-remove. Closes: #48518
408 * Increased the cache size. Closes: #47648
409 * Comment woopsie. Closes: #48789
410 * Removes existing links when linking sources. Closes: #48775
411 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
412 * Clearer usage message about 'source' Closes: #48858
413 * Immediate configure internal error Closes: #49062, #48884
415 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
417 apt (0.3.13) unstable; urgency=low
419 * Fix timestamp miss in FTP. Closes: #44363
420 * Fix sorting of Kept packages. Closes: #44377
421 * Fix Segfault for dselect-upgrade. Closes: #44436
422 * Fix handling of '/' for the dist name. Closes #43830
423 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
424 * Add commented-out deb-src URI to default sources.list file.
426 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
428 apt (0.3.12) unstable; urgency=low
430 * Fix for typo in the dhelp index. Closes: #40377
431 * Multiple media swap support
432 * Purge support. Closes: #33291, #40694
433 * Better handling of - remove notation. Closes: #41024
434 * Purge support. Closes: #33291, #40694
435 * Error code on failed update. Closes: #41053
436 * apt-cdrom adds entries for source directories. Closes: #41231
437 * Sorts the output of any list. Closes: #41107
438 * Fixes the looping problem. Closes: #41784, #42414, #44022
439 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
440 * More checks to keep the display sane. Particularly when fail-over is
441 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
442 * PThread lockup problem on certain sparc/m68k. Closes: #40628
443 * apt-cdrom understands .gz Package files too. Closes: #42779
444 * Spelling error in dselect method description. Closes: #43251
445 * Added security to the default source list. Closes: #43356
447 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
449 apt (0.3.11) unstable; urgency=low
451 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
452 * Fix for properly upgrading the system from perl 5.004 to 5.005
454 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
456 apt (0.3.9) unstable; urgency=low
458 * Spelling error in cachefile.cc. Closes: #39885
459 * Trailing slash in dselect install if you try to use the
460 default config file. Closes: #40011
461 * Simulate works for autoclean. Closes: #39141
462 * Fixed spelling errors. Closes: #39673
463 * Changed url parsing a bit. Closes: #40070, #40069
464 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
466 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
468 apt (0.3.7) unstable; urgency=low
470 * Fixed missing text in the apt-get(8) page. Closes: #37596
471 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
472 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
473 * Fixed handling of the -q option with not-entirely integer arguments
475 * Man page typo Closes: #37762
476 * Fixed parsing of the Source: line. Closes: #37679
477 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
478 * Added a check for an empty cache directory. Closes: #37963
479 * Return a failure code if -d is given and packages fail to download.
481 * Arranged for an ftp proxy specifing an http server to work. See the
482 important note in the sources.list man page.
483 * Accounted for resumed files in the cps calculation. Closes: #36787
484 * Deal with duplicate same version different packages. Closes: #30237
485 * Added --no-download. Closes: #38095
486 * Order of apt-cdrom dist detection. Closes: #38139
487 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
489 * Suggests dpkg-dev for apt-get source. Closes: #38158
490 * Fixed typo in apt-get help. Closes: #38712
491 * Improved the error message in the case of broken held package. Closes: #38777
492 * Fixed handling of MD5 failures
493 * Documented list notation Closes: #39008
494 * Change the 'b' to 'B'. Closes: #39007
496 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
498 apt (0.3.6) unstable; urgency=low
500 * Note that 0.3.5 never made it out the door..
501 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
502 * Made APT print numbers in decimal. Closes: #35617, #37319
503 * Buffer munching fix for FTP. Closes: #35868
504 * Typo in sample config file. Closes: #35907
505 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
506 * Changed installed size counter to only count unpacked packages.
508 * apt-get source support. Closes: #23934, #27190
509 * Renames .debs that fail MD5 checking, provides automatic corruption
510 recovery. Closes: #35931
511 * Fixed autoconf verison. Closes: #37305
512 * Random Segfaulting. Closes: #37312, #37530
513 * Fixed apt-cache man page. Closes: #36904
514 * Added a newline to apt-cache showpkg. Closes: #36903
516 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
518 apt (0.3.4) unstable; urgency=low
520 * Release for Ben while he is out of town.
521 * Checked the size of partial files. Closes: #33705
522 * apt-get should not print progress on non-tty. Closes: #34944
523 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
524 * Applied cdrom patches from Torsten. Closes: #35140, #35141
525 * smbmounted cdrom fix. Closes: #35470
526 * Changed ie to eg. Closes: #35196
528 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
530 apt (0.3.3) unstable; urgency=low
532 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
534 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
536 apt (0.3.2) unstable; urgency=low
538 * Major release into unstable of v3
539 * These bugs have been fixed, explanations are in the bug system, read
540 the man pages as well..
541 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
542 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
543 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
544 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
545 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
546 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
547 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
548 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
550 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
552 apt (0.3.1) experimental; urgency=low
554 * Minor release of cvs version.
555 * Added virtual package libapt-pkgx.x
557 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
559 apt (0.3.0) experimental; urgency=low
561 * New experimental version.
563 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
565 apt (0.1.9) frozen unstable; urgency=low
567 * Return to the wacky numbering for when we build 0.1.8 for hamm
568 * Important bug related to APT on the Alpha fixed
569 * apt-get dist-upgrade problems fixed
570 * tiny patch for http method to fix an endless loop
571 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
572 libtool and add proper shared lib dependancies
573 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
574 in case an old libpkg is installed while building APT to prevent
575 spurious dependancies
577 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
579 apt (0.1.7) unstable; urgency=low
581 * New build with libstdc++2.9.
582 * Various fixes; read the Changelog.
584 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
586 apt (0.1.6) unstable; urgency=low
588 * Various fixes in the FTP method for error checking. Fixes: #26188.
589 * Spelling corrections in dselect method. Fixes: #25884
590 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
591 * No more bo releases: we're using a normal numbering system now.
593 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
595 apt (0.1.5) unstable; urgency=low
597 * Changed sources.list to point to 'unstable' by default, as
598 'frozen' no longer exists!
600 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
602 apt (0.1.3) unstable; urgency=low
604 * New upstreamish version.
605 * ftp method rewritten in C. Removes dependancies on all perl/perl
606 related modules. This fixes many of the ftp method bugs.
608 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
610 apt (0.1.1) unstable; urgency=low
612 * Release for unstable.
614 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
616 apt (0.1) unstable; urgency=low
618 * Kludge to fix problem in libnet-perl with illegal anonymous
620 * Moved to unstable; apt is in a useable state now.
621 * Fixed version numbering. From now on, numbering will be:
622 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
623 0.1.1 (release for unstable). Thanks, Manoj.
625 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
627 apt (0.0.17-1) experimental; urgency=low
629 * Fixed problem with libc6 version compare
630 * Scott's away for a while, so I'll be packaging apt for the time
633 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
635 apt (0.0.16-1) experimental; urgency=low
637 * Modifications to make apt-get more friendly when backgrounded.
638 * Updated documentation.
639 * Updates to graphic widgets
641 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
643 apt (0.0.15-0.2bo) experimental; urgency=low
646 * Bob Hilliards crash
648 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
650 apt (0.0.15-0.1bo) experimental; urgency=low
655 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
657 apt (0.0.15) experimental; urgency=low
659 * Clean up source tarball (no user-visible changes)
661 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
663 apt (0.0.14) experimental; urgency=low
665 * Updates in ordering code to make sure certain upgrades work correctly.
666 * Made dselect/setup understand ftp as well as http
668 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
670 apt (0.0.13-bo1) experimental; urgency=low
674 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
676 apt (0.0.13) experimental; urgency=low
678 * Remove hardcoded egcc from debian/rules (#21575)
679 * Fixes for ordering logic when system has a number of unpacked
680 but unconfigured packages installed.
681 * Spelling fix in dselect install method (#22556)
683 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
685 apt (0.0.12) experimental; urgency=low
687 * Fixed problems with package cache corruption.
688 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
690 * Interface and documentation improvements.
692 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
694 apt (0.0.11) experimental; urgency=low
696 * Change dependancies to pre-depends since breaking your packaging tools
697 in the middle of an installation isn't very good.
698 * Bug fixes to ftp method and general apt-get code
700 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
702 apt (0.0.10) experimental; urgency=low
704 * Run "dpkg --configure -a" after an aborted dselect install
705 * Fixed problem with install looping
706 * Support for authenticating proxys: (note this isn't terribly secure)
707 http_proxy="http://user:pass@firewall:port/"
708 * Substitute $ARCH in sources.list
709 * Fixes in the resumption code for ftp
711 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
713 apt (0.0.9) experimental; urgency=low
716 * Various other less visible bug fixes.
717 * Fixed problem with segfault when apt-get invoked in a non-existant
718 directory (Bug #21863)
719 * Bumped policy to 2.4.1
721 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
723 apt (0.0.8) experimental; urgency=low
725 * Fixed generated available file (Bug #21836)
726 * Added download ETA (Bug #21774).
727 * Fixed hardcoded ARCH (Bug #21751).
728 * Fixed check on http_proxy (Bug #21795).
729 * Added download speed indicator.
731 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
733 apt (0.0.7) experimental; urgency=low
735 * Remove libdeity and apt from package for now, since only apt-get and
736 apt-cache are actually useful right now.
737 * Clean up handling of package installation errors.
738 * Added timeout to http transfers (#21269)
739 * Updated setup for dselect/apt method.
741 * Long options (added in 0.0.6)
743 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
745 apt (0.0.6) experimental; urgency=low
748 * Revamped download status display.
749 * Call apt-get clean after successful install in dselect.
750 * Added "apt-get clean" which deletes package files from /var/cache/apt
752 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
754 apt (0.0.5) experimental; urgency=low
756 * Ignore signals while dpkg is running so we don't leave dpkg running in
757 the background (#20804)
758 * Check Packages as well as Packages.gz for file URIs (#20784)
759 * Spelling cleanup (#20800)
760 * Added -m option to permit upgrade to go on in the case of a bad mirror.
761 This option may result in incomplete upgrades when used with -f.
763 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
765 apt (0.0.4) experimental; urgency=low
768 * Various documentation updates and cleanup.
769 * Added '-f' option to apt-get attempt to fix broken dependancies.
771 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
773 apt (0.0.3) experimental; urgency=low
775 * Added a shlibs.local file to prevent apt from depending on itself.
776 * Updates to how apt-get handles bad states in installed packages.
777 * Updated rules to make sure build works from a freshly checked out source
778 archive. Building from CVS needs libtool/automake/autoconf, builds from
779 the distributed source package should have no such dependancy.
781 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
783 apt (0.0.2) unstable; urgency=low
785 * Updates to apt-get and http binding for dselect method (apt).
786 * Updating version number from 0.0.1, which was released only on IRC.
788 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
790 apt (0.0.1) unstable; urgency=low
794 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500