2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
6 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
7 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
8 export DEB_HOST_MULTIARCH ?
= $(shell dpkg-architecture
-qDEB_HOST_MULTIARCH
)
10 # FOR AUTOCONF 2.52 AND NEWER ONLY
11 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
12 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
14 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
18 -include build
/environment.mak
20 ifneq (,$(shell which dpkg-buildflags
))
21 export CXXFLAGS
= $(shell dpkg-buildflags
--get CXXFLAGS
)
22 export LDFLAGS
= $(shell dpkg-buildflags
--get LDFLAGS
)
23 export CPPFLAGS
= $(shell dpkg-buildflags
--get CPPFLAGS
)
25 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
26 export CXXFLAGS
= -O0
-g
-Wall
28 export CXXFLAGS
= -O2
-g
-Wall
36 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
--preserve-envvar CCACHE_DIR
-us
-uc
$(DEB_BUILD_PROG_OPTS
)
38 # Determine the build directory to use
41 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
43 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
--machine
) $(BASE
)/build
45 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
46 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
47 override BLD
:= $(BUILDX
)
49 ifeq ($(words $(BLD
)),0)
50 override BLD
:= .
/build
53 # APT Programs in apt-utils
54 APT_UTILS
=ftparchive sortpkgs extracttemplates
56 # Uncomment this to turn on verbose mode.
59 # Find the libapt-pkg major version for use in other control files
60 include buildlib
/libversion.mak
62 # Determine which library package names to use
63 LIBAPT_PKG
=libapt-pkg
$(LIBAPTPKG_MAJOR
)
64 LIBAPT_INST
=libapt-inst
$(LIBAPTINST_MAJOR
)
66 # do not fail as we are just experimenting with symbol files for now
67 export DPKG_GENSYMBOLS_CHECK_LEVEL
=0
69 build
: build
/build-stamp
70 build-debiandoc
: build
/build-debiandoc-stamp
71 build-manpages
: build
/build-manpages-stamp
73 # Note that this is unconditionally done first as part of loading environment.mak
74 # The true is needed to force make to reload environment.mak after running
75 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
76 build
/environment.mak
: build
/configure-stamp
79 configure
: configure.in
80 build
/configure-stamp
: configure
83 cp COPYING debian
/copyright
84 cd build
&& CXXFLAGS
="$(CXXFLAGS)" LDFLAGS
="$(LDFLAGS)" CPPFLAGS
="$(CPPFLAGS)" ..
/configure
$(confflags
)
87 build
/build-stamp
: build
/configure-stamp
88 # Add here commands to compile the package.
90 # compat symlink for the locale split
91 mkdir
-p build
/usr
/share
92 cd build
/usr
/share
&& ln
-f
-s ..
/..
/locale .
93 # compile and run tests
94 ifeq (,$(findstring nocheck
, $(DEB_BUILD_OPTIONS
)))
97 @echo
"Tests DISABLED"
101 build
/build-debiandoc-stamp
: build
/configure-stamp
102 # Add here commands to compile the package.
106 build
/build-manpages-stamp
: build
/configure-stamp
107 # Add here commands to compile the package.
114 [ ! -f Makefile
] ||
$(MAKE
) clean distclean
116 rm -f debian
/$(LIBAPT_PKG
).
install debian
/$(LIBAPT_INST
).
install \
117 debian
/libapt-pkg-dev.
install
119 debian
/%.
install: debian
/%.
install.in
120 sed
's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
122 binary-indep
: apt-doc libapt-pkg-doc
123 # Build architecture-independent files here.
124 libapt-pkg-doc
: build-debiandoc
130 # libapt-pkg-doc install
132 dh_installdocs
-p
$@
$(BLD
)/docs
/design
* \
133 $(BLD
)/docs
/dpkg-tech
* \
135 $(BLD
)/docs
/method
* \
136 doc
/libapt-pkg2_to_3.txt \
138 $(BLD
)/doc
/doxygen
/html
139 dh_installexamples
-p
$@
141 dh_installchangelogs
-p
$@
150 apt-doc
: build-debiandoc
158 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text \
159 $(BLD
)/docs
/guide
*.html \
160 $(BLD
)/docs
/offline
*.text \
161 $(BLD
)/docs
/offline
*.html
162 dh_installchangelogs
-p
$@
172 # Build architecture-dependent files here.
174 binary-arch
: $(LIBAPT_PKG
) $(LIBAPT_INST
) apt libapt-pkg-dev apt-utils apt-transport-https
175 apt_MANPAGES
= apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
176 apt
: build build-manpages
184 cp debian
/apt.conf.autoremove debian
/$@
/etc
/apt
/apt.conf.d
/01autoremove
186 # make rosetta happy and remove pot files in po/ (but leave stuff
187 # in po/domains/* untouched) and cp *.po into each domain dir
191 dh_install
-p
$@
--sourcedir
=$(BLD
)
193 # Remove the bits that are in apt-utils
194 rm $(addprefix debian
/$@
/usr
/bin
/apt-
,$(APT_UTILS
) dump-solver internal-solver
)
196 # https has its own package
197 rm debian
/$@
/usr
/lib
/apt
/methods
/https
199 # move the mirror failure script in place
200 #mv debian/$@/usr/bin/apt-report-mirror-failure \
201 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
205 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
206 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/%.
[158],$(apt_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt_MANPAGES
)))
209 dh_installchangelogs
-p
$@
210 dh_installlogrotate
-p
$@
220 libapt-pkg-dev
: build debian
/libapt-pkg-dev.
install
226 # libapt-pkg-dev install
228 dh_install
-p
$@
--sourcedir
=$(BLD
)
230 dh_installchangelogs
-p
$@
235 dh_gencontrol
-p
$@
-- -Vlibapt-pkg-name
=$(LIBAPT_PKG
) -Vlibapt-inst-name
=$(LIBAPT_INST
)
239 apt-utils_MANPAGES
= apt-sortpkgs apt-ftparchive apt-extracttemplates
240 apt-utils
: build build-manpages
246 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
247 cp
$(BLD
)/bin
/apt-dump-solver debian
/$@
/usr
/lib
/apt
/solvers
/dump
248 cp
$(BLD
)/bin
/apt-internal-solver debian
/$@
/usr
/lib
/apt
/solvers
/apt
250 dh_install
-p
$@
--sourcedir
=$(BLD
)
253 dh_installexamples
-p
$@
255 # Install the man pages..
256 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/%.
[158],$(apt-utils_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt-utils_MANPAGES
)))
258 dh_installchangelogs
-p
$@
269 $(LIBAPT_PKG
): build debian
/$(LIBAPT_PKG
).
install
275 dh_install
-p
$@
--sourcedir
=$(BLD
)
277 dh_installchangelogs
-p
$@
288 $(LIBAPT_INST
): build debian
/$(LIBAPT_INST
).
install
294 dh_install
-p
$@
--sourcedir
=$(BLD
)
296 dh_installchangelogs
-p
$@
307 apt-transport-https
: build libapt-pkg-dev
313 dh_install
-p
$@
--sourcedir
=$(BLD
)
314 dh_installdocs
-p
$@ debian
/apt-transport-https.README
315 dh_installexamples
-p
$@
317 # Install the man pages..
320 dh_installchangelogs
-p
$@
334 -find .
-name Makefile.in
-print0 | xargs
--null
--no-run-if-empty
-- rm -f
335 find
-name ChangeLog | xargs
rm -f
338 binary
: binary-indep binary-arch
339 .PHONY
: build
clean binary-indep binary-arch binary