2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.20 2000/05/10 05:59:12 jgg Exp $
8 # For the deb builder, you can run 'debian/rules cvs-build', which does all
9 # steps nescessary to produce a proper source tarball with the CVS/ removed.
10 # It builds in debian/cvs-build/apt-<VER>/, and places files in
11 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
12 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 DEB_BUILD_PROG
:=debuild
-us
-uc
16 APT_DEBVER
=$(shell dpkg-parsechangelog |sed
-n
-e
'/^Version:/s/^Version: //p')
17 APT_CONFVER
=$(shell sed
-n
-e
's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in
)
19 # Determine the build directory to use
22 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
24 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
-m
) $(BASE
)/build
26 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
27 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
28 override BLD
:= $(BUILDX
)
30 ifeq ($(words $(BLD
)),0)
31 override BLD
:= .
/build
34 ifneq ($(APT_DEBVER
),$(APT_CONFVER
))
37 sed
-e
's/$(APT_CONFVER)/$(APT_DEBVER)/' $@
> $@.
$$$$;mv
$@.
$$$$ $@
42 # Uncomment this to turn on verbose mode.
45 # Find the libapt-pkg major version for use in other control files
46 export LIBAPT_MAJOR
:=$(shell egrep
'^MAJOR=' apt-pkg
/makefile |cut
-d
'=' -f
2)
49 # echo "libapt-pkg $(LIBAPT_MAJOR) libapt-pkg$(LIBAPT_MAJOR)" >> $@
50 # echo "libapt-pkg $(LIBAPT_MAJOR) apt $(APT_DEBVER)" >> $@
53 build-stamp
: configure
56 (cd build
; ..
/configure
)
57 # cd build && CXXFLAGS="-g -Wall -D_POSIX_C_SOURCE=199309" ../configure --disable-nls --disable-static --prefix=/usr
58 # cd build && make all-hdr
61 # Add here commands to compile the package.
71 # Add here commands to clean up after the build process.
76 binary-indep
: libapt-pkg-doc
77 # Build architecture-independent files here.
78 libapt-pkg-doc
: build debian
/shlibs.local
84 # libapt-pkg-doc install
86 dh_installdocs
-p
$@
$(BLD
)/docs
/cache
* $(BLD
)/docs
/design
* $(BLD
)/docs
/dpkg-tech
* \
87 $(BLD
)/docs
/files
* $(BLD
)/docs
/method
*
89 -cp
-a debian
/libapt-pkg-doc.dhelp debian
/libapt-pkg-doc
/usr
/doc
/libapt-pkg-doc
/.dhelp
90 -cp
-a debian
/libapt-pkg-doc.dhelp debian
/libapt-pkg-doc
/usr
/share
/doc
/libapt-pkg-doc
/.dhelp
92 dh_installexamples
-p
$@
96 # dh_installmanpages -p$@
98 # dh_undocumented -p$@
99 dh_installchangelogs
-p
$@
103 # dh_suidregister -p$@
105 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:major
=${LIBAPT_MAJOR}
110 # Build architecture-dependent files here.
112 binary-arch
: apt libapt-pkg-dev
113 apt
: build debian
/shlibs.local
121 cp
$(BLD
)/bin
/apt-
* debian
/tmp
/usr
/bin
/
123 # install the shared libs
124 find
$(BLD
)/bin
/ -type f
-name
"libapt-pkg.so.*" -exec cp
-a
"{}" debian
/tmp
/usr
/lib
/ \
;
125 find
$(BLD
)/bin
/ -type l
-name
"libapt-pkg.so.*" -exec cp
-a
"{}" debian
/tmp
/usr
/lib
/ \
;
127 cp
$(BLD
)/bin
/methods
/* debian
/tmp
/usr
/lib
/apt
/methods
/
129 cp
$(BLD
)/scripts
/dselect
/* debian
/tmp
/usr
/lib
/dpkg
/methods
/apt
/
132 dh_installdocs
-p
$@
$(BLD
)/docs
/guide.text
$(BLD
)/docs
/guide.html \
133 $(BLD
)/docs
/offline.text
$(BLD
)/docs
/offline.html
136 -cp
-a debian
/dhelp debian
/tmp
/usr
/doc
/apt
/.dhelp
137 -cp
-a debian
/dhelp debian
/tmp
/usr
/share
/doc
/apt
/.dhelp
139 # head -n 500 ChangeLog > debian/ChangeLog
141 dh_installexamples
-papt
$(BLD
)/docs
/examples
/*
142 dh_installmanpages
-p
$@
144 dh_installchangelogs
-p
$@
149 LD_LIBRARY_PATH
=`pwd`/debian
/tmp
/usr
/lib dh_shlibdeps
-papt
150 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:major
=${LIBAPT_MAJOR}
151 dh_makeshlibs
-m
${LIBAPT_MAJOR} -Vlibapt-pkg
${LIBAPT_MAJOR} -papt
155 libapt-pkg-dev
: build debian
/shlibs.local
161 # libapt-pkg-dev install
163 cp
-a
$(BLD
)/bin
/libapt-pkg.so debian
/libapt-pkg-dev
/usr
/lib
/
164 #ln -s libapt-pkg.so.${LIBAPT_MAJOR} debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
165 cp
$(BLD
)/include/apt-pkg
/*.h debian
/libapt-pkg-dev
/usr
/include/apt-pkg
/
168 # dh_installmenu -papt
169 # dh_installinit -papt
170 # dh_installcron -papt
171 # dh_installmanpages -p$@
173 dh_installchangelogs
-p
$@
177 # dh_suidregister -p$@
179 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:major
=${LIBAPT_MAJOR}
184 @echo
>&2 'source and diff are obsolete - use dpkg-source -b'; false
191 # Update from CVS and then configure for build
192 super-l33ch
: l33ch Makefile.in
197 l33ch-stamp
: super-l33ch
201 -find
-name Makefile.in
-print0 | xargs
-0r
rm -f
202 find
-name ChangeLog | xargs
rm -f
205 binary
: binary-indep binary-arch
206 .PHONY
: build
clean binary-indep binary-arch binary debian
/shlibs.local
209 # Done by the uploader.
211 #edit debian/changelog
212 # configure.in has the version automatically updated now.
214 # debian/rules cvs-build
217 rm -rf debian
/cvs-build
222 tar c
--exclude CVS
--exclude debian
/cvs-build . |\
223 (mkdir
-p debian
/cvs-build
/apt-
$(APT_DEBVER
);cd debian
/cvs-build
/apt-
$(APT_DEBVER
);tar x
)
224 # The next line isn't needed, as debuild will make the .tar.gz for us.
225 # (cd debian/cvs-build;tar zcf apt_$(APT_DEBVER).tar.gz apt-$(APT_DEBVER))
226 (cd debian
/cvs-build
/apt-
$(APT_DEBVER
);$(DEB_BUILD_PROG
))
230 -mkdir
-p ..
/upload-
$(APT_DEBVER
)
231 cp
`find debian/cvs-build -maxdepth 1 -type f` ..
/upload-
$(APT_DEBVER
)