2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
6 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
7 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
8 export DEB_HOST_MULTIARCH ?
= $(shell dpkg-architecture
-qDEB_HOST_MULTIARCH
)
10 # FOR AUTOCONF 2.52 AND NEWER ONLY
11 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
12 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
14 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
18 -include build
/environment.mak
20 ifneq (,$(shell which dpkg-buildflags
))
21 export CXXFLAGS
= $(shell dpkg-buildflags
--get CXXFLAGS
)
22 export LDFLAGS
= $(shell dpkg-buildflags
--get LDFLAGS
)
23 export CPPFLAGS
= $(shell dpkg-buildflags
--get CPPFLAGS
)
25 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
26 export CXXFLAGS
= -O0
-g
-Wall
28 export CXXFLAGS
= -O2
-g
-Wall
36 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
--preserve-envvar CCACHE_DIR
-us
-uc
$(DEB_BUILD_PROG_OPTS
)
38 # Determine the build directory to use
41 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
43 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
--machine
) $(BASE
)/build
45 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
46 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
47 override BLD
:= $(BUILDX
)
49 ifeq ($(words $(BLD
)),0)
50 override BLD
:= .
/build
53 # APT Programs in apt-utils
54 APT_UTILS
=ftparchive sortpkgs extracttemplates
56 # Uncomment this to turn on verbose mode.
59 # Find the libapt-pkg major version for use in other control files
60 include buildlib
/libversion.mak
62 # Determine which library package names to use
63 LIBAPT_PKG
=libapt-pkg
$(LIBAPTPKG_MAJOR
)
64 LIBAPT_INST
=libapt-inst
$(LIBAPTINST_MAJOR
)
66 # do not fail as we are just experimenting with symbol files for now
67 export DPKG_GENSYMBOLS_CHECK_LEVEL
=0
69 build-binary
: build
/build-binary-stamp
70 build-debiandoc
: build
/build-debiandoc-stamp
71 build-manpages
: build
/build-manpages-stamp
73 # Note that this is unconditionally done first as part of loading environment.mak
74 # The true is needed to force make to reload environment.mak after running
75 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
76 build
/environment.mak
: build
/configure-stamp
79 configure
: configure.ac
80 build
/configure-stamp
: configure buildlib
/config.sub buildlib
/config.guess
83 cp COPYING debian
/copyright
84 cd build
&& CXXFLAGS
="$(CXXFLAGS)" LDFLAGS
="$(LDFLAGS)" CPPFLAGS
="$(CPPFLAGS)" ..
/configure
$(confflags
)
87 build
/build-binary-stamp
: build
/configure-stamp
88 # Add here commands to compile the package.
90 # compat symlink for the locale split
91 mkdir
-p build
/usr
/share
92 cd build
/usr
/share
&& ln
-f
-s ..
/..
/locale .
93 # compile and run tests
94 ifeq (,$(findstring nocheck
, $(DEB_BUILD_OPTIONS
)))
97 @echo
"Tests DISABLED"
101 build
/build-debiandoc-stamp
: build
/configure-stamp
102 # Add here commands to compile the package.
106 build
/build-manpages-stamp
: build
/configure-stamp
107 # Add here commands to compile the package.
115 [ ! -f Makefile
] ||
$(MAKE
) clean distclean
117 rm -f debian
/$(LIBAPT_PKG
).
install debian
/$(LIBAPT_INST
).
install \
118 debian
/libapt-pkg-dev.
install
119 test ! -L buildlib
/config.guess ||
rm -f buildlib
/config.guess
120 test ! -L buildlib
/config.sub ||
rm -f buildlib
/config.sub
122 debian
/%.
install: debian
/%.
install.in
123 sed
's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
125 # Build architecture-independent files here.
126 libapt-pkg-doc
: build-debiandoc
132 # libapt-pkg-doc install
134 dh_installdocs
-p
$@
$(BLD
)/docs
/design
* \
135 $(BLD
)/docs
/dpkg-tech
* \
137 $(BLD
)/docs
/method
* \
138 doc
/libapt-pkg2_to_3.txt \
140 $(BLD
)/doc
/doxygen
/html
141 dh_installexamples
-p
$@
143 dh_installchangelogs
-p
$@
152 apt-doc
: build-debiandoc
160 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text \
161 $(BLD
)/docs
/guide
*.html \
162 $(BLD
)/docs
/offline
*.text \
163 $(BLD
)/docs
/offline
*.html
164 dh_installchangelogs
-p
$@
174 # Build architecture-dependent files here.
176 apt_MANPAGES
= apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
177 apt
: build-binary build-manpages
185 cp debian
/apt.conf.autoremove debian
/$@
/etc
/apt
/apt.conf.d
/01autoremove
186 cp debian
/apt.auto-removal.sh debian
/$@
/etc
/kernel
/postinst.d
/apt-auto-removal
187 chmod
755 debian
/$@
/etc
/kernel
/postinst.d
/apt-auto-removal
189 # make rosetta happy and remove pot files in po/ (but leave stuff
190 # in po/domains/* untouched) and cp *.po into each domain dir
194 dh_install
-p
$@
--sourcedir
=$(BLD
)
196 # Remove the bits that are in apt-utils
197 rm $(addprefix debian
/$@
/usr
/bin
/apt-
,$(APT_UTILS
) dump-solver internal-solver
)
199 # https has its own package
200 rm debian
/$@
/usr
/lib
/apt
/methods
/https
202 # move the mirror failure script in place
203 #mv debian/$@/usr/bin/apt-report-mirror-failure \
204 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
208 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
209 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/en
/%.
[158],$(apt_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt_MANPAGES
)))
212 dh_installchangelogs
-p
$@
213 dh_installlogrotate
-p
$@
223 libapt-pkg-dev
: build-binary debian
/libapt-pkg-dev.
install
229 # libapt-pkg-dev install
231 dh_install
-p
$@
--sourcedir
=$(BLD
)
233 dh_installchangelogs
-p
$@
238 dh_gencontrol
-p
$@
-- -Vlibapt-pkg-name
=$(LIBAPT_PKG
) -Vlibapt-inst-name
=$(LIBAPT_INST
)
242 apt-utils_MANPAGES
= apt-sortpkgs apt-ftparchive apt-extracttemplates
243 apt-utils
: build-binary build-manpages
249 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
250 cp
$(BLD
)/bin
/apt-dump-solver debian
/$@
/usr
/lib
/apt
/solvers
/dump
251 cp
$(BLD
)/bin
/apt-internal-solver debian
/$@
/usr
/lib
/apt
/solvers
/apt
253 dh_install
-p
$@
--sourcedir
=$(BLD
)
256 dh_installexamples
-p
$@
258 # Install the man pages..
259 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/en
/%.
[158],$(apt-utils_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt-utils_MANPAGES
)))
261 dh_installchangelogs
-p
$@
272 $(LIBAPT_PKG
): build-binary debian
/$(LIBAPT_PKG
).
install
278 dh_install
-p
$@
--sourcedir
=$(BLD
)
280 dh_installchangelogs
-p
$@
291 $(LIBAPT_INST
): build-binary debian
/$(LIBAPT_INST
).
install
297 dh_install
-p
$@
--sourcedir
=$(BLD
)
299 dh_installchangelogs
-p
$@
310 apt-transport-https
: build-binary libapt-pkg-dev
316 dh_install
-p
$@
--sourcedir
=$(BLD
)
317 dh_installdocs
-p
$@ debian
/apt-transport-https.README
318 dh_installexamples
-p
$@
320 # Install the man pages..
323 dh_installchangelogs
-p
$@
333 buildlib
/config.guess buildlib
/config.sub
:
339 # translate targets to targets required by debian-policy
340 binary-arch
: $(LIBAPT_PKG
) $(LIBAPT_INST
) apt libapt-pkg-dev apt-utils apt-transport-https
341 binary-indep
: apt-doc libapt-pkg-doc
342 binary
: binary-indep binary-arch
343 build-arch
: build-binary
344 build-indep
: build-manpages build-debiandoc
345 build
: build-indep build-arch
347 .PHONY
: build
clean binary-indep binary-arch binary