1 apt (0.5.5) unstable; urgency=low
3 * New deb version compare function, that has no integer limits, and
4 supports pre-versions using ~. Code ported from dpkg.
5 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
6 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
7 * "apt-get --arch-only build-dep" to install only architecture-
8 dependent build dependencies. Bump minor shared lib number to reflect
9 small change in BuildDepend API.
10 * APT::Build-Essential configuration option (defaults to "build-essential")
11 so that "apt-get build-dep" will ensure build essential packages are
12 installed prior to installing other build-dependencies. Closes: #148879
13 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
14 * /usr/doc reference in postinst. Closes: #126189
15 * Doc updates. Closes: #120689
16 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
18 * Print special message for EAI_AGAIN. Closes: #131397
19 * libapt-pkg-dev needs to bring in the apt-inst library if linking
20 is to work. Closes: #133943
21 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
22 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
23 #139994, #142955, #151654, #151834, #147611, #154268
24 * Fix possibility for tag file parsing to fail in some unlikely situations.
26 * Use std C++ names for some header files. Closes: #128741,
27 * Do not check for free space if --no-download. Closes: #117856
28 * Actually implement or group handling for 'upgrade'. Closes: #133950
29 * "Internal Error, Couldn't configure pre-depend" is not actually an
30 internal error, it is a packaging error and now it says so, and
31 pinpoints the problem dependency. Closes: #155621
32 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
33 * Use usr/share/doc for dhelp. Closes: #115701
34 * --print-uris works with 'update'. Closes: #57070
35 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
37 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
39 * Allow an uninstalled package to be marked for removal on an install
40 line (meaning not to automatically install it), also fix some dodgy
41 handling of protected packages. Closes: #92287, #116011
42 * Fix errant prefix matching in version selection. Closes: #105968
43 * Ensure that all files needed to run APT as a user are readable and
44 ignore roots umask for these files. Closes: #108801
45 * Support larger config spaces. Closes: #111914
46 * 'apt-get update' no longer does 'Building Dependency Tree'.
47 * When matching regexs allways print a message. Change regex activation
48 charset. Closes: #147817
49 * Don't die if lines in sources.list are too long. Closes: #146846
50 * Show file name on apt-extracttemplate error messges. Closes: #151835
51 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
52 * Some highly unlikely memory faults. Closes: #155842
53 * C++ stuff for G++3.2. Closes: #162617, #165515,
54 * apt-config dumps sends to stdout not stderr now. Closes: #146294
55 * Fix segfault in FindAny when /i is used, and there is no default.
57 * Add s390x to archtable. Closese: #160992.
58 * Update config.sub/config.guess in cvs, and add support to debian/rules
59 to update them from /usr/share/misc if they exist. Closes: #155014
60 * Remove 'Sorry' from messages. Closes: #148824.
61 * Change wording of 'additional disk space usage' message. Closes:
63 * apt-extracttemplates now prepends the package name when extracting
64 files. Closes: #132776
65 * Add -n synonym for --names-only for apt-cache. Closes: #130689
66 * Display both current version and new version in apt-get -s. Closes:
68 * Add an options and timeout config item to ssh/rsh. Closes: #90654
69 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
70 * Change verbose logging output of apt-ftparchive to go to stderr,
71 instead of stdout. Also, errors that occur no longer go to stdout,
72 but stderr. Closes: #161592
73 * Test for timegm in configure. Closes: #165516.
74 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
75 support compliation on platforms where st_mtime is a macro. Closes:
77 * Check the currently mounted cdrom, to see if it's the one we are
78 interested in. Closes: #154602
79 * Rebuild with gcc-3.2. Closes: #177752, #178008.
80 * Fix build-dep handling of | dependencies.
81 Closes: #98640, #145997, #158896, #172901
82 * Double default value of APT::Cache-Limit, until such time as it
83 can be made more dynamic. Closes: #178623.
85 -- Jason Gunthorpe <jgg@debian.org> Sun, 15 Sep 2002 17:16:59 -0600
87 apt (0.5.4) unstable; urgency=low
89 * M68k config.guess patch. Closes: #88913
90 * Bi-yearly test on OpenBSD and Solaris
91 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
92 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
94 * Various cosmetic code updates. Closes: #89066, #89066, #89152
95 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
97 * More patches from Alfredo for Vendors and more SHA-1 stuff
98 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
99 similar situations. Closes: #56708, #59432
100 * no_proxy and ftp. Closes: #89671
101 * Philippe Batailler's man page patches.
102 * Fix for display bug. Closes: #92033, #93652, #98468
103 * Use more than 16bits for the dep ID. Some people ran out..
104 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
105 #106911, #107395, #108968
106 * Reordered some things to make dante and FTP happier. Closes: #92757
107 * James R. Van Zandt's guide.sgml updates. Closes: #90027
108 * apt-ftparchive copes with no uncompressed package files + contents.
109 * French man pages from philippe batailler - well sort of. They
111 * run-parts. Closes: #94286
112 * 'apt-cache policy' preferences debug tool.
113 * Whatever. Closes: #89762
114 * libstdc++ and HURD. Closes: #92025
115 * More apt-utils verbage. Closes: #86954
116 * Fliped comparision operator. Closes: #94618
117 * Used the right copyright file. Closes: #65691
118 * Randolph's G++3 patches.
119 * Fixed no_proxy tokanizing. Closes: #100046
120 * Strip Config-Version when copying status to available. Closes: #97520
121 * Segfault with missing source files. Closes: #100325
122 * EINTR check. Closes: #102293
123 * Various changes to the locking metholodgy for --print-uris.
125 * Lame LD_LIBRARY_PATH thing. Closes: #98928
126 * apt-cache search searchs provide names too now. Closes: #98695
127 * Checksum and long lines problem. Closes: #106591
128 * .aptignr and empty files are just a warning. Closes: #97364
130 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
132 apt (0.5.3) unstable; urgency=low
134 * JoeyH's dpkg::preconfig not working. Closes: #88675
135 * Fixed apt override disparity
136 * Alfredo's SHA-1 and related patches
138 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
140 apt (0.5.2) unstable; urgency=low
142 * Fixed mention of /usr/doc in the long description
143 * JoeyH's downgrade bug -- don't use 0.5.1
144 * Doc bug. Closes: #88538
145 * Fault in building release strings. Closes: #88533
147 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
149 apt (0.5.1) unstable; urgency=low
151 * Fixed #82894 again, or should be and.
152 * Process the option string right. Closes: #86921
153 * Don't eat the last command for pipes. Closes: #86923
154 * Ignore .* for configuration directory processing. Closes: #86923
155 * Alfredo's no_proxy patch
156 * Documentation fixes. Closes: #87091
157 * JoeyH's double slash bug. Closes: #87266
158 * Unintitialized buffer and apt-ftparchive contents generation.
160 * Build-deps on virtual packages. Closes: #87639
161 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
162 libstdc++ version info in the library soname and in the package
163 provides. Closes: #87426
164 * Updated soname version to 0.3.2
165 * apt-extracttemplates moved from debconf into apt-utils
166 * s390 archtable entry. Closes: #88232
168 * Some instances where the status file can source a package in a
169 non-sensical way. Closes: #87390
170 * Work better if there are duplicate sources.list entries.
171 * Fixed the resetting of Dir with "dir {};". Closes: #87323
173 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
175 apt (0.5.0) unstable; urgency=low
177 * Fixed an obscure bug with missing final double new lines in
179 * Changed the apt-cdrom index copy routine to use the new section
181 * Added a package file sorter, apt-sortpkgs
182 * Parse obsolete Optional dependencies.
183 * Added Ben's rsh method. Closes: #57794
184 * Added IPv6 FTP support and better DNS rotation support.
185 * Include the server IP in error messages when using a DNS rotation.
187 * Made most of the byte counters into doubles to prevent 32bit overflow.
189 * HTTP Authorization. Closes: #61158
190 * Ability to parse and return source index build depends from Randolph.
191 * new 'apt-get build-dep' command from Randolph. Closes: #63982
192 * Added apt-ftparchive the all dancing all singing FTP archive
194 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
196 * Removed useless internal cruft including the xstatus file.
197 * Fixed config parser bugs. Closes: #67848, #71108
198 * Brain Damanged apt-get config options changed, does not change the command
199 line interface, except to allow --enable-* to undo a configuration
202 No-Download -> Download
203 No-Upgrade -> Upgrade
204 * Made this fix configable (DSelect::CheckDir) and default to disabled:
205 * No remove prompt if the archives dir has not changed. Closes: #55709
206 Because it is stupid in the case where no files were downloaded due to
207 a resumed-aborted install, or a full cache! Closes: #65952
208 * Obscure divide by zero problem. Closes: #64394
209 * Update sizetable for mips. Closes: #62288
210 * Fixed a bug with passive FTP connections
211 * Has sizetable entry for sparc64. Closes: #64869
212 * Escape special characters in the ::Label section of the cdroms.lst
213 * Created apt-utils and python-apt packages
214 * Due to the new policy engine, the available file may contain entries
215 from the status file. These are generated if the package is not obsolete
216 but the policy engine prohibits using the version from the package files.
217 They can be identified by the lack of a Filename field.
218 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
219 #36223, #33468, #22551
220 * Fixed deb-src line for non-us. Closes: #71501, #71601
221 * Fixes for G++ 2.96, s/friend/friend class/
222 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
223 * Confirmed fix for missing new line problem. Closes: #69386
224 * Fixed up dhelp files. Closes: #71312
225 * Added some notes about dselect and offline usage. Closes: #66473, #38316
226 * Lock files on read only file systems are ignored w/ warning.
228 * apt-get update foo now gives an error! Closes: #42891
229 * Added test for shlibs on hurd. Closes: #71499
230 * Clarified apt-cache document. Closes: #71934
231 * DocBook SGML man pages and some improvements in the text..
232 * sigwinch thing. Closes: #72382
233 * Caching can be turned off by setting the cache file names blank.
234 * Ignores arches it does not know about when autocleaning. Closes: #72862
235 * New function in apt-config to return dirs, files, bools and integers.
236 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
237 complex cases involving OR groups and provides.
238 68754 describes confusing messages which are the result of this..
239 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
240 * Speeling mistake and return code for the 'wicked' resolver error
241 Closes: #72621, #75226, #77464
242 * Solved unable to upgrade libc6 from potato to woody due to 3 package
243 libc6 dependency loop problem.
244 * Leading sources.list spaces. Closes: #76010
245 * Removed a possible infinite loop while processing installations.
246 * Man page updates. Closes: #75411, #75560, #64292, #78469
247 * ReduceSourceList bug. Closes: #76027
248 * --only-source option. Closes: #76320
249 * Typos. Closes: #77812, #77999
250 * Different status messages. Closes: #76652, #78353
251 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
252 * OS detection an support for the new pseduo standard of os-arch for the
253 Architecture string. Also uses regexing.. Closes: #39227, #72349
254 * Various i18n stuff. Note that this still needs some i18n wizard
255 to do the last gettextization right. Closes: #62386
256 * Fixed a problem with some odd http servers/proxies that did not return
257 the content size in the header. Closes: #79878, #44379
258 * Little acquire bugs. Closes: #77029, #55820
259 * _POSIX_THREADS may not be defined to anything, just defined..
261 * Spelling of Ignore-Hold correctly. Closes: #78042
262 * Unlock the dpkg db if in download only mode. Closes: #84851
263 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
264 * Patch from BenC. Closes: #80810
265 * Single output of some names in lists. Closes: #80498, #43286
266 * Nice message for people who can't read syserror output. Closes: #84734
267 * OR search function. Closes: #82894
268 * User's guide updates. Closes: #82469
269 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
270 * Various CD bugs, again thanks to Greenbush
271 Closes: #80946, #76547, #71810, #70049, #69482
272 * Using potato debhelper. Closes: #57977
273 * I cannot self-terminate. Closes: #74928
275 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
277 apt (0.3.19) frozen unstable; urgency=low
279 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
281 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
282 * Fixed hardcoded path. Closes: #59743
283 * Fixed Jay's relative path bug
284 * Allowed source only CDs. Closes: #58952
285 * Space check is supressed if --print-uris is given. Closes: #58965
286 * Clarified the documenation examples for non-us. Closes: #58646
287 * Typo in the package description. Closes: #60230
288 * Man Page typo. Closes: #60347
289 * Typo in Algorithms.cc. Closes: #63577
290 * Evil dotty function in apt-cache for generating dependency graphs
291 with the as-yet-unpackaged GraphVis.
292 * Appears to have been fixed in Janurary.. Closes: #57981
293 * New config.guess/sub for the new archs. Closes: #60874
294 * Fixed error reporting for certain kinds of resolution failures.
296 * Made autoclean respect 'q' settings. Closes: #63023
297 * Fixed up the example sources.list. Closes: #63676
298 * Added DPkg::FlushSTDIN to control the flushing of stdin before
299 forking dpkg. Closes: #63991
301 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
303 apt (0.3.18) frozen unstable; urgency=low
305 * Changes in the postinst script. Closes: #56855, #57237
306 * Fixed bashism. Closes: #57216, #57335
307 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
309 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
311 apt (0.3.17) unstable; urgency=low
313 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
314 * Fixed the configuration parser to not blow up if ; is in the config
316 * Applied visual patch to dselect install script . Closes #55214
317 * Included the configure-index example
319 * Library soname has increased
320 * Fixed default sources.list to have correct URLs for potato when it
322 * Added a message about erasing sources.list to dselect setup script
324 * No remove prompt if the archives dir has not changed. Closes: #55709
325 * Fixed inclusion of 2nd sample config file. Closes: #55374
326 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
329 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
331 apt (0.3.16) unstable; urgency=low
333 * Made --no-download work. Closes: #52993
334 * Now compiles on OpenBSD, Solaris and HP-UX
335 * Clarify segfault errors
336 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
337 * Fix for Joel's discovery of glibc removal behavoir.
338 * Fix for Ben Collins file: uri from slink upgrade.
339 * Fixed resume code in FTP. Closes: #54323
340 * Take more precautions to prevent the corruption Joey Hess saw.
341 * Fixed --no-list-cleanup
342 * RFC 2732 URI parsing ([] for hostnames).
343 * Typo in apt-cache man page. Closes: #54949
345 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
347 apt (0.3.15) unstable; urgency=low
349 * Added DSelect::WaitAfterDownload Closes: #49549
350 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
351 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
352 * Made -s and clean not do anything. Closes: #50238
353 * Problem with Protected packages and the new OR code.
354 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
355 * Remove doesn't require a package to be installable. Closes: #51175
356 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
358 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
360 apt (0.3.14) unstable; urgency=low
362 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
363 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
364 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
365 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
366 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
367 Closes: #45034, #45695, #46537
368 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
369 * Added APT::Clean-Installed option. Closes: #45973
370 * Moves the free space check to after the calculated size is printed.
371 Closes: #46639, #47498
372 * mipsel arch Closes: #47614
373 * Beautified URI printing to not include passwords Closes: #46857
374 * Fixed little problem with --no-download Closes: #47557
375 * Tweaked Dselect 'update' script to re-gen the avail file even in the
376 event of a failure Closes: #47112
377 * Retries for source archives too Closes: #47529
378 * Unmounts CDROMs iff it mounted them Closes: #45299
379 * Checks for the partial directories before doing downloads Closes: #47392
380 * no_proxy environment variable (http only!) Closes: #43476
381 * apt-cache showsrc Closes: #45799
382 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
383 * Regexs for install. Closes: #35304, #38835
384 * Dependency reports now show OR group relations
385 * Re-Install feature. Cloes: #46961, #37393, #38919
386 * Locks archive directory on clean (woops)
387 * Remove is not 'sticky'. Closes: #48392
388 * Slightly more accurate 'can not find package' message. Closes: #48311
389 * --trivial-only and --no-remove. Closes: #48518
390 * Increased the cache size. Closes: #47648
391 * Comment woopsie. Closes: #48789
392 * Removes existing links when linking sources. Closes: #48775
393 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
394 * Clearer usage message about 'source' Closes: #48858
395 * Immediate configure internal error Closes: #49062, #48884
397 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
399 apt (0.3.13) unstable; urgency=low
401 * Fix timestamp miss in FTP. Closes: #44363
402 * Fix sorting of Kept packages. Closes: #44377
403 * Fix Segfault for dselect-upgrade. Closes: #44436
404 * Fix handling of '/' for the dist name. Closes #43830
405 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
406 * Add commented-out deb-src URI to default sources.list file.
408 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
410 apt (0.3.12) unstable; urgency=low
412 * Fix for typo in the dhelp index. Closes: #40377
413 * Multiple media swap support
414 * Purge support. Closes: #33291, #40694
415 * Better handling of - remove notation. Closes: #41024
416 * Purge support. Closes: #33291, #40694
417 * Error code on failed update. Closes: #41053
418 * apt-cdrom adds entries for source directories. Closes: #41231
419 * Sorts the output of any list. Closes: #41107
420 * Fixes the looping problem. Closes: #41784, #42414, #44022
421 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
422 * More checks to keep the display sane. Particularly when fail-over is
423 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
424 * PThread lockup problem on certain sparc/m68k. Closes: #40628
425 * apt-cdrom understands .gz Package files too. Closes: #42779
426 * Spelling error in dselect method description. Closes: #43251
427 * Added security to the default source list. Closes: #43356
429 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
431 apt (0.3.11) unstable; urgency=low
433 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
434 * Fix for properly upgrading the system from perl 5.004 to 5.005
436 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
438 apt (0.3.9) unstable; urgency=low
440 * Spelling error in cachefile.cc. Closes: #39885
441 * Trailing slash in dselect install if you try to use the
442 default config file. Closes: #40011
443 * Simulate works for autoclean. Closes: #39141
444 * Fixed spelling errors. Closes: #39673
445 * Changed url parsing a bit. Closes: #40070, #40069
446 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
448 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
450 apt (0.3.7) unstable; urgency=low
452 * Fixed missing text in the apt-get(8) page. Closes: #37596
453 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
454 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
455 * Fixed handling of the -q option with not-entirely integer arguments
457 * Man page typo Closes: #37762
458 * Fixed parsing of the Source: line. Closes: #37679
459 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
460 * Added a check for an empty cache directory. Closes: #37963
461 * Return a failure code if -d is given and packages fail to download.
463 * Arranged for an ftp proxy specifing an http server to work. See the
464 important note in the sources.list man page.
465 * Accounted for resumed files in the cps calculation. Closes: #36787
466 * Deal with duplicate same version different packages. Closes: #30237
467 * Added --no-download. Closes: #38095
468 * Order of apt-cdrom dist detection. Closes: #38139
469 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
471 * Suggests dpkg-dev for apt-get source. Closes: #38158
472 * Fixed typo in apt-get help. Closes: #38712
473 * Improved the error message in the case of broken held package. Closes: #38777
474 * Fixed handling of MD5 failures
475 * Documented list notation Closes: #39008
476 * Change the 'b' to 'B'. Closes: #39007
478 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
480 apt (0.3.6) unstable; urgency=low
482 * Note that 0.3.5 never made it out the door..
483 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
484 * Made APT print numbers in decimal. Closes: #35617, #37319
485 * Buffer munching fix for FTP. Closes: #35868
486 * Typo in sample config file. Closes: #35907
487 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
488 * Changed installed size counter to only count unpacked packages.
490 * apt-get source support. Closes: #23934, #27190
491 * Renames .debs that fail MD5 checking, provides automatic corruption
492 recovery. Closes: #35931
493 * Fixed autoconf verison. Closes: #37305
494 * Random Segfaulting. Closes: #37312, #37530
495 * Fixed apt-cache man page. Closes: #36904
496 * Added a newline to apt-cache showpkg. Closes: #36903
498 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
500 apt (0.3.4) unstable; urgency=low
502 * Release for Ben while he is out of town.
503 * Checked the size of partial files. Closes: #33705
504 * apt-get should not print progress on non-tty. Closes: #34944
505 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
506 * Applied cdrom patches from Torsten. Closes: #35140, #35141
507 * smbmounted cdrom fix. Closes: #35470
508 * Changed ie to eg. Closes: #35196
510 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
512 apt (0.3.3) unstable; urgency=low
514 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
516 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
518 apt (0.3.2) unstable; urgency=low
520 * Major release into unstable of v3
521 * These bugs have been fixed, explanations are in the bug system, read
522 the man pages as well..
523 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
524 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
525 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
526 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
527 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
528 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
529 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
530 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
532 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
534 apt (0.3.1) experimental; urgency=low
536 * Minor release of cvs version.
537 * Added virtual package libapt-pkgx.x
539 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
541 apt (0.3.0) experimental; urgency=low
543 * New experimental version.
545 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
547 apt (0.1.9) frozen unstable; urgency=low
549 * Return to the wacky numbering for when we build 0.1.8 for hamm
550 * Important bug related to APT on the Alpha fixed
551 * apt-get dist-upgrade problems fixed
552 * tiny patch for http method to fix an endless loop
553 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
554 libtool and add proper shared lib dependancies
555 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
556 in case an old libpkg is installed while building APT to prevent
557 spurious dependancies
559 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
561 apt (0.1.7) unstable; urgency=low
563 * New build with libstdc++2.9.
564 * Various fixes; read the Changelog.
566 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
568 apt (0.1.6) unstable; urgency=low
570 * Various fixes in the FTP method for error checking. Fixes: #26188.
571 * Spelling corrections in dselect method. Fixes: #25884
572 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
573 * No more bo releases: we're using a normal numbering system now.
575 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
577 apt (0.1.5) unstable; urgency=low
579 * Changed sources.list to point to 'unstable' by default, as
580 'frozen' no longer exists!
582 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
584 apt (0.1.3) unstable; urgency=low
586 * New upstreamish version.
587 * ftp method rewritten in C. Removes dependancies on all perl/perl
588 related modules. This fixes many of the ftp method bugs.
590 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
592 apt (0.1.1) unstable; urgency=low
594 * Release for unstable.
596 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
598 apt (0.1) unstable; urgency=low
600 * Kludge to fix problem in libnet-perl with illegal anonymous
602 * Moved to unstable; apt is in a useable state now.
603 * Fixed version numbering. From now on, numbering will be:
604 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
605 0.1.1 (release for unstable). Thanks, Manoj.
607 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
609 apt (0.0.17-1) experimental; urgency=low
611 * Fixed problem with libc6 version compare
612 * Scott's away for a while, so I'll be packaging apt for the time
615 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
617 apt (0.0.16-1) experimental; urgency=low
619 * Modifications to make apt-get more friendly when backgrounded.
620 * Updated documentation.
621 * Updates to graphic widgets
623 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
625 apt (0.0.15-0.2bo) experimental; urgency=low
628 * Bob Hilliards crash
630 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
632 apt (0.0.15-0.1bo) experimental; urgency=low
637 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
639 apt (0.0.15) experimental; urgency=low
641 * Clean up source tarball (no user-visible changes)
643 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
645 apt (0.0.14) experimental; urgency=low
647 * Updates in ordering code to make sure certain upgrades work correctly.
648 * Made dselect/setup understand ftp as well as http
650 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
652 apt (0.0.13-bo1) experimental; urgency=low
656 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
658 apt (0.0.13) experimental; urgency=low
660 * Remove hardcoded egcc from debian/rules (#21575)
661 * Fixes for ordering logic when system has a number of unpacked
662 but unconfigured packages installed.
663 * Spelling fix in dselect install method (#22556)
665 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
667 apt (0.0.12) experimental; urgency=low
669 * Fixed problems with package cache corruption.
670 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
672 * Interface and documentation improvements.
674 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
676 apt (0.0.11) experimental; urgency=low
678 * Change dependancies to pre-depends since breaking your packaging tools
679 in the middle of an installation isn't very good.
680 * Bug fixes to ftp method and general apt-get code
682 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
684 apt (0.0.10) experimental; urgency=low
686 * Run "dpkg --configure -a" after an aborted dselect install
687 * Fixed problem with install looping
688 * Support for authenticating proxys: (note this isn't terribly secure)
689 http_proxy="http://user:pass@firewall:port/"
690 * Substitute $ARCH in sources.list
691 * Fixes in the resumption code for ftp
693 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
695 apt (0.0.9) experimental; urgency=low
698 * Various other less visible bug fixes.
699 * Fixed problem with segfault when apt-get invoked in a non-existant
700 directory (Bug #21863)
701 * Bumped policy to 2.4.1
703 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
705 apt (0.0.8) experimental; urgency=low
707 * Fixed generated available file (Bug #21836)
708 * Added download ETA (Bug #21774).
709 * Fixed hardcoded ARCH (Bug #21751).
710 * Fixed check on http_proxy (Bug #21795).
711 * Added download speed indicator.
713 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
715 apt (0.0.7) experimental; urgency=low
717 * Remove libdeity and apt from package for now, since only apt-get and
718 apt-cache are actually useful right now.
719 * Clean up handling of package installation errors.
720 * Added timeout to http transfers (#21269)
721 * Updated setup for dselect/apt method.
723 * Long options (added in 0.0.6)
725 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
727 apt (0.0.6) experimental; urgency=low
730 * Revamped download status display.
731 * Call apt-get clean after successful install in dselect.
732 * Added "apt-get clean" which deletes package files from /var/cache/apt
734 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
736 apt (0.0.5) experimental; urgency=low
738 * Ignore signals while dpkg is running so we don't leave dpkg running in
739 the background (#20804)
740 * Check Packages as well as Packages.gz for file URIs (#20784)
741 * Spelling cleanup (#20800)
742 * Added -m option to permit upgrade to go on in the case of a bad mirror.
743 This option may result in incomplete upgrades when used with -f.
745 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
747 apt (0.0.4) experimental; urgency=low
750 * Various documentation updates and cleanup.
751 * Added '-f' option to apt-get attempt to fix broken dependancies.
753 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
755 apt (0.0.3) experimental; urgency=low
757 * Added a shlibs.local file to prevent apt from depending on itself.
758 * Updates to how apt-get handles bad states in installed packages.
759 * Updated rules to make sure build works from a freshly checked out source
760 archive. Building from CVS needs libtool/automake/autoconf, builds from
761 the distributed source package should have no such dependancy.
763 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
765 apt (0.0.2) unstable; urgency=low
767 * Updates to apt-get and http binding for dselect method (apt).
768 * Updating version number from 0.0.1, which was released only on IRC.
770 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
772 apt (0.0.1) unstable; urgency=low
776 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500