5 # we need the buildin webserver for the tests
6 if [ ! -e environment.mak
]; then
9 make -C test
/interactive
-helper/
11 # run against the installed apt
12 APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR
=$(pwd)/build
/bin \
13 APT_INTEGRATION_TESTS_METHODS_DIR
=/usr
/lib
/apt
/methods \
14 APT_INTEGRATION_TESTS_LIBEXEC_DIR
=/usr
/lib
/apt
/ \
15 APT_INTEGRATION_TESTS_INTERNAL_SOLVER
=/usr
/lib
/apt
/solvers
/apt \
16 APT_INTEGRATION_TESTS_BUILD_DIR
=/usr
/bin \
17 APT_INTEGRATION_TESTS_LIBRARY_PATH
=/dev
/null
/does
/not
/exist \
18 .
/test
/integration
/run
-tests