]> git.saurik.com Git - apt.git/blob - debian/rules
use $(CURDIR) instead of $(pwd)
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
18 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19
20 # FOR AUTOCONF 2.52 AND NEWER ONLY
21 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
22 confflags += --build $(DEB_HOST_GNU_TYPE)
23 else
24 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
25 endif
26
27 # See below
28 -include build/environment.mak
29
30 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
31 export CXXFLAGS = -O0 -g -Wall
32 else
33 export CXXFLAGS = -O2 -g -Wall
34 endif
35
36 # Default rule
37 build:
38
39 PKG=apt
40 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
41 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
42 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
43 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
44
45 # Determine the build directory to use
46 BASE=.
47 ifdef BUILD
48 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
49 else
50 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
51 endif
52 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
53 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
54 override BLD := $(BUILDX)
55
56 ifeq ($(words $(BLD)),0)
57 override BLD := ./build
58 endif
59
60 # Rebuild configure.in to have the correct version from the change log
61 ifneq ($(APT_DEBVER),$(APT_CONFVER))
62 ifneq ($(APT_DEBVER),)
63 .PHONY: configure.in
64 configure.in:
65 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
66 endif
67 else
68 configure.in:
69 endif
70
71 # APT Programs in apt-utils
72 APT_UTILS=ftparchive sortpkgs extracttemplates
73
74 # Uncomment this to turn on verbose mode.
75 #export DH_VERBOSE=1
76
77 # Find the libapt-pkg major version for use in other control files
78 include buildlib/libversion.mak
79
80 # Determine which package we should provide in the control files
81 LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
82 LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
83
84 debian/shlibs.local: apt-pkg/makefile
85 # We have 3 shlibs.local files: One for 'apt', one for 'apt-utils' and
86 # one for the rest of the packages. This ensures that each package gets
87 # the right overrides…
88 rm -rf $@ $@.apt $@.apt-utils
89 echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
90
91 echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
92 echo "libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
93
94 echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
95 echo "libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
96
97 build: build/build-stamp
98 build-doc: build/build-doc-stamp
99
100 # Note that this is unconditionally done first as part of loading environment.mak
101 # The true is needed to force make to reload environment.mak after running
102 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
103 build/environment.mak: build/configure-stamp
104 @true
105
106 configure: configure.in
107 build/configure-stamp: configure
108 dh_testdir
109 -mkdir build
110 cp COPYING debian/copyright
111 cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
112 touch $@
113
114 build/build-stamp: build/configure-stamp
115 # Add here commands to compile the package.
116 $(MAKE) binary
117 touch $@
118
119 build/build-doc-stamp: build/configure-stamp
120 # Add here commands to compile the package.
121 $(MAKE) doc
122 touch $@
123
124 clean:
125 dh_testdir
126
127 [ ! -f Makefile ] || $(MAKE) clean distclean
128 rm -rf build
129
130 # Add here commands to clean up after the build process.
131 dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
132
133 binary-indep: apt-doc libapt-pkg-doc
134 # Build architecture-independent files here.
135 libapt-pkg-doc: build-doc debian/shlibs.local
136 dh_testdir -p$@
137 dh_testroot -p$@
138 dh_clean -p$@ -k
139 dh_installdirs -p$@
140 #
141 # libapt-pkg-doc install
142 #
143 dh_installdocs -p$@ $(BLD)/docs/design* \
144 $(BLD)/docs/dpkg-tech* \
145 $(BLD)/docs/files* \
146 $(BLD)/docs/method* \
147 doc/libapt-pkg2_to_3.txt \
148 doc/style.txt \
149 $(BLD)/doc/doxygen/html
150 dh_installexamples -p$@
151
152 dh_installchangelogs -p$@
153 dh_strip -p$@
154 dh_compress -p$@
155 dh_fixperms -p$@
156 dh_installdeb -p$@
157 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
158 dh_md5sums -p$@
159 dh_builddeb -p$@
160
161 apt-doc: build-doc
162 dh_testdir -p$@
163 dh_testroot -p$@
164 dh_clean -p$@ -k
165 #
166 # apt-doc install
167 #
168 # Copy the guides
169 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
170 $(BLD)/docs/guide*.html \
171 $(BLD)/docs/offline*.text \
172 $(BLD)/docs/offline*.html
173 dh_installchangelogs -p$@
174 dh_compress -p$@
175 dh_fixperms -p$@
176 dh_installdeb -p$@
177 dh_gencontrol -p$@
178 dh_md5sums -p$@
179 dh_builddeb -p$@
180
181
182
183 # Build architecture-dependent files here.
184
185 binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
186 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
187 apt: build build-doc debian/shlibs.local
188 dh_testdir -p$@
189 dh_testroot -p$@
190 dh_clean -p$@ -k
191 dh_installdirs -p$@
192 #
193 # apt install
194 #
195 cp $(BLD)/bin/apt-* debian/$@/usr/bin/
196
197 # Remove the bits that are in apt-utils
198 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
199
200 # install the shared libs
201 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
202 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
203
204 cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
205 # https has its own package
206 rm debian/$@/usr/lib/apt/methods/https
207
208 cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
209 cp -r $(BLD)/locale debian/$@/usr/share/
210
211 cp debian/bugscript debian/$@/usr/share/bug/apt/script
212 cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
213
214 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
215
216 # copy lintian override
217 cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
218
219 # make rosetta happy and remove pot files in po/ (but leave stuff
220 # in po/domains/* untouched) and cp *.po into each domain dir
221 rm -f build/po/*.pot
222 rm -f po/*.pot
223
224 dh_installexamples -p$@ $(BLD)/docs/examples/*
225 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
226 dh_installcron -p$@
227 dh_installdocs -p$@
228 dh_installchangelogs -p$@
229 dh_strip -p$@
230 dh_compress -p$@
231 dh_fixperms -p$@
232 dh_makeshlibs -p$@ --major=$(LIBAPTPKG_MAJOR) --version-info='$(LIBAPTPKG_PROVIDE)'
233 dh_installdeb -p$@
234 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
235 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
236 dh_md5sums -p$@
237 dh_builddeb -p$@
238
239 libapt-pkg-dev: build debian/shlibs.local
240 dh_testdir -p$@
241 dh_testroot -p$@
242 dh_clean -p$@ -k
243 dh_installdirs -p$@
244 #
245 # libapt-pkg-dev install
246 #
247 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
248 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
249 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
250 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
251
252 dh_installdocs -p$@
253
254 dh_installchangelogs -p$@
255 dh_strip -p$@
256 dh_compress -p$@
257 dh_fixperms -p$@
258 dh_installdeb -p$@
259 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
260 dh_md5sums -p$@
261 dh_builddeb -p$@
262
263 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
264 apt-utils: build debian/shlibs.local
265 dh_testdir -p$@
266 dh_testroot -p$@
267 dh_clean -p$@ -k
268 dh_installdirs -p$@
269
270 # install the shared libs
271 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
272 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
273
274 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
275 dh_installdocs -p$@
276 dh_installexamples -p$@
277
278 # Install the man pages..
279 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
280
281 dh_installchangelogs -p$@
282 dh_strip -p$@
283 dh_compress -p$@
284 dh_fixperms -p$@
285 dh_makeshlibs -p$@ --major=$(LIBAPTINST_MAJOR) --version-info='$(LIBAPTINST_PROVIDE)'
286 dh_installdeb -p$@
287 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
288 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
289 dh_md5sums -p$@
290 dh_builddeb -p$@
291
292 apt-transport-https: build debian/shlibs.local libapt-pkg-dev
293 dh_testdir -p$@
294 dh_testroot -p$@
295 dh_clean -p$@ -k
296 dh_installdirs -p$@
297
298 # install the method
299 mkdir --parents debian/$@/usr/lib/apt/methods
300 cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
301
302 dh_installdocs -p$@ debian/apt-transport-https.README
303 dh_installexamples -p$@
304
305 # Install the man pages..
306 dh_installman -p$@
307
308 dh_installchangelogs -p$@
309 dh_strip -p$@
310 dh_compress -p$@
311 dh_fixperms -p$@
312 dh_installdeb -p$@
313 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
314 dh_gencontrol -p$@
315 dh_md5sums -p$@
316 dh_builddeb -p$@
317
318 configure:
319 $(MAKE) configure
320
321 really-clean: clean
322 -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
323 find -name ChangeLog | xargs rm -f
324 rm -f l33ch-stamp
325
326 binary: binary-indep binary-arch
327 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local