2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
17 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
18 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
20 # FOR AUTOCONF 2.52 AND NEWER ONLY
21 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
22 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
24 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
28 -include build
/environment.mak
30 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
31 export CXXFLAGS
= -O0
-g
-Wall
33 export CXXFLAGS
= -O2
-g
-Wall
40 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
--preserve-envvar CCACHE_DIR
-us
-uc
$(DEB_BUILD_PROG_OPTS
)
41 APT_DEBVER
=$(shell dpkg-parsechangelog |sed
-n
-e
'/^Version:/s/^Version: //p' | sed
-e
's/\+.*$$//')
42 APT_CONFVER
=$(shell sed
-n
-e
's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in
)
43 APT_CVSTAG
=$(shell echo
"$(APT_DEBVER)" | sed
-e
's/^/v/' -e
's/\./_/g')
45 # Determine the build directory to use
48 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
50 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
--machine
) $(BASE
)/build
52 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
53 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
54 override BLD
:= $(BUILDX
)
56 ifeq ($(words $(BLD
)),0)
57 override BLD
:= .
/build
60 # Rebuild configure.in to have the correct version from the change log
61 ifneq ($(APT_DEBVER
),$(APT_CONFVER
))
62 ifneq ($(APT_DEBVER
),)
65 sed
-e
's/$(APT_CONFVER)/$(APT_DEBVER)/' $@
> $@.
$$$$ && mv
$@.
$$$$ $@
71 # APT Programs in apt-utils
72 APT_UTILS
=ftparchive sortpkgs extracttemplates
74 # Uncomment this to turn on verbose mode.
77 # Find the libapt-pkg major version for use in other control files
78 include buildlib
/libversion.mak
80 # Determine which package we should provide in the control files
81 LIBAPTPKG_PROVIDE
=libapt-pkg
$(LIBAPTPKG_MAJOR
)
82 LIBAPTINST_PROVIDE
=libapt-inst
$(LIBAPTINST_MAJOR
)
84 debian
/shlibs.local
: apt-pkg
/makefile
85 # We have 3 shlibs.local files: One for 'apt', one for 'apt-utils' and
86 # one for the rest of the packages. This ensures that each package gets
87 # the right overrides…
88 rm -rf
$@
$@.apt
$@.apt-utils
89 echo
"libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
91 echo
"libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
92 echo
"libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
94 echo
"libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
95 echo
"libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
97 build
: build
/build-stamp
98 build-doc
: build
/build-doc-stamp
100 # Note that this is unconditionally done first as part of loading environment.mak
101 # The true is needed to force make to reload environment.mak after running
102 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
103 build
/environment.mak
: build
/configure-stamp
106 configure
: configure.in
107 build
/configure-stamp
: configure
110 cp COPYING debian
/copyright
111 cd build
&& CXXFLAGS
="$(confcxxflags)" ..
/configure
$(confflags
)
114 build
/build-stamp
: build
/configure-stamp
115 # Add here commands to compile the package.
119 build
/build-doc-stamp
: build
/configure-stamp
120 # Add here commands to compile the package.
127 [ ! -f Makefile
] ||
$(MAKE
) clean distclean
130 # Add here commands to clean up after the build process.
131 dh_clean debian
/copyright debian
/shlibs.local debian
/shlibs.local.apt debian
/shlibs.local.apt-utils
133 binary-indep
: apt-doc libapt-pkg-doc
134 # Build architecture-independent files here.
135 libapt-pkg-doc
: build-doc debian
/shlibs.local
141 # libapt-pkg-doc install
143 dh_installdocs
-p
$@
$(BLD
)/docs
/design
* \
144 $(BLD
)/docs
/dpkg-tech
* \
146 $(BLD
)/docs
/method
* \
147 doc
/libapt-pkg2_to_3.txt \
149 $(BLD
)/doc
/doxygen
/html
150 dh_installexamples
-p
$@
152 dh_installchangelogs
-p
$@
157 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
)
169 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text \
170 $(BLD
)/docs
/guide
*.html \
171 $(BLD
)/docs
/offline
*.text \
172 $(BLD
)/docs
/offline
*.html
173 dh_installchangelogs
-p
$@
183 # Build architecture-dependent files here.
185 binary-arch
: apt libapt-pkg-dev apt-utils apt-transport-https
186 apt_MANPAGES
= apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
187 apt
: build build-doc debian
/shlibs.local
195 cp
$(BLD
)/bin
/apt-
* debian
/$@
/usr
/bin
/
197 # Remove the bits that are in apt-utils
198 rm $(addprefix debian
/$@
/usr
/bin
/apt-
,$(APT_UTILS
))
200 # install the shared libs
201 find
$(BLD
)/bin
/ -type f
-name
"libapt-pkg*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
202 find
$(BLD
)/bin
/ -type l
-name
"libapt-pkg*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
204 cp
$(BLD
)/bin
/methods
/* debian
/$@
/usr
/lib
/apt
/methods
/
205 # https has its own package
206 rm debian
/$@
/usr
/lib
/apt
/methods
/https
208 cp
$(BLD
)/scripts
/dselect
/* debian
/$@
/usr
/lib
/dpkg
/methods
/apt
/
209 cp
-r
$(BLD
)/locale debian
/$@
/usr
/share
/
211 cp debian
/bugscript debian
/$@
/usr
/share
/bug
/apt
/script
212 cp debian
/apt.logrotate debian
/$@
/etc
/logrotate.d
/apt
214 cp debian
/apt.conf.autoremove debian
/$@
/etc
/apt
/apt.conf.d
/01autoremove
216 # copy lintian override
217 cp share
/lintian-overrides debian
/$@
/usr
/share
/lintian
/overrides
/apt
219 # make rosetta happy and remove pot files in po/ (but leave stuff
220 # in po/domains/* untouched) and cp *.po into each domain dir
224 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
225 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/%.
[158],$(apt_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt_MANPAGES
)))
228 dh_installchangelogs
-p
$@
232 dh_makeshlibs
-p
$@
--major
=$(LIBAPTPKG_MAJOR
) --version-info
='$(LIBAPTPKG_PROVIDE)'
234 dh_shlibdeps
-p
$@
-l
$(CURDIR
)/debian
/apt
/usr
/lib
:$(CURDIR
)/debian
/$@
/usr
/lib
-- -Ldebian
/shlibs.local.apt
235 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
)
239 libapt-pkg-dev
: build debian
/shlibs.local
245 # libapt-pkg-dev install
247 cp
-a
$(BLD
)/bin
/libapt-pkg
*.so debian
/libapt-pkg-dev
/usr
/lib
/
248 cp
-a
$(BLD
)/bin
/libapt-inst
*.so debian
/libapt-pkg-dev
/usr
/lib
/
249 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
250 cp
$(BLD
)/include/apt-pkg
/*.h debian
/libapt-pkg-dev
/usr
/include/apt-pkg
/
254 dh_installchangelogs
-p
$@
259 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
) -Vlibapt-inst
:provides
=$(LIBAPTINST_PROVIDE
)
263 apt-utils_MANPAGES
= apt-sortpkgs apt-ftparchive apt-extracttemplates
264 apt-utils
: build debian
/shlibs.local
270 # install the shared libs
271 find
$(BLD
)/bin
/ -type f
-name
"libapt-inst*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
272 find
$(BLD
)/bin
/ -type l
-name
"libapt-inst*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
274 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
276 dh_installexamples
-p
$@
278 # Install the man pages..
279 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/%.
[158],$(apt-utils_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt-utils_MANPAGES
)))
281 dh_installchangelogs
-p
$@
285 dh_makeshlibs
-p
$@
--major
=$(LIBAPTINST_MAJOR
) --version-info
='$(LIBAPTINST_PROVIDE)'
287 dh_shlibdeps
-p
$@
-l
$(CURDIR
)/debian
/apt
/usr
/lib
:$(CURDIR
)/debian
/$@
/usr
/lib
-- -Ldebian
/shlibs.local.apt-utils
288 dh_gencontrol
-p
$@
-u
-Vlibapt-inst
:provides
=$(LIBAPTINST_PROVIDE
)
292 apt-transport-https
: build debian
/shlibs.local libapt-pkg-dev
299 mkdir
--parents debian
/$@
/usr
/lib
/apt
/methods
300 cp
$(BLD
)/bin
/methods
/https debian
/$@
/usr
/lib
/apt
/methods
302 dh_installdocs
-p
$@ debian
/apt-transport-https.README
303 dh_installexamples
-p
$@
305 # Install the man pages..
308 dh_installchangelogs
-p
$@
313 dh_shlibdeps
-p
$@
-l
$(CURDIR
)/debian
/apt
/usr
/lib
:$(CURDIR
)/debian
/$@
/usr
/lib
322 -find .
-name Makefile.in
-print0 | xargs
--null
--no-run-if-empty
-- rm -f
323 find
-name ChangeLog | xargs
rm -f
326 binary
: binary-indep binary-arch
327 .PHONY
: build
clean binary-indep binary-arch binary debian
/shlibs.local