]>
git.saurik.com Git - apt.git/blob - debian/apt.postinst
5 # summary of how this script can be called:
6 # * <postinst> `configure' <most-recently-configured-version>
7 # * <old-postinst> `abort-upgrade' <new version>
8 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
10 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
11 # <failed-install-package> <version> `removing'
12 # <conflicting-package> <version>
13 # for details, see http://www.debian.org/doc/debian-policy/ or
14 # the debian-policy package
18 if ! test -f /etc
/apt
/trusted.gpg
; then
19 cp /usr
/share
/apt
/ubuntu
-archive.gpg
/etc
/apt
/trusted.gpg
23 abort
-upgrade|abort
-remove|abort
-deconfigure)
28 echo "postinst called with unknown argument \`$1'" >&2
33 # dh_installdeb will replace this with shell code automatically
34 # generated by other debhelper scripts.