2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.6 1999/02/15 08:23:10 jgg Exp $
8 # Uncomment this to turn on verbose mode.
12 build-stamp
: configure
15 cd build
; ..
/configure
17 # cd build && CXXFLAGS="-g -Wall -D_POSIX_C_SOURCE=199309" ../configure --disable-nls --disable-static --prefix=/usr
18 # cd build && make all-hdr
21 # Add here commands to compile the package.
31 # Add here commands to clean up after the build process.
36 # Build architecture-independent files here.
37 binary-indep
: build libapt-pkg-doc
38 # We have nothing to do by default.
40 # Build architecture-dependent files here.
41 binary-arch
: build apt libapt-pkg-dev
44 # dh_testversion -papt
48 dh_installdirs
-papt usr
/bin usr
/lib
/apt
/methods usr
/lib
/dpkg
/methods
/apt etc
/apt usr
/doc
/apt var
/cache
/apt
/archives
/partial var
/state
/apt
/lists
/partial
50 cp build
/bin
/apt-
* debian
/tmp
/usr
/bin
/
52 # install the shared libs
53 find build
/bin
/ -type f
-name
"libapt-pkg.so.*" -exec cp
-a
"{}" debian
/tmp
/usr
/lib
/ \
;
54 find build
/bin
/ -type l
-name
"libapt-pkg.so.*" -exec cp
-a
"{}" debian
/tmp
/usr
/lib
/ \
;
56 cp build
/bin
/methods
/* debian
/tmp
/usr
/lib
/apt
/methods
/
58 cp build
/scripts
/dselect
/* debian
/tmp
/usr
/lib
/dpkg
/methods
/apt
/
59 # cp debian/sources.list debian/tmp/etc/apt/
61 # Copy the users guide
62 cp build
/docs
/guide.text debian
/tmp
/usr
/doc
/apt
/users-guide.txt
63 mkdir debian
/tmp
/usr
/doc
/apt
/users-guide.html
/
64 cp
-a build
/docs
/guide.html
/* debian
/tmp
/usr
/doc
/apt
/users-guide.html
/
66 # Copy the offline guide
67 cp build
/docs
/offline.text debian
/tmp
/usr
/doc
/apt
/offline.txt
68 mkdir debian
/tmp
/usr
/doc
/apt
/offline.html
/
69 cp
-a build
/docs
/offline.html
/* debian
/tmp
/usr
/doc
/apt
/offline.html
/
71 cp
-a debian
/dhelp debian
/tmp
/usr
/doc
/apt
/.dhelp
73 # head -n 500 ChangeLog > debian/ChangeLog
76 dh_installexamples
-papt build
/docs
/examples
/*
77 # dh_installmenu -papt
78 # dh_installinit -papt
79 # dh_installcron -papt
80 dh_installmanpages
-papt
82 # dh_undocumented -papt
83 dh_installchangelogs
-papt
89 LD_LIBRARY_PATH
=debian
/tmp
/usr
/lib dh_shlibdeps
-papt
96 dh_testdir
-plibapt-pkg-dev
97 dh_testroot
-plibapt-pkg-dev
98 dh_clean
-plibapt-pkg-dev
-k
99 dh_installdirs
-plibapt-pkg-dev usr
/lib usr
/include/apt-pkg
101 ln
-s libapt-pkg.so
.2.0 debian
/libapt-pkg-dev
/usr
/lib
/libapt-pkg.so
103 cp build
/include/apt-pkg
/*.h debian
/libapt-pkg-dev
/usr
/include/apt-pkg
/
105 dh_installdocs
-plibapt-pkg-dev
106 dh_installchangelogs
-plibapt-pkg-dev
107 dh_strip
-plibapt-pkg-dev
108 dh_compress
-plibapt-pkg-dev
109 dh_fixperms
-plibapt-pkg-dev
110 dh_installdeb
-plibapt-pkg-dev
111 dh_shlibdeps
-plibapt-pkg-dev
112 dh_gencontrol
-plibapt-pkg-dev
113 dh_md5sums
-plibapt-pkg-dev
114 dh_builddeb
-plibapt-pkg-dev
116 libapt-pkg-doc
: build
117 dh_testdir
-plibapt-pkg-doc
118 dh_testroot
-plibapt-pkg-doc
119 dh_clean
-plibapt-pkg-doc
-k
120 dh_installdirs
-plibapt-pkg-doc usr
/doc
/apt usr
/doc
/libapt-pkg-doc
122 cp
-a build
/docs
/cache
* build
/docs
/design
* build
/docs
/dpkg-tech
* \
123 build
/docs
/files
* build
/docs
/method
* debian
/libapt-pkg-doc
/usr
/doc
/apt
/
124 cp
-a debian
/libapt-pkg-doc.dhelp debian
/libapt-pkg-doc
/usr
/doc
/libapt-pkg-doc
/.dhelp
126 dh_installdocs
-plibapt-pkg-doc
127 dh_installchangelogs
-plibapt-pkg-doc
128 dh_strip
-plibapt-pkg-doc
129 dh_compress
-plibapt-pkg-doc
130 dh_fixperms
-plibapt-pkg-doc
131 dh_installdeb
-plibapt-pkg-doc
132 dh_shlibdeps
-plibapt-pkg-doc
133 dh_gencontrol
-plibapt-pkg-doc
134 dh_md5sums
-plibapt-pkg-doc
135 dh_builddeb
-plibapt-pkg-doc
138 @echo
>&2 'source and diff are obsolete - use dpkg-source -b'; false
145 # Update from CVS and then configure for build
146 super-l33ch
: l33ch Makefile.in
151 l33ch-stamp
: super-l33ch
155 -find
-name Makefile.in
-print0 | xargs
-0r
rm -f
156 find
-name ChangeLog | xargs
rm -f
159 binary
: binary-indep binary-arch
160 .PHONY
: build
clean binary-indep binary-arch binary