1 apt (0.5.5) unstable; urgency=low
3 * New deb version compare function, that has no integer limits, and
4 supports pre-versions using ~. Code ported from dpkg.
5 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
6 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
7 * "apt-get --arch-only build-dep" to install only architecture-
8 dependent build dependencies. Bump minor shared lib number to reflect
9 small change in BuildDepend API.
10 * APT::Build-Essential configuration option (defaults to "build-essential")
11 so that "apt-get build-dep" will ensure build essential packages are
12 installed prior to installing other build-dependencies. Closes: #148879
13 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
14 * /usr/doc reference in postinst. Closes: #126189
15 * Doc updates. Closes: #120689
16 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
18 * Print special message for EAI_AGAIN. Closes: #131397
19 * libapt-pkg-dev needs to bring in the apt-inst library if linking
20 is to work. Closes: #133943
21 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
22 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
23 #139994, #142955, #151654, #151834, #147611, #154268
24 * Fix possibility for tag file parsing to fail in some unlikely situations.
26 * Use std C++ names for some header files. Closes: #128741,
27 * Do not check for free space if --no-download. Closes: #117856
28 * Actually implement or group handling for 'upgrade'. Closes: #133950
29 * "Internal Error, Couldn't configure pre-depend" is not actually an
30 internal error, it is a packaging error and now it says so, and
31 pinpoints the problem dependency. Closes: #155621
32 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
33 * Use usr/share/doc for dhelp. Closes: #115701
34 * --print-uris works with 'update'. Closes: #57070
35 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
37 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
39 * Allow an uninstalled package to be marked for removal on an install
40 line (meaning not to automatically install it), also fix some dodgy
41 handling of protected packages. Closes: #92287, #116011
42 * Fix errant prefix matching in version selection. Closes: #105968
43 * Ensure that all files needed to run APT as a user are readable and
44 ignore roots umask for these files. Closes: #108801
45 * Support larger config spaces. Closes: #111914
46 * 'apt-get update' no longer does 'Building Dependency Tree'.
47 * When matching regexs allways print a message. Change regex activation
48 charset. Closes: #147817
49 * Don't die if lines in sources.list are too long. Closes: #146846
50 * Show file name on apt-extracttemplate error messges. Closes: #151835
51 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
52 * Some highly unlikely memory faults. Closes: #155842
53 * C++ stuff for G++3.2. Closes: #162617, #165515,
54 * apt-config dumps sends to stdout not stderr now. Closes: #146294
55 * Fix segfault in FindAny when /i is used, and there is no default.
57 * Add s390x to archtable. Closese: #160992.
58 * Update config.sub/config.guess in cvs, and add support to debian/rules
59 to update them from /usr/share/misc if they exist. Closes: #155014
60 * Remove 'Sorry' from messages. Closes: #148824.
61 * Change wording of 'additional disk space usage' message. Closes:
63 * apt-extracttemplates now prepends the package name when extracting
64 files. Closes: #132776
65 * Add -n synonym for --names-only for apt-cache. Closes: #130689
66 * Display both current version and new version in apt-get -s. Closes:
68 * Add an options and timeout config item to ssh/rsh. Closes: #90654
69 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
70 * Change verbose logging output of apt-ftparchive to go to stderr,
71 instead of stdout. Also, errors that occur no longer go to stdout,
72 but stderr. Closes: #161592
73 * Test for timegm in configure. Closes: #165516.
74 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
75 support compliation on platforms where st_mtime is a macro. Closes:
77 * Check the currently mounted cdrom, to see if it's the one we are
78 interested in. Closes: #154602
79 * Rebuild with gcc-3.2. Closes: #177752, #178008.
80 * Fix build-dep handling of | dependencies.
81 Closes: #98640, #145997, #158896, #172901
83 -- Jason Gunthorpe <jgg@debian.org> Sun, 15 Sep 2002 17:16:59 -0600
85 apt (0.5.4) unstable; urgency=low
87 * M68k config.guess patch. Closes: #88913
88 * Bi-yearly test on OpenBSD and Solaris
89 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
90 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
92 * Various cosmetic code updates. Closes: #89066, #89066, #89152
93 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
95 * More patches from Alfredo for Vendors and more SHA-1 stuff
96 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
97 similar situations. Closes: #56708, #59432
98 * no_proxy and ftp. Closes: #89671
99 * Philippe Batailler's man page patches.
100 * Fix for display bug. Closes: #92033, #93652, #98468
101 * Use more than 16bits for the dep ID. Some people ran out..
102 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
103 #106911, #107395, #108968
104 * Reordered some things to make dante and FTP happier. Closes: #92757
105 * James R. Van Zandt's guide.sgml updates. Closes: #90027
106 * apt-ftparchive copes with no uncompressed package files + contents.
107 * French man pages from philippe batailler - well sort of. They
109 * run-parts. Closes: #94286
110 * 'apt-cache policy' preferences debug tool.
111 * Whatever. Closes: #89762
112 * libstdc++ and HURD. Closes: #92025
113 * More apt-utils verbage. Closes: #86954
114 * Fliped comparision operator. Closes: #94618
115 * Used the right copyright file. Closes: #65691
116 * Randolph's G++3 patches.
117 * Fixed no_proxy tokanizing. Closes: #100046
118 * Strip Config-Version when copying status to available. Closes: #97520
119 * Segfault with missing source files. Closes: #100325
120 * EINTR check. Closes: #102293
121 * Various changes to the locking metholodgy for --print-uris.
123 * Lame LD_LIBRARY_PATH thing. Closes: #98928
124 * apt-cache search searchs provide names too now. Closes: #98695
125 * Checksum and long lines problem. Closes: #106591
126 * .aptignr and empty files are just a warning. Closes: #97364
128 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
130 apt (0.5.3) unstable; urgency=low
132 * JoeyH's dpkg::preconfig not working. Closes: #88675
133 * Fixed apt override disparity
134 * Alfredo's SHA-1 and related patches
136 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
138 apt (0.5.2) unstable; urgency=low
140 * Fixed mention of /usr/doc in the long description
141 * JoeyH's downgrade bug -- don't use 0.5.1
142 * Doc bug. Closes: #88538
143 * Fault in building release strings. Closes: #88533
145 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
147 apt (0.5.1) unstable; urgency=low
149 * Fixed #82894 again, or should be and.
150 * Process the option string right. Closes: #86921
151 * Don't eat the last command for pipes. Closes: #86923
152 * Ignore .* for configuration directory processing. Closes: #86923
153 * Alfredo's no_proxy patch
154 * Documentation fixes. Closes: #87091
155 * JoeyH's double slash bug. Closes: #87266
156 * Unintitialized buffer and apt-ftparchive contents generation.
158 * Build-deps on virtual packages. Closes: #87639
159 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
160 libstdc++ version info in the library soname and in the package
161 provides. Closes: #87426
162 * Updated soname version to 0.3.2
163 * apt-extracttemplates moved from debconf into apt-utils
164 * s390 archtable entry. Closes: #88232
166 * Some instances where the status file can source a package in a
167 non-sensical way. Closes: #87390
168 * Work better if there are duplicate sources.list entries.
169 * Fixed the resetting of Dir with "dir {};". Closes: #87323
171 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
173 apt (0.5.0) unstable; urgency=low
175 * Fixed an obscure bug with missing final double new lines in
177 * Changed the apt-cdrom index copy routine to use the new section
179 * Added a package file sorter, apt-sortpkgs
180 * Parse obsolete Optional dependencies.
181 * Added Ben's rsh method. Closes: #57794
182 * Added IPv6 FTP support and better DNS rotation support.
183 * Include the server IP in error messages when using a DNS rotation.
185 * Made most of the byte counters into doubles to prevent 32bit overflow.
187 * HTTP Authorization. Closes: #61158
188 * Ability to parse and return source index build depends from Randolph.
189 * new 'apt-get build-dep' command from Randolph. Closes: #63982
190 * Added apt-ftparchive the all dancing all singing FTP archive
192 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
194 * Removed useless internal cruft including the xstatus file.
195 * Fixed config parser bugs. Closes: #67848, #71108
196 * Brain Damanged apt-get config options changed, does not change the command
197 line interface, except to allow --enable-* to undo a configuration
200 No-Download -> Download
201 No-Upgrade -> Upgrade
202 * Made this fix configable (DSelect::CheckDir) and default to disabled:
203 * No remove prompt if the archives dir has not changed. Closes: #55709
204 Because it is stupid in the case where no files were downloaded due to
205 a resumed-aborted install, or a full cache! Closes: #65952
206 * Obscure divide by zero problem. Closes: #64394
207 * Update sizetable for mips. Closes: #62288
208 * Fixed a bug with passive FTP connections
209 * Has sizetable entry for sparc64. Closes: #64869
210 * Escape special characters in the ::Label section of the cdroms.lst
211 * Created apt-utils and python-apt packages
212 * Due to the new policy engine, the available file may contain entries
213 from the status file. These are generated if the package is not obsolete
214 but the policy engine prohibits using the version from the package files.
215 They can be identified by the lack of a Filename field.
216 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
217 #36223, #33468, #22551
218 * Fixed deb-src line for non-us. Closes: #71501, #71601
219 * Fixes for G++ 2.96, s/friend/friend class/
220 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
221 * Confirmed fix for missing new line problem. Closes: #69386
222 * Fixed up dhelp files. Closes: #71312
223 * Added some notes about dselect and offline usage. Closes: #66473, #38316
224 * Lock files on read only file systems are ignored w/ warning.
226 * apt-get update foo now gives an error! Closes: #42891
227 * Added test for shlibs on hurd. Closes: #71499
228 * Clarified apt-cache document. Closes: #71934
229 * DocBook SGML man pages and some improvements in the text..
230 * sigwinch thing. Closes: #72382
231 * Caching can be turned off by setting the cache file names blank.
232 * Ignores arches it does not know about when autocleaning. Closes: #72862
233 * New function in apt-config to return dirs, files, bools and integers.
234 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
235 complex cases involving OR groups and provides.
236 68754 describes confusing messages which are the result of this..
237 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
238 * Speeling mistake and return code for the 'wicked' resolver error
239 Closes: #72621, #75226, #77464
240 * Solved unable to upgrade libc6 from potato to woody due to 3 package
241 libc6 dependency loop problem.
242 * Leading sources.list spaces. Closes: #76010
243 * Removed a possible infinite loop while processing installations.
244 * Man page updates. Closes: #75411, #75560, #64292, #78469
245 * ReduceSourceList bug. Closes: #76027
246 * --only-source option. Closes: #76320
247 * Typos. Closes: #77812, #77999
248 * Different status messages. Closes: #76652, #78353
249 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
250 * OS detection an support for the new pseduo standard of os-arch for the
251 Architecture string. Also uses regexing.. Closes: #39227, #72349
252 * Various i18n stuff. Note that this still needs some i18n wizard
253 to do the last gettextization right. Closes: #62386
254 * Fixed a problem with some odd http servers/proxies that did not return
255 the content size in the header. Closes: #79878, #44379
256 * Little acquire bugs. Closes: #77029, #55820
257 * _POSIX_THREADS may not be defined to anything, just defined..
259 * Spelling of Ignore-Hold correctly. Closes: #78042
260 * Unlock the dpkg db if in download only mode. Closes: #84851
261 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
262 * Patch from BenC. Closes: #80810
263 * Single output of some names in lists. Closes: #80498, #43286
264 * Nice message for people who can't read syserror output. Closes: #84734
265 * OR search function. Closes: #82894
266 * User's guide updates. Closes: #82469
267 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
268 * Various CD bugs, again thanks to Greenbush
269 Closes: #80946, #76547, #71810, #70049, #69482
270 * Using potato debhelper. Closes: #57977
271 * I cannot self-terminate. Closes: #74928
273 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
275 apt (0.3.19) frozen unstable; urgency=low
277 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
279 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
280 * Fixed hardcoded path. Closes: #59743
281 * Fixed Jay's relative path bug
282 * Allowed source only CDs. Closes: #58952
283 * Space check is supressed if --print-uris is given. Closes: #58965
284 * Clarified the documenation examples for non-us. Closes: #58646
285 * Typo in the package description. Closes: #60230
286 * Man Page typo. Closes: #60347
287 * Typo in Algorithms.cc. Closes: #63577
288 * Evil dotty function in apt-cache for generating dependency graphs
289 with the as-yet-unpackaged GraphVis.
290 * Appears to have been fixed in Janurary.. Closes: #57981
291 * New config.guess/sub for the new archs. Closes: #60874
292 * Fixed error reporting for certain kinds of resolution failures.
294 * Made autoclean respect 'q' settings. Closes: #63023
295 * Fixed up the example sources.list. Closes: #63676
296 * Added DPkg::FlushSTDIN to control the flushing of stdin before
297 forking dpkg. Closes: #63991
299 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
301 apt (0.3.18) frozen unstable; urgency=low
303 * Changes in the postinst script. Closes: #56855, #57237
304 * Fixed bashism. Closes: #57216, #57335
305 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
307 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
309 apt (0.3.17) unstable; urgency=low
311 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
312 * Fixed the configuration parser to not blow up if ; is in the config
314 * Applied visual patch to dselect install script . Closes #55214
315 * Included the configure-index example
317 * Library soname has increased
318 * Fixed default sources.list to have correct URLs for potato when it
320 * Added a message about erasing sources.list to dselect setup script
322 * No remove prompt if the archives dir has not changed. Closes: #55709
323 * Fixed inclusion of 2nd sample config file. Closes: #55374
324 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
327 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
329 apt (0.3.16) unstable; urgency=low
331 * Made --no-download work. Closes: #52993
332 * Now compiles on OpenBSD, Solaris and HP-UX
333 * Clarify segfault errors
334 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
335 * Fix for Joel's discovery of glibc removal behavoir.
336 * Fix for Ben Collins file: uri from slink upgrade.
337 * Fixed resume code in FTP. Closes: #54323
338 * Take more precautions to prevent the corruption Joey Hess saw.
339 * Fixed --no-list-cleanup
340 * RFC 2732 URI parsing ([] for hostnames).
341 * Typo in apt-cache man page. Closes: #54949
343 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
345 apt (0.3.15) unstable; urgency=low
347 * Added DSelect::WaitAfterDownload Closes: #49549
348 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
349 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
350 * Made -s and clean not do anything. Closes: #50238
351 * Problem with Protected packages and the new OR code.
352 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
353 * Remove doesn't require a package to be installable. Closes: #51175
354 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
356 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
358 apt (0.3.14) unstable; urgency=low
360 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
361 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
362 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
363 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
364 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
365 Closes: #45034, #45695, #46537
366 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
367 * Added APT::Clean-Installed option. Closes: #45973
368 * Moves the free space check to after the calculated size is printed.
369 Closes: #46639, #47498
370 * mipsel arch Closes: #47614
371 * Beautified URI printing to not include passwords Closes: #46857
372 * Fixed little problem with --no-download Closes: #47557
373 * Tweaked Dselect 'update' script to re-gen the avail file even in the
374 event of a failure Closes: #47112
375 * Retries for source archives too Closes: #47529
376 * Unmounts CDROMs iff it mounted them Closes: #45299
377 * Checks for the partial directories before doing downloads Closes: #47392
378 * no_proxy environment variable (http only!) Closes: #43476
379 * apt-cache showsrc Closes: #45799
380 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
381 * Regexs for install. Closes: #35304, #38835
382 * Dependency reports now show OR group relations
383 * Re-Install feature. Cloes: #46961, #37393, #38919
384 * Locks archive directory on clean (woops)
385 * Remove is not 'sticky'. Closes: #48392
386 * Slightly more accurate 'can not find package' message. Closes: #48311
387 * --trivial-only and --no-remove. Closes: #48518
388 * Increased the cache size. Closes: #47648
389 * Comment woopsie. Closes: #48789
390 * Removes existing links when linking sources. Closes: #48775
391 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
392 * Clearer usage message about 'source' Closes: #48858
393 * Immediate configure internal error Closes: #49062, #48884
395 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
397 apt (0.3.13) unstable; urgency=low
399 * Fix timestamp miss in FTP. Closes: #44363
400 * Fix sorting of Kept packages. Closes: #44377
401 * Fix Segfault for dselect-upgrade. Closes: #44436
402 * Fix handling of '/' for the dist name. Closes #43830
403 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
404 * Add commented-out deb-src URI to default sources.list file.
406 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
408 apt (0.3.12) unstable; urgency=low
410 * Fix for typo in the dhelp index. Closes: #40377
411 * Multiple media swap support
412 * Purge support. Closes: #33291, #40694
413 * Better handling of - remove notation. Closes: #41024
414 * Purge support. Closes: #33291, #40694
415 * Error code on failed update. Closes: #41053
416 * apt-cdrom adds entries for source directories. Closes: #41231
417 * Sorts the output of any list. Closes: #41107
418 * Fixes the looping problem. Closes: #41784, #42414, #44022
419 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
420 * More checks to keep the display sane. Particularly when fail-over is
421 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
422 * PThread lockup problem on certain sparc/m68k. Closes: #40628
423 * apt-cdrom understands .gz Package files too. Closes: #42779
424 * Spelling error in dselect method description. Closes: #43251
425 * Added security to the default source list. Closes: #43356
427 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
429 apt (0.3.11) unstable; urgency=low
431 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
432 * Fix for properly upgrading the system from perl 5.004 to 5.005
434 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
436 apt (0.3.9) unstable; urgency=low
438 * Spelling error in cachefile.cc. Closes: #39885
439 * Trailing slash in dselect install if you try to use the
440 default config file. Closes: #40011
441 * Simulate works for autoclean. Closes: #39141
442 * Fixed spelling errors. Closes: #39673
443 * Changed url parsing a bit. Closes: #40070, #40069
444 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
446 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
448 apt (0.3.7) unstable; urgency=low
450 * Fixed missing text in the apt-get(8) page. Closes: #37596
451 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
452 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
453 * Fixed handling of the -q option with not-entirely integer arguments
455 * Man page typo Closes: #37762
456 * Fixed parsing of the Source: line. Closes: #37679
457 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
458 * Added a check for an empty cache directory. Closes: #37963
459 * Return a failure code if -d is given and packages fail to download.
461 * Arranged for an ftp proxy specifing an http server to work. See the
462 important note in the sources.list man page.
463 * Accounted for resumed files in the cps calculation. Closes: #36787
464 * Deal with duplicate same version different packages. Closes: #30237
465 * Added --no-download. Closes: #38095
466 * Order of apt-cdrom dist detection. Closes: #38139
467 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
469 * Suggests dpkg-dev for apt-get source. Closes: #38158
470 * Fixed typo in apt-get help. Closes: #38712
471 * Improved the error message in the case of broken held package. Closes: #38777
472 * Fixed handling of MD5 failures
473 * Documented list notation Closes: #39008
474 * Change the 'b' to 'B'. Closes: #39007
476 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
478 apt (0.3.6) unstable; urgency=low
480 * Note that 0.3.5 never made it out the door..
481 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
482 * Made APT print numbers in decimal. Closes: #35617, #37319
483 * Buffer munching fix for FTP. Closes: #35868
484 * Typo in sample config file. Closes: #35907
485 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
486 * Changed installed size counter to only count unpacked packages.
488 * apt-get source support. Closes: #23934, #27190
489 * Renames .debs that fail MD5 checking, provides automatic corruption
490 recovery. Closes: #35931
491 * Fixed autoconf verison. Closes: #37305
492 * Random Segfaulting. Closes: #37312, #37530
493 * Fixed apt-cache man page. Closes: #36904
494 * Added a newline to apt-cache showpkg. Closes: #36903
496 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
498 apt (0.3.4) unstable; urgency=low
500 * Release for Ben while he is out of town.
501 * Checked the size of partial files. Closes: #33705
502 * apt-get should not print progress on non-tty. Closes: #34944
503 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
504 * Applied cdrom patches from Torsten. Closes: #35140, #35141
505 * smbmounted cdrom fix. Closes: #35470
506 * Changed ie to eg. Closes: #35196
508 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
510 apt (0.3.3) unstable; urgency=low
512 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
514 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
516 apt (0.3.2) unstable; urgency=low
518 * Major release into unstable of v3
519 * These bugs have been fixed, explanations are in the bug system, read
520 the man pages as well..
521 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
522 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
523 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
524 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
525 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
526 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
527 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
528 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
530 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
532 apt (0.3.1) experimental; urgency=low
534 * Minor release of cvs version.
535 * Added virtual package libapt-pkgx.x
537 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
539 apt (0.3.0) experimental; urgency=low
541 * New experimental version.
543 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
545 apt (0.1.9) frozen unstable; urgency=low
547 * Return to the wacky numbering for when we build 0.1.8 for hamm
548 * Important bug related to APT on the Alpha fixed
549 * apt-get dist-upgrade problems fixed
550 * tiny patch for http method to fix an endless loop
551 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
552 libtool and add proper shared lib dependancies
553 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
554 in case an old libpkg is installed while building APT to prevent
555 spurious dependancies
557 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
559 apt (0.1.7) unstable; urgency=low
561 * New build with libstdc++2.9.
562 * Various fixes; read the Changelog.
564 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
566 apt (0.1.6) unstable; urgency=low
568 * Various fixes in the FTP method for error checking. Fixes: #26188.
569 * Spelling corrections in dselect method. Fixes: #25884
570 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
571 * No more bo releases: we're using a normal numbering system now.
573 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
575 apt (0.1.5) unstable; urgency=low
577 * Changed sources.list to point to 'unstable' by default, as
578 'frozen' no longer exists!
580 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
582 apt (0.1.3) unstable; urgency=low
584 * New upstreamish version.
585 * ftp method rewritten in C. Removes dependancies on all perl/perl
586 related modules. This fixes many of the ftp method bugs.
588 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
590 apt (0.1.1) unstable; urgency=low
592 * Release for unstable.
594 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
596 apt (0.1) unstable; urgency=low
598 * Kludge to fix problem in libnet-perl with illegal anonymous
600 * Moved to unstable; apt is in a useable state now.
601 * Fixed version numbering. From now on, numbering will be:
602 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
603 0.1.1 (release for unstable). Thanks, Manoj.
605 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
607 apt (0.0.17-1) experimental; urgency=low
609 * Fixed problem with libc6 version compare
610 * Scott's away for a while, so I'll be packaging apt for the time
613 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
615 apt (0.0.16-1) experimental; urgency=low
617 * Modifications to make apt-get more friendly when backgrounded.
618 * Updated documentation.
619 * Updates to graphic widgets
621 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
623 apt (0.0.15-0.2bo) experimental; urgency=low
626 * Bob Hilliards crash
628 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
630 apt (0.0.15-0.1bo) experimental; urgency=low
635 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
637 apt (0.0.15) experimental; urgency=low
639 * Clean up source tarball (no user-visible changes)
641 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
643 apt (0.0.14) experimental; urgency=low
645 * Updates in ordering code to make sure certain upgrades work correctly.
646 * Made dselect/setup understand ftp as well as http
648 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
650 apt (0.0.13-bo1) experimental; urgency=low
654 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
656 apt (0.0.13) experimental; urgency=low
658 * Remove hardcoded egcc from debian/rules (#21575)
659 * Fixes for ordering logic when system has a number of unpacked
660 but unconfigured packages installed.
661 * Spelling fix in dselect install method (#22556)
663 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
665 apt (0.0.12) experimental; urgency=low
667 * Fixed problems with package cache corruption.
668 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
670 * Interface and documentation improvements.
672 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
674 apt (0.0.11) experimental; urgency=low
676 * Change dependancies to pre-depends since breaking your packaging tools
677 in the middle of an installation isn't very good.
678 * Bug fixes to ftp method and general apt-get code
680 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
682 apt (0.0.10) experimental; urgency=low
684 * Run "dpkg --configure -a" after an aborted dselect install
685 * Fixed problem with install looping
686 * Support for authenticating proxys: (note this isn't terribly secure)
687 http_proxy="http://user:pass@firewall:port/"
688 * Substitute $ARCH in sources.list
689 * Fixes in the resumption code for ftp
691 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
693 apt (0.0.9) experimental; urgency=low
696 * Various other less visible bug fixes.
697 * Fixed problem with segfault when apt-get invoked in a non-existant
698 directory (Bug #21863)
699 * Bumped policy to 2.4.1
701 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
703 apt (0.0.8) experimental; urgency=low
705 * Fixed generated available file (Bug #21836)
706 * Added download ETA (Bug #21774).
707 * Fixed hardcoded ARCH (Bug #21751).
708 * Fixed check on http_proxy (Bug #21795).
709 * Added download speed indicator.
711 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
713 apt (0.0.7) experimental; urgency=low
715 * Remove libdeity and apt from package for now, since only apt-get and
716 apt-cache are actually useful right now.
717 * Clean up handling of package installation errors.
718 * Added timeout to http transfers (#21269)
719 * Updated setup for dselect/apt method.
721 * Long options (added in 0.0.6)
723 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
725 apt (0.0.6) experimental; urgency=low
728 * Revamped download status display.
729 * Call apt-get clean after successful install in dselect.
730 * Added "apt-get clean" which deletes package files from /var/cache/apt
732 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
734 apt (0.0.5) experimental; urgency=low
736 * Ignore signals while dpkg is running so we don't leave dpkg running in
737 the background (#20804)
738 * Check Packages as well as Packages.gz for file URIs (#20784)
739 * Spelling cleanup (#20800)
740 * Added -m option to permit upgrade to go on in the case of a bad mirror.
741 This option may result in incomplete upgrades when used with -f.
743 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
745 apt (0.0.4) experimental; urgency=low
748 * Various documentation updates and cleanup.
749 * Added '-f' option to apt-get attempt to fix broken dependancies.
751 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
753 apt (0.0.3) experimental; urgency=low
755 * Added a shlibs.local file to prevent apt from depending on itself.
756 * Updates to how apt-get handles bad states in installed packages.
757 * Updated rules to make sure build works from a freshly checked out source
758 archive. Building from CVS needs libtool/automake/autoconf, builds from
759 the distributed source package should have no such dependancy.
761 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
763 apt (0.0.2) unstable; urgency=low
765 * Updates to apt-get and http binding for dselect method (apt).
766 * Updating version number from 0.0.1, which was released only on IRC.
768 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
770 apt (0.0.1) unstable; urgency=low
774 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500