2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
6 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
7 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
9 # FOR AUTOCONF 2.52 AND NEWER ONLY
10 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
11 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
13 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
17 -include build
/environment.mak
19 ifneq (,$(shell which dpkg-buildflags
))
20 export CXXFLAGS
= $(shell dpkg-buildflags
--get CXXFLAGS
)
22 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
23 export CXXFLAGS
= -O0
-g
-Wall
25 export CXXFLAGS
= -O2
-g
-Wall
33 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
--preserve-envvar CCACHE_DIR
-us
-uc
$(DEB_BUILD_PROG_OPTS
)
34 APT_DEBVER
=$(shell dpkg-parsechangelog |sed
-n
-e
'/^Version:/s/^Version: //p' | sed
-e
's/\+.*$$//')
35 APT_CONFVER
=$(shell sed
-n
-e
's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in
)
36 APT_CVSTAG
=$(shell echo
"$(APT_DEBVER)" | sed
-e
's/^/v/' -e
's/\./_/g')
38 # Determine the build directory to use
41 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
43 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
--machine
) $(BASE
)/build
45 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
46 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
47 override BLD
:= $(BUILDX
)
49 ifeq ($(words $(BLD
)),0)
50 override BLD
:= .
/build
53 # Rebuild configure.in to have the correct version from the change log
54 ifneq ($(APT_DEBVER
),$(APT_CONFVER
))
55 ifneq ($(APT_DEBVER
),)
58 sed
-e
's/$(APT_CONFVER)/$(APT_DEBVER)/' $@
> $@.
$$$$ && mv
$@.
$$$$ $@
64 # APT Programs in apt-utils
65 APT_UTILS
=ftparchive sortpkgs extracttemplates internal-solver
67 # Uncomment this to turn on verbose mode.
70 # Find the libapt-pkg major version for use in other control files
71 include buildlib
/libversion.mak
73 # Determine which library package names to use
74 LIBAPT_PKG
=libapt-pkg
$(LIBAPTPKG_MAJOR
)
75 LIBAPT_INST
=libapt-inst
$(LIBAPTINST_MAJOR
)
77 # do not fail as we are just experimenting with symbol files for now
78 export DPKG_GENSYMBOLS_CHECK_LEVEL
=0
80 build
: build
/build-stamp
81 build-doc
: build
/build-doc-stamp
83 # Note that this is unconditionally done first as part of loading environment.mak
84 # The true is needed to force make to reload environment.mak after running
85 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
86 build
/environment.mak
: build
/configure-stamp
89 configure
: configure.in
90 build
/configure-stamp
: configure
93 cp COPYING debian
/copyright
94 cd build
&& CXXFLAGS
="$(CXXFLAGS)" ..
/configure
$(confflags
)
97 build
/build-stamp
: build
/configure-stamp
98 # Add here commands to compile the package.
100 # compat symlink for the locale split
101 mkdir
-p build
/usr
/share
102 cd build
/usr
/share
&& ln
-f
-s ..
/..
/locale .
106 build
/build-doc-stamp
: build
/configure-stamp
107 # Add here commands to compile the package.
114 [ ! -f Makefile
] ||
$(MAKE
) clean distclean
117 binary-indep
: apt-doc libapt-pkg-doc
118 # Build architecture-independent files here.
119 libapt-pkg-doc
: build-doc
125 # libapt-pkg-doc install
127 # remove doxygen's embedded jquery as we don't use it anyway (#622147)
128 rm -f
$(BLD
)/doc
/doxygen
/html
/jquery.js
130 dh_installdocs
-p
$@
$(BLD
)/docs
/design
* \
131 $(BLD
)/docs
/dpkg-tech
* \
133 $(BLD
)/docs
/method
* \
134 doc
/libapt-pkg2_to_3.txt \
136 $(BLD
)/doc
/doxygen
/html
137 dh_installexamples
-p
$@
139 dh_installchangelogs
-p
$@
156 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text \
157 $(BLD
)/docs
/guide
*.html \
158 $(BLD
)/docs
/offline
*.text \
159 $(BLD
)/docs
/offline
*.html
160 dh_installchangelogs
-p
$@
170 # Build architecture-dependent files here.
172 binary-arch
: $(LIBAPT_PKG
) $(LIBAPT_INST
) apt libapt-pkg-dev apt-utils apt-transport-https
173 apt_MANPAGES
= apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
182 cp debian
/apt.conf.autoremove debian
/$@
/etc
/apt
/apt.conf.d
/01autoremove
184 # make rosetta happy and remove pot files in po/ (but leave stuff
185 # in po/domains/* untouched) and cp *.po into each domain dir
189 dh_install
-p
$@
--sourcedir
=$(BLD
)
191 # Remove the bits that are in apt-utils
192 rm $(addprefix debian
/$@
/usr
/bin
/apt-
,$(APT_UTILS
) dump-solver
)
194 # https has its own package
195 rm debian
/$@
/usr
/lib
/apt
/methods
/https
197 # move the mirror failure script in place
198 #mv debian/$@/usr/bin/apt-report-mirror-failure \
199 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
203 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
204 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/%.
[158],$(apt_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt_MANPAGES
)))
207 dh_installchangelogs
-p
$@
208 dh_installlogrotate
-p
$@
218 libapt-pkg-dev
: build
224 # libapt-pkg-dev install
226 dh_install
-p
$@
--sourcedir
=$(BLD
)
228 dh_installchangelogs
-p
$@
233 dh_gencontrol
-p
$@
-- -Vlibapt-pkg-name
=$(LIBAPT_PKG
) -Vlibapt-inst-name
=$(LIBAPT_INST
)
237 apt-utils_MANPAGES
= apt-sortpkgs apt-ftparchive apt-extracttemplates
244 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
245 cp
$(BLD
)/bin
/apt-dump-solver debian
/$@
/usr
/lib
/apt
/solvers
/dump
247 dh_install
-p
$@
--sourcedir
=$(BLD
)
250 dh_installexamples
-p
$@
252 # Install the man pages..
253 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/%.
[158],$(apt-utils_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt-utils_MANPAGES
)))
255 dh_installchangelogs
-p
$@
272 dh_install
-p
$@
--sourcedir
=$(BLD
)
274 dh_installchangelogs
-p
$@
285 $(LIBAPT_INST
): build
291 dh_install
-p
$@
--sourcedir
=$(BLD
)
293 dh_installchangelogs
-p
$@
304 apt-transport-https
: build libapt-pkg-dev
310 dh_install
-p
$@
--sourcedir
=$(BLD
)
311 dh_installdocs
-p
$@ debian
/apt-transport-https.README
312 dh_installexamples
-p
$@
314 # Install the man pages..
317 dh_installchangelogs
-p
$@
331 -find .
-name Makefile.in
-print0 | xargs
--null
--no-run-if-empty
-- rm -f
332 find
-name ChangeLog | xargs
rm -f
335 binary
: binary-indep binary-arch
336 .PHONY
: build
clean binary-indep binary-arch binary