1 apt (0.5.5.1) unstable; urgency=low
3 * Move the target of the example docs from doc to binary. Closes:
5 * Fix api breakage that broke apt-ftparchive and apt-cache dumpavail, by
6 backing out change that incorretly attempted to handle Package sections
7 larger than 32k. Closes: #192373
8 * Fix never-ending loop with apt-get install -V. Closes: #192355.
9 * Fix segfault when handling /etc/apt/preferences. Closes: #192409.
11 -- Adam Heath <doogie@debian.org> Mon, 19 May 2003 12:30:16 -0500
13 apt (0.5.5) unstable; urgency=low
15 * New deb version compare function, that has no integer limits, and
16 supports pre-versions using ~. Code ported from dpkg.
17 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
18 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
19 * "apt-get --arch-only build-dep" to install only architecture-
20 dependent build dependencies. Bump minor shared lib number to reflect
21 small change in BuildDepend API.
22 * APT::Build-Essential configuration option (defaults to "build-essential")
23 so that "apt-get build-dep" will ensure build essential packages are
24 installed prior to installing other build-dependencies. Closes: #148879
25 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
26 * /usr/doc reference in postinst. Closes: #126189
27 * Doc updates. Closes: #120689
28 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
30 * Print special message for EAI_AGAIN. Closes: #131397
31 * libapt-pkg-dev needs to bring in the apt-inst library if linking
32 is to work. Closes: #133943
33 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
34 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
35 #139994, #142955, #151654, #151834, #147611, #154268, #173971
36 * Fix possibility for tag file parsing to fail in some unlikely situations.
38 * Use std C++ names for some header files. Closes: #128741
39 * Do not check for free space if --no-download. Closes: #117856
40 * Actually implement or group handling for 'upgrade'. Closes: #133950
41 * "Internal Error, Couldn't configure pre-depend" is not actually an
42 internal error, it is a packaging error and now it says so, and
43 pinpoints the problem dependency. Closes: #155621
44 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
45 * Use usr/share/doc for dhelp. Closes: #115701
46 * --print-uris works with 'update'. Closes: #57070
47 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
49 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
51 * Allow an uninstalled package to be marked for removal on an install
52 line (meaning not to automatically install it), also fix some dodgy
53 handling of protected packages. Closes: #92287, #116011
54 * Fix errant prefix matching in version selection. Closes: #105968
55 * Ensure that all files needed to run APT as a user are readable and
56 ignore roots umask for these files. Closes: #108801
57 * Support larger config spaces. Closes: #111914
58 * 'apt-get update' no longer does 'Building Dependency Tree'.
59 * When matching regexs allways print a message. Change regex activation
60 charset. Closes: #147817
61 * Don't die if lines in sources.list are too long. Closes: #146846
62 * Show file name on apt-extracttemplate error messges. Closes: #151835
63 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
64 * Some highly unlikely memory faults. Closes: #155842
65 * C++ stuff for G++3.2. Closes: #162617, #165515,
66 * apt-config dumps sends to stdout not stderr now. Closes: #146294
67 * Fix segfault in FindAny when /i is used, and there is no default.
69 * Add s390x to archtable. Closese: #160992.
70 * Update config.sub/config.guess in cvs, and add support to debian/rules
71 to update them from /usr/share/misc if they exist. Closes: #155014
72 * Remove 'Sorry' from messages. Closes: #148824.
73 * Change wording of 'additional disk space usage' message. Closes:
75 * apt-extracttemplates now prepends the package name when extracting
76 files. Closes: #132776
77 * Add -n synonym for --names-only for apt-cache. Closes: #130689
78 * Display both current version and new version in apt-get -s. Closes:
80 * Add an options and timeout config item to ssh/rsh. Closes: #90654
81 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
82 * Change verbose logging output of apt-ftparchive to go to stderr,
83 instead of stdout. Also, errors that occur no longer go to stdout,
84 but stderr. Closes: #161592
85 * Test for timegm in configure. Closes: #165516.
86 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
87 support compliation on platforms where st_mtime is a macro. Closes:
89 * Check the currently mounted cdrom, to see if it's the one we are
90 interested in. Closes: #154602
91 * Refer to reportbug instead of bug in the man pages. Closes: #173745
92 * Link apt-inst to apt-pkg. Closes: #175055
93 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
95 * Fix > 300 col screen segfault. Closes: #176052
96 * Rebuild with gcc-3.2. Closes: #177752, #178008.
97 * Fix build-dep handling of | dependencies.
98 Closes: #98640, #145997, #158896, #172901
99 * Double default value of APT::Cache-Limit, until such time as it
100 can be made more dynamic. Closes: #178623.
101 * Report uris with '.gz' when there are errors. Closes: #178435.
102 * When installing build-deps, make sure the new version will
103 satisfy build requirements. Closes: #178121
104 * Split offline and guide documentation into apt-doc. This was done so
105 that binary-arch builds do not require documention deps. Note, that
106 apt-doc is not installed on upgrades.
107 * Use doc-base, instead of dhelp directly. Closes: #110389
108 * Change http message 'Waiting for file' to 'Waiting for headers'.
110 * Remove trailing lines on package lists in apt-get. Closes: #178736.
111 * Fix origin pins for file:// uris. Closes: #189014.
112 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
114 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
116 * Fix some typos in the apt-get manual. Closes: #163932.
117 * Apply patch from bug, to change frozen to testing, and then do it
118 everywhere else. Closes: #165085.
119 * Update es.po. Closes: #183111.
120 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
122 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
123 * Add option to apt-get to show versions of packages being
125 * Be quiet in apt.post{inst,rm}. Closes: #70685.
126 * apt-get now prints out suggested and recommended packages. Closes:
128 * Insert some newlines in the cdrom change media message. Closes:
130 * Add a rdepends command to apt-cache. Closes: #159864.
131 * When building the dpkg command line, allow for 8192 chars to be used,
132 instead of only 1024.
133 * APT::Immediate-Configure had inverted semantics(false meant it was
134 enabled). Closes: #173619.
135 * Fix status file parser so that if a record is larger than 32k, the
136 buffer size will be doubled, and the read attempted again. Closes:
139 -- Adam Heath <doogie@debian.org> Sun, 27 Apr 2003 01:23:12 -0500
141 apt (0.5.4) unstable; urgency=low
143 * M68k config.guess patch. Closes: #88913
144 * Bi-yearly test on OpenBSD and Solaris
145 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
146 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
148 * Various cosmetic code updates. Closes: #89066, #89066, #89152
149 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
151 * More patches from Alfredo for Vendors and more SHA-1 stuff
152 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
153 similar situations. Closes: #56708, #59432
154 * no_proxy and ftp. Closes: #89671
155 * Philippe Batailler's man page patches.
156 * Fix for display bug. Closes: #92033, #93652, #98468
157 * Use more than 16bits for the dep ID. Some people ran out..
158 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
159 #106911, #107395, #108968
160 * Reordered some things to make dante and FTP happier. Closes: #92757
161 * James R. Van Zandt's guide.sgml updates. Closes: #90027
162 * apt-ftparchive copes with no uncompressed package files + contents.
163 * French man pages from philippe batailler - well sort of. They
165 * run-parts. Closes: #94286
166 * 'apt-cache policy' preferences debug tool.
167 * Whatever. Closes: #89762
168 * libstdc++ and HURD. Closes: #92025
169 * More apt-utils verbage. Closes: #86954
170 * Fliped comparision operator. Closes: #94618
171 * Used the right copyright file. Closes: #65691
172 * Randolph's G++3 patches.
173 * Fixed no_proxy tokanizing. Closes: #100046
174 * Strip Config-Version when copying status to available. Closes: #97520
175 * Segfault with missing source files. Closes: #100325
176 * EINTR check. Closes: #102293
177 * Various changes to the locking metholodgy for --print-uris.
179 * Lame LD_LIBRARY_PATH thing. Closes: #98928
180 * apt-cache search searchs provide names too now. Closes: #98695
181 * Checksum and long lines problem. Closes: #106591
182 * .aptignr and empty files are just a warning. Closes: #97364
184 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
186 apt (0.5.3) unstable; urgency=low
188 * JoeyH's dpkg::preconfig not working. Closes: #88675
189 * Fixed apt override disparity
190 * Alfredo's SHA-1 and related patches
192 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
194 apt (0.5.2) unstable; urgency=low
196 * Fixed mention of /usr/doc in the long description
197 * JoeyH's downgrade bug -- don't use 0.5.1
198 * Doc bug. Closes: #88538
199 * Fault in building release strings. Closes: #88533
201 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
203 apt (0.5.1) unstable; urgency=low
205 * Fixed #82894 again, or should be and.
206 * Process the option string right. Closes: #86921
207 * Don't eat the last command for pipes. Closes: #86923
208 * Ignore .* for configuration directory processing. Closes: #86923
209 * Alfredo's no_proxy patch
210 * Documentation fixes. Closes: #87091
211 * JoeyH's double slash bug. Closes: #87266
212 * Unintitialized buffer and apt-ftparchive contents generation.
214 * Build-deps on virtual packages. Closes: #87639
215 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
216 libstdc++ version info in the library soname and in the package
217 provides. Closes: #87426
218 * Updated soname version to 0.3.2
219 * apt-extracttemplates moved from debconf into apt-utils
220 * s390 archtable entry. Closes: #88232
222 * Some instances where the status file can source a package in a
223 non-sensical way. Closes: #87390
224 * Work better if there are duplicate sources.list entries.
225 * Fixed the resetting of Dir with "dir {};". Closes: #87323
227 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
229 apt (0.5.0) unstable; urgency=low
231 * Fixed an obscure bug with missing final double new lines in
233 * Changed the apt-cdrom index copy routine to use the new section
235 * Added a package file sorter, apt-sortpkgs
236 * Parse obsolete Optional dependencies.
237 * Added Ben's rsh method. Closes: #57794
238 * Added IPv6 FTP support and better DNS rotation support.
239 * Include the server IP in error messages when using a DNS rotation.
241 * Made most of the byte counters into doubles to prevent 32bit overflow.
243 * HTTP Authorization. Closes: #61158
244 * Ability to parse and return source index build depends from Randolph.
245 * new 'apt-get build-dep' command from Randolph. Closes: #63982
246 * Added apt-ftparchive the all dancing all singing FTP archive
248 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
250 * Removed useless internal cruft including the xstatus file.
251 * Fixed config parser bugs. Closes: #67848, #71108
252 * Brain Damanged apt-get config options changed, does not change the command
253 line interface, except to allow --enable-* to undo a configuration
256 No-Download -> Download
257 No-Upgrade -> Upgrade
258 * Made this fix configable (DSelect::CheckDir) and default to disabled:
259 * No remove prompt if the archives dir has not changed. Closes: #55709
260 Because it is stupid in the case where no files were downloaded due to
261 a resumed-aborted install, or a full cache! Closes: #65952
262 * Obscure divide by zero problem. Closes: #64394
263 * Update sizetable for mips. Closes: #62288
264 * Fixed a bug with passive FTP connections
265 * Has sizetable entry for sparc64. Closes: #64869
266 * Escape special characters in the ::Label section of the cdroms.lst
267 * Created apt-utils and python-apt packages
268 * Due to the new policy engine, the available file may contain entries
269 from the status file. These are generated if the package is not obsolete
270 but the policy engine prohibits using the version from the package files.
271 They can be identified by the lack of a Filename field.
272 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
273 #36223, #33468, #22551
274 * Fixed deb-src line for non-us. Closes: #71501, #71601
275 * Fixes for G++ 2.96, s/friend/friend class/
276 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
277 * Confirmed fix for missing new line problem. Closes: #69386
278 * Fixed up dhelp files. Closes: #71312
279 * Added some notes about dselect and offline usage. Closes: #66473, #38316
280 * Lock files on read only file systems are ignored w/ warning.
282 * apt-get update foo now gives an error! Closes: #42891
283 * Added test for shlibs on hurd. Closes: #71499
284 * Clarified apt-cache document. Closes: #71934
285 * DocBook SGML man pages and some improvements in the text..
286 * sigwinch thing. Closes: #72382
287 * Caching can be turned off by setting the cache file names blank.
288 * Ignores arches it does not know about when autocleaning. Closes: #72862
289 * New function in apt-config to return dirs, files, bools and integers.
290 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
291 complex cases involving OR groups and provides.
292 68754 describes confusing messages which are the result of this..
293 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
294 * Speeling mistake and return code for the 'wicked' resolver error
295 Closes: #72621, #75226, #77464
296 * Solved unable to upgrade libc6 from potato to woody due to 3 package
297 libc6 dependency loop problem.
298 * Leading sources.list spaces. Closes: #76010
299 * Removed a possible infinite loop while processing installations.
300 * Man page updates. Closes: #75411, #75560, #64292, #78469
301 * ReduceSourceList bug. Closes: #76027
302 * --only-source option. Closes: #76320
303 * Typos. Closes: #77812, #77999
304 * Different status messages. Closes: #76652, #78353
305 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
306 * OS detection an support for the new pseduo standard of os-arch for the
307 Architecture string. Also uses regexing.. Closes: #39227, #72349
308 * Various i18n stuff. Note that this still needs some i18n wizard
309 to do the last gettextization right. Closes: #62386
310 * Fixed a problem with some odd http servers/proxies that did not return
311 the content size in the header. Closes: #79878, #44379
312 * Little acquire bugs. Closes: #77029, #55820
313 * _POSIX_THREADS may not be defined to anything, just defined..
315 * Spelling of Ignore-Hold correctly. Closes: #78042
316 * Unlock the dpkg db if in download only mode. Closes: #84851
317 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
318 * Patch from BenC. Closes: #80810
319 * Single output of some names in lists. Closes: #80498, #43286
320 * Nice message for people who can't read syserror output. Closes: #84734
321 * OR search function. Closes: #82894
322 * User's guide updates. Closes: #82469
323 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
324 * Various CD bugs, again thanks to Greenbush
325 Closes: #80946, #76547, #71810, #70049, #69482
326 * Using potato debhelper. Closes: #57977
327 * I cannot self-terminate. Closes: #74928
329 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
331 apt (0.3.19) frozen unstable; urgency=low
333 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
335 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
336 * Fixed hardcoded path. Closes: #59743
337 * Fixed Jay's relative path bug
338 * Allowed source only CDs. Closes: #58952
339 * Space check is supressed if --print-uris is given. Closes: #58965
340 * Clarified the documenation examples for non-us. Closes: #58646
341 * Typo in the package description. Closes: #60230
342 * Man Page typo. Closes: #60347
343 * Typo in Algorithms.cc. Closes: #63577
344 * Evil dotty function in apt-cache for generating dependency graphs
345 with the as-yet-unpackaged GraphVis.
346 * Appears to have been fixed in Janurary.. Closes: #57981
347 * New config.guess/sub for the new archs. Closes: #60874
348 * Fixed error reporting for certain kinds of resolution failures.
350 * Made autoclean respect 'q' settings. Closes: #63023
351 * Fixed up the example sources.list. Closes: #63676
352 * Added DPkg::FlushSTDIN to control the flushing of stdin before
353 forking dpkg. Closes: #63991
355 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
357 apt (0.3.18) frozen unstable; urgency=low
359 * Changes in the postinst script. Closes: #56855, #57237
360 * Fixed bashism. Closes: #57216, #57335
361 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
363 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
365 apt (0.3.17) unstable; urgency=low
367 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
368 * Fixed the configuration parser to not blow up if ; is in the config
370 * Applied visual patch to dselect install script . Closes #55214
371 * Included the configure-index example
373 * Library soname has increased
374 * Fixed default sources.list to have correct URLs for potato when it
376 * Added a message about erasing sources.list to dselect setup script
378 * No remove prompt if the archives dir has not changed. Closes: #55709
379 * Fixed inclusion of 2nd sample config file. Closes: #55374
380 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
383 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
385 apt (0.3.16) unstable; urgency=low
387 * Made --no-download work. Closes: #52993
388 * Now compiles on OpenBSD, Solaris and HP-UX
389 * Clarify segfault errors
390 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
391 * Fix for Joel's discovery of glibc removal behavoir.
392 * Fix for Ben Collins file: uri from slink upgrade.
393 * Fixed resume code in FTP. Closes: #54323
394 * Take more precautions to prevent the corruption Joey Hess saw.
395 * Fixed --no-list-cleanup
396 * RFC 2732 URI parsing ([] for hostnames).
397 * Typo in apt-cache man page. Closes: #54949
399 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
401 apt (0.3.15) unstable; urgency=low
403 * Added DSelect::WaitAfterDownload Closes: #49549
404 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
405 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
406 * Made -s and clean not do anything. Closes: #50238
407 * Problem with Protected packages and the new OR code.
408 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
409 * Remove doesn't require a package to be installable. Closes: #51175
410 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
412 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
414 apt (0.3.14) unstable; urgency=low
416 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
417 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
418 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
419 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
420 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
421 Closes: #45034, #45695, #46537
422 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
423 * Added APT::Clean-Installed option. Closes: #45973
424 * Moves the free space check to after the calculated size is printed.
425 Closes: #46639, #47498
426 * mipsel arch Closes: #47614
427 * Beautified URI printing to not include passwords Closes: #46857
428 * Fixed little problem with --no-download Closes: #47557
429 * Tweaked Dselect 'update' script to re-gen the avail file even in the
430 event of a failure Closes: #47112
431 * Retries for source archives too Closes: #47529
432 * Unmounts CDROMs iff it mounted them Closes: #45299
433 * Checks for the partial directories before doing downloads Closes: #47392
434 * no_proxy environment variable (http only!) Closes: #43476
435 * apt-cache showsrc Closes: #45799
436 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
437 * Regexs for install. Closes: #35304, #38835
438 * Dependency reports now show OR group relations
439 * Re-Install feature. Cloes: #46961, #37393, #38919
440 * Locks archive directory on clean (woops)
441 * Remove is not 'sticky'. Closes: #48392
442 * Slightly more accurate 'can not find package' message. Closes: #48311
443 * --trivial-only and --no-remove. Closes: #48518
444 * Increased the cache size. Closes: #47648
445 * Comment woopsie. Closes: #48789
446 * Removes existing links when linking sources. Closes: #48775
447 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
448 * Clearer usage message about 'source' Closes: #48858
449 * Immediate configure internal error Closes: #49062, #48884
451 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
453 apt (0.3.13) unstable; urgency=low
455 * Fix timestamp miss in FTP. Closes: #44363
456 * Fix sorting of Kept packages. Closes: #44377
457 * Fix Segfault for dselect-upgrade. Closes: #44436
458 * Fix handling of '/' for the dist name. Closes #43830
459 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
460 * Add commented-out deb-src URI to default sources.list file.
462 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
464 apt (0.3.12) unstable; urgency=low
466 * Fix for typo in the dhelp index. Closes: #40377
467 * Multiple media swap support
468 * Purge support. Closes: #33291, #40694
469 * Better handling of - remove notation. Closes: #41024
470 * Purge support. Closes: #33291, #40694
471 * Error code on failed update. Closes: #41053
472 * apt-cdrom adds entries for source directories. Closes: #41231
473 * Sorts the output of any list. Closes: #41107
474 * Fixes the looping problem. Closes: #41784, #42414, #44022
475 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
476 * More checks to keep the display sane. Particularly when fail-over is
477 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
478 * PThread lockup problem on certain sparc/m68k. Closes: #40628
479 * apt-cdrom understands .gz Package files too. Closes: #42779
480 * Spelling error in dselect method description. Closes: #43251
481 * Added security to the default source list. Closes: #43356
483 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
485 apt (0.3.11) unstable; urgency=low
487 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
488 * Fix for properly upgrading the system from perl 5.004 to 5.005
490 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
492 apt (0.3.9) unstable; urgency=low
494 * Spelling error in cachefile.cc. Closes: #39885
495 * Trailing slash in dselect install if you try to use the
496 default config file. Closes: #40011
497 * Simulate works for autoclean. Closes: #39141
498 * Fixed spelling errors. Closes: #39673
499 * Changed url parsing a bit. Closes: #40070, #40069
500 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
502 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
504 apt (0.3.7) unstable; urgency=low
506 * Fixed missing text in the apt-get(8) page. Closes: #37596
507 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
508 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
509 * Fixed handling of the -q option with not-entirely integer arguments
511 * Man page typo Closes: #37762
512 * Fixed parsing of the Source: line. Closes: #37679
513 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
514 * Added a check for an empty cache directory. Closes: #37963
515 * Return a failure code if -d is given and packages fail to download.
517 * Arranged for an ftp proxy specifing an http server to work. See the
518 important note in the sources.list man page.
519 * Accounted for resumed files in the cps calculation. Closes: #36787
520 * Deal with duplicate same version different packages. Closes: #30237
521 * Added --no-download. Closes: #38095
522 * Order of apt-cdrom dist detection. Closes: #38139
523 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
525 * Suggests dpkg-dev for apt-get source. Closes: #38158
526 * Fixed typo in apt-get help. Closes: #38712
527 * Improved the error message in the case of broken held package. Closes: #38777
528 * Fixed handling of MD5 failures
529 * Documented list notation Closes: #39008
530 * Change the 'b' to 'B'. Closes: #39007
532 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
534 apt (0.3.6) unstable; urgency=low
536 * Note that 0.3.5 never made it out the door..
537 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
538 * Made APT print numbers in decimal. Closes: #35617, #37319
539 * Buffer munching fix for FTP. Closes: #35868
540 * Typo in sample config file. Closes: #35907
541 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
542 * Changed installed size counter to only count unpacked packages.
544 * apt-get source support. Closes: #23934, #27190
545 * Renames .debs that fail MD5 checking, provides automatic corruption
546 recovery. Closes: #35931
547 * Fixed autoconf verison. Closes: #37305
548 * Random Segfaulting. Closes: #37312, #37530
549 * Fixed apt-cache man page. Closes: #36904
550 * Added a newline to apt-cache showpkg. Closes: #36903
552 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
554 apt (0.3.4) unstable; urgency=low
556 * Release for Ben while he is out of town.
557 * Checked the size of partial files. Closes: #33705
558 * apt-get should not print progress on non-tty. Closes: #34944
559 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
560 * Applied cdrom patches from Torsten. Closes: #35140, #35141
561 * smbmounted cdrom fix. Closes: #35470
562 * Changed ie to eg. Closes: #35196
564 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
566 apt (0.3.3) unstable; urgency=low
568 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
570 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
572 apt (0.3.2) unstable; urgency=low
574 * Major release into unstable of v3
575 * These bugs have been fixed, explanations are in the bug system, read
576 the man pages as well..
577 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
578 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
579 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
580 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
581 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
582 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
583 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
584 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
586 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
588 apt (0.3.1) experimental; urgency=low
590 * Minor release of cvs version.
591 * Added virtual package libapt-pkgx.x
593 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
595 apt (0.3.0) experimental; urgency=low
597 * New experimental version.
599 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
601 apt (0.1.9) frozen unstable; urgency=low
603 * Return to the wacky numbering for when we build 0.1.8 for hamm
604 * Important bug related to APT on the Alpha fixed
605 * apt-get dist-upgrade problems fixed
606 * tiny patch for http method to fix an endless loop
607 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
608 libtool and add proper shared lib dependancies
609 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
610 in case an old libpkg is installed while building APT to prevent
611 spurious dependancies
613 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
615 apt (0.1.7) unstable; urgency=low
617 * New build with libstdc++2.9.
618 * Various fixes; read the Changelog.
620 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
622 apt (0.1.6) unstable; urgency=low
624 * Various fixes in the FTP method for error checking. Fixes: #26188.
625 * Spelling corrections in dselect method. Fixes: #25884
626 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
627 * No more bo releases: we're using a normal numbering system now.
629 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
631 apt (0.1.5) unstable; urgency=low
633 * Changed sources.list to point to 'unstable' by default, as
634 'frozen' no longer exists!
636 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
638 apt (0.1.3) unstable; urgency=low
640 * New upstreamish version.
641 * ftp method rewritten in C. Removes dependancies on all perl/perl
642 related modules. This fixes many of the ftp method bugs.
644 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
646 apt (0.1.1) unstable; urgency=low
648 * Release for unstable.
650 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
652 apt (0.1) unstable; urgency=low
654 * Kludge to fix problem in libnet-perl with illegal anonymous
656 * Moved to unstable; apt is in a useable state now.
657 * Fixed version numbering. From now on, numbering will be:
658 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
659 0.1.1 (release for unstable). Thanks, Manoj.
661 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
663 apt (0.0.17-1) experimental; urgency=low
665 * Fixed problem with libc6 version compare
666 * Scott's away for a while, so I'll be packaging apt for the time
669 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
671 apt (0.0.16-1) experimental; urgency=low
673 * Modifications to make apt-get more friendly when backgrounded.
674 * Updated documentation.
675 * Updates to graphic widgets
677 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
679 apt (0.0.15-0.2bo) experimental; urgency=low
682 * Bob Hilliards crash
684 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
686 apt (0.0.15-0.1bo) experimental; urgency=low
691 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
693 apt (0.0.15) experimental; urgency=low
695 * Clean up source tarball (no user-visible changes)
697 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
699 apt (0.0.14) experimental; urgency=low
701 * Updates in ordering code to make sure certain upgrades work correctly.
702 * Made dselect/setup understand ftp as well as http
704 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
706 apt (0.0.13-bo1) experimental; urgency=low
710 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
712 apt (0.0.13) experimental; urgency=low
714 * Remove hardcoded egcc from debian/rules (#21575)
715 * Fixes for ordering logic when system has a number of unpacked
716 but unconfigured packages installed.
717 * Spelling fix in dselect install method (#22556)
719 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
721 apt (0.0.12) experimental; urgency=low
723 * Fixed problems with package cache corruption.
724 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
726 * Interface and documentation improvements.
728 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
730 apt (0.0.11) experimental; urgency=low
732 * Change dependancies to pre-depends since breaking your packaging tools
733 in the middle of an installation isn't very good.
734 * Bug fixes to ftp method and general apt-get code
736 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
738 apt (0.0.10) experimental; urgency=low
740 * Run "dpkg --configure -a" after an aborted dselect install
741 * Fixed problem with install looping
742 * Support for authenticating proxys: (note this isn't terribly secure)
743 http_proxy="http://user:pass@firewall:port/"
744 * Substitute $ARCH in sources.list
745 * Fixes in the resumption code for ftp
747 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
749 apt (0.0.9) experimental; urgency=low
752 * Various other less visible bug fixes.
753 * Fixed problem with segfault when apt-get invoked in a non-existant
754 directory (Bug #21863)
755 * Bumped policy to 2.4.1
757 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
759 apt (0.0.8) experimental; urgency=low
761 * Fixed generated available file (Bug #21836)
762 * Added download ETA (Bug #21774).
763 * Fixed hardcoded ARCH (Bug #21751).
764 * Fixed check on http_proxy (Bug #21795).
765 * Added download speed indicator.
767 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
769 apt (0.0.7) experimental; urgency=low
771 * Remove libdeity and apt from package for now, since only apt-get and
772 apt-cache are actually useful right now.
773 * Clean up handling of package installation errors.
774 * Added timeout to http transfers (#21269)
775 * Updated setup for dselect/apt method.
777 * Long options (added in 0.0.6)
779 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
781 apt (0.0.6) experimental; urgency=low
784 * Revamped download status display.
785 * Call apt-get clean after successful install in dselect.
786 * Added "apt-get clean" which deletes package files from /var/cache/apt
788 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
790 apt (0.0.5) experimental; urgency=low
792 * Ignore signals while dpkg is running so we don't leave dpkg running in
793 the background (#20804)
794 * Check Packages as well as Packages.gz for file URIs (#20784)
795 * Spelling cleanup (#20800)
796 * Added -m option to permit upgrade to go on in the case of a bad mirror.
797 This option may result in incomplete upgrades when used with -f.
799 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
801 apt (0.0.4) experimental; urgency=low
804 * Various documentation updates and cleanup.
805 * Added '-f' option to apt-get attempt to fix broken dependancies.
807 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
809 apt (0.0.3) experimental; urgency=low
811 * Added a shlibs.local file to prevent apt from depending on itself.
812 * Updates to how apt-get handles bad states in installed packages.
813 * Updated rules to make sure build works from a freshly checked out source
814 archive. Building from CVS needs libtool/automake/autoconf, builds from
815 the distributed source package should have no such dependancy.
817 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
819 apt (0.0.2) unstable; urgency=low
821 * Updates to apt-get and http binding for dselect method (apt).
822 * Updating version number from 0.0.1, which was released only on IRC.
824 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
826 apt (0.0.1) unstable; urgency=low
830 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500