2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.47 2003/02/12 14:28:03 doogie Exp $
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
19 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
20 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
22 # FOR AUTOCONF 2.52 AND NEWER ONLY
23 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
24 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
26 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
30 -include build
/environment.mak
35 DEB_BUILD_PROG
:=debuild
-us
-uc
36 APT_DEBVER
=$(shell dpkg-parsechangelog |sed
-n
-e
'/^Version:/s/^Version: //p')
37 APT_CONFVER
=$(shell sed
-n
-e
's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in
)
39 # Determine the build directory to use
42 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
44 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
-m
) $(BASE
)/build
46 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
47 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
48 override BLD
:= $(BUILDX
)
50 ifeq ($(words $(BLD
)),0)
51 override BLD
:= .
/build
54 # Rebuild configure.in to have the correct version from the change log
55 ifneq ($(APT_DEBVER
),$(APT_CONFVER
))
58 sed
-e
's/$(APT_CONFVER)/$(APT_DEBVER)/' $@
> $@.
$$$$;mv
$@.
$$$$ $@
63 # APT Programs in apt-utils
64 APT_UTILS
=ftparchive sortpkgs extracttemplates
66 # Uncomment this to turn on verbose mode.
69 # Find the libapt-pkg major version for use in other control files
70 export LIBAPTPKG_MAJOR
:=$(shell egrep
'^MAJOR=' apt-pkg
/makefile |cut
-d
'=' -f
2)
71 export LIBAPTINST_MAJOR
:=$(shell egrep
'^MAJOR=' apt-inst
/makefile |cut
-d
'=' -f
2)
73 # Determine which package we should provide in the control files
74 LIBAPTPKG_PROVIDE
=libapt-pkg
$(GLIBC_VER
)$(LIBSTDCPP_VER
)-$(LIBAPTPKG_MAJOR
)
75 LIBAPTINST_PROVIDE
=libapt-inst
$(GLIBC_VER
)$(LIBSTDCPP_VER
)-$(LIBAPTINST_MAJOR
)
77 debian
/shlibs.local
: apt-pkg
/makefile
78 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
79 # one for the rest of the packages. This ensures that each package gets
80 # the right overrides..
81 rm -rf
$@
$@.apt
$@.apt-utils
82 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
84 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
85 echo
"libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
87 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
88 echo
"libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
90 build
: build
/build-stamp
91 build-doc
: build
/build-doc-stamp
93 # Note that this is unconditionally done first as part of loading environment.mak
94 # The true is needed to force make to reload environment.mak after running
95 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
96 build
/environment.mak
: build
/configure-stamp
99 configure
: configure.in
100 build
/configure-stamp
: configure
103 cp COPYING debian
/copyright
104 ifneq ($(wildcard /usr
/share
/misc
/config.sub
),)
105 cp
-a
/usr
/share
/misc
/config.sub buildlib
/config.sub
106 echo Updating buildlib
/config.sub
108 ifneq ($(wildcard /usr
/share
/misc
/config.guess
),)
109 cp
-a
/usr
/share
/misc
/config.guess buildlib
/config.guess
110 echo Updating buildlib
/config.guess
112 cd build
&& ..
/configure
$(confflags
)
115 build
/build-stamp
: build
/configure-stamp
116 # Add here commands to compile the package.
120 build
/build-doc-stamp
: build
/configure-stamp
121 # Add here commands to compile the package.
133 # Add here commands to clean up after the build process.
134 dh_clean debian
/copyright debian
/shlibs.local debian
/shlibs.local.apt debian
/shlibs.local.apt-utils
136 binary-indep
: apt-doc libapt-pkg-doc
137 # Build architecture-independent files here.
138 libapt-pkg-doc
: build-doc debian
/shlibs.local
144 # libapt-pkg-doc install
146 dh_installdocs
-p
$@
$(BLD
)/docs
/cache
* $(BLD
)/docs
/design
* $(BLD
)/docs
/dpkg-tech
* \
147 $(BLD
)/docs
/files
* $(BLD
)/docs
/method
* \
148 doc
/libapt-pkg2_to_3.txt doc
/style.txt
150 -cp
-a debian
/libapt-pkg-doc.dhelp debian
/libapt-pkg-doc
/usr
/doc
/libapt-pkg-doc
/.dhelp
151 -cp
-a debian
/libapt-pkg-doc.dhelp debian
/libapt-pkg-doc
/usr
/share
/doc
/libapt-pkg-doc
/.dhelp
153 dh_installexamples
-p
$@
154 # dh_installmenu -p$@
155 # dh_installinit -p$@
156 # dh_installcron -p$@
157 # dh_installmanpages -p$@
159 # dh_undocumented -p$@
160 dh_installchangelogs
-p
$@
164 # dh_suidregister -p$@
166 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
)
178 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text
$(BLD
)/docs
/guide
*.html \
179 $(BLD
)/docs
/offline.text
$(BLD
)/docs
/offline.html
182 -cp
-a debian
/apt-doc.dhelp debian
/apt
/usr
/doc
/apt-doc
/.dhelp
183 -cp
-a debian
/apt-doc.dhelp debian
/apt
/usr
/share
/doc
/apt-doc
/.dhelp
185 dh_installchangelogs
-p
$@
195 # Build architecture-dependent files here.
197 binary-arch
: apt libapt-pkg-dev apt-utils
198 apt
: build debian
/shlibs.local
202 dh_installdirs
-p
$@
/usr
/share
206 cp
$(BLD
)/bin
/apt-
* debian
/apt
/usr
/bin
/
208 # Remove the bits that are in apt-utils
209 rm $(addprefix debian
/apt
/usr
/bin
/apt-
,$(APT_UTILS
))
211 # install the shared libs
212 find
$(BLD
)/bin
/ -type f
-name
"libapt-pkg*.so.*" -exec cp
-a
"{}" debian
/apt
/usr
/lib
/ \
;
213 find
$(BLD
)/bin
/ -type l
-name
"libapt-pkg*.so.*" -exec cp
-a
"{}" debian
/apt
/usr
/lib
/ \
;
215 cp
$(BLD
)/bin
/methods
/* debian
/apt
/usr
/lib
/apt
/methods
/
217 cp
$(BLD
)/scripts
/dselect
/* debian
/apt
/usr
/lib
/dpkg
/methods
/apt
/
218 cp
-r
$(BLD
)/locale debian
/apt
/usr
/share
/
220 # head -n 500 ChangeLog > debian/ChangeLog
222 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
223 dh_installmanpages
-p
$@ apt-ftparchive
.1 apt-sortpkgs
.1 apt-extracttemplates
.1
225 dh_installchangelogs
-p
$@
230 dh_shlibdeps
-papt
-l
`pwd`/debian
/apt
/usr
/lib
-- -Ldebian
/shlibs.local.apt
231 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
)
232 dh_makeshlibs
-m
$(LIBAPTPKG_MAJOR
) -V
'$(LIBAPTPKG_PROVIDE)' -papt
236 libapt-pkg-dev
: build debian
/shlibs.local
242 # libapt-pkg-dev install
244 cp
-a
$(BLD
)/bin
/libapt-pkg
*.so debian
/libapt-pkg-dev
/usr
/lib
/
245 cp
-a
$(BLD
)/bin
/libapt-inst
*.so debian
/libapt-pkg-dev
/usr
/lib
/
246 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
247 cp
$(BLD
)/include/apt-pkg
/*.h debian
/libapt-pkg-dev
/usr
/include/apt-pkg
/
250 # dh_installmenu -p$@
251 # dh_installinit -p$@
252 # dh_installcron -p$@
253 # dh_installmanpages -p$@
255 dh_installchangelogs
-p
$@
259 # dh_suidregister -p$@
261 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
) -Vlibapt-inst
:provides
=$(LIBAPTINST_PROVIDE
)
265 apt-utils
: build debian
/shlibs.local
271 # install the shared libs
272 find
$(BLD
)/bin
/ -type f
-name
"libapt-inst*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
273 find
$(BLD
)/bin
/ -type l
-name
"libapt-inst*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
275 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
278 # Install the man pages..
279 mkdir
-p debian
/$@
/usr
/share
/man
/man1
280 -cp doc
/apt-sortpkgs
.1 doc
/apt-ftparchive
.1 doc
/apt-extracttemplates
.1 debian
/$@
/usr
/share
/man
/man1
/
282 dh_installchangelogs
-p
$@
287 LD_LIBRARY_PATH
=$$LD_LIBRARY_PATH:`pwd`/debian
/apt
/usr
/lib
:`pwd`/debian
/$@
/usr
/lib dh_shlibdeps
-p
$@
-- -Ldebian
/shlibs.local.apt-utils
288 dh_gencontrol
-p
$@
-u
-Vlibapt-inst
:provides
=$(LIBAPTINST_PROVIDE
)
289 dh_makeshlibs
-m
$(LIBAPTINST_MAJOR
) -V
'$(LIBAPTINST_PROVIDE)' -p
$@
294 @echo
>&2 'source and diff are obsolete - use dpkg-source -b'; false
301 # Update from CVS and then configure for build
302 super-l33ch
: l33ch Makefile.in
307 l33ch-stamp
: super-l33ch
311 -find
-name Makefile.in
-print0 | xargs
-0r
rm -f
312 find
-name ChangeLog | xargs
rm -f
315 binary
: binary-indep binary-arch
316 .PHONY
: build
clean binary-indep binary-arch binary debian
/shlibs.local
319 # Done by the uploader.
321 #edit debian/changelog
322 # configure.in has the version automatically updated now.
324 # debian/rules cvs-build
327 rm -rf debian
/cvs-build
331 tar c
--exclude CVS
--exclude cvs-build . |\
332 (mkdir
-p debian
/cvs-build
/apt-
$(APT_DEBVER
);cd debian
/cvs-build
/apt-
$(APT_DEBVER
);tar x
)
333 (cd debian
/cvs-build
/apt-
$(APT_DEBVER
);$(DEB_BUILD_PROG
))
336 -mkdir
-p ..
/upload-
$(APT_DEBVER
)
337 cp
`find debian/cvs-build -maxdepth 1 -type f` ..
/upload-
$(APT_DEBVER
)