2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.19 1999/12/07 07:38:19 jgg Exp $
8 # For the deb builder, you can run 'debian/rules cvs-build', which does all
9 # steps nescessary to produce a proper source tarball with the CVS/ removed.
10 # It builds in debian/cvs-build/apt-<VER>/, and places files in
11 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
12 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 DEB_BUILD_PROG
:=debuild
-us
-uc
16 APT_DEBVER
=$(shell dpkg-parsechangelog |sed
-n
-e
'/^Version:/s/^Version: //p')
17 APT_CONFVER
=$(shell sed
-n
-e
's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in
)
19 # Determine the build directory to use
22 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
24 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
-m
) $(BASE
)/build
26 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
27 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
28 override BLD
:= $(BUILDX
)
30 ifneq ($(APT_DEBVER
),$(APT_CONFVER
))
33 sed
-e
's/$(APT_CONFVER)/$(APT_DEBVER)/' $@
> $@.
$$$$;mv
$@.
$$$$ $@
38 # Uncomment this to turn on verbose mode.
41 # Find the libapt-pkg major version for use in other control files
42 export LIBAPT_MAJOR
:=$(shell egrep
'^MAJOR=' apt-pkg
/makefile |cut
-d
'=' -f
2)
45 # echo "libapt-pkg $(LIBAPT_MAJOR) libapt-pkg$(LIBAPT_MAJOR)" >> $@
46 # echo "libapt-pkg $(LIBAPT_MAJOR) apt $(APT_DEBVER)" >> $@
49 build-stamp
: configure
52 (cd build
; ..
/configure
)
53 # cd build && CXXFLAGS="-g -Wall -D_POSIX_C_SOURCE=199309" ../configure --disable-nls --disable-static --prefix=/usr
54 # cd build && make all-hdr
57 # Add here commands to compile the package.
67 # Add here commands to clean up after the build process.
72 binary-indep
: libapt-pkg-doc
73 # Build architecture-independent files here.
74 libapt-pkg-doc
: build debian
/shlibs.local
80 # libapt-pkg-doc install
82 dh_installdocs
-p
$@
$(BLD
)/docs
/cache
* $(BLD
)/docs
/design
* $(BLD
)/docs
/dpkg-tech
* \
83 $(BLD
)/docs
/files
* $(BLD
)/docs
/method
*
85 -cp
-a debian
/libapt-pkg-doc.dhelp debian
/libapt-pkg-doc
/usr
/doc
/libapt-pkg-doc
/.dhelp
86 -cp
-a debian
/libapt-pkg-doc.dhelp debian
/libapt-pkg-doc
/usr
/share
/doc
/libapt-pkg-doc
/.dhelp
88 dh_installexamples
-p
$@
92 # dh_installmanpages -p$@
94 # dh_undocumented -p$@
95 dh_installchangelogs
-p
$@
99 # dh_suidregister -p$@
101 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:major
=${LIBAPT_MAJOR}
106 # Build architecture-dependent files here.
108 binary-arch
: apt libapt-pkg-dev
109 apt
: build debian
/shlibs.local
117 cp
$(BLD
)/bin
/apt-
* debian
/tmp
/usr
/bin
/
119 # install the shared libs
120 find
$(BLD
)/bin
/ -type f
-name
"libapt-pkg.so.*" -exec cp
-a
"{}" debian
/tmp
/usr
/lib
/ \
;
121 find
$(BLD
)/bin
/ -type l
-name
"libapt-pkg.so.*" -exec cp
-a
"{}" debian
/tmp
/usr
/lib
/ \
;
123 cp
$(BLD
)/bin
/methods
/* debian
/tmp
/usr
/lib
/apt
/methods
/
125 cp
$(BLD
)/scripts
/dselect
/* debian
/tmp
/usr
/lib
/dpkg
/methods
/apt
/
128 dh_installdocs
-p
$@
$(BLD
)/docs
/guide.text
$(BLD
)/docs
/guide.html \
129 $(BLD
)/docs
/offline.text
$(BLD
)/docs
/offline.html
132 -cp
-a debian
/dhelp debian
/tmp
/usr
/doc
/apt
/.dhelp
133 -cp
-a debian
/dhelp debian
/tmp
/usr
/share
/doc
/apt
/.dhelp
135 # head -n 500 ChangeLog > debian/ChangeLog
137 dh_installexamples
-papt
$(BLD
)/docs
/examples
/*
138 dh_installmanpages
-p
$@
140 dh_installchangelogs
-p
$@
145 LD_LIBRARY_PATH
=`pwd`/debian
/tmp
/usr
/lib dh_shlibdeps
-papt
146 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:major
=${LIBAPT_MAJOR}
147 dh_makeshlibs
-m
${LIBAPT_MAJOR} -Vlibapt-pkg
${LIBAPT_MAJOR} -papt
151 libapt-pkg-dev
: build debian
/shlibs.local
157 # libapt-pkg-dev install
159 cp
-a
$(BLD
)/bin
/libapt-pkg.so debian
/libapt-pkg-dev
/usr
/lib
/
160 #ln -s libapt-pkg.so.${LIBAPT_MAJOR} debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
161 cp
$(BLD
)/include/apt-pkg
/*.h debian
/libapt-pkg-dev
/usr
/include/apt-pkg
/
164 # dh_installmenu -papt
165 # dh_installinit -papt
166 # dh_installcron -papt
167 # dh_installmanpages -p$@
169 dh_installchangelogs
-p
$@
173 # dh_suidregister -p$@
175 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:major
=${LIBAPT_MAJOR}
180 @echo
>&2 'source and diff are obsolete - use dpkg-source -b'; false
187 # Update from CVS and then configure for build
188 super-l33ch
: l33ch Makefile.in
193 l33ch-stamp
: super-l33ch
197 -find
-name Makefile.in
-print0 | xargs
-0r
rm -f
198 find
-name ChangeLog | xargs
rm -f
201 binary
: binary-indep binary-arch
202 .PHONY
: build
clean binary-indep binary-arch binary debian
/shlibs.local
205 # Done by the uploader.
207 #edit debian/changelog
208 # configure.in has the version automatically updated now.
210 # debian/rules cvs-build
213 rm -rf debian
/cvs-build
218 tar c
--exclude CVS
--exclude debian
/cvs-build . |\
219 (mkdir
-p debian
/cvs-build
/apt-
$(APT_DEBVER
);cd debian
/cvs-build
/apt-
$(APT_DEBVER
);tar x
)
220 # The next line isn't needed, as debuild will make the .tar.gz for us.
221 # (cd debian/cvs-build;tar zcf apt_$(APT_DEBVER).tar.gz apt-$(APT_DEBVER))
222 (cd debian
/cvs-build
/apt-
$(APT_DEBVER
);$(DEB_BUILD_PROG
))
226 -mkdir
-p ..
/upload-
$(APT_DEBVER
)
227 cp
`find debian/cvs-build -maxdepth 1 -type f` ..
/upload-
$(APT_DEBVER
)