]> git.saurik.com Git - apt.git/blob - debian/rules
merge from the lp:~mvo/apt/mvo branch
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
8 export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
9
10 # FOR AUTOCONF 2.52 AND NEWER ONLY
11 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
12 confflags += --build $(DEB_HOST_GNU_TYPE)
13 else
14 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
15 endif
16
17 # See below
18 -include build/environment.mak
19
20 ifneq (,$(shell which dpkg-buildflags))
21 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
22 export LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
23 export CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
24 else
25 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
26 export CXXFLAGS = -O0 -g -Wall
27 else
28 export CXXFLAGS = -O2 -g -Wall
29 endif
30 endif
31
32 # Default rule
33 build:
34
35 PKG=apt
36 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
37
38 # Determine the build directory to use
39 BASE=.
40 ifdef BUILD
41 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
42 else
43 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
44 endif
45 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
46 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
47 override BLD := $(BUILDX)
48
49 ifeq ($(words $(BLD)),0)
50 override BLD := ./build
51 endif
52
53 # APT Programs in apt-utils
54 APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver
55
56 # Uncomment this to turn on verbose mode.
57 #export DH_VERBOSE=1
58
59 # Find the libapt-pkg major version for use in other control files
60 include buildlib/libversion.mak
61
62 # Determine which library package names to use
63 LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
64 LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
65
66 # do not fail as we are just experimenting with symbol files for now
67 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
68
69 build: build/build-stamp
70 build-doc: build/build-doc-stamp
71
72 # Note that this is unconditionally done first as part of loading environment.mak
73 # The true is needed to force make to reload environment.mak after running
74 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
75 build/environment.mak: build/configure-stamp
76 @true
77
78 configure: configure.in
79 build/configure-stamp: configure
80 dh_testdir
81 -mkdir build
82 cp COPYING debian/copyright
83 cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
84 touch $@
85
86 build/build-stamp: build/configure-stamp
87 # Add here commands to compile the package.
88 $(MAKE) binary
89 # compat symlink for the locale split
90 mkdir -p build/usr/share
91 cd build/usr/share && ln -f -s ../../locale .
92 # compile and run tests
93 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
94 $(MAKE) test
95 else
96 @echo "Tests DISABLED"
97 endif
98 touch $@
99
100 build/build-doc-stamp: build/configure-stamp
101 # Add here commands to compile the package.
102 $(MAKE) doc
103 touch $@
104
105 clean:
106 dh_testdir
107
108 [ ! -f Makefile ] || $(MAKE) clean distclean
109 rm -rf build
110 rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
111 debian/libapt-pkg-dev.install
112
113 debian/%.install: debian/%.install.in
114 sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
115
116 binary-indep: apt-doc libapt-pkg-doc
117 # Build architecture-independent files here.
118 libapt-pkg-doc: build-doc
119 dh_testdir -p$@
120 dh_testroot -p$@
121 dh_prep -p$@
122 dh_installdirs -p$@
123 #
124 # libapt-pkg-doc install
125 #
126 dh_installdocs -p$@ $(BLD)/docs/design* \
127 $(BLD)/docs/dpkg-tech* \
128 $(BLD)/docs/files* \
129 $(BLD)/docs/method* \
130 doc/libapt-pkg2_to_3.txt \
131 doc/style.txt \
132 $(BLD)/doc/doxygen/html
133 dh_installexamples -p$@
134
135 dh_installchangelogs -p$@
136 dh_strip -p$@
137 dh_compress -p$@
138 dh_fixperms -p$@
139 dh_installdeb -p$@
140 dh_gencontrol -p$@
141 dh_md5sums -p$@
142 dh_builddeb -p$@
143
144 apt-doc: build-doc
145 dh_testdir -p$@
146 dh_testroot -p$@
147 dh_prep -p$@
148 #
149 # apt-doc install
150 #
151 # Copy the guides
152 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
153 $(BLD)/docs/guide*.html \
154 $(BLD)/docs/offline*.text \
155 $(BLD)/docs/offline*.html
156 dh_installchangelogs -p$@
157 dh_compress -p$@
158 dh_fixperms -p$@
159 dh_installdeb -p$@
160 dh_gencontrol -p$@
161 dh_md5sums -p$@
162 dh_builddeb -p$@
163
164
165
166 # Build architecture-dependent files here.
167
168 binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
169 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
170 apt: build build-doc
171 dh_testdir -p$@
172 dh_testroot -p$@
173 dh_prep -p$@
174 dh_installdirs -p$@
175 #
176 # apt install
177 #
178 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
179
180 # make rosetta happy and remove pot files in po/ (but leave stuff
181 # in po/domains/* untouched) and cp *.po into each domain dir
182 rm -f build/po/*.pot
183 rm -f po/*.pot
184
185 dh_install -p$@ --sourcedir=$(BLD)
186
187 # Remove the bits that are in apt-utils
188 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver)
189
190 # https has its own package
191 rm debian/$@/usr/lib/apt/methods/https
192
193 # move the mirror failure script in place
194 #mv debian/$@/usr/bin/apt-report-mirror-failure \
195 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
196
197 dh_bugfiles -p$@
198 dh_lintian -p$@
199 dh_installexamples -p$@ $(BLD)/docs/examples/*
200 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
201 dh_installcron -p$@
202 dh_installdocs -p$@
203 dh_installchangelogs -p$@
204 dh_installlogrotate -p$@
205 dh_strip -p$@
206 dh_compress -p$@
207 dh_fixperms -p$@
208 dh_installdeb -p$@
209 dh_shlibdeps -p$@
210 dh_gencontrol -p$@
211 dh_md5sums -p$@
212 dh_builddeb -p$@
213
214 libapt-pkg-dev: build debian/libapt-pkg-dev.install
215 dh_testdir -p$@
216 dh_testroot -p$@
217 dh_prep -p$@
218 dh_installdirs -p$@
219 #
220 # libapt-pkg-dev install
221 #
222 dh_install -p$@ --sourcedir=$(BLD)
223 dh_installdocs -p$@
224 dh_installchangelogs -p$@
225 dh_strip -p$@
226 dh_compress -p$@
227 dh_fixperms -p$@
228 dh_installdeb -p$@
229 dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
230 dh_md5sums -p$@
231 dh_builddeb -p$@
232
233 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
234 apt-utils: build
235 dh_testdir -p$@
236 dh_testroot -p$@
237 dh_prep -p$@
238 dh_installdirs -p$@
239
240 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
241 cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
242
243 dh_install -p$@ --sourcedir=$(BLD)
244 dh_link -p$@
245 dh_installdocs -p$@
246 dh_installexamples -p$@
247
248 # Install the man pages..
249 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
250
251 dh_installchangelogs -p$@
252 dh_strip -p$@
253 dh_compress -p$@
254 dh_fixperms -p$@
255 dh_makeshlibs -p$@
256 dh_installdeb -p$@
257 dh_shlibdeps -p$@
258 dh_gencontrol -p$@
259 dh_md5sums -p$@
260 dh_builddeb -p$@
261
262 $(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
263 dh_testdir -p$@
264 dh_testroot -p$@
265 dh_prep -p$@
266 dh_installdirs -p$@
267
268 dh_install -p$@ --sourcedir=$(BLD)
269 dh_installdocs -p$@
270 dh_installchangelogs -p$@
271 dh_strip -p$@
272 dh_compress -p$@
273 dh_fixperms -p$@
274 dh_makeshlibs -p$@
275 dh_installdeb -p$@
276 dh_shlibdeps -p$@
277 dh_gencontrol -p$@
278 dh_md5sums -p$@
279 dh_builddeb -p$@
280
281 $(LIBAPT_INST): build debian/$(LIBAPT_INST).install
282 dh_testdir -p$@
283 dh_testroot -p$@
284 dh_prep -p$@
285 dh_installdirs -p$@
286
287 dh_install -p$@ --sourcedir=$(BLD)
288 dh_installdocs -p$@
289 dh_installchangelogs -p$@
290 dh_strip -p$@
291 dh_compress -p$@
292 dh_fixperms -p$@
293 dh_makeshlibs -p$@
294 dh_installdeb -p$@
295 dh_shlibdeps -p$@
296 dh_gencontrol -p$@
297 dh_md5sums -p$@
298 dh_builddeb -p$@
299
300 apt-transport-https: build libapt-pkg-dev
301 dh_testdir -p$@
302 dh_testroot -p$@
303 dh_prep -p$@
304 dh_installdirs -p$@
305
306 dh_install -p$@ --sourcedir=$(BLD)
307 dh_installdocs -p$@ debian/apt-transport-https.README
308 dh_installexamples -p$@
309
310 # Install the man pages..
311 dh_installman -p$@
312
313 dh_installchangelogs -p$@
314 dh_strip -p$@
315 dh_compress -p$@
316 dh_fixperms -p$@
317 dh_installdeb -p$@
318 dh_shlibdeps -p$@
319 dh_gencontrol -p$@
320 dh_md5sums -p$@
321 dh_builddeb -p$@
322
323 configure:
324 $(MAKE) configure
325
326 really-clean: clean
327 -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
328 find -name ChangeLog | xargs rm -f
329 rm -f l33ch-stamp
330
331 binary: binary-indep binary-arch
332 .PHONY: build clean binary-indep binary-arch binary