]> git.saurik.com Git - apt.git/blob - debian/changelog
Change frozen to testing everywhere.
[apt.git] / debian / changelog
1 apt (0.5.4.9) unstable; urgency=low
2
3 * New deb version compare function, that has no integer limits, and
4 supports pre-versions using ~. Code ported from dpkg.
5 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
6 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
7 * "apt-get --arch-only build-dep" to install only architecture-
8 dependent build dependencies. Bump minor shared lib number to reflect
9 small change in BuildDepend API.
10 * APT::Build-Essential configuration option (defaults to "build-essential")
11 so that "apt-get build-dep" will ensure build essential packages are
12 installed prior to installing other build-dependencies. Closes: #148879
13 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
14 * /usr/doc reference in postinst. Closes: #126189
15 * Doc updates. Closes: #120689
16 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
17 #131062, #136749
18 * Print special message for EAI_AGAIN. Closes: #131397
19 * libapt-pkg-dev needs to bring in the apt-inst library if linking
20 is to work. Closes: #133943
21 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
22 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
23 #139994, #142955, #151654, #151834, #147611, #154268, #173971
24 * Fix possibility for tag file parsing to fail in some unlikely situations.
25 Closes: #139328
26 * Use std C++ names for some header files. Closes: #128741
27 * Do not check for free space if --no-download. Closes: #117856
28 * Actually implement or group handling for 'upgrade'. Closes: #133950
29 * "Internal Error, Couldn't configure pre-depend" is not actually an
30 internal error, it is a packaging error and now it says so, and
31 pinpoints the problem dependency. Closes: #155621
32 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
33 * Use usr/share/doc for dhelp. Closes: #115701
34 * --print-uris works with 'update'. Closes: #57070
35 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
36 command line.
37 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
38 #142298
39 * Allow an uninstalled package to be marked for removal on an install
40 line (meaning not to automatically install it), also fix some dodgy
41 handling of protected packages. Closes: #92287, #116011
42 * Fix errant prefix matching in version selection. Closes: #105968
43 * Ensure that all files needed to run APT as a user are readable and
44 ignore roots umask for these files. Closes: #108801
45 * Support larger config spaces. Closes: #111914
46 * 'apt-get update' no longer does 'Building Dependency Tree'.
47 * When matching regexs allways print a message. Change regex activation
48 charset. Closes: #147817
49 * Don't die if lines in sources.list are too long. Closes: #146846
50 * Show file name on apt-extracttemplate error messges. Closes: #151835
51 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
52 * Some highly unlikely memory faults. Closes: #155842
53 * C++ stuff for G++3.2. Closes: #162617, #165515,
54 * apt-config dumps sends to stdout not stderr now. Closes: #146294
55 * Fix segfault in FindAny when /i is used, and there is no default.
56 Closes: #165891
57 * Add s390x to archtable. Closese: #160992.
58 * Update config.sub/config.guess in cvs, and add support to debian/rules
59 to update them from /usr/share/misc if they exist. Closes: #155014
60 * Remove 'Sorry' from messages. Closes: #148824.
61 * Change wording of 'additional disk space usage' message. Closes:
62 #135021.
63 * apt-extracttemplates now prepends the package name when extracting
64 files. Closes: #132776
65 * Add -n synonym for --names-only for apt-cache. Closes: #130689
66 * Display both current version and new version in apt-get -s. Closes:
67 #92358
68 * Add an options and timeout config item to ssh/rsh. Closes: #90654
69 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
70 * Change verbose logging output of apt-ftparchive to go to stderr,
71 instead of stdout. Also, errors that occur no longer go to stdout,
72 but stderr. Closes: #161592
73 * Test for timegm in configure. Closes: #165516.
74 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
75 support compliation on platforms where st_mtime is a macro. Closes:
76 #165518
77 * Check the currently mounted cdrom, to see if it's the one we are
78 interested in. Closes: #154602
79 * Refer to reportbug instead of bug in the man pages. Closes: #173745
80 * Link apt-inst to apt-pkg. Closes: #175055
81 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
82 and others.
83 * Fix > 300 col screen segfault. Closes: #176052
84 * Rebuild with gcc-3.2. Closes: #177752, #178008.
85 * Fix build-dep handling of | dependencies.
86 Closes: #98640, #145997, #158896, #172901
87 * Double default value of APT::Cache-Limit, until such time as it
88 can be made more dynamic. Closes: #178623.
89 * Report uris with '.gz' when there are errors. Closes: #178435.
90 * When installing build-deps, make sure the new version will
91 satisfy build requirements. Closes: #178121
92 * Split offline and guide documentation into apt-doc. This was done so
93 that binary-arch builds do not require documention deps. Note, that
94 apt-doc is not installed on upgrades.
95 * Use doc-base, instead of dhelp directly. Closes: #110389
96 * Change http message 'Waiting for file' to 'Waiting for headers'.
97 Closes: #178537
98 * Remove trailing lines on package lists in apt-get. Closes: #178736.
99 * Fix origin pins for file:// uris. Closes: #189014.
100 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
101 #155194
102 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
103 Closes: #153734.
104 * Fix some typos in the apt-get manual. Closes: #163932.
105 * Apply patch from bug, to change frozen to testing, and then do it
106 everywhere else. Closes: #165085.
107
108 -- Adam Heath <doogie@debian.org> Sun, 02 Feb 2003 02:54:45 -0600
109
110 apt (0.5.4) unstable; urgency=low
111
112 * M68k config.guess patch. Closes: #88913
113 * Bi-yearly test on OpenBSD and Solaris
114 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
115 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
116 #105606, #105377
117 * Various cosmetic code updates. Closes: #89066, #89066, #89152
118 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
119 update).
120 * More patches from Alfredo for Vendors and more SHA-1 stuff
121 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
122 similar situations. Closes: #56708, #59432
123 * no_proxy and ftp. Closes: #89671
124 * Philippe Batailler's man page patches.
125 * Fix for display bug. Closes: #92033, #93652, #98468
126 * Use more than 16bits for the dep ID. Some people ran out..
127 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
128 #106911, #107395, #108968
129 * Reordered some things to make dante and FTP happier. Closes: #92757
130 * James R. Van Zandt's guide.sgml updates. Closes: #90027
131 * apt-ftparchive copes with no uncompressed package files + contents.
132 * French man pages from philippe batailler - well sort of. They
133 don't build yet..
134 * run-parts. Closes: #94286
135 * 'apt-cache policy' preferences debug tool.
136 * Whatever. Closes: #89762
137 * libstdc++ and HURD. Closes: #92025
138 * More apt-utils verbage. Closes: #86954
139 * Fliped comparision operator. Closes: #94618
140 * Used the right copyright file. Closes: #65691
141 * Randolph's G++3 patches.
142 * Fixed no_proxy tokanizing. Closes: #100046
143 * Strip Config-Version when copying status to available. Closes: #97520
144 * Segfault with missing source files. Closes: #100325
145 * EINTR check. Closes: #102293
146 * Various changes to the locking metholodgy for --print-uris.
147 Closes: #100590
148 * Lame LD_LIBRARY_PATH thing. Closes: #98928
149 * apt-cache search searchs provide names too now. Closes: #98695
150 * Checksum and long lines problem. Closes: #106591
151 * .aptignr and empty files are just a warning. Closes: #97364
152
153 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
154
155 apt (0.5.3) unstable; urgency=low
156
157 * JoeyH's dpkg::preconfig not working. Closes: #88675
158 * Fixed apt override disparity
159 * Alfredo's SHA-1 and related patches
160
161 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
162
163 apt (0.5.2) unstable; urgency=low
164
165 * Fixed mention of /usr/doc in the long description
166 * JoeyH's downgrade bug -- don't use 0.5.1
167 * Doc bug. Closes: #88538
168 * Fault in building release strings. Closes: #88533
169
170 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
171
172 apt (0.5.1) unstable; urgency=low
173
174 * Fixed #82894 again, or should be and.
175 * Process the option string right. Closes: #86921
176 * Don't eat the last command for pipes. Closes: #86923
177 * Ignore .* for configuration directory processing. Closes: #86923
178 * Alfredo's no_proxy patch
179 * Documentation fixes. Closes: #87091
180 * JoeyH's double slash bug. Closes: #87266
181 * Unintitialized buffer and apt-ftparchive contents generation.
182 Closes: #87612
183 * Build-deps on virtual packages. Closes: #87639
184 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
185 libstdc++ version info in the library soname and in the package
186 provides. Closes: #87426
187 * Updated soname version to 0.3.2
188 * apt-extracttemplates moved from debconf into apt-utils
189 * s390 archtable entry. Closes: #88232
190 * Dan's segfault
191 * Some instances where the status file can source a package in a
192 non-sensical way. Closes: #87390
193 * Work better if there are duplicate sources.list entries.
194 * Fixed the resetting of Dir with "dir {};". Closes: #87323
195
196 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
197
198 apt (0.5.0) unstable; urgency=low
199
200 * Fixed an obscure bug with missing final double new lines in
201 package files
202 * Changed the apt-cdrom index copy routine to use the new section
203 rewriter
204 * Added a package file sorter, apt-sortpkgs
205 * Parse obsolete Optional dependencies.
206 * Added Ben's rsh method. Closes: #57794
207 * Added IPv6 FTP support and better DNS rotation support.
208 * Include the server IP in error messages when using a DNS rotation.
209 Closes: #64895
210 * Made most of the byte counters into doubles to prevent 32bit overflow.
211 Closes: #65349
212 * HTTP Authorization. Closes: #61158
213 * Ability to parse and return source index build depends from Randolph.
214 * new 'apt-get build-dep' command from Randolph. Closes: #63982
215 * Added apt-ftparchive the all dancing all singing FTP archive
216 maintinance program
217 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
218 in apt-get.
219 * Removed useless internal cruft including the xstatus file.
220 * Fixed config parser bugs. Closes: #67848, #71108
221 * Brain Damanged apt-get config options changed, does not change the command
222 line interface, except to allow --enable-* to undo a configuration
223 option:
224 No-Remove -> Remove
225 No-Download -> Download
226 No-Upgrade -> Upgrade
227 * Made this fix configable (DSelect::CheckDir) and default to disabled:
228 * No remove prompt if the archives dir has not changed. Closes: #55709
229 Because it is stupid in the case where no files were downloaded due to
230 a resumed-aborted install, or a full cache! Closes: #65952
231 * Obscure divide by zero problem. Closes: #64394
232 * Update sizetable for mips. Closes: #62288
233 * Fixed a bug with passive FTP connections
234 * Has sizetable entry for sparc64. Closes: #64869
235 * Escape special characters in the ::Label section of the cdroms.lst
236 * Created apt-utils and python-apt packages
237 * Due to the new policy engine, the available file may contain entries
238 from the status file. These are generated if the package is not obsolete
239 but the policy engine prohibits using the version from the package files.
240 They can be identified by the lack of a Filename field.
241 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
242 #36223, #33468, #22551
243 * Fixed deb-src line for non-us. Closes: #71501, #71601
244 * Fixes for G++ 2.96, s/friend/friend class/
245 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
246 * Confirmed fix for missing new line problem. Closes: #69386
247 * Fixed up dhelp files. Closes: #71312
248 * Added some notes about dselect and offline usage. Closes: #66473, #38316
249 * Lock files on read only file systems are ignored w/ warning.
250 Closes: #61701
251 * apt-get update foo now gives an error! Closes: #42891
252 * Added test for shlibs on hurd. Closes: #71499
253 * Clarified apt-cache document. Closes: #71934
254 * DocBook SGML man pages and some improvements in the text..
255 * sigwinch thing. Closes: #72382
256 * Caching can be turned off by setting the cache file names blank.
257 * Ignores arches it does not know about when autocleaning. Closes: #72862
258 * New function in apt-config to return dirs, files, bools and integers.
259 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
260 complex cases involving OR groups and provides.
261 68754 describes confusing messages which are the result of this..
262 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
263 * Speeling mistake and return code for the 'wicked' resolver error
264 Closes: #72621, #75226, #77464
265 * Solved unable to upgrade libc6 from potato to woody due to 3 package
266 libc6 dependency loop problem.
267 * Leading sources.list spaces. Closes: #76010
268 * Removed a possible infinite loop while processing installations.
269 * Man page updates. Closes: #75411, #75560, #64292, #78469
270 * ReduceSourceList bug. Closes: #76027
271 * --only-source option. Closes: #76320
272 * Typos. Closes: #77812, #77999
273 * Different status messages. Closes: #76652, #78353
274 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
275 * OS detection an support for the new pseduo standard of os-arch for the
276 Architecture string. Also uses regexing.. Closes: #39227, #72349
277 * Various i18n stuff. Note that this still needs some i18n wizard
278 to do the last gettextization right. Closes: #62386
279 * Fixed a problem with some odd http servers/proxies that did not return
280 the content size in the header. Closes: #79878, #44379
281 * Little acquire bugs. Closes: #77029, #55820
282 * _POSIX_THREADS may not be defined to anything, just defined..
283 Closes: #78996
284 * Spelling of Ignore-Hold correctly. Closes: #78042
285 * Unlock the dpkg db if in download only mode. Closes: #84851
286 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
287 * Patch from BenC. Closes: #80810
288 * Single output of some names in lists. Closes: #80498, #43286
289 * Nice message for people who can't read syserror output. Closes: #84734
290 * OR search function. Closes: #82894
291 * User's guide updates. Closes: #82469
292 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
293 * Various CD bugs, again thanks to Greenbush
294 Closes: #80946, #76547, #71810, #70049, #69482
295 * Using potato debhelper. Closes: #57977
296 * I cannot self-terminate. Closes: #74928
297
298 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
299
300 apt (0.3.19) frozen unstable; urgency=low
301
302 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
303 Paul Wade.
304 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
305 * Fixed hardcoded path. Closes: #59743
306 * Fixed Jay's relative path bug
307 * Allowed source only CDs. Closes: #58952
308 * Space check is supressed if --print-uris is given. Closes: #58965
309 * Clarified the documenation examples for non-us. Closes: #58646
310 * Typo in the package description. Closes: #60230
311 * Man Page typo. Closes: #60347
312 * Typo in Algorithms.cc. Closes: #63577
313 * Evil dotty function in apt-cache for generating dependency graphs
314 with the as-yet-unpackaged GraphVis.
315 * Appears to have been fixed in Janurary.. Closes: #57981
316 * New config.guess/sub for the new archs. Closes: #60874
317 * Fixed error reporting for certain kinds of resolution failures.
318 Closes: #61327
319 * Made autoclean respect 'q' settings. Closes: #63023
320 * Fixed up the example sources.list. Closes: #63676
321 * Added DPkg::FlushSTDIN to control the flushing of stdin before
322 forking dpkg. Closes: #63991
323
324 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
325
326 apt (0.3.18) frozen unstable; urgency=low
327
328 * Changes in the postinst script. Closes: #56855, #57237
329 * Fixed bashism. Closes: #57216, #57335
330 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
331
332 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
333
334 apt (0.3.17) unstable; urgency=low
335
336 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
337 * Fixed the configuration parser to not blow up if ; is in the config
338 string
339 * Applied visual patch to dselect install script . Closes #55214
340 * Included the configure-index example
341 * Minimal CD swaps
342 * Library soname has increased
343 * Fixed default sources.list to have correct URLs for potato when it
344 becomes stable
345 * Added a message about erasing sources.list to dselect setup script
346 Closes: #55755
347 * No remove prompt if the archives dir has not changed. Closes: #55709
348 * Fixed inclusion of 2nd sample config file. Closes: #55374
349 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
350 Closes: #55991
351
352 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
353
354 apt (0.3.16) unstable; urgency=low
355
356 * Made --no-download work. Closes: #52993
357 * Now compiles on OpenBSD, Solaris and HP-UX
358 * Clarify segfault errors
359 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
360 * Fix for Joel's discovery of glibc removal behavoir.
361 * Fix for Ben Collins file: uri from slink upgrade.
362 * Fixed resume code in FTP. Closes: #54323
363 * Take more precautions to prevent the corruption Joey Hess saw.
364 * Fixed --no-list-cleanup
365 * RFC 2732 URI parsing ([] for hostnames).
366 * Typo in apt-cache man page. Closes: #54949
367
368 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
369
370 apt (0.3.15) unstable; urgency=low
371
372 * Added DSelect::WaitAfterDownload Closes: #49549
373 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
374 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
375 * Made -s and clean not do anything. Closes: #50238
376 * Problem with Protected packages and the new OR code.
377 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
378 * Remove doesn't require a package to be installable. Closes: #51175
379 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
380
381 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
382
383 apt (0.3.14) unstable; urgency=low
384
385 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
386 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
387 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
388 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
389 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
390 Closes: #45034, #45695, #46537
391 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
392 * Added APT::Clean-Installed option. Closes: #45973
393 * Moves the free space check to after the calculated size is printed.
394 Closes: #46639, #47498
395 * mipsel arch Closes: #47614
396 * Beautified URI printing to not include passwords Closes: #46857
397 * Fixed little problem with --no-download Closes: #47557
398 * Tweaked Dselect 'update' script to re-gen the avail file even in the
399 event of a failure Closes: #47112
400 * Retries for source archives too Closes: #47529
401 * Unmounts CDROMs iff it mounted them Closes: #45299
402 * Checks for the partial directories before doing downloads Closes: #47392
403 * no_proxy environment variable (http only!) Closes: #43476
404 * apt-cache showsrc Closes: #45799
405 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
406 * Regexs for install. Closes: #35304, #38835
407 * Dependency reports now show OR group relations
408 * Re-Install feature. Cloes: #46961, #37393, #38919
409 * Locks archive directory on clean (woops)
410 * Remove is not 'sticky'. Closes: #48392
411 * Slightly more accurate 'can not find package' message. Closes: #48311
412 * --trivial-only and --no-remove. Closes: #48518
413 * Increased the cache size. Closes: #47648
414 * Comment woopsie. Closes: #48789
415 * Removes existing links when linking sources. Closes: #48775
416 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
417 * Clearer usage message about 'source' Closes: #48858
418 * Immediate configure internal error Closes: #49062, #48884
419
420 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
421
422 apt (0.3.13) unstable; urgency=low
423
424 * Fix timestamp miss in FTP. Closes: #44363
425 * Fix sorting of Kept packages. Closes: #44377
426 * Fix Segfault for dselect-upgrade. Closes: #44436
427 * Fix handling of '/' for the dist name. Closes #43830
428 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
429 * Add commented-out deb-src URI to default sources.list file.
430
431 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
432
433 apt (0.3.12) unstable; urgency=low
434
435 * Fix for typo in the dhelp index. Closes: #40377
436 * Multiple media swap support
437 * Purge support. Closes: #33291, #40694
438 * Better handling of - remove notation. Closes: #41024
439 * Purge support. Closes: #33291, #40694
440 * Error code on failed update. Closes: #41053
441 * apt-cdrom adds entries for source directories. Closes: #41231
442 * Sorts the output of any list. Closes: #41107
443 * Fixes the looping problem. Closes: #41784, #42414, #44022
444 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
445 * More checks to keep the display sane. Particularly when fail-over is
446 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
447 * PThread lockup problem on certain sparc/m68k. Closes: #40628
448 * apt-cdrom understands .gz Package files too. Closes: #42779
449 * Spelling error in dselect method description. Closes: #43251
450 * Added security to the default source list. Closes: #43356
451
452 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
453
454 apt (0.3.11) unstable; urgency=low
455
456 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
457 * Fix for properly upgrading the system from perl 5.004 to 5.005
458
459 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
460
461 apt (0.3.9) unstable; urgency=low
462
463 * Spelling error in cachefile.cc. Closes: #39885
464 * Trailing slash in dselect install if you try to use the
465 default config file. Closes: #40011
466 * Simulate works for autoclean. Closes: #39141
467 * Fixed spelling errors. Closes: #39673
468 * Changed url parsing a bit. Closes: #40070, #40069
469 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
470
471 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
472
473 apt (0.3.7) unstable; urgency=low
474
475 * Fixed missing text in the apt-get(8) page. Closes: #37596
476 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
477 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
478 * Fixed handling of the -q option with not-entirely integer arguments
479 Closes: #37499
480 * Man page typo Closes: #37762
481 * Fixed parsing of the Source: line. Closes: #37679
482 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
483 * Added a check for an empty cache directory. Closes: #37963
484 * Return a failure code if -d is given and packages fail to download.
485 Closes: #38127
486 * Arranged for an ftp proxy specifing an http server to work. See the
487 important note in the sources.list man page.
488 * Accounted for resumed files in the cps calculation. Closes: #36787
489 * Deal with duplicate same version different packages. Closes: #30237
490 * Added --no-download. Closes: #38095
491 * Order of apt-cdrom dist detection. Closes: #38139
492 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
493 * IPv6 http support
494 * Suggests dpkg-dev for apt-get source. Closes: #38158
495 * Fixed typo in apt-get help. Closes: #38712
496 * Improved the error message in the case of broken held package. Closes: #38777
497 * Fixed handling of MD5 failures
498 * Documented list notation Closes: #39008
499 * Change the 'b' to 'B'. Closes: #39007
500
501 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
502
503 apt (0.3.6) unstable; urgency=low
504
505 * Note that 0.3.5 never made it out the door..
506 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
507 * Made APT print numbers in decimal. Closes: #35617, #37319
508 * Buffer munching fix for FTP. Closes: #35868
509 * Typo in sample config file. Closes: #35907
510 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
511 * Changed installed size counter to only count unpacked packages.
512 Closes: #36201
513 * apt-get source support. Closes: #23934, #27190
514 * Renames .debs that fail MD5 checking, provides automatic corruption
515 recovery. Closes: #35931
516 * Fixed autoconf verison. Closes: #37305
517 * Random Segfaulting. Closes: #37312, #37530
518 * Fixed apt-cache man page. Closes: #36904
519 * Added a newline to apt-cache showpkg. Closes: #36903
520
521 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
522
523 apt (0.3.4) unstable; urgency=low
524
525 * Release for Ben while he is out of town.
526 * Checked the size of partial files. Closes: #33705
527 * apt-get should not print progress on non-tty. Closes: #34944
528 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
529 * Applied cdrom patches from Torsten. Closes: #35140, #35141
530 * smbmounted cdrom fix. Closes: #35470
531 * Changed ie to eg. Closes: #35196
532
533 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
534
535 apt (0.3.3) unstable; urgency=low
536
537 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
538
539 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
540
541 apt (0.3.2) unstable; urgency=low
542
543 * Major release into unstable of v3
544 * These bugs have been fixed, explanations are in the bug system, read
545 the man pages as well..
546 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
547 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
548 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
549 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
550 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
551 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
552 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
553 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
554
555 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
556
557 apt (0.3.1) experimental; urgency=low
558
559 * Minor release of cvs version.
560 * Added virtual package libapt-pkgx.x
561
562 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
563
564 apt (0.3.0) experimental; urgency=low
565
566 * New experimental version.
567
568 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
569
570 apt (0.1.9) frozen unstable; urgency=low
571
572 * Return to the wacky numbering for when we build 0.1.8 for hamm
573 * Important bug related to APT on the Alpha fixed
574 * apt-get dist-upgrade problems fixed
575 * tiny patch for http method to fix an endless loop
576 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
577 libtool and add proper shared lib dependancies
578 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
579 in case an old libpkg is installed while building APT to prevent
580 spurious dependancies
581
582 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
583
584 apt (0.1.7) unstable; urgency=low
585
586 * New build with libstdc++2.9.
587 * Various fixes; read the Changelog.
588
589 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
590
591 apt (0.1.6) unstable; urgency=low
592
593 * Various fixes in the FTP method for error checking. Fixes: #26188.
594 * Spelling corrections in dselect method. Fixes: #25884
595 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
596 * No more bo releases: we're using a normal numbering system now.
597
598 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
599
600 apt (0.1.5) unstable; urgency=low
601
602 * Changed sources.list to point to 'unstable' by default, as
603 'frozen' no longer exists!
604
605 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
606
607 apt (0.1.3) unstable; urgency=low
608
609 * New upstreamish version.
610 * ftp method rewritten in C. Removes dependancies on all perl/perl
611 related modules. This fixes many of the ftp method bugs.
612
613 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
614
615 apt (0.1.1) unstable; urgency=low
616
617 * Release for unstable.
618
619 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
620
621 apt (0.1) unstable; urgency=low
622
623 * Kludge to fix problem in libnet-perl with illegal anonymous
624 FTP passwords.
625 * Moved to unstable; apt is in a useable state now.
626 * Fixed version numbering. From now on, numbering will be:
627 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
628 0.1.1 (release for unstable). Thanks, Manoj.
629
630 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
631
632 apt (0.0.17-1) experimental; urgency=low
633
634 * Fixed problem with libc6 version compare
635 * Scott's away for a while, so I'll be packaging apt for the time
636 being.
637
638 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
639
640 apt (0.0.16-1) experimental; urgency=low
641
642 * Modifications to make apt-get more friendly when backgrounded.
643 * Updated documentation.
644 * Updates to graphic widgets
645
646 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
647
648 apt (0.0.15-0.2bo) experimental; urgency=low
649
650 * Bo compilation
651 * Bob Hilliards crash
652
653 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
654
655 apt (0.0.15-0.1bo) experimental; urgency=low
656
657 * Bo compilation
658 * libstdc++272 patch
659
660 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
661
662 apt (0.0.15) experimental; urgency=low
663
664 * Clean up source tarball (no user-visible changes)
665
666 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
667
668 apt (0.0.14) experimental; urgency=low
669
670 * Updates in ordering code to make sure certain upgrades work correctly.
671 * Made dselect/setup understand ftp as well as http
672
673 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
674
675 apt (0.0.13-bo1) experimental; urgency=low
676
677 * Bo compilation
678
679 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
680
681 apt (0.0.13) experimental; urgency=low
682
683 * Remove hardcoded egcc from debian/rules (#21575)
684 * Fixes for ordering logic when system has a number of unpacked
685 but unconfigured packages installed.
686 * Spelling fix in dselect install method (#22556)
687
688 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
689
690 apt (0.0.12) experimental; urgency=low
691
692 * Fixed problems with package cache corruption.
693 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
694 earlier versions.
695 * Interface and documentation improvements.
696
697 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
698
699 apt (0.0.11) experimental; urgency=low
700
701 * Change dependancies to pre-depends since breaking your packaging tools
702 in the middle of an installation isn't very good.
703 * Bug fixes to ftp method and general apt-get code
704
705 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
706
707 apt (0.0.10) experimental; urgency=low
708
709 * Run "dpkg --configure -a" after an aborted dselect install
710 * Fixed problem with install looping
711 * Support for authenticating proxys: (note this isn't terribly secure)
712 http_proxy="http://user:pass@firewall:port/"
713 * Substitute $ARCH in sources.list
714 * Fixes in the resumption code for ftp
715
716 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
717
718 apt (0.0.9) experimental; urgency=low
719
720 * Added ftp support.
721 * Various other less visible bug fixes.
722 * Fixed problem with segfault when apt-get invoked in a non-existant
723 directory (Bug #21863)
724 * Bumped policy to 2.4.1
725
726 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
727
728 apt (0.0.8) experimental; urgency=low
729
730 * Fixed generated available file (Bug #21836)
731 * Added download ETA (Bug #21774).
732 * Fixed hardcoded ARCH (Bug #21751).
733 * Fixed check on http_proxy (Bug #21795).
734 * Added download speed indicator.
735
736 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
737
738 apt (0.0.7) experimental; urgency=low
739
740 * Remove libdeity and apt from package for now, since only apt-get and
741 apt-cache are actually useful right now.
742 * Clean up handling of package installation errors.
743 * Added timeout to http transfers (#21269)
744 * Updated setup for dselect/apt method.
745 * Updated man pages
746 * Long options (added in 0.0.6)
747
748 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
749
750 apt (0.0.6) experimental; urgency=low
751
752 * Spelling changes.
753 * Revamped download status display.
754 * Call apt-get clean after successful install in dselect.
755 * Added "apt-get clean" which deletes package files from /var/cache/apt
756
757 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
758
759 apt (0.0.5) experimental; urgency=low
760
761 * Ignore signals while dpkg is running so we don't leave dpkg running in
762 the background (#20804)
763 * Check Packages as well as Packages.gz for file URIs (#20784)
764 * Spelling cleanup (#20800)
765 * Added -m option to permit upgrade to go on in the case of a bad mirror.
766 This option may result in incomplete upgrades when used with -f.
767
768 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
769
770 apt (0.0.4) experimental; urgency=low
771
772 * New usage guide.
773 * Various documentation updates and cleanup.
774 * Added '-f' option to apt-get attempt to fix broken dependancies.
775
776 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
777
778 apt (0.0.3) experimental; urgency=low
779
780 * Added a shlibs.local file to prevent apt from depending on itself.
781 * Updates to how apt-get handles bad states in installed packages.
782 * Updated rules to make sure build works from a freshly checked out source
783 archive. Building from CVS needs libtool/automake/autoconf, builds from
784 the distributed source package should have no such dependancy.
785
786 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
787
788 apt (0.0.2) unstable; urgency=low
789
790 * Updates to apt-get and http binding for dselect method (apt).
791 * Updating version number from 0.0.1, which was released only on IRC.
792
793 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
794
795 apt (0.0.1) unstable; urgency=low
796
797 * Initial Release.
798
799 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500
800