1 apt (0.5.5) unstable; urgency=low
3 * New deb version compare function, that has no integer limits, and
4 supports pre-versions using ~. Code ported from dpkg.
5 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
6 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
7 * "apt-get --arch-only build-dep" to install only architecture-
8 dependent build dependencies. Bump minor shared lib number to reflect
9 small change in BuildDepend API.
10 * APT::Build-Essential configuration option (defaults to "build-essential")
11 so that "apt-get build-dep" will ensure build essential packages are
12 installed prior to installing other build-dependencies. Closes: #148879
13 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
14 * /usr/doc reference in postinst. Closes: #126189
15 * Doc updates. Closes: #120689
16 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
18 * Print special message for EAI_AGAIN. Closes: #131397
19 * libapt-pkg-dev needs to bring in the apt-inst library if linking
20 is to work. Closes: #133943
21 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
22 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
23 #139994, #142955, #151654, #151834, #147611, #154268, #173971
24 * Fix possibility for tag file parsing to fail in some unlikely situations.
26 * Use std C++ names for some header files. Closes: #128741
27 * Do not check for free space if --no-download. Closes: #117856
28 * Actually implement or group handling for 'upgrade'. Closes: #133950
29 * "Internal Error, Couldn't configure pre-depend" is not actually an
30 internal error, it is a packaging error and now it says so, and
31 pinpoints the problem dependency. Closes: #155621
32 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
33 * Use usr/share/doc for dhelp. Closes: #115701
34 * --print-uris works with 'update'. Closes: #57070
35 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
37 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
39 * Allow an uninstalled package to be marked for removal on an install
40 line (meaning not to automatically install it), also fix some dodgy
41 handling of protected packages. Closes: #92287, #116011
42 * Fix errant prefix matching in version selection. Closes: #105968
43 * Ensure that all files needed to run APT as a user are readable and
44 ignore roots umask for these files. Closes: #108801
45 * Support larger config spaces. Closes: #111914
46 * 'apt-get update' no longer does 'Building Dependency Tree'.
47 * When matching regexs allways print a message. Change regex activation
48 charset. Closes: #147817
49 * Don't die if lines in sources.list are too long. Closes: #146846
50 * Show file name on apt-extracttemplate error messges. Closes: #151835
51 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
52 * Some highly unlikely memory faults. Closes: #155842
53 * C++ stuff for G++3.2. Closes: #162617, #165515,
54 * apt-config dumps sends to stdout not stderr now. Closes: #146294
55 * Fix segfault in FindAny when /i is used, and there is no default.
57 * Add s390x to archtable. Closese: #160992.
58 * Update config.sub/config.guess in cvs, and add support to debian/rules
59 to update them from /usr/share/misc if they exist. Closes: #155014
60 * Remove 'Sorry' from messages. Closes: #148824.
61 * Change wording of 'additional disk space usage' message. Closes:
63 * apt-extracttemplates now prepends the package name when extracting
64 files. Closes: #132776
65 * Add -n synonym for --names-only for apt-cache. Closes: #130689
66 * Display both current version and new version in apt-get -s. Closes:
68 * Add an options and timeout config item to ssh/rsh. Closes: #90654
69 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
70 * Change verbose logging output of apt-ftparchive to go to stderr,
71 instead of stdout. Also, errors that occur no longer go to stdout,
72 but stderr. Closes: #161592
73 * Test for timegm in configure. Closes: #165516.
74 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
75 support compliation on platforms where st_mtime is a macro. Closes:
77 * Check the currently mounted cdrom, to see if it's the one we are
78 interested in. Closes: #154602
79 * Refer to reportbug instead of bug in the man pages. Closes: #173745
80 * Link apt-inst to apt-pkg. Closes: #175055
81 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
83 * Fix > 300 col screen segfault. Closes: #176052
84 * Rebuild with gcc-3.2. Closes: #177752, #178008.
85 * Fix build-dep handling of | dependencies.
86 Closes: #98640, #145997, #158896, #172901
87 * Double default value of APT::Cache-Limit, until such time as it
88 can be made more dynamic. Closes: #178623.
89 * Report uris with '.gz' when there are errors. Closes: #178435.
90 * When installing build-deps, make sure the new version will
91 satisfy build requirements. Closes: #178121
93 -- Jason Gunthorpe <jgg@debian.org> Sun, 15 Sep 2002 17:16:59 -0600
95 apt (0.5.4) unstable; urgency=low
97 * M68k config.guess patch. Closes: #88913
98 * Bi-yearly test on OpenBSD and Solaris
99 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
100 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
102 * Various cosmetic code updates. Closes: #89066, #89066, #89152
103 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
105 * More patches from Alfredo for Vendors and more SHA-1 stuff
106 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
107 similar situations. Closes: #56708, #59432
108 * no_proxy and ftp. Closes: #89671
109 * Philippe Batailler's man page patches.
110 * Fix for display bug. Closes: #92033, #93652, #98468
111 * Use more than 16bits for the dep ID. Some people ran out..
112 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
113 #106911, #107395, #108968
114 * Reordered some things to make dante and FTP happier. Closes: #92757
115 * James R. Van Zandt's guide.sgml updates. Closes: #90027
116 * apt-ftparchive copes with no uncompressed package files + contents.
117 * French man pages from philippe batailler - well sort of. They
119 * run-parts. Closes: #94286
120 * 'apt-cache policy' preferences debug tool.
121 * Whatever. Closes: #89762
122 * libstdc++ and HURD. Closes: #92025
123 * More apt-utils verbage. Closes: #86954
124 * Fliped comparision operator. Closes: #94618
125 * Used the right copyright file. Closes: #65691
126 * Randolph's G++3 patches.
127 * Fixed no_proxy tokanizing. Closes: #100046
128 * Strip Config-Version when copying status to available. Closes: #97520
129 * Segfault with missing source files. Closes: #100325
130 * EINTR check. Closes: #102293
131 * Various changes to the locking metholodgy for --print-uris.
133 * Lame LD_LIBRARY_PATH thing. Closes: #98928
134 * apt-cache search searchs provide names too now. Closes: #98695
135 * Checksum and long lines problem. Closes: #106591
136 * .aptignr and empty files are just a warning. Closes: #97364
138 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
140 apt (0.5.3) unstable; urgency=low
142 * JoeyH's dpkg::preconfig not working. Closes: #88675
143 * Fixed apt override disparity
144 * Alfredo's SHA-1 and related patches
146 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
148 apt (0.5.2) unstable; urgency=low
150 * Fixed mention of /usr/doc in the long description
151 * JoeyH's downgrade bug -- don't use 0.5.1
152 * Doc bug. Closes: #88538
153 * Fault in building release strings. Closes: #88533
155 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
157 apt (0.5.1) unstable; urgency=low
159 * Fixed #82894 again, or should be and.
160 * Process the option string right. Closes: #86921
161 * Don't eat the last command for pipes. Closes: #86923
162 * Ignore .* for configuration directory processing. Closes: #86923
163 * Alfredo's no_proxy patch
164 * Documentation fixes. Closes: #87091
165 * JoeyH's double slash bug. Closes: #87266
166 * Unintitialized buffer and apt-ftparchive contents generation.
168 * Build-deps on virtual packages. Closes: #87639
169 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
170 libstdc++ version info in the library soname and in the package
171 provides. Closes: #87426
172 * Updated soname version to 0.3.2
173 * apt-extracttemplates moved from debconf into apt-utils
174 * s390 archtable entry. Closes: #88232
176 * Some instances where the status file can source a package in a
177 non-sensical way. Closes: #87390
178 * Work better if there are duplicate sources.list entries.
179 * Fixed the resetting of Dir with "dir {};". Closes: #87323
181 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
183 apt (0.5.0) unstable; urgency=low
185 * Fixed an obscure bug with missing final double new lines in
187 * Changed the apt-cdrom index copy routine to use the new section
189 * Added a package file sorter, apt-sortpkgs
190 * Parse obsolete Optional dependencies.
191 * Added Ben's rsh method. Closes: #57794
192 * Added IPv6 FTP support and better DNS rotation support.
193 * Include the server IP in error messages when using a DNS rotation.
195 * Made most of the byte counters into doubles to prevent 32bit overflow.
197 * HTTP Authorization. Closes: #61158
198 * Ability to parse and return source index build depends from Randolph.
199 * new 'apt-get build-dep' command from Randolph. Closes: #63982
200 * Added apt-ftparchive the all dancing all singing FTP archive
202 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
204 * Removed useless internal cruft including the xstatus file.
205 * Fixed config parser bugs. Closes: #67848, #71108
206 * Brain Damanged apt-get config options changed, does not change the command
207 line interface, except to allow --enable-* to undo a configuration
210 No-Download -> Download
211 No-Upgrade -> Upgrade
212 * Made this fix configable (DSelect::CheckDir) and default to disabled:
213 * No remove prompt if the archives dir has not changed. Closes: #55709
214 Because it is stupid in the case where no files were downloaded due to
215 a resumed-aborted install, or a full cache! Closes: #65952
216 * Obscure divide by zero problem. Closes: #64394
217 * Update sizetable for mips. Closes: #62288
218 * Fixed a bug with passive FTP connections
219 * Has sizetable entry for sparc64. Closes: #64869
220 * Escape special characters in the ::Label section of the cdroms.lst
221 * Created apt-utils and python-apt packages
222 * Due to the new policy engine, the available file may contain entries
223 from the status file. These are generated if the package is not obsolete
224 but the policy engine prohibits using the version from the package files.
225 They can be identified by the lack of a Filename field.
226 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
227 #36223, #33468, #22551
228 * Fixed deb-src line for non-us. Closes: #71501, #71601
229 * Fixes for G++ 2.96, s/friend/friend class/
230 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
231 * Confirmed fix for missing new line problem. Closes: #69386
232 * Fixed up dhelp files. Closes: #71312
233 * Added some notes about dselect and offline usage. Closes: #66473, #38316
234 * Lock files on read only file systems are ignored w/ warning.
236 * apt-get update foo now gives an error! Closes: #42891
237 * Added test for shlibs on hurd. Closes: #71499
238 * Clarified apt-cache document. Closes: #71934
239 * DocBook SGML man pages and some improvements in the text..
240 * sigwinch thing. Closes: #72382
241 * Caching can be turned off by setting the cache file names blank.
242 * Ignores arches it does not know about when autocleaning. Closes: #72862
243 * New function in apt-config to return dirs, files, bools and integers.
244 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
245 complex cases involving OR groups and provides.
246 68754 describes confusing messages which are the result of this..
247 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
248 * Speeling mistake and return code for the 'wicked' resolver error
249 Closes: #72621, #75226, #77464
250 * Solved unable to upgrade libc6 from potato to woody due to 3 package
251 libc6 dependency loop problem.
252 * Leading sources.list spaces. Closes: #76010
253 * Removed a possible infinite loop while processing installations.
254 * Man page updates. Closes: #75411, #75560, #64292, #78469
255 * ReduceSourceList bug. Closes: #76027
256 * --only-source option. Closes: #76320
257 * Typos. Closes: #77812, #77999
258 * Different status messages. Closes: #76652, #78353
259 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
260 * OS detection an support for the new pseduo standard of os-arch for the
261 Architecture string. Also uses regexing.. Closes: #39227, #72349
262 * Various i18n stuff. Note that this still needs some i18n wizard
263 to do the last gettextization right. Closes: #62386
264 * Fixed a problem with some odd http servers/proxies that did not return
265 the content size in the header. Closes: #79878, #44379
266 * Little acquire bugs. Closes: #77029, #55820
267 * _POSIX_THREADS may not be defined to anything, just defined..
269 * Spelling of Ignore-Hold correctly. Closes: #78042
270 * Unlock the dpkg db if in download only mode. Closes: #84851
271 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
272 * Patch from BenC. Closes: #80810
273 * Single output of some names in lists. Closes: #80498, #43286
274 * Nice message for people who can't read syserror output. Closes: #84734
275 * OR search function. Closes: #82894
276 * User's guide updates. Closes: #82469
277 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
278 * Various CD bugs, again thanks to Greenbush
279 Closes: #80946, #76547, #71810, #70049, #69482
280 * Using potato debhelper. Closes: #57977
281 * I cannot self-terminate. Closes: #74928
283 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
285 apt (0.3.19) frozen unstable; urgency=low
287 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
289 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
290 * Fixed hardcoded path. Closes: #59743
291 * Fixed Jay's relative path bug
292 * Allowed source only CDs. Closes: #58952
293 * Space check is supressed if --print-uris is given. Closes: #58965
294 * Clarified the documenation examples for non-us. Closes: #58646
295 * Typo in the package description. Closes: #60230
296 * Man Page typo. Closes: #60347
297 * Typo in Algorithms.cc. Closes: #63577
298 * Evil dotty function in apt-cache for generating dependency graphs
299 with the as-yet-unpackaged GraphVis.
300 * Appears to have been fixed in Janurary.. Closes: #57981
301 * New config.guess/sub for the new archs. Closes: #60874
302 * Fixed error reporting for certain kinds of resolution failures.
304 * Made autoclean respect 'q' settings. Closes: #63023
305 * Fixed up the example sources.list. Closes: #63676
306 * Added DPkg::FlushSTDIN to control the flushing of stdin before
307 forking dpkg. Closes: #63991
309 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
311 apt (0.3.18) frozen unstable; urgency=low
313 * Changes in the postinst script. Closes: #56855, #57237
314 * Fixed bashism. Closes: #57216, #57335
315 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
317 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
319 apt (0.3.17) unstable; urgency=low
321 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
322 * Fixed the configuration parser to not blow up if ; is in the config
324 * Applied visual patch to dselect install script . Closes #55214
325 * Included the configure-index example
327 * Library soname has increased
328 * Fixed default sources.list to have correct URLs for potato when it
330 * Added a message about erasing sources.list to dselect setup script
332 * No remove prompt if the archives dir has not changed. Closes: #55709
333 * Fixed inclusion of 2nd sample config file. Closes: #55374
334 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
337 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
339 apt (0.3.16) unstable; urgency=low
341 * Made --no-download work. Closes: #52993
342 * Now compiles on OpenBSD, Solaris and HP-UX
343 * Clarify segfault errors
344 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
345 * Fix for Joel's discovery of glibc removal behavoir.
346 * Fix for Ben Collins file: uri from slink upgrade.
347 * Fixed resume code in FTP. Closes: #54323
348 * Take more precautions to prevent the corruption Joey Hess saw.
349 * Fixed --no-list-cleanup
350 * RFC 2732 URI parsing ([] for hostnames).
351 * Typo in apt-cache man page. Closes: #54949
353 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
355 apt (0.3.15) unstable; urgency=low
357 * Added DSelect::WaitAfterDownload Closes: #49549
358 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
359 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
360 * Made -s and clean not do anything. Closes: #50238
361 * Problem with Protected packages and the new OR code.
362 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
363 * Remove doesn't require a package to be installable. Closes: #51175
364 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
366 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
368 apt (0.3.14) unstable; urgency=low
370 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
371 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
372 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
373 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
374 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
375 Closes: #45034, #45695, #46537
376 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
377 * Added APT::Clean-Installed option. Closes: #45973
378 * Moves the free space check to after the calculated size is printed.
379 Closes: #46639, #47498
380 * mipsel arch Closes: #47614
381 * Beautified URI printing to not include passwords Closes: #46857
382 * Fixed little problem with --no-download Closes: #47557
383 * Tweaked Dselect 'update' script to re-gen the avail file even in the
384 event of a failure Closes: #47112
385 * Retries for source archives too Closes: #47529
386 * Unmounts CDROMs iff it mounted them Closes: #45299
387 * Checks for the partial directories before doing downloads Closes: #47392
388 * no_proxy environment variable (http only!) Closes: #43476
389 * apt-cache showsrc Closes: #45799
390 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
391 * Regexs for install. Closes: #35304, #38835
392 * Dependency reports now show OR group relations
393 * Re-Install feature. Cloes: #46961, #37393, #38919
394 * Locks archive directory on clean (woops)
395 * Remove is not 'sticky'. Closes: #48392
396 * Slightly more accurate 'can not find package' message. Closes: #48311
397 * --trivial-only and --no-remove. Closes: #48518
398 * Increased the cache size. Closes: #47648
399 * Comment woopsie. Closes: #48789
400 * Removes existing links when linking sources. Closes: #48775
401 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
402 * Clearer usage message about 'source' Closes: #48858
403 * Immediate configure internal error Closes: #49062, #48884
405 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
407 apt (0.3.13) unstable; urgency=low
409 * Fix timestamp miss in FTP. Closes: #44363
410 * Fix sorting of Kept packages. Closes: #44377
411 * Fix Segfault for dselect-upgrade. Closes: #44436
412 * Fix handling of '/' for the dist name. Closes #43830
413 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
414 * Add commented-out deb-src URI to default sources.list file.
416 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
418 apt (0.3.12) unstable; urgency=low
420 * Fix for typo in the dhelp index. Closes: #40377
421 * Multiple media swap support
422 * Purge support. Closes: #33291, #40694
423 * Better handling of - remove notation. Closes: #41024
424 * Purge support. Closes: #33291, #40694
425 * Error code on failed update. Closes: #41053
426 * apt-cdrom adds entries for source directories. Closes: #41231
427 * Sorts the output of any list. Closes: #41107
428 * Fixes the looping problem. Closes: #41784, #42414, #44022
429 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
430 * More checks to keep the display sane. Particularly when fail-over is
431 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
432 * PThread lockup problem on certain sparc/m68k. Closes: #40628
433 * apt-cdrom understands .gz Package files too. Closes: #42779
434 * Spelling error in dselect method description. Closes: #43251
435 * Added security to the default source list. Closes: #43356
437 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
439 apt (0.3.11) unstable; urgency=low
441 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
442 * Fix for properly upgrading the system from perl 5.004 to 5.005
444 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
446 apt (0.3.9) unstable; urgency=low
448 * Spelling error in cachefile.cc. Closes: #39885
449 * Trailing slash in dselect install if you try to use the
450 default config file. Closes: #40011
451 * Simulate works for autoclean. Closes: #39141
452 * Fixed spelling errors. Closes: #39673
453 * Changed url parsing a bit. Closes: #40070, #40069
454 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
456 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
458 apt (0.3.7) unstable; urgency=low
460 * Fixed missing text in the apt-get(8) page. Closes: #37596
461 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
462 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
463 * Fixed handling of the -q option with not-entirely integer arguments
465 * Man page typo Closes: #37762
466 * Fixed parsing of the Source: line. Closes: #37679
467 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
468 * Added a check for an empty cache directory. Closes: #37963
469 * Return a failure code if -d is given and packages fail to download.
471 * Arranged for an ftp proxy specifing an http server to work. See the
472 important note in the sources.list man page.
473 * Accounted for resumed files in the cps calculation. Closes: #36787
474 * Deal with duplicate same version different packages. Closes: #30237
475 * Added --no-download. Closes: #38095
476 * Order of apt-cdrom dist detection. Closes: #38139
477 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
479 * Suggests dpkg-dev for apt-get source. Closes: #38158
480 * Fixed typo in apt-get help. Closes: #38712
481 * Improved the error message in the case of broken held package. Closes: #38777
482 * Fixed handling of MD5 failures
483 * Documented list notation Closes: #39008
484 * Change the 'b' to 'B'. Closes: #39007
486 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
488 apt (0.3.6) unstable; urgency=low
490 * Note that 0.3.5 never made it out the door..
491 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
492 * Made APT print numbers in decimal. Closes: #35617, #37319
493 * Buffer munching fix for FTP. Closes: #35868
494 * Typo in sample config file. Closes: #35907
495 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
496 * Changed installed size counter to only count unpacked packages.
498 * apt-get source support. Closes: #23934, #27190
499 * Renames .debs that fail MD5 checking, provides automatic corruption
500 recovery. Closes: #35931
501 * Fixed autoconf verison. Closes: #37305
502 * Random Segfaulting. Closes: #37312, #37530
503 * Fixed apt-cache man page. Closes: #36904
504 * Added a newline to apt-cache showpkg. Closes: #36903
506 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
508 apt (0.3.4) unstable; urgency=low
510 * Release for Ben while he is out of town.
511 * Checked the size of partial files. Closes: #33705
512 * apt-get should not print progress on non-tty. Closes: #34944
513 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
514 * Applied cdrom patches from Torsten. Closes: #35140, #35141
515 * smbmounted cdrom fix. Closes: #35470
516 * Changed ie to eg. Closes: #35196
518 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
520 apt (0.3.3) unstable; urgency=low
522 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
524 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
526 apt (0.3.2) unstable; urgency=low
528 * Major release into unstable of v3
529 * These bugs have been fixed, explanations are in the bug system, read
530 the man pages as well..
531 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
532 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
533 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
534 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
535 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
536 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
537 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
538 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
540 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
542 apt (0.3.1) experimental; urgency=low
544 * Minor release of cvs version.
545 * Added virtual package libapt-pkgx.x
547 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
549 apt (0.3.0) experimental; urgency=low
551 * New experimental version.
553 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
555 apt (0.1.9) frozen unstable; urgency=low
557 * Return to the wacky numbering for when we build 0.1.8 for hamm
558 * Important bug related to APT on the Alpha fixed
559 * apt-get dist-upgrade problems fixed
560 * tiny patch for http method to fix an endless loop
561 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
562 libtool and add proper shared lib dependancies
563 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
564 in case an old libpkg is installed while building APT to prevent
565 spurious dependancies
567 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
569 apt (0.1.7) unstable; urgency=low
571 * New build with libstdc++2.9.
572 * Various fixes; read the Changelog.
574 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
576 apt (0.1.6) unstable; urgency=low
578 * Various fixes in the FTP method for error checking. Fixes: #26188.
579 * Spelling corrections in dselect method. Fixes: #25884
580 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
581 * No more bo releases: we're using a normal numbering system now.
583 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
585 apt (0.1.5) unstable; urgency=low
587 * Changed sources.list to point to 'unstable' by default, as
588 'frozen' no longer exists!
590 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
592 apt (0.1.3) unstable; urgency=low
594 * New upstreamish version.
595 * ftp method rewritten in C. Removes dependancies on all perl/perl
596 related modules. This fixes many of the ftp method bugs.
598 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
600 apt (0.1.1) unstable; urgency=low
602 * Release for unstable.
604 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
606 apt (0.1) unstable; urgency=low
608 * Kludge to fix problem in libnet-perl with illegal anonymous
610 * Moved to unstable; apt is in a useable state now.
611 * Fixed version numbering. From now on, numbering will be:
612 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
613 0.1.1 (release for unstable). Thanks, Manoj.
615 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
617 apt (0.0.17-1) experimental; urgency=low
619 * Fixed problem with libc6 version compare
620 * Scott's away for a while, so I'll be packaging apt for the time
623 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
625 apt (0.0.16-1) experimental; urgency=low
627 * Modifications to make apt-get more friendly when backgrounded.
628 * Updated documentation.
629 * Updates to graphic widgets
631 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
633 apt (0.0.15-0.2bo) experimental; urgency=low
636 * Bob Hilliards crash
638 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
640 apt (0.0.15-0.1bo) experimental; urgency=low
645 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
647 apt (0.0.15) experimental; urgency=low
649 * Clean up source tarball (no user-visible changes)
651 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
653 apt (0.0.14) experimental; urgency=low
655 * Updates in ordering code to make sure certain upgrades work correctly.
656 * Made dselect/setup understand ftp as well as http
658 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
660 apt (0.0.13-bo1) experimental; urgency=low
664 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
666 apt (0.0.13) experimental; urgency=low
668 * Remove hardcoded egcc from debian/rules (#21575)
669 * Fixes for ordering logic when system has a number of unpacked
670 but unconfigured packages installed.
671 * Spelling fix in dselect install method (#22556)
673 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
675 apt (0.0.12) experimental; urgency=low
677 * Fixed problems with package cache corruption.
678 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
680 * Interface and documentation improvements.
682 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
684 apt (0.0.11) experimental; urgency=low
686 * Change dependancies to pre-depends since breaking your packaging tools
687 in the middle of an installation isn't very good.
688 * Bug fixes to ftp method and general apt-get code
690 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
692 apt (0.0.10) experimental; urgency=low
694 * Run "dpkg --configure -a" after an aborted dselect install
695 * Fixed problem with install looping
696 * Support for authenticating proxys: (note this isn't terribly secure)
697 http_proxy="http://user:pass@firewall:port/"
698 * Substitute $ARCH in sources.list
699 * Fixes in the resumption code for ftp
701 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
703 apt (0.0.9) experimental; urgency=low
706 * Various other less visible bug fixes.
707 * Fixed problem with segfault when apt-get invoked in a non-existant
708 directory (Bug #21863)
709 * Bumped policy to 2.4.1
711 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
713 apt (0.0.8) experimental; urgency=low
715 * Fixed generated available file (Bug #21836)
716 * Added download ETA (Bug #21774).
717 * Fixed hardcoded ARCH (Bug #21751).
718 * Fixed check on http_proxy (Bug #21795).
719 * Added download speed indicator.
721 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
723 apt (0.0.7) experimental; urgency=low
725 * Remove libdeity and apt from package for now, since only apt-get and
726 apt-cache are actually useful right now.
727 * Clean up handling of package installation errors.
728 * Added timeout to http transfers (#21269)
729 * Updated setup for dselect/apt method.
731 * Long options (added in 0.0.6)
733 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
735 apt (0.0.6) experimental; urgency=low
738 * Revamped download status display.
739 * Call apt-get clean after successful install in dselect.
740 * Added "apt-get clean" which deletes package files from /var/cache/apt
742 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
744 apt (0.0.5) experimental; urgency=low
746 * Ignore signals while dpkg is running so we don't leave dpkg running in
747 the background (#20804)
748 * Check Packages as well as Packages.gz for file URIs (#20784)
749 * Spelling cleanup (#20800)
750 * Added -m option to permit upgrade to go on in the case of a bad mirror.
751 This option may result in incomplete upgrades when used with -f.
753 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
755 apt (0.0.4) experimental; urgency=low
758 * Various documentation updates and cleanup.
759 * Added '-f' option to apt-get attempt to fix broken dependancies.
761 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
763 apt (0.0.3) experimental; urgency=low
765 * Added a shlibs.local file to prevent apt from depending on itself.
766 * Updates to how apt-get handles bad states in installed packages.
767 * Updated rules to make sure build works from a freshly checked out source
768 archive. Building from CVS needs libtool/automake/autoconf, builds from
769 the distributed source package should have no such dependancy.
771 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
773 apt (0.0.2) unstable; urgency=low
775 * Updates to apt-get and http binding for dselect method (apt).
776 * Updating version number from 0.0.1, which was released only on IRC.
778 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
780 apt (0.0.1) unstable; urgency=low
784 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500