1 apt (0.5.5) unstable; urgency=low
3 * New deb version compare function, that has no integer limits, and
4 supports pre-versions using ~. Code ported from dpkg.
5 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
6 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
7 * "apt-get --arch-only build-dep" to install only architecture-
8 dependent build dependencies. Bump minor shared lib number to reflect
9 small change in BuildDepend API.
10 * APT::Build-Essential configuration option (defaults to "build-essential")
11 so that "apt-get build-dep" will ensure build essential packages are
12 installed prior to installing other build-dependencies. Closes: #148879
13 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
14 * /usr/doc reference in postinst. Closes: #126189
15 * Doc updates. Closes: #120689
16 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
18 * Print special message for EAI_AGAIN. Closes: #131397
19 * libapt-pkg-dev needs to bring in the apt-inst library if linking
20 is to work. Closes: #133943
21 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
22 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
23 #139994, #142955, #151654, #151834, #147611, #154268, #173971
24 * Fix possibility for tag file parsing to fail in some unlikely situations.
26 * Use std C++ names for some header files. Closes: #128741
27 * Do not check for free space if --no-download. Closes: #117856
28 * Actually implement or group handling for 'upgrade'. Closes: #133950
29 * "Internal Error, Couldn't configure pre-depend" is not actually an
30 internal error, it is a packaging error and now it says so, and
31 pinpoints the problem dependency. Closes: #155621
32 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
33 * Use usr/share/doc for dhelp. Closes: #115701
34 * --print-uris works with 'update'. Closes: #57070
35 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
37 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
39 * Allow an uninstalled package to be marked for removal on an install
40 line (meaning not to automatically install it), also fix some dodgy
41 handling of protected packages. Closes: #92287, #116011
42 * Fix errant prefix matching in version selection. Closes: #105968
43 * Ensure that all files needed to run APT as a user are readable and
44 ignore roots umask for these files. Closes: #108801
45 * Support larger config spaces. Closes: #111914
46 * 'apt-get update' no longer does 'Building Dependency Tree'.
47 * When matching regexs allways print a message. Change regex activation
48 charset. Closes: #147817
49 * Don't die if lines in sources.list are too long. Closes: #146846
50 * Show file name on apt-extracttemplate error messges. Closes: #151835
51 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
52 * Some highly unlikely memory faults. Closes: #155842
53 * C++ stuff for G++3.2. Closes: #162617, #165515,
54 * apt-config dumps sends to stdout not stderr now. Closes: #146294
55 * Fix segfault in FindAny when /i is used, and there is no default.
57 * Add s390x to archtable. Closese: #160992.
58 * Update config.sub/config.guess in cvs, and add support to debian/rules
59 to update them from /usr/share/misc if they exist. Closes: #155014
60 * Remove 'Sorry' from messages. Closes: #148824.
61 * Change wording of 'additional disk space usage' message. Closes:
63 * apt-extracttemplates now prepends the package name when extracting
64 files. Closes: #132776
65 * Add -n synonym for --names-only for apt-cache. Closes: #130689
66 * Display both current version and new version in apt-get -s. Closes:
68 * Add an options and timeout config item to ssh/rsh. Closes: #90654
69 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
70 * Change verbose logging output of apt-ftparchive to go to stderr,
71 instead of stdout. Also, errors that occur no longer go to stdout,
72 but stderr. Closes: #161592
73 * Test for timegm in configure. Closes: #165516.
74 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
75 support compliation on platforms where st_mtime is a macro. Closes:
77 * Check the currently mounted cdrom, to see if it's the one we are
78 interested in. Closes: #154602
79 * Refer to reportbug instead of bug in the man pages. Closes: #173745
80 * Link apt-inst to apt-pkg. Closes: #175055
81 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
83 * Fix > 300 col screen segfault. Closes: #176052
84 * Rebuild with gcc-3.2. Closes: #177752, #178008.
85 * Fix build-dep handling of | dependencies.
86 Closes: #98640, #145997, #158896, #172901
87 * Double default value of APT::Cache-Limit, until such time as it
88 can be made more dynamic. Closes: #178623.
89 * Report uris with '.gz' when there are errors. Closes: #178435.
90 * When installing build-deps, make sure the new version will
91 satisfy build requirements. Closes: #178121
92 * Split offline and guide documentation into apt-doc. This was done so
93 that binary-arch builds do not require documention deps. Note, that
94 apt-doc is not installed on upgrades.
95 * Use doc-base, instead of dhelp directly. Closes: #110389
96 * Change http message 'Waiting for file' to 'Waiting for headers'.
98 * Remove trailing lines on package lists in apt-get. Closes: #178736.
99 * Fix origin pins for file:// uris. Closes: #189014.
100 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
102 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
104 * Fix some typos in the apt-get manual. Closes: #163932.
105 * Apply patch from bug, to change frozen to testing, and then do it
106 everywhere else. Closes: #165085.
107 * Update es.po. Closes: #183111.
108 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
110 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
111 * Add option to apt-get to show versions of packages being
113 * Be quiet in apt.post{inst,rm}. Closes: #70685.
114 * apt-get now prints out suggested and recommended packages. Closes:
116 * Insert some newlines in the cdrom change media message. Closes:
118 * Add a rdepends command to apt-cache. Closes: #159864.
119 * When building the dpkg command line, allow for 8192 chars to be used,
120 instead of only 1024.
121 * APT::Immediate-Configure had inverted semantics(false meant it was
122 enabled). Closes: #173619.
123 * Fix status file parser so that if a record is larger than 32k, the
124 buffer size will be doubled, and the read attempted again. Closes:
127 -- Adam Heath <doogie@debian.org> Sun, 27 Apr 2003 01:23:12 -0500
129 apt (0.5.4) unstable; urgency=low
131 * M68k config.guess patch. Closes: #88913
132 * Bi-yearly test on OpenBSD and Solaris
133 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
134 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
136 * Various cosmetic code updates. Closes: #89066, #89066, #89152
137 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
139 * More patches from Alfredo for Vendors and more SHA-1 stuff
140 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
141 similar situations. Closes: #56708, #59432
142 * no_proxy and ftp. Closes: #89671
143 * Philippe Batailler's man page patches.
144 * Fix for display bug. Closes: #92033, #93652, #98468
145 * Use more than 16bits for the dep ID. Some people ran out..
146 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
147 #106911, #107395, #108968
148 * Reordered some things to make dante and FTP happier. Closes: #92757
149 * James R. Van Zandt's guide.sgml updates. Closes: #90027
150 * apt-ftparchive copes with no uncompressed package files + contents.
151 * French man pages from philippe batailler - well sort of. They
153 * run-parts. Closes: #94286
154 * 'apt-cache policy' preferences debug tool.
155 * Whatever. Closes: #89762
156 * libstdc++ and HURD. Closes: #92025
157 * More apt-utils verbage. Closes: #86954
158 * Fliped comparision operator. Closes: #94618
159 * Used the right copyright file. Closes: #65691
160 * Randolph's G++3 patches.
161 * Fixed no_proxy tokanizing. Closes: #100046
162 * Strip Config-Version when copying status to available. Closes: #97520
163 * Segfault with missing source files. Closes: #100325
164 * EINTR check. Closes: #102293
165 * Various changes to the locking metholodgy for --print-uris.
167 * Lame LD_LIBRARY_PATH thing. Closes: #98928
168 * apt-cache search searchs provide names too now. Closes: #98695
169 * Checksum and long lines problem. Closes: #106591
170 * .aptignr and empty files are just a warning. Closes: #97364
172 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
174 apt (0.5.3) unstable; urgency=low
176 * JoeyH's dpkg::preconfig not working. Closes: #88675
177 * Fixed apt override disparity
178 * Alfredo's SHA-1 and related patches
180 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
182 apt (0.5.2) unstable; urgency=low
184 * Fixed mention of /usr/doc in the long description
185 * JoeyH's downgrade bug -- don't use 0.5.1
186 * Doc bug. Closes: #88538
187 * Fault in building release strings. Closes: #88533
189 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
191 apt (0.5.1) unstable; urgency=low
193 * Fixed #82894 again, or should be and.
194 * Process the option string right. Closes: #86921
195 * Don't eat the last command for pipes. Closes: #86923
196 * Ignore .* for configuration directory processing. Closes: #86923
197 * Alfredo's no_proxy patch
198 * Documentation fixes. Closes: #87091
199 * JoeyH's double slash bug. Closes: #87266
200 * Unintitialized buffer and apt-ftparchive contents generation.
202 * Build-deps on virtual packages. Closes: #87639
203 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
204 libstdc++ version info in the library soname and in the package
205 provides. Closes: #87426
206 * Updated soname version to 0.3.2
207 * apt-extracttemplates moved from debconf into apt-utils
208 * s390 archtable entry. Closes: #88232
210 * Some instances where the status file can source a package in a
211 non-sensical way. Closes: #87390
212 * Work better if there are duplicate sources.list entries.
213 * Fixed the resetting of Dir with "dir {};". Closes: #87323
215 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
217 apt (0.5.0) unstable; urgency=low
219 * Fixed an obscure bug with missing final double new lines in
221 * Changed the apt-cdrom index copy routine to use the new section
223 * Added a package file sorter, apt-sortpkgs
224 * Parse obsolete Optional dependencies.
225 * Added Ben's rsh method. Closes: #57794
226 * Added IPv6 FTP support and better DNS rotation support.
227 * Include the server IP in error messages when using a DNS rotation.
229 * Made most of the byte counters into doubles to prevent 32bit overflow.
231 * HTTP Authorization. Closes: #61158
232 * Ability to parse and return source index build depends from Randolph.
233 * new 'apt-get build-dep' command from Randolph. Closes: #63982
234 * Added apt-ftparchive the all dancing all singing FTP archive
236 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
238 * Removed useless internal cruft including the xstatus file.
239 * Fixed config parser bugs. Closes: #67848, #71108
240 * Brain Damanged apt-get config options changed, does not change the command
241 line interface, except to allow --enable-* to undo a configuration
244 No-Download -> Download
245 No-Upgrade -> Upgrade
246 * Made this fix configable (DSelect::CheckDir) and default to disabled:
247 * No remove prompt if the archives dir has not changed. Closes: #55709
248 Because it is stupid in the case where no files were downloaded due to
249 a resumed-aborted install, or a full cache! Closes: #65952
250 * Obscure divide by zero problem. Closes: #64394
251 * Update sizetable for mips. Closes: #62288
252 * Fixed a bug with passive FTP connections
253 * Has sizetable entry for sparc64. Closes: #64869
254 * Escape special characters in the ::Label section of the cdroms.lst
255 * Created apt-utils and python-apt packages
256 * Due to the new policy engine, the available file may contain entries
257 from the status file. These are generated if the package is not obsolete
258 but the policy engine prohibits using the version from the package files.
259 They can be identified by the lack of a Filename field.
260 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
261 #36223, #33468, #22551
262 * Fixed deb-src line for non-us. Closes: #71501, #71601
263 * Fixes for G++ 2.96, s/friend/friend class/
264 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
265 * Confirmed fix for missing new line problem. Closes: #69386
266 * Fixed up dhelp files. Closes: #71312
267 * Added some notes about dselect and offline usage. Closes: #66473, #38316
268 * Lock files on read only file systems are ignored w/ warning.
270 * apt-get update foo now gives an error! Closes: #42891
271 * Added test for shlibs on hurd. Closes: #71499
272 * Clarified apt-cache document. Closes: #71934
273 * DocBook SGML man pages and some improvements in the text..
274 * sigwinch thing. Closes: #72382
275 * Caching can be turned off by setting the cache file names blank.
276 * Ignores arches it does not know about when autocleaning. Closes: #72862
277 * New function in apt-config to return dirs, files, bools and integers.
278 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
279 complex cases involving OR groups and provides.
280 68754 describes confusing messages which are the result of this..
281 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
282 * Speeling mistake and return code for the 'wicked' resolver error
283 Closes: #72621, #75226, #77464
284 * Solved unable to upgrade libc6 from potato to woody due to 3 package
285 libc6 dependency loop problem.
286 * Leading sources.list spaces. Closes: #76010
287 * Removed a possible infinite loop while processing installations.
288 * Man page updates. Closes: #75411, #75560, #64292, #78469
289 * ReduceSourceList bug. Closes: #76027
290 * --only-source option. Closes: #76320
291 * Typos. Closes: #77812, #77999
292 * Different status messages. Closes: #76652, #78353
293 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
294 * OS detection an support for the new pseduo standard of os-arch for the
295 Architecture string. Also uses regexing.. Closes: #39227, #72349
296 * Various i18n stuff. Note that this still needs some i18n wizard
297 to do the last gettextization right. Closes: #62386
298 * Fixed a problem with some odd http servers/proxies that did not return
299 the content size in the header. Closes: #79878, #44379
300 * Little acquire bugs. Closes: #77029, #55820
301 * _POSIX_THREADS may not be defined to anything, just defined..
303 * Spelling of Ignore-Hold correctly. Closes: #78042
304 * Unlock the dpkg db if in download only mode. Closes: #84851
305 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
306 * Patch from BenC. Closes: #80810
307 * Single output of some names in lists. Closes: #80498, #43286
308 * Nice message for people who can't read syserror output. Closes: #84734
309 * OR search function. Closes: #82894
310 * User's guide updates. Closes: #82469
311 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
312 * Various CD bugs, again thanks to Greenbush
313 Closes: #80946, #76547, #71810, #70049, #69482
314 * Using potato debhelper. Closes: #57977
315 * I cannot self-terminate. Closes: #74928
317 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
319 apt (0.3.19) frozen unstable; urgency=low
321 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
323 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
324 * Fixed hardcoded path. Closes: #59743
325 * Fixed Jay's relative path bug
326 * Allowed source only CDs. Closes: #58952
327 * Space check is supressed if --print-uris is given. Closes: #58965
328 * Clarified the documenation examples for non-us. Closes: #58646
329 * Typo in the package description. Closes: #60230
330 * Man Page typo. Closes: #60347
331 * Typo in Algorithms.cc. Closes: #63577
332 * Evil dotty function in apt-cache for generating dependency graphs
333 with the as-yet-unpackaged GraphVis.
334 * Appears to have been fixed in Janurary.. Closes: #57981
335 * New config.guess/sub for the new archs. Closes: #60874
336 * Fixed error reporting for certain kinds of resolution failures.
338 * Made autoclean respect 'q' settings. Closes: #63023
339 * Fixed up the example sources.list. Closes: #63676
340 * Added DPkg::FlushSTDIN to control the flushing of stdin before
341 forking dpkg. Closes: #63991
343 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
345 apt (0.3.18) frozen unstable; urgency=low
347 * Changes in the postinst script. Closes: #56855, #57237
348 * Fixed bashism. Closes: #57216, #57335
349 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
351 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
353 apt (0.3.17) unstable; urgency=low
355 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
356 * Fixed the configuration parser to not blow up if ; is in the config
358 * Applied visual patch to dselect install script . Closes #55214
359 * Included the configure-index example
361 * Library soname has increased
362 * Fixed default sources.list to have correct URLs for potato when it
364 * Added a message about erasing sources.list to dselect setup script
366 * No remove prompt if the archives dir has not changed. Closes: #55709
367 * Fixed inclusion of 2nd sample config file. Closes: #55374
368 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
371 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
373 apt (0.3.16) unstable; urgency=low
375 * Made --no-download work. Closes: #52993
376 * Now compiles on OpenBSD, Solaris and HP-UX
377 * Clarify segfault errors
378 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
379 * Fix for Joel's discovery of glibc removal behavoir.
380 * Fix for Ben Collins file: uri from slink upgrade.
381 * Fixed resume code in FTP. Closes: #54323
382 * Take more precautions to prevent the corruption Joey Hess saw.
383 * Fixed --no-list-cleanup
384 * RFC 2732 URI parsing ([] for hostnames).
385 * Typo in apt-cache man page. Closes: #54949
387 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
389 apt (0.3.15) unstable; urgency=low
391 * Added DSelect::WaitAfterDownload Closes: #49549
392 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
393 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
394 * Made -s and clean not do anything. Closes: #50238
395 * Problem with Protected packages and the new OR code.
396 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
397 * Remove doesn't require a package to be installable. Closes: #51175
398 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
400 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
402 apt (0.3.14) unstable; urgency=low
404 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
405 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
406 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
407 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
408 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
409 Closes: #45034, #45695, #46537
410 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
411 * Added APT::Clean-Installed option. Closes: #45973
412 * Moves the free space check to after the calculated size is printed.
413 Closes: #46639, #47498
414 * mipsel arch Closes: #47614
415 * Beautified URI printing to not include passwords Closes: #46857
416 * Fixed little problem with --no-download Closes: #47557
417 * Tweaked Dselect 'update' script to re-gen the avail file even in the
418 event of a failure Closes: #47112
419 * Retries for source archives too Closes: #47529
420 * Unmounts CDROMs iff it mounted them Closes: #45299
421 * Checks for the partial directories before doing downloads Closes: #47392
422 * no_proxy environment variable (http only!) Closes: #43476
423 * apt-cache showsrc Closes: #45799
424 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
425 * Regexs for install. Closes: #35304, #38835
426 * Dependency reports now show OR group relations
427 * Re-Install feature. Cloes: #46961, #37393, #38919
428 * Locks archive directory on clean (woops)
429 * Remove is not 'sticky'. Closes: #48392
430 * Slightly more accurate 'can not find package' message. Closes: #48311
431 * --trivial-only and --no-remove. Closes: #48518
432 * Increased the cache size. Closes: #47648
433 * Comment woopsie. Closes: #48789
434 * Removes existing links when linking sources. Closes: #48775
435 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
436 * Clearer usage message about 'source' Closes: #48858
437 * Immediate configure internal error Closes: #49062, #48884
439 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
441 apt (0.3.13) unstable; urgency=low
443 * Fix timestamp miss in FTP. Closes: #44363
444 * Fix sorting of Kept packages. Closes: #44377
445 * Fix Segfault for dselect-upgrade. Closes: #44436
446 * Fix handling of '/' for the dist name. Closes #43830
447 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
448 * Add commented-out deb-src URI to default sources.list file.
450 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
452 apt (0.3.12) unstable; urgency=low
454 * Fix for typo in the dhelp index. Closes: #40377
455 * Multiple media swap support
456 * Purge support. Closes: #33291, #40694
457 * Better handling of - remove notation. Closes: #41024
458 * Purge support. Closes: #33291, #40694
459 * Error code on failed update. Closes: #41053
460 * apt-cdrom adds entries for source directories. Closes: #41231
461 * Sorts the output of any list. Closes: #41107
462 * Fixes the looping problem. Closes: #41784, #42414, #44022
463 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
464 * More checks to keep the display sane. Particularly when fail-over is
465 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
466 * PThread lockup problem on certain sparc/m68k. Closes: #40628
467 * apt-cdrom understands .gz Package files too. Closes: #42779
468 * Spelling error in dselect method description. Closes: #43251
469 * Added security to the default source list. Closes: #43356
471 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
473 apt (0.3.11) unstable; urgency=low
475 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
476 * Fix for properly upgrading the system from perl 5.004 to 5.005
478 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
480 apt (0.3.9) unstable; urgency=low
482 * Spelling error in cachefile.cc. Closes: #39885
483 * Trailing slash in dselect install if you try to use the
484 default config file. Closes: #40011
485 * Simulate works for autoclean. Closes: #39141
486 * Fixed spelling errors. Closes: #39673
487 * Changed url parsing a bit. Closes: #40070, #40069
488 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
490 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
492 apt (0.3.7) unstable; urgency=low
494 * Fixed missing text in the apt-get(8) page. Closes: #37596
495 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
496 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
497 * Fixed handling of the -q option with not-entirely integer arguments
499 * Man page typo Closes: #37762
500 * Fixed parsing of the Source: line. Closes: #37679
501 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
502 * Added a check for an empty cache directory. Closes: #37963
503 * Return a failure code if -d is given and packages fail to download.
505 * Arranged for an ftp proxy specifing an http server to work. See the
506 important note in the sources.list man page.
507 * Accounted for resumed files in the cps calculation. Closes: #36787
508 * Deal with duplicate same version different packages. Closes: #30237
509 * Added --no-download. Closes: #38095
510 * Order of apt-cdrom dist detection. Closes: #38139
511 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
513 * Suggests dpkg-dev for apt-get source. Closes: #38158
514 * Fixed typo in apt-get help. Closes: #38712
515 * Improved the error message in the case of broken held package. Closes: #38777
516 * Fixed handling of MD5 failures
517 * Documented list notation Closes: #39008
518 * Change the 'b' to 'B'. Closes: #39007
520 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
522 apt (0.3.6) unstable; urgency=low
524 * Note that 0.3.5 never made it out the door..
525 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
526 * Made APT print numbers in decimal. Closes: #35617, #37319
527 * Buffer munching fix for FTP. Closes: #35868
528 * Typo in sample config file. Closes: #35907
529 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
530 * Changed installed size counter to only count unpacked packages.
532 * apt-get source support. Closes: #23934, #27190
533 * Renames .debs that fail MD5 checking, provides automatic corruption
534 recovery. Closes: #35931
535 * Fixed autoconf verison. Closes: #37305
536 * Random Segfaulting. Closes: #37312, #37530
537 * Fixed apt-cache man page. Closes: #36904
538 * Added a newline to apt-cache showpkg. Closes: #36903
540 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
542 apt (0.3.4) unstable; urgency=low
544 * Release for Ben while he is out of town.
545 * Checked the size of partial files. Closes: #33705
546 * apt-get should not print progress on non-tty. Closes: #34944
547 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
548 * Applied cdrom patches from Torsten. Closes: #35140, #35141
549 * smbmounted cdrom fix. Closes: #35470
550 * Changed ie to eg. Closes: #35196
552 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
554 apt (0.3.3) unstable; urgency=low
556 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
558 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
560 apt (0.3.2) unstable; urgency=low
562 * Major release into unstable of v3
563 * These bugs have been fixed, explanations are in the bug system, read
564 the man pages as well..
565 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
566 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
567 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
568 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
569 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
570 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
571 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
572 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
574 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
576 apt (0.3.1) experimental; urgency=low
578 * Minor release of cvs version.
579 * Added virtual package libapt-pkgx.x
581 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
583 apt (0.3.0) experimental; urgency=low
585 * New experimental version.
587 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
589 apt (0.1.9) frozen unstable; urgency=low
591 * Return to the wacky numbering for when we build 0.1.8 for hamm
592 * Important bug related to APT on the Alpha fixed
593 * apt-get dist-upgrade problems fixed
594 * tiny patch for http method to fix an endless loop
595 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
596 libtool and add proper shared lib dependancies
597 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
598 in case an old libpkg is installed while building APT to prevent
599 spurious dependancies
601 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
603 apt (0.1.7) unstable; urgency=low
605 * New build with libstdc++2.9.
606 * Various fixes; read the Changelog.
608 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
610 apt (0.1.6) unstable; urgency=low
612 * Various fixes in the FTP method for error checking. Fixes: #26188.
613 * Spelling corrections in dselect method. Fixes: #25884
614 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
615 * No more bo releases: we're using a normal numbering system now.
617 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
619 apt (0.1.5) unstable; urgency=low
621 * Changed sources.list to point to 'unstable' by default, as
622 'frozen' no longer exists!
624 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
626 apt (0.1.3) unstable; urgency=low
628 * New upstreamish version.
629 * ftp method rewritten in C. Removes dependancies on all perl/perl
630 related modules. This fixes many of the ftp method bugs.
632 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
634 apt (0.1.1) unstable; urgency=low
636 * Release for unstable.
638 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
640 apt (0.1) unstable; urgency=low
642 * Kludge to fix problem in libnet-perl with illegal anonymous
644 * Moved to unstable; apt is in a useable state now.
645 * Fixed version numbering. From now on, numbering will be:
646 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
647 0.1.1 (release for unstable). Thanks, Manoj.
649 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
651 apt (0.0.17-1) experimental; urgency=low
653 * Fixed problem with libc6 version compare
654 * Scott's away for a while, so I'll be packaging apt for the time
657 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
659 apt (0.0.16-1) experimental; urgency=low
661 * Modifications to make apt-get more friendly when backgrounded.
662 * Updated documentation.
663 * Updates to graphic widgets
665 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
667 apt (0.0.15-0.2bo) experimental; urgency=low
670 * Bob Hilliards crash
672 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
674 apt (0.0.15-0.1bo) experimental; urgency=low
679 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
681 apt (0.0.15) experimental; urgency=low
683 * Clean up source tarball (no user-visible changes)
685 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
687 apt (0.0.14) experimental; urgency=low
689 * Updates in ordering code to make sure certain upgrades work correctly.
690 * Made dselect/setup understand ftp as well as http
692 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
694 apt (0.0.13-bo1) experimental; urgency=low
698 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
700 apt (0.0.13) experimental; urgency=low
702 * Remove hardcoded egcc from debian/rules (#21575)
703 * Fixes for ordering logic when system has a number of unpacked
704 but unconfigured packages installed.
705 * Spelling fix in dselect install method (#22556)
707 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
709 apt (0.0.12) experimental; urgency=low
711 * Fixed problems with package cache corruption.
712 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
714 * Interface and documentation improvements.
716 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
718 apt (0.0.11) experimental; urgency=low
720 * Change dependancies to pre-depends since breaking your packaging tools
721 in the middle of an installation isn't very good.
722 * Bug fixes to ftp method and general apt-get code
724 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
726 apt (0.0.10) experimental; urgency=low
728 * Run "dpkg --configure -a" after an aborted dselect install
729 * Fixed problem with install looping
730 * Support for authenticating proxys: (note this isn't terribly secure)
731 http_proxy="http://user:pass@firewall:port/"
732 * Substitute $ARCH in sources.list
733 * Fixes in the resumption code for ftp
735 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
737 apt (0.0.9) experimental; urgency=low
740 * Various other less visible bug fixes.
741 * Fixed problem with segfault when apt-get invoked in a non-existant
742 directory (Bug #21863)
743 * Bumped policy to 2.4.1
745 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
747 apt (0.0.8) experimental; urgency=low
749 * Fixed generated available file (Bug #21836)
750 * Added download ETA (Bug #21774).
751 * Fixed hardcoded ARCH (Bug #21751).
752 * Fixed check on http_proxy (Bug #21795).
753 * Added download speed indicator.
755 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
757 apt (0.0.7) experimental; urgency=low
759 * Remove libdeity and apt from package for now, since only apt-get and
760 apt-cache are actually useful right now.
761 * Clean up handling of package installation errors.
762 * Added timeout to http transfers (#21269)
763 * Updated setup for dselect/apt method.
765 * Long options (added in 0.0.6)
767 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
769 apt (0.0.6) experimental; urgency=low
772 * Revamped download status display.
773 * Call apt-get clean after successful install in dselect.
774 * Added "apt-get clean" which deletes package files from /var/cache/apt
776 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
778 apt (0.0.5) experimental; urgency=low
780 * Ignore signals while dpkg is running so we don't leave dpkg running in
781 the background (#20804)
782 * Check Packages as well as Packages.gz for file URIs (#20784)
783 * Spelling cleanup (#20800)
784 * Added -m option to permit upgrade to go on in the case of a bad mirror.
785 This option may result in incomplete upgrades when used with -f.
787 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
789 apt (0.0.4) experimental; urgency=low
792 * Various documentation updates and cleanup.
793 * Added '-f' option to apt-get attempt to fix broken dependancies.
795 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
797 apt (0.0.3) experimental; urgency=low
799 * Added a shlibs.local file to prevent apt from depending on itself.
800 * Updates to how apt-get handles bad states in installed packages.
801 * Updated rules to make sure build works from a freshly checked out source
802 archive. Building from CVS needs libtool/automake/autoconf, builds from
803 the distributed source package should have no such dependancy.
805 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
807 apt (0.0.2) unstable; urgency=low
809 * Updates to apt-get and http binding for dselect method (apt).
810 * Updating version number from 0.0.1, which was released only on IRC.
812 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
814 apt (0.0.1) unstable; urgency=low
818 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500