]> git.saurik.com Git - apt.git/blob - debian/rules
* test/*
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
8
9 # FOR AUTOCONF 2.52 AND NEWER ONLY
10 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
11 confflags += --build $(DEB_HOST_GNU_TYPE)
12 else
13 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
14 endif
15
16 # See below
17 -include build/environment.mak
18
19 ifneq (,$(shell which dpkg-buildflags))
20 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
21 else
22 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 export CXXFLAGS = -O0 -g -Wall
24 else
25 export CXXFLAGS = -O2 -g -Wall
26 endif
27 endif
28
29 # Default rule
30 build:
31
32 PKG=apt
33 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
34 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
35 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
36 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
37
38 # Determine the build directory to use
39 BASE=.
40 ifdef BUILD
41 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
42 else
43 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
44 endif
45 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
46 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
47 override BLD := $(BUILDX)
48
49 ifeq ($(words $(BLD)),0)
50 override BLD := ./build
51 endif
52
53 # Rebuild configure.in to have the correct version from the change log
54 ifneq ($(APT_DEBVER),$(APT_CONFVER))
55 ifneq ($(APT_DEBVER),)
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
59 endif
60 else
61 configure.in:
62 endif
63
64 # APT Programs in apt-utils
65 APT_UTILS=ftparchive sortpkgs extracttemplates
66
67 # Uncomment this to turn on verbose mode.
68 #export DH_VERBOSE=1
69
70 # Find the libapt-pkg major version for use in other control files
71 include buildlib/libversion.mak
72
73 # Determine which package we should provide in the control files
74 LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
75 LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
76
77 # do not fail as we are just experimenting with symbol files for now
78 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
79
80 build: build/build-stamp
81 build-doc: build/build-doc-stamp
82
83 # Note that this is unconditionally done first as part of loading environment.mak
84 # The true is needed to force make to reload environment.mak after running
85 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
86 build/environment.mak: build/configure-stamp
87 @true
88
89 configure: configure.in
90 build/configure-stamp: configure
91 dh_testdir
92 -mkdir build
93 cp COPYING debian/copyright
94 cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
95 touch $@
96
97 build/build-stamp: build/configure-stamp
98 # Add here commands to compile the package.
99 $(MAKE) binary
100 $(MAKE) test
101 touch $@
102
103 build/build-doc-stamp: build/configure-stamp
104 # Add here commands to compile the package.
105 $(MAKE) doc
106 touch $@
107
108 clean:
109 dh_testdir
110
111 [ ! -f Makefile ] || $(MAKE) clean distclean
112 rm -rf build
113
114 binary-indep: apt-doc libapt-pkg-doc
115 # Build architecture-independent files here.
116 libapt-pkg-doc: build-doc
117 dh_testdir -p$@
118 dh_testroot -p$@
119 dh_prep -p$@
120 dh_installdirs -p$@
121 #
122 # libapt-pkg-doc install
123 #
124 dh_installdocs -p$@ $(BLD)/docs/design* \
125 $(BLD)/docs/dpkg-tech* \
126 $(BLD)/docs/files* \
127 $(BLD)/docs/method* \
128 doc/libapt-pkg2_to_3.txt \
129 doc/style.txt \
130 $(BLD)/doc/doxygen/html
131 dh_installexamples -p$@
132
133 dh_installchangelogs -p$@
134 dh_strip -p$@
135 dh_compress -p$@
136 dh_fixperms -p$@
137 dh_installdeb -p$@
138 dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
139 dh_md5sums -p$@
140 dh_builddeb -p$@
141
142 apt-doc: build-doc
143 dh_testdir -p$@
144 dh_testroot -p$@
145 dh_prep -p$@
146 #
147 # apt-doc install
148 #
149 # Copy the guides
150 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
151 $(BLD)/docs/guide*.html \
152 $(BLD)/docs/offline*.text \
153 $(BLD)/docs/offline*.html
154 dh_installchangelogs -p$@
155 dh_compress -p$@
156 dh_fixperms -p$@
157 dh_installdeb -p$@
158 dh_gencontrol -p$@
159 dh_md5sums -p$@
160 dh_builddeb -p$@
161
162
163
164 # Build architecture-dependent files here.
165
166 binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
167 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
168 apt: build build-doc
169 dh_testdir -p$@
170 dh_testroot -p$@
171 dh_prep -p$@
172 dh_installdirs -p$@
173 #
174 # apt install
175 #
176 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
177
178 # make rosetta happy and remove pot files in po/ (but leave stuff
179 # in po/domains/* untouched) and cp *.po into each domain dir
180 rm -f build/po/*.pot
181 rm -f po/*.pot
182
183 dh_install -p$@ --sourcedir=$(BLD)
184
185 # Remove the bits that are in apt-utils
186 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
187
188 # https has its own package
189 rm debian/$@/usr/lib/apt/methods/https
190
191 # move the mirror failure script in place
192 #mv debian/$@/usr/bin/apt-report-mirror-failure \
193 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
194
195 dh_bugfiles -p$@
196 dh_lintian -p$@
197 dh_installexamples -p$@ $(BLD)/docs/examples/*
198 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
199 dh_installcron -p$@
200 dh_installdocs -p$@
201 dh_installchangelogs -p$@
202 dh_installlogrotate -p$@
203 dh_strip -p$@
204 dh_compress -p$@
205 dh_fixperms -p$@
206 dh_makeshlibs -p$@
207 dh_installdeb -p$@
208 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
209 dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
210 dh_md5sums -p$@
211 dh_builddeb -p$@
212
213 libapt-pkg-dev: build
214 dh_testdir -p$@
215 dh_testroot -p$@
216 dh_prep -p$@
217 dh_installdirs -p$@
218 #
219 # libapt-pkg-dev install
220 #
221 dh_install -p$@ --sourcedir=$(BLD)
222 dh_installdocs -p$@
223 dh_installchangelogs -p$@
224 dh_strip -p$@
225 dh_compress -p$@
226 dh_fixperms -p$@
227 dh_installdeb -p$@
228 dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
229 dh_md5sums -p$@
230 dh_builddeb -p$@
231
232 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
233 apt-utils: build
234 dh_testdir -p$@
235 dh_testroot -p$@
236 dh_prep -p$@
237 dh_installdirs -p$@
238
239 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
240
241 dh_install -p$@ --sourcedir=$(BLD)
242 dh_installdocs -p$@
243 dh_installexamples -p$@
244
245 # Install the man pages..
246 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
247
248 dh_installchangelogs -p$@
249 dh_strip -p$@
250 dh_compress -p$@
251 dh_fixperms -p$@
252 dh_makeshlibs -p$@
253 dh_installdeb -p$@
254 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
255 dh_gencontrol -p$@ -- -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
256 dh_md5sums -p$@
257 dh_builddeb -p$@
258
259 apt-transport-https: build libapt-pkg-dev
260 dh_testdir -p$@
261 dh_testroot -p$@
262 dh_prep -p$@
263 dh_installdirs -p$@
264
265 dh_install -p$@ --sourcedir=$(BLD)
266 dh_installdocs -p$@ debian/apt-transport-https.README
267 dh_installexamples -p$@
268
269 # Install the man pages..
270 dh_installman -p$@
271
272 dh_installchangelogs -p$@
273 dh_strip -p$@
274 dh_compress -p$@
275 dh_fixperms -p$@
276 dh_installdeb -p$@
277 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
278 dh_gencontrol -p$@
279 dh_md5sums -p$@
280 dh_builddeb -p$@
281
282 configure:
283 $(MAKE) configure
284
285 really-clean: clean
286 -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
287 find -name ChangeLog | xargs rm -f
288 rm -f l33ch-stamp
289
290 binary: binary-indep binary-arch
291 .PHONY: build clean binary-indep binary-arch binary