2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
6 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
7 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
8 export DEB_HOST_MULTIARCH ?
= $(shell dpkg-architecture
-qDEB_HOST_MULTIARCH
)
10 # FOR AUTOCONF 2.52 AND NEWER ONLY
11 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
12 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
14 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
18 -include build
/environment.mak
20 ifneq (,$(shell which dpkg-buildflags
))
21 export CXXFLAGS
= $(shell dpkg-buildflags
--get CXXFLAGS
)
22 export LDFLAGS
= $(shell dpkg-buildflags
--get LDFLAGS
)
23 export CPPFLAGS
= $(shell dpkg-buildflags
--get CPPFLAGS
)
25 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
26 export CXXFLAGS
= -O0
-g
-Wall
28 export CXXFLAGS
= -O2
-g
-Wall
36 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
--preserve-envvar CCACHE_DIR
-us
-uc
$(DEB_BUILD_PROG_OPTS
)
37 APT_DEBVER
=$(shell dpkg-parsechangelog |sed
-n
-e
'/^Version:/s/^Version: //p' | sed
-e
's/\+.*$$//')
38 APT_CONFVER
=$(shell sed
-n
-e
's/^PACKAGE_VERSION="\(.*\)"/\1/p' configure.in
)
39 APT_CVSTAG
=$(shell echo
"$(APT_DEBVER)" | sed
-e
's/^/v/' -e
's/\./_/g')
41 # Determine the build directory to use
44 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
46 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
--machine
) $(BASE
)/build
48 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
49 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
50 override BLD
:= $(BUILDX
)
52 ifeq ($(words $(BLD
)),0)
53 override BLD
:= .
/build
56 # Rebuild configure.in to have the correct version from the change log
57 ifneq ($(APT_DEBVER
),$(APT_CONFVER
))
58 ifneq ($(APT_DEBVER
),)
61 sed
-e
's/$(APT_CONFVER)/$(APT_DEBVER)/' $@
> $@.
$$$$ && mv
$@.
$$$$ $@
67 # APT Programs in apt-utils
68 APT_UTILS
=ftparchive sortpkgs extracttemplates internal-solver
70 # Uncomment this to turn on verbose mode.
73 # Find the libapt-pkg major version for use in other control files
74 include buildlib
/libversion.mak
76 # Determine which library package names to use
77 LIBAPT_PKG
=libapt-pkg
$(LIBAPTPKG_MAJOR
)
78 LIBAPT_INST
=libapt-inst
$(LIBAPTINST_MAJOR
)
80 # do not fail as we are just experimenting with symbol files for now
81 export DPKG_GENSYMBOLS_CHECK_LEVEL
=0
83 build
: build
/build-stamp
84 build-doc
: build
/build-doc-stamp
86 # Note that this is unconditionally done first as part of loading environment.mak
87 # The true is needed to force make to reload environment.mak after running
88 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
89 build
/environment.mak
: build
/configure-stamp
92 configure
: configure.in
93 build
/configure-stamp
: configure
96 cp COPYING debian
/copyright
97 cd build
&& CXXFLAGS
="$(CXXFLAGS)" LDFLAGS
="$(LDFLAGS)" CPPFLAGS
="$(CPPFLAGS)" ..
/configure
$(confflags
)
100 build
/build-stamp
: build
/configure-stamp
101 # Add here commands to compile the package.
103 # compat symlink for the locale split
104 mkdir
-p build
/usr
/share
105 cd build
/usr
/share
&& ln
-f
-s ..
/..
/locale .
106 # compile and run tests
107 ifeq (,$(findstring nocheck
, $(DEB_BUILD_OPTIONS
)))
110 @echo
"Tests DISABLED"
114 build
/build-doc-stamp
: build
/configure-stamp
115 # Add here commands to compile the package.
122 [ ! -f Makefile
] ||
$(MAKE
) clean distclean
124 rm -f debian
/$(LIBAPT_PKG
).
install debian
/$(LIBAPT_INST
).
install \
125 debian
/libapt-pkg-dev.
install
127 debian
/%.
install: debian
/%.
install.in
128 sed
's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
130 binary-indep
: apt-doc libapt-pkg-doc
131 # Build architecture-independent files here.
132 libapt-pkg-doc
: build-doc
138 # libapt-pkg-doc install
140 dh_installdocs
-p
$@
$(BLD
)/docs
/design
* \
141 $(BLD
)/docs
/dpkg-tech
* \
143 $(BLD
)/docs
/method
* \
144 doc
/libapt-pkg2_to_3.txt \
146 $(BLD
)/doc
/doxygen
/html
147 dh_installexamples
-p
$@
149 dh_installchangelogs
-p
$@
166 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text \
167 $(BLD
)/docs
/guide
*.html \
168 $(BLD
)/docs
/offline
*.text \
169 $(BLD
)/docs
/offline
*.html
170 dh_installchangelogs
-p
$@
180 # Build architecture-dependent files here.
182 binary-arch
: $(LIBAPT_PKG
) $(LIBAPT_INST
) apt libapt-pkg-dev apt-utils apt-transport-https
183 apt_MANPAGES
= apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
192 cp debian
/apt.conf.autoremove debian
/$@
/etc
/apt
/apt.conf.d
/01autoremove
194 # make rosetta happy and remove pot files in po/ (but leave stuff
195 # in po/domains/* untouched) and cp *.po into each domain dir
199 dh_install
-p
$@
--sourcedir
=$(BLD
)
201 # Remove the bits that are in apt-utils
202 rm $(addprefix debian
/$@
/usr
/bin
/apt-
,$(APT_UTILS
) dump-solver
)
204 # https has its own package
205 rm debian
/$@
/usr
/lib
/apt
/methods
/https
207 # move the mirror failure script in place
208 #mv debian/$@/usr/bin/apt-report-mirror-failure \
209 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
213 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
214 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/%.
[158],$(apt_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt_MANPAGES
)))
217 dh_installchangelogs
-p
$@
218 dh_installlogrotate
-p
$@
228 libapt-pkg-dev
: build debian
/libapt-pkg-dev.
install
234 # libapt-pkg-dev install
236 dh_install
-p
$@
--sourcedir
=$(BLD
)
238 dh_installchangelogs
-p
$@
243 dh_gencontrol
-p
$@
-- -Vlibapt-pkg-name
=$(LIBAPT_PKG
) -Vlibapt-inst-name
=$(LIBAPT_INST
)
247 apt-utils_MANPAGES
= apt-sortpkgs apt-ftparchive apt-extracttemplates
254 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
255 cp
$(BLD
)/bin
/apt-dump-solver debian
/$@
/usr
/lib
/apt
/solvers
/dump
257 dh_install
-p
$@
--sourcedir
=$(BLD
)
260 dh_installexamples
-p
$@
262 # Install the man pages..
263 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/%.
[158],$(apt-utils_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt-utils_MANPAGES
)))
265 dh_installchangelogs
-p
$@
276 $(LIBAPT_PKG
): build debian
/$(LIBAPT_PKG
).
install
282 dh_install
-p
$@
--sourcedir
=$(BLD
)
284 dh_installchangelogs
-p
$@
295 $(LIBAPT_INST
): build debian
/$(LIBAPT_INST
).
install
301 dh_install
-p
$@
--sourcedir
=$(BLD
)
303 dh_installchangelogs
-p
$@
314 apt-transport-https
: build libapt-pkg-dev
320 dh_install
-p
$@
--sourcedir
=$(BLD
)
321 dh_installdocs
-p
$@ debian
/apt-transport-https.README
322 dh_installexamples
-p
$@
324 # Install the man pages..
327 dh_installchangelogs
-p
$@
341 -find .
-name Makefile.in
-print0 | xargs
--null
--no-run-if-empty
-- rm -f
342 find
-name ChangeLog | xargs
rm -f
345 binary
: binary-indep binary-arch
346 .PHONY
: build
clean binary-indep binary-arch binary