5 # we need the buildin webserver for the tests
6 if [ ! -e environment.mak
]; then
9 make -C test
/interactive
-helper/
11 # run tests against the installed apt, use "env -i" to ensure
12 # the host env does not pollute our environment
14 APT_INTEGRATION_TESTS_WEBSERVER_BIN_DIR
=$(pwd)/build
/bin \
15 APT_INTEGRATION_TESTS_METHODS_DIR
=/usr
/lib
/apt
/methods \
16 APT_INTEGRATION_TESTS_LIBEXEC_DIR
=/usr
/lib
/apt
/ \
17 APT_INTEGRATION_TESTS_INTERNAL_SOLVER
=/usr
/lib
/apt
/solvers
/apt \
18 APT_INTEGRATION_TESTS_DUMP_SOLVER
=/usr
/lib
/apt
/solvers
/dump \
19 APT_INTEGRATION_TESTS_BUILD_DIR
=/usr
/bin \
20 APT_INTEGRATION_TESTS_LIBRARY_PATH
=/dev
/null
/does
/not
/exist \
21 .
/test
/integration
/run
-tests