1 apt (0.5.6) unstable; urgency=low
3 * Adam Heath <doogie@debian.org>
4 - Fix segfault when handling /etc/apt/preferences. Closes: #192409.
5 * Matt Zimmerman <mdz@debian.org>
6 - Clean up some string handling, patch from Peter Lundkvist
7 <p.lundkvist@telia.com> (Closes: #192225)
8 - Don't fall off the end of the buffer when comparing versions.
9 Patch from Koblinger Egmont <egmont@uhulinux.hu> (Closes: #194327)
10 - Minor fixes to apt-ftparchive(1) (Closes: #118156)
11 - Fix typo in apt-ftparchive help text (Closes: #119072)
12 - More typos in apt-ftparchive help text (Closes: #190936)
13 - Update config.guess, config.sub to latest versions
14 - Modify the description for apt-utils to reflect the fact that it is not
15 (any longer) infrequently used (Closes: #138045)
16 - Make setup script for dselect method more explicit about
17 overwriting sources.list (Closes: #151727)
18 - Fix typo in apt-cache(8) (Closes: #161243)
19 - Remove duplicate 'showpkg' from synopsis on apt-cache(8)
21 - Document in apt-get(8) the meaning of the '*' in ShowList, which is that
22 the package is being purged (Closes: #182369)
23 - Fix extra "/" character in apt.conf(5) (Closes: #185545)
24 - Fix typo in tar error message (Closes: #191424)
25 - Clarify description of 'search' on apt-cache(8) (Closes: #192216)
26 - Fix incorrect path for 'partial' directory on apt-get(8)
28 - Fixes to pt_BR translation from Andre Luis Lopes <andrelop@ig.com.br>
30 - Updated apt_preferences(5) man page with many corrections and
31 clarifications from Thomas Hood <jdthood@yahoo.co.uk>
36 apt (0.5.5.1) unstable; urgency=low
38 * Move the target of the example docs from doc to binary. Closes:
40 * Fix api breakage that broke apt-ftparchive and apt-cache dumpavail, by
41 backing out change that incorretly attempted to handle Package sections
42 larger than 32k. Closes: #192373
43 * Fix never-ending loop with apt-get install -V. Closes: #192355.
45 -- Adam Heath <doogie@debian.org> Mon, 19 May 2003 12:30:16 -0500
47 apt (0.5.5) unstable; urgency=low
49 * New deb version compare function, that has no integer limits, and
50 supports pre-versions using ~. Code ported from dpkg.
51 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
52 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
53 * "apt-get --arch-only build-dep" to install only architecture-
54 dependent build dependencies. Bump minor shared lib number to reflect
55 small change in BuildDepend API.
56 * APT::Build-Essential configuration option (defaults to "build-essential")
57 so that "apt-get build-dep" will ensure build essential packages are
58 installed prior to installing other build-dependencies. Closes: #148879
59 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
60 * /usr/doc reference in postinst. Closes: #126189
61 * Doc updates. Closes: #120689
62 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
64 * Print special message for EAI_AGAIN. Closes: #131397
65 * libapt-pkg-dev needs to bring in the apt-inst library if linking
66 is to work. Closes: #133943
67 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
68 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
69 #139994, #142955, #151654, #151834, #147611, #154268, #173971
70 * Fix possibility for tag file parsing to fail in some unlikely situations.
72 * Use std C++ names for some header files. Closes: #128741
73 * Do not check for free space if --no-download. Closes: #117856
74 * Actually implement or group handling for 'upgrade'. Closes: #133950
75 * "Internal Error, Couldn't configure pre-depend" is not actually an
76 internal error, it is a packaging error and now it says so, and
77 pinpoints the problem dependency. Closes: #155621
78 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
79 * Use usr/share/doc for dhelp. Closes: #115701
80 * --print-uris works with 'update'. Closes: #57070
81 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
83 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
85 * Allow an uninstalled package to be marked for removal on an install
86 line (meaning not to automatically install it), also fix some dodgy
87 handling of protected packages. Closes: #92287, #116011
88 * Fix errant prefix matching in version selection. Closes: #105968
89 * Ensure that all files needed to run APT as a user are readable and
90 ignore roots umask for these files. Closes: #108801
91 * Support larger config spaces. Closes: #111914
92 * 'apt-get update' no longer does 'Building Dependency Tree'.
93 * When matching regexs allways print a message. Change regex activation
94 charset. Closes: #147817
95 * Don't die if lines in sources.list are too long. Closes: #146846
96 * Show file name on apt-extracttemplate error messges. Closes: #151835
97 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
98 * Some highly unlikely memory faults. Closes: #155842
99 * C++ stuff for G++3.2. Closes: #162617, #165515,
100 * apt-config dumps sends to stdout not stderr now. Closes: #146294
101 * Fix segfault in FindAny when /i is used, and there is no default.
103 * Add s390x to archtable. Closese: #160992.
104 * Update config.sub/config.guess in cvs, and add support to debian/rules
105 to update them from /usr/share/misc if they exist. Closes: #155014
106 * Remove 'Sorry' from messages. Closes: #148824.
107 * Change wording of 'additional disk space usage' message. Closes:
109 * apt-extracttemplates now prepends the package name when extracting
110 files. Closes: #132776
111 * Add -n synonym for --names-only for apt-cache. Closes: #130689
112 * Display both current version and new version in apt-get -s. Closes:
114 * Add an options and timeout config item to ssh/rsh. Closes: #90654
115 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
116 * Change verbose logging output of apt-ftparchive to go to stderr,
117 instead of stdout. Also, errors that occur no longer go to stdout,
118 but stderr. Closes: #161592
119 * Test for timegm in configure. Closes: #165516.
120 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
121 support compliation on platforms where st_mtime is a macro. Closes:
123 * Check the currently mounted cdrom, to see if it's the one we are
124 interested in. Closes: #154602
125 * Refer to reportbug instead of bug in the man pages. Closes: #173745
126 * Link apt-inst to apt-pkg. Closes: #175055
127 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
129 * Fix > 300 col screen segfault. Closes: #176052
130 * Rebuild with gcc-3.2. Closes: #177752, #178008.
131 * Fix build-dep handling of | dependencies.
132 Closes: #98640, #145997, #158896, #172901
133 * Double default value of APT::Cache-Limit, until such time as it
134 can be made more dynamic. Closes: #178623.
135 * Report uris with '.gz' when there are errors. Closes: #178435.
136 * When installing build-deps, make sure the new version will
137 satisfy build requirements. Closes: #178121
138 * Split offline and guide documentation into apt-doc. This was done so
139 that binary-arch builds do not require documention deps. Note, that
140 apt-doc is not installed on upgrades.
141 * Use doc-base, instead of dhelp directly. Closes: #110389
142 * Change http message 'Waiting for file' to 'Waiting for headers'.
144 * Remove trailing lines on package lists in apt-get. Closes: #178736.
145 * Fix origin pins for file:// uris. Closes: #189014.
146 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
148 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
150 * Fix some typos in the apt-get manual. Closes: #163932.
151 * Apply patch from bug, to change frozen to testing, and then do it
152 everywhere else. Closes: #165085.
153 * Update es.po. Closes: #183111.
154 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
156 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
157 * Add option to apt-get to show versions of packages being
159 * Be quiet in apt.post{inst,rm}. Closes: #70685.
160 * apt-get now prints out suggested and recommended packages. Closes:
162 * Insert some newlines in the cdrom change media message. Closes:
164 * Add a rdepends command to apt-cache. Closes: #159864.
165 * When building the dpkg command line, allow for 8192 chars to be used,
166 instead of only 1024.
167 * APT::Immediate-Configure had inverted semantics(false meant it was
168 enabled). Closes: #173619.
169 * Fix status file parser so that if a record is larger than 32k, the
170 buffer size will be doubled, and the read attempted again. Closes:
173 -- Adam Heath <doogie@debian.org> Sun, 27 Apr 2003 01:23:12 -0500
175 apt (0.5.4) unstable; urgency=low
177 * M68k config.guess patch. Closes: #88913
178 * Bi-yearly test on OpenBSD and Solaris
179 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
180 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
182 * Various cosmetic code updates. Closes: #89066, #89066, #89152
183 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
185 * More patches from Alfredo for Vendors and more SHA-1 stuff
186 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
187 similar situations. Closes: #56708, #59432
188 * no_proxy and ftp. Closes: #89671
189 * Philippe Batailler's man page patches.
190 * Fix for display bug. Closes: #92033, #93652, #98468
191 * Use more than 16bits for the dep ID. Some people ran out..
192 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
193 #106911, #107395, #108968
194 * Reordered some things to make dante and FTP happier. Closes: #92757
195 * James R. Van Zandt's guide.sgml updates. Closes: #90027
196 * apt-ftparchive copes with no uncompressed package files + contents.
197 * French man pages from philippe batailler - well sort of. They
199 * run-parts. Closes: #94286
200 * 'apt-cache policy' preferences debug tool.
201 * Whatever. Closes: #89762
202 * libstdc++ and HURD. Closes: #92025
203 * More apt-utils verbage. Closes: #86954
204 * Fliped comparision operator. Closes: #94618
205 * Used the right copyright file. Closes: #65691
206 * Randolph's G++3 patches.
207 * Fixed no_proxy tokanizing. Closes: #100046
208 * Strip Config-Version when copying status to available. Closes: #97520
209 * Segfault with missing source files. Closes: #100325
210 * EINTR check. Closes: #102293
211 * Various changes to the locking metholodgy for --print-uris.
213 * Lame LD_LIBRARY_PATH thing. Closes: #98928
214 * apt-cache search searchs provide names too now. Closes: #98695
215 * Checksum and long lines problem. Closes: #106591
216 * .aptignr and empty files are just a warning. Closes: #97364
218 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
220 apt (0.5.3) unstable; urgency=low
222 * JoeyH's dpkg::preconfig not working. Closes: #88675
223 * Fixed apt override disparity
224 * Alfredo's SHA-1 and related patches
226 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
228 apt (0.5.2) unstable; urgency=low
230 * Fixed mention of /usr/doc in the long description
231 * JoeyH's downgrade bug -- don't use 0.5.1
232 * Doc bug. Closes: #88538
233 * Fault in building release strings. Closes: #88533
235 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
237 apt (0.5.1) unstable; urgency=low
239 * Fixed #82894 again, or should be and.
240 * Process the option string right. Closes: #86921
241 * Don't eat the last command for pipes. Closes: #86923
242 * Ignore .* for configuration directory processing. Closes: #86923
243 * Alfredo's no_proxy patch
244 * Documentation fixes. Closes: #87091
245 * JoeyH's double slash bug. Closes: #87266
246 * Unintitialized buffer and apt-ftparchive contents generation.
248 * Build-deps on virtual packages. Closes: #87639
249 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
250 libstdc++ version info in the library soname and in the package
251 provides. Closes: #87426
252 * Updated soname version to 0.3.2
253 * apt-extracttemplates moved from debconf into apt-utils
254 * s390 archtable entry. Closes: #88232
256 * Some instances where the status file can source a package in a
257 non-sensical way. Closes: #87390
258 * Work better if there are duplicate sources.list entries.
259 * Fixed the resetting of Dir with "dir {};". Closes: #87323
261 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
263 apt (0.5.0) unstable; urgency=low
265 * Fixed an obscure bug with missing final double new lines in
267 * Changed the apt-cdrom index copy routine to use the new section
269 * Added a package file sorter, apt-sortpkgs
270 * Parse obsolete Optional dependencies.
271 * Added Ben's rsh method. Closes: #57794
272 * Added IPv6 FTP support and better DNS rotation support.
273 * Include the server IP in error messages when using a DNS rotation.
275 * Made most of the byte counters into doubles to prevent 32bit overflow.
277 * HTTP Authorization. Closes: #61158
278 * Ability to parse and return source index build depends from Randolph.
279 * new 'apt-get build-dep' command from Randolph. Closes: #63982
280 * Added apt-ftparchive the all dancing all singing FTP archive
282 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
284 * Removed useless internal cruft including the xstatus file.
285 * Fixed config parser bugs. Closes: #67848, #71108
286 * Brain Damanged apt-get config options changed, does not change the command
287 line interface, except to allow --enable-* to undo a configuration
290 No-Download -> Download
291 No-Upgrade -> Upgrade
292 * Made this fix configable (DSelect::CheckDir) and default to disabled:
293 * No remove prompt if the archives dir has not changed. Closes: #55709
294 Because it is stupid in the case where no files were downloaded due to
295 a resumed-aborted install, or a full cache! Closes: #65952
296 * Obscure divide by zero problem. Closes: #64394
297 * Update sizetable for mips. Closes: #62288
298 * Fixed a bug with passive FTP connections
299 * Has sizetable entry for sparc64. Closes: #64869
300 * Escape special characters in the ::Label section of the cdroms.lst
301 * Created apt-utils and python-apt packages
302 * Due to the new policy engine, the available file may contain entries
303 from the status file. These are generated if the package is not obsolete
304 but the policy engine prohibits using the version from the package files.
305 They can be identified by the lack of a Filename field.
306 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
307 #36223, #33468, #22551
308 * Fixed deb-src line for non-us. Closes: #71501, #71601
309 * Fixes for G++ 2.96, s/friend/friend class/
310 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
311 * Confirmed fix for missing new line problem. Closes: #69386
312 * Fixed up dhelp files. Closes: #71312
313 * Added some notes about dselect and offline usage. Closes: #66473, #38316
314 * Lock files on read only file systems are ignored w/ warning.
316 * apt-get update foo now gives an error! Closes: #42891
317 * Added test for shlibs on hurd. Closes: #71499
318 * Clarified apt-cache document. Closes: #71934
319 * DocBook SGML man pages and some improvements in the text..
320 * sigwinch thing. Closes: #72382
321 * Caching can be turned off by setting the cache file names blank.
322 * Ignores arches it does not know about when autocleaning. Closes: #72862
323 * New function in apt-config to return dirs, files, bools and integers.
324 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
325 complex cases involving OR groups and provides.
326 68754 describes confusing messages which are the result of this..
327 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
328 * Speeling mistake and return code for the 'wicked' resolver error
329 Closes: #72621, #75226, #77464
330 * Solved unable to upgrade libc6 from potato to woody due to 3 package
331 libc6 dependency loop problem.
332 * Leading sources.list spaces. Closes: #76010
333 * Removed a possible infinite loop while processing installations.
334 * Man page updates. Closes: #75411, #75560, #64292, #78469
335 * ReduceSourceList bug. Closes: #76027
336 * --only-source option. Closes: #76320
337 * Typos. Closes: #77812, #77999
338 * Different status messages. Closes: #76652, #78353
339 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
340 * OS detection an support for the new pseduo standard of os-arch for the
341 Architecture string. Also uses regexing.. Closes: #39227, #72349
342 * Various i18n stuff. Note that this still needs some i18n wizard
343 to do the last gettextization right. Closes: #62386
344 * Fixed a problem with some odd http servers/proxies that did not return
345 the content size in the header. Closes: #79878, #44379
346 * Little acquire bugs. Closes: #77029, #55820
347 * _POSIX_THREADS may not be defined to anything, just defined..
349 * Spelling of Ignore-Hold correctly. Closes: #78042
350 * Unlock the dpkg db if in download only mode. Closes: #84851
351 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
352 * Patch from BenC. Closes: #80810
353 * Single output of some names in lists. Closes: #80498, #43286
354 * Nice message for people who can't read syserror output. Closes: #84734
355 * OR search function. Closes: #82894
356 * User's guide updates. Closes: #82469
357 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
358 * Various CD bugs, again thanks to Greenbush
359 Closes: #80946, #76547, #71810, #70049, #69482
360 * Using potato debhelper. Closes: #57977
361 * I cannot self-terminate. Closes: #74928
363 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
365 apt (0.3.19) frozen unstable; urgency=low
367 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
369 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
370 * Fixed hardcoded path. Closes: #59743
371 * Fixed Jay's relative path bug
372 * Allowed source only CDs. Closes: #58952
373 * Space check is supressed if --print-uris is given. Closes: #58965
374 * Clarified the documenation examples for non-us. Closes: #58646
375 * Typo in the package description. Closes: #60230
376 * Man Page typo. Closes: #60347
377 * Typo in Algorithms.cc. Closes: #63577
378 * Evil dotty function in apt-cache for generating dependency graphs
379 with the as-yet-unpackaged GraphVis.
380 * Appears to have been fixed in Janurary.. Closes: #57981
381 * New config.guess/sub for the new archs. Closes: #60874
382 * Fixed error reporting for certain kinds of resolution failures.
384 * Made autoclean respect 'q' settings. Closes: #63023
385 * Fixed up the example sources.list. Closes: #63676
386 * Added DPkg::FlushSTDIN to control the flushing of stdin before
387 forking dpkg. Closes: #63991
389 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
391 apt (0.3.18) frozen unstable; urgency=low
393 * Changes in the postinst script. Closes: #56855, #57237
394 * Fixed bashism. Closes: #57216, #57335
395 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
397 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
399 apt (0.3.17) unstable; urgency=low
401 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
402 * Fixed the configuration parser to not blow up if ; is in the config
404 * Applied visual patch to dselect install script . Closes #55214
405 * Included the configure-index example
407 * Library soname has increased
408 * Fixed default sources.list to have correct URLs for potato when it
410 * Added a message about erasing sources.list to dselect setup script
412 * No remove prompt if the archives dir has not changed. Closes: #55709
413 * Fixed inclusion of 2nd sample config file. Closes: #55374
414 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
417 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
419 apt (0.3.16) unstable; urgency=low
421 * Made --no-download work. Closes: #52993
422 * Now compiles on OpenBSD, Solaris and HP-UX
423 * Clarify segfault errors
424 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
425 * Fix for Joel's discovery of glibc removal behavoir.
426 * Fix for Ben Collins file: uri from slink upgrade.
427 * Fixed resume code in FTP. Closes: #54323
428 * Take more precautions to prevent the corruption Joey Hess saw.
429 * Fixed --no-list-cleanup
430 * RFC 2732 URI parsing ([] for hostnames).
431 * Typo in apt-cache man page. Closes: #54949
433 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
435 apt (0.3.15) unstable; urgency=low
437 * Added DSelect::WaitAfterDownload Closes: #49549
438 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
439 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
440 * Made -s and clean not do anything. Closes: #50238
441 * Problem with Protected packages and the new OR code.
442 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
443 * Remove doesn't require a package to be installable. Closes: #51175
444 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
446 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
448 apt (0.3.14) unstable; urgency=low
450 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
451 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
452 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
453 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
454 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
455 Closes: #45034, #45695, #46537
456 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
457 * Added APT::Clean-Installed option. Closes: #45973
458 * Moves the free space check to after the calculated size is printed.
459 Closes: #46639, #47498
460 * mipsel arch Closes: #47614
461 * Beautified URI printing to not include passwords Closes: #46857
462 * Fixed little problem with --no-download Closes: #47557
463 * Tweaked Dselect 'update' script to re-gen the avail file even in the
464 event of a failure Closes: #47112
465 * Retries for source archives too Closes: #47529
466 * Unmounts CDROMs iff it mounted them Closes: #45299
467 * Checks for the partial directories before doing downloads Closes: #47392
468 * no_proxy environment variable (http only!) Closes: #43476
469 * apt-cache showsrc Closes: #45799
470 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
471 * Regexs for install. Closes: #35304, #38835
472 * Dependency reports now show OR group relations
473 * Re-Install feature. Cloes: #46961, #37393, #38919
474 * Locks archive directory on clean (woops)
475 * Remove is not 'sticky'. Closes: #48392
476 * Slightly more accurate 'can not find package' message. Closes: #48311
477 * --trivial-only and --no-remove. Closes: #48518
478 * Increased the cache size. Closes: #47648
479 * Comment woopsie. Closes: #48789
480 * Removes existing links when linking sources. Closes: #48775
481 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
482 * Clearer usage message about 'source' Closes: #48858
483 * Immediate configure internal error Closes: #49062, #48884
485 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
487 apt (0.3.13) unstable; urgency=low
489 * Fix timestamp miss in FTP. Closes: #44363
490 * Fix sorting of Kept packages. Closes: #44377
491 * Fix Segfault for dselect-upgrade. Closes: #44436
492 * Fix handling of '/' for the dist name. Closes #43830
493 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
494 * Add commented-out deb-src URI to default sources.list file.
496 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
498 apt (0.3.12) unstable; urgency=low
500 * Fix for typo in the dhelp index. Closes: #40377
501 * Multiple media swap support
502 * Purge support. Closes: #33291, #40694
503 * Better handling of - remove notation. Closes: #41024
504 * Purge support. Closes: #33291, #40694
505 * Error code on failed update. Closes: #41053
506 * apt-cdrom adds entries for source directories. Closes: #41231
507 * Sorts the output of any list. Closes: #41107
508 * Fixes the looping problem. Closes: #41784, #42414, #44022
509 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
510 * More checks to keep the display sane. Particularly when fail-over is
511 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
512 * PThread lockup problem on certain sparc/m68k. Closes: #40628
513 * apt-cdrom understands .gz Package files too. Closes: #42779
514 * Spelling error in dselect method description. Closes: #43251
515 * Added security to the default source list. Closes: #43356
517 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
519 apt (0.3.11) unstable; urgency=low
521 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
522 * Fix for properly upgrading the system from perl 5.004 to 5.005
524 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
526 apt (0.3.9) unstable; urgency=low
528 * Spelling error in cachefile.cc. Closes: #39885
529 * Trailing slash in dselect install if you try to use the
530 default config file. Closes: #40011
531 * Simulate works for autoclean. Closes: #39141
532 * Fixed spelling errors. Closes: #39673
533 * Changed url parsing a bit. Closes: #40070, #40069
534 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
536 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
538 apt (0.3.7) unstable; urgency=low
540 * Fixed missing text in the apt-get(8) page. Closes: #37596
541 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
542 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
543 * Fixed handling of the -q option with not-entirely integer arguments
545 * Man page typo Closes: #37762
546 * Fixed parsing of the Source: line. Closes: #37679
547 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
548 * Added a check for an empty cache directory. Closes: #37963
549 * Return a failure code if -d is given and packages fail to download.
551 * Arranged for an ftp proxy specifing an http server to work. See the
552 important note in the sources.list man page.
553 * Accounted for resumed files in the cps calculation. Closes: #36787
554 * Deal with duplicate same version different packages. Closes: #30237
555 * Added --no-download. Closes: #38095
556 * Order of apt-cdrom dist detection. Closes: #38139
557 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
559 * Suggests dpkg-dev for apt-get source. Closes: #38158
560 * Fixed typo in apt-get help. Closes: #38712
561 * Improved the error message in the case of broken held package. Closes: #38777
562 * Fixed handling of MD5 failures
563 * Documented list notation Closes: #39008
564 * Change the 'b' to 'B'. Closes: #39007
566 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
568 apt (0.3.6) unstable; urgency=low
570 * Note that 0.3.5 never made it out the door..
571 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
572 * Made APT print numbers in decimal. Closes: #35617, #37319
573 * Buffer munching fix for FTP. Closes: #35868
574 * Typo in sample config file. Closes: #35907
575 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
576 * Changed installed size counter to only count unpacked packages.
578 * apt-get source support. Closes: #23934, #27190
579 * Renames .debs that fail MD5 checking, provides automatic corruption
580 recovery. Closes: #35931
581 * Fixed autoconf verison. Closes: #37305
582 * Random Segfaulting. Closes: #37312, #37530
583 * Fixed apt-cache man page. Closes: #36904
584 * Added a newline to apt-cache showpkg. Closes: #36903
586 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
588 apt (0.3.4) unstable; urgency=low
590 * Release for Ben while he is out of town.
591 * Checked the size of partial files. Closes: #33705
592 * apt-get should not print progress on non-tty. Closes: #34944
593 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
594 * Applied cdrom patches from Torsten. Closes: #35140, #35141
595 * smbmounted cdrom fix. Closes: #35470
596 * Changed ie to eg. Closes: #35196
598 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
600 apt (0.3.3) unstable; urgency=low
602 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
604 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
606 apt (0.3.2) unstable; urgency=low
608 * Major release into unstable of v3
609 * These bugs have been fixed, explanations are in the bug system, read
610 the man pages as well..
611 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
612 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
613 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
614 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
615 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
616 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
617 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
618 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
620 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
622 apt (0.3.1) experimental; urgency=low
624 * Minor release of cvs version.
625 * Added virtual package libapt-pkgx.x
627 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
629 apt (0.3.0) experimental; urgency=low
631 * New experimental version.
633 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
635 apt (0.1.9) frozen unstable; urgency=low
637 * Return to the wacky numbering for when we build 0.1.8 for hamm
638 * Important bug related to APT on the Alpha fixed
639 * apt-get dist-upgrade problems fixed
640 * tiny patch for http method to fix an endless loop
641 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
642 libtool and add proper shared lib dependancies
643 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
644 in case an old libpkg is installed while building APT to prevent
645 spurious dependancies
647 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
649 apt (0.1.7) unstable; urgency=low
651 * New build with libstdc++2.9.
652 * Various fixes; read the Changelog.
654 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
656 apt (0.1.6) unstable; urgency=low
658 * Various fixes in the FTP method for error checking. Fixes: #26188.
659 * Spelling corrections in dselect method. Fixes: #25884
660 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
661 * No more bo releases: we're using a normal numbering system now.
663 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
665 apt (0.1.5) unstable; urgency=low
667 * Changed sources.list to point to 'unstable' by default, as
668 'frozen' no longer exists!
670 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
672 apt (0.1.3) unstable; urgency=low
674 * New upstreamish version.
675 * ftp method rewritten in C. Removes dependancies on all perl/perl
676 related modules. This fixes many of the ftp method bugs.
678 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
680 apt (0.1.1) unstable; urgency=low
682 * Release for unstable.
684 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
686 apt (0.1) unstable; urgency=low
688 * Kludge to fix problem in libnet-perl with illegal anonymous
690 * Moved to unstable; apt is in a useable state now.
691 * Fixed version numbering. From now on, numbering will be:
692 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
693 0.1.1 (release for unstable). Thanks, Manoj.
695 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
697 apt (0.0.17-1) experimental; urgency=low
699 * Fixed problem with libc6 version compare
700 * Scott's away for a while, so I'll be packaging apt for the time
703 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
705 apt (0.0.16-1) experimental; urgency=low
707 * Modifications to make apt-get more friendly when backgrounded.
708 * Updated documentation.
709 * Updates to graphic widgets
711 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
713 apt (0.0.15-0.2bo) experimental; urgency=low
716 * Bob Hilliards crash
718 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
720 apt (0.0.15-0.1bo) experimental; urgency=low
725 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
727 apt (0.0.15) experimental; urgency=low
729 * Clean up source tarball (no user-visible changes)
731 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
733 apt (0.0.14) experimental; urgency=low
735 * Updates in ordering code to make sure certain upgrades work correctly.
736 * Made dselect/setup understand ftp as well as http
738 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
740 apt (0.0.13-bo1) experimental; urgency=low
744 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
746 apt (0.0.13) experimental; urgency=low
748 * Remove hardcoded egcc from debian/rules (#21575)
749 * Fixes for ordering logic when system has a number of unpacked
750 but unconfigured packages installed.
751 * Spelling fix in dselect install method (#22556)
753 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
755 apt (0.0.12) experimental; urgency=low
757 * Fixed problems with package cache corruption.
758 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
760 * Interface and documentation improvements.
762 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
764 apt (0.0.11) experimental; urgency=low
766 * Change dependancies to pre-depends since breaking your packaging tools
767 in the middle of an installation isn't very good.
768 * Bug fixes to ftp method and general apt-get code
770 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
772 apt (0.0.10) experimental; urgency=low
774 * Run "dpkg --configure -a" after an aborted dselect install
775 * Fixed problem with install looping
776 * Support for authenticating proxys: (note this isn't terribly secure)
777 http_proxy="http://user:pass@firewall:port/"
778 * Substitute $ARCH in sources.list
779 * Fixes in the resumption code for ftp
781 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
783 apt (0.0.9) experimental; urgency=low
786 * Various other less visible bug fixes.
787 * Fixed problem with segfault when apt-get invoked in a non-existant
788 directory (Bug #21863)
789 * Bumped policy to 2.4.1
791 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
793 apt (0.0.8) experimental; urgency=low
795 * Fixed generated available file (Bug #21836)
796 * Added download ETA (Bug #21774).
797 * Fixed hardcoded ARCH (Bug #21751).
798 * Fixed check on http_proxy (Bug #21795).
799 * Added download speed indicator.
801 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
803 apt (0.0.7) experimental; urgency=low
805 * Remove libdeity and apt from package for now, since only apt-get and
806 apt-cache are actually useful right now.
807 * Clean up handling of package installation errors.
808 * Added timeout to http transfers (#21269)
809 * Updated setup for dselect/apt method.
811 * Long options (added in 0.0.6)
813 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
815 apt (0.0.6) experimental; urgency=low
818 * Revamped download status display.
819 * Call apt-get clean after successful install in dselect.
820 * Added "apt-get clean" which deletes package files from /var/cache/apt
822 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
824 apt (0.0.5) experimental; urgency=low
826 * Ignore signals while dpkg is running so we don't leave dpkg running in
827 the background (#20804)
828 * Check Packages as well as Packages.gz for file URIs (#20784)
829 * Spelling cleanup (#20800)
830 * Added -m option to permit upgrade to go on in the case of a bad mirror.
831 This option may result in incomplete upgrades when used with -f.
833 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
835 apt (0.0.4) experimental; urgency=low
838 * Various documentation updates and cleanup.
839 * Added '-f' option to apt-get attempt to fix broken dependancies.
841 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
843 apt (0.0.3) experimental; urgency=low
845 * Added a shlibs.local file to prevent apt from depending on itself.
846 * Updates to how apt-get handles bad states in installed packages.
847 * Updated rules to make sure build works from a freshly checked out source
848 archive. Building from CVS needs libtool/automake/autoconf, builds from
849 the distributed source package should have no such dependancy.
851 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
853 apt (0.0.2) unstable; urgency=low
855 * Updates to apt-get and http binding for dselect method (apt).
856 * Updating version number from 0.0.1, which was released only on IRC.
858 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
860 apt (0.0.1) unstable; urgency=low
864 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500