]> git.saurik.com Git - apt.git/blob - debian/rules
Changed ld_library_path
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.35 2001/08/03 04:58:10 jgg Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DH_COMPAT=2
18
19 # See below
20 include build/environment.mak
21
22 # Default rule
23 build:
24
25 DEB_BUILD_PROG:=debuild -us -uc
26 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
27 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
28
29 # Determine the build directory to use
30 BASE=.
31 ifdef BUILD
32 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
33 else
34 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
35 endif
36 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
37 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
38 override BLD := $(BUILDX)
39
40 ifeq ($(words $(BLD)),0)
41 override BLD := ./build
42 endif
43
44 # Rebuild configure.in to have the correct version from the change log
45 ifneq ($(APT_DEBVER),$(APT_CONFVER))
46 .PHONY: configure.in
47 configure.in:
48 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
49 else
50 configure.in:
51 endif
52
53 # APT Programs in apt-utils
54 APT_UTILS=ftparchive sortpkgs extracttemplates
55
56 # Uncomment this to turn on verbose mode.
57 #export DH_VERBOSE=1
58
59 # Find the libapt-pkg major version for use in other control files
60 export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
61 export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
62
63 # Determine which package we should provide in the control files
64 LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
65 LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
66
67 debian/shlibs.local: apt-pkg/makefile
68 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
69 # one for the rest of the packages. This ensures that each package gets
70 # the right overrides..
71 rm -rf $@ $@.apt $@.apt-utils
72 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
73
74 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
75 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
76
77 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
78 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
79
80 build: build/build-stamp
81
82 # Note that this is unconditionally done first as part of loading environment.mak
83 # The true is needed to force make to reload environment.mak after running
84 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
85 build/environment.mak: build/configure-stamp
86 @true
87
88 configure: configure.in
89 build/configure-stamp: configure
90 dh_testdir
91 -mkdir build
92 cp COPYING debian/copyright
93 (cd build; ../configure)
94 touch $@
95
96 build/build-stamp: build/configure-stamp
97 # Add here commands to compile the package.
98 $(MAKE) -s
99 touch $@
100
101 clean:
102 dh_testdir
103 # dh_testroot
104 rm -f build-stamp debian/shlibs.local
105 rm -rf build
106 rm -f debian/shlibs.local.apt debian/shlibs.local.apt-utils
107
108 # Add here commands to clean up after the build process.
109 -$(MAKE) clean
110 -$(MAKE) distclean
111 dh_clean
112
113 binary-indep: libapt-pkg-doc
114 # Build architecture-independent files here.
115 libapt-pkg-doc: build debian/shlibs.local
116 dh_testdir -p$@
117 dh_testroot -p$@
118 dh_clean -p$@ -k
119 dh_installdirs -p$@
120 #
121 # libapt-pkg-doc install
122 #
123 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
124 $(BLD)/docs/files* $(BLD)/docs/method* \
125 doc/libapt-pkg2_to_3.txt doc/style.txt
126
127 -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
128 -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
129
130 dh_installexamples -p$@
131 # dh_installmenu -p$@
132 # dh_installinit -p$@
133 # dh_installcron -p$@
134 # dh_installmanpages -p$@
135
136 # dh_undocumented -p$@
137 dh_installchangelogs -p$@
138 dh_strip -p$@
139 dh_compress -p$@
140 dh_fixperms -p$@
141 # dh_suidregister -p$@
142 dh_installdeb -p$@
143 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
144 dh_md5sums -p$@
145 dh_builddeb -p$@
146
147
148 # Build architecture-dependent files here.
149
150 binary-arch: apt libapt-pkg-dev apt-utils
151 apt: build debian/shlibs.local
152 dh_testdir -p$@
153 dh_testroot -p$@
154 dh_clean -p$@ -k
155 dh_installdirs -p$@
156 #
157 # apt install
158 #
159 cp $(BLD)/bin/apt-* debian/apt/usr/bin/
160
161 # Remove the bits that are in apt-utils
162 rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
163
164 # install the shared libs
165 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
166 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
167
168 cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
169
170 cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
171
172 # Copy the guides
173 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
174 $(BLD)/docs/offline.text $(BLD)/docs/offline.html
175
176 # One or the other..
177 -cp -a debian/dhelp debian/apt/usr/doc/apt/.dhelp
178 -cp -a debian/dhelp debian/apt/usr/share/doc/apt/.dhelp
179
180 # head -n 500 ChangeLog > debian/ChangeLog
181
182 dh_installexamples -p$@ $(BLD)/docs/examples/*
183 dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1 apt-extracttemplates.1
184
185 dh_installchangelogs -p$@
186 dh_strip -p$@
187 dh_compress -p$@
188 dh_fixperms -p$@
189 dh_installdeb -p$@
190 dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
191 # LD_LIBRARY_PATH=`pwd`/debian/apt/usr/lib dh_shlibdeps -papt
192 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
193 dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
194 dh_md5sums -p$@
195 dh_builddeb -p$@
196
197 libapt-pkg-dev: build debian/shlibs.local
198 dh_testdir -p$@
199 dh_testroot -p$@
200 dh_clean -p$@ -k
201 dh_installdirs -p$@
202 #
203 # libapt-pkg-dev install
204 #
205 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
206 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
207 #ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
208 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
209
210 dh_installdocs -p$@
211 # dh_installmenu -p$@
212 # dh_installinit -p$@
213 # dh_installcron -p$@
214 # dh_installmanpages -p$@
215
216 dh_installchangelogs -p$@
217 dh_strip -p$@
218 dh_compress -p$@
219 dh_fixperms -p$@
220 # dh_suidregister -p$@
221 dh_installdeb -p$@
222 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
223 dh_md5sums -p$@
224 dh_builddeb -p$@
225
226 apt-utils: build debian/shlibs.local
227 dh_testdir -p$@
228 dh_testroot -p$@
229 dh_clean -p$@ -k
230 dh_installdirs -p$@
231
232 # install the shared libs
233 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
234 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
235
236 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
237 dh_installdocs -p$@
238
239 # Install the man pages..
240 mkdir -p debian/$@/usr/share/man/man1
241 -cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 doc/apt-extracttemplates.1 debian/$@/usr/share/man/man1/
242
243 dh_installchangelogs -p$@
244 dh_strip -p$@
245 dh_compress -p$@
246 dh_fixperms -p$@
247 dh_installdeb -p$@
248 LD_LIBRARY_PATH=\$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
249 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
250 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
251 dh_md5sums -p$@
252 dh_builddeb -p$@
253
254 source diff:
255 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
256
257 # Update from CVS
258 l33ch: really-clean
259 cvs update
260 buildlib/mkChangeLog
261
262 # Update from CVS and then configure for build
263 super-l33ch: l33ch Makefile.in
264
265 configure:
266 $(MAKE) configure
267
268 l33ch-stamp: super-l33ch
269 touch $@
270
271 really-clean: clean
272 -find -name Makefile.in -print0 | xargs -0r rm -f
273 find -name ChangeLog | xargs rm -f
274 rm -f l33ch-stamp
275
276 binary: binary-indep binary-arch
277 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
278
279
280 # Done by the uploader.
281 #cvs update..
282 #edit debian/changelog
283 # configure.in has the version automatically updated now.
284 # edit configure.in
285 # debian/rules cvs-build
286
287 cvs-build:
288 rm -rf debian/cvs-build
289 cvs update
290 #buildlib/mkChangeLog
291 $(MAKE) startup
292 $(MAKE) doc
293 tar c --exclude CVS --exclude cvs-build . |\
294 (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
295 # The next line isn't needed, as debuild will make the .tar.gz for us.
296 # (cd debian/cvs-build;tar zcf apt_$(APT_DEBVER).tar.gz apt-$(APT_DEBVER))
297 (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
298 #rm ChangeLog
299
300 cvs-mkul:
301 -mkdir -p ../upload-$(APT_DEBVER)
302 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)