]> git.saurik.com Git - apt.git/blob - debian/changelog
Some more g++-3.2 fixes.
[apt.git] / debian / changelog
1 apt (0.5.5) unstable; urgency=low
2
3 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
4 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
5 * "apt-get --arch-only build-dep" to install only architecture-
6 dependent build dependencies. Bump minor shared lib number to reflect
7 small change in BuildDepend API.
8 * APT::Build-Essential configuration option (defaults to "build-essential")
9 so that "apt-get build-dep" will ensure build essential packages are
10 installed prior to installing other build-dependencies. Closes: #148879
11 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
12 * /usr/doc reference in postinst. Closes: #126189
13 * Doc updates. Closes: #120689
14 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
15 #131062, #136749
16 * Print special message for EAI_AGAIN. Closes: #131397
17 * libapt-pkg-dev needs to bring in the apt-inst library if linking
18 is to work. Closes: #133943
19 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
20 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
21 #139994, #142955, #151654, #151834, #147611, #154268
22 * Fix possibility for tag file parsing to fail in some unlikely situations.
23 Closes: #139328
24 * Use std C++ names for some header files. Closes: #128741,
25 * Do not check for free space if --no-download. Closes: #117856
26 * Actually implement or group handling for 'upgrade'. Closes: #133950
27 * "Internal Error, Couldn't configure pre-depend" is not actually an
28 internal error, it is a packaging error and now it says so, and
29 pinpoints the problem dependency. Closes: #155621
30 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
31 * Use usr/share/doc for dhelp. Closes: #115701
32 * --print-uris works with 'update'. Closes: #57070
33 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
34 command line.
35 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
36 #142298
37 * Allow an uninstalled package to be marked for removal on an install
38 line (meaning not to automatically install it), also fix some dodgy
39 handling of protected packages. Closes: #92287, #116011
40 * Fix errant prefix matching in version selection. Closes: #105968
41 * Ensure that all files needed to run APT as a user are readable and
42 ignore roots umask for these files. Closes: #108801
43 * Support larger config spaces. Closes: #111914
44 * 'apt-get update' no longer does 'Building Dependency Tree'.
45 * When matching regexs allways print a message. Change regex activation
46 charset. Closes: #147817
47 * Don't die if lines in sources.list are too long. Closes: #146846
48 * Show file name on apt-extracttemplate error messges. Closes: #151835
49 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
50 * Some highly unlikely memory faults. Closes: #155842
51 * C++ stuff for G++3.2. Closes: #162617, #165515,
52 * apt-config dumps sends to stdout not stderr now. Closes: #146294
53 * Fix segfault in FindAny when /i is used, and there is no default.
54 Closes: #165891
55 * Add s390x to archtable. Closese: #160992.
56 * Update config.sub/config.guess in cvs, and add support to debian/rules
57 to update them from /usr/share/misc if they exist. Closes: #155014
58 * Remove 'Sorry' from messages. Closes: #148824.
59 * Change wording of 'additional disk space usage' message. Closes:
60 #135021.
61 * apt-extracttemplates now prepends the package name when extracting
62 files. Closes: #132776
63 * Add -n synonym for --names-only for apt-cache. Closes: #130689
64 * Display both current version and new version in apt-get -s. Closes:
65 #92358
66 * Add an options and timeout config item to ssh/rsh. Closes: #90654
67 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
68 * Change verbose logging output of apt-ftparchive to go to stderr,
69 instead of stdout. Also, errors that occur no longer go to stdout,
70 but stderr. Closes: #161592
71
72 -- Jason Gunthorpe <jgg@debian.org> Sun, 15 Sep 2002 17:16:59 -0600
73
74 apt (0.5.4) unstable; urgency=low
75
76 * M68k config.guess patch. Closes: #88913
77 * Bi-yearly test on OpenBSD and Solaris
78 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
79 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
80 #105606, #105377
81 * Various cosmetic code updates. Closes: #89066, #89066, #89152
82 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
83 update).
84 * More patches from Alfredo for Vendors and more SHA-1 stuff
85 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
86 similar situations. Closes: #56708, #59432
87 * no_proxy and ftp. Closes: #89671
88 * Philippe Batailler's man page patches.
89 * Fix for display bug. Closes: #92033, #93652, #98468
90 * Use more than 16bits for the dep ID. Some people ran out..
91 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
92 #106911, #107395, #108968
93 * Reordered some things to make dante and FTP happier. Closes: #92757
94 * James R. Van Zandt's guide.sgml updates. Closes: #90027
95 * apt-ftparchive copes with no uncompressed package files + contents.
96 * French man pages from philippe batailler - well sort of. They
97 don't build yet..
98 * run-parts. Closes: #94286
99 * 'apt-cache policy' preferences debug tool.
100 * Whatever. Closes: #89762
101 * libstdc++ and HURD. Closes: #92025
102 * More apt-utils verbage. Closes: #86954
103 * Fliped comparision operator. Closes: #94618
104 * Used the right copyright file. Closes: #65691
105 * Randolph's G++3 patches.
106 * Fixed no_proxy tokanizing. Closes: #100046
107 * Strip Config-Version when copying status to available. Closes: #97520
108 * Segfault with missing source files. Closes: #100325
109 * EINTR check. Closes: #102293
110 * Various changes to the locking metholodgy for --print-uris.
111 Closes: #100590
112 * Lame LD_LIBRARY_PATH thing. Closes: #98928
113 * apt-cache search searchs provide names too now. Closes: #98695
114 * Checksum and long lines problem. Closes: #106591
115 * .aptignr and empty files are just a warning. Closes: #97364
116
117 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
118
119 apt (0.5.3) unstable; urgency=low
120
121 * JoeyH's dpkg::preconfig not working. Closes: #88675
122 * Fixed apt override disparity
123 * Alfredo's SHA-1 and related patches
124
125 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
126
127 apt (0.5.2) unstable; urgency=low
128
129 * Fixed mention of /usr/doc in the long description
130 * JoeyH's downgrade bug -- don't use 0.5.1
131 * Doc bug. Closes: #88538
132 * Fault in building release strings. Closes: #88533
133
134 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
135
136 apt (0.5.1) unstable; urgency=low
137
138 * Fixed #82894 again, or should be and.
139 * Process the option string right. Closes: #86921
140 * Don't eat the last command for pipes. Closes: #86923
141 * Ignore .* for configuration directory processing. Closes: #86923
142 * Alfredo's no_proxy patch
143 * Documentation fixes. Closes: #87091
144 * JoeyH's double slash bug. Closes: #87266
145 * Unintitialized buffer and apt-ftparchive contents generation.
146 Closes: #87612
147 * Build-deps on virtual packages. Closes: #87639
148 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
149 libstdc++ version info in the library soname and in the package
150 provides. Closes: #87426
151 * Updated soname version to 0.3.2
152 * apt-extracttemplates moved from debconf into apt-utils
153 * s390 archtable entry. Closes: #88232
154 * Dan's segfault
155 * Some instances where the status file can source a package in a
156 non-sensical way. Closes: #87390
157 * Work better if there are duplicate sources.list entries.
158 * Fixed the resetting of Dir with "dir {};". Closes: #87323
159
160 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
161
162 apt (0.5.0) unstable; urgency=low
163
164 * Fixed an obscure bug with missing final double new lines in
165 package files
166 * Changed the apt-cdrom index copy routine to use the new section
167 rewriter
168 * Added a package file sorter, apt-sortpkgs
169 * Parse obsolete Optional dependencies.
170 * Added Ben's rsh method. Closes: #57794
171 * Added IPv6 FTP support and better DNS rotation support.
172 * Include the server IP in error messages when using a DNS rotation.
173 Closes: #64895
174 * Made most of the byte counters into doubles to prevent 32bit overflow.
175 Closes: #65349
176 * HTTP Authorization. Closes: #61158
177 * Ability to parse and return source index build depends from Randolph.
178 * new 'apt-get build-dep' command from Randolph. Closes: #63982
179 * Added apt-ftparchive the all dancing all singing FTP archive
180 maintinance program
181 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
182 in apt-get.
183 * Removed useless internal cruft including the xstatus file.
184 * Fixed config parser bugs. Closes: #67848, #71108
185 * Brain Damanged apt-get config options changed, does not change the command
186 line interface, except to allow --enable-* to undo a configuration
187 option:
188 No-Remove -> Remove
189 No-Download -> Download
190 No-Upgrade -> Upgrade
191 * Made this fix configable (DSelect::CheckDir) and default to disabled:
192 * No remove prompt if the archives dir has not changed. Closes: #55709
193 Because it is stupid in the case where no files were downloaded due to
194 a resumed-aborted install, or a full cache! Closes: #65952
195 * Obscure divide by zero problem. Closes: #64394
196 * Update sizetable for mips. Closes: #62288
197 * Fixed a bug with passive FTP connections
198 * Has sizetable entry for sparc64. Closes: #64869
199 * Escape special characters in the ::Label section of the cdroms.lst
200 * Created apt-utils and python-apt packages
201 * Due to the new policy engine, the available file may contain entries
202 from the status file. These are generated if the package is not obsolete
203 but the policy engine prohibits using the version from the package files.
204 They can be identified by the lack of a Filename field.
205 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
206 #36223, #33468, #22551
207 * Fixed deb-src line for non-us. Closes: #71501, #71601
208 * Fixes for G++ 2.96, s/friend/friend class/
209 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
210 * Confirmed fix for missing new line problem. Closes: #69386
211 * Fixed up dhelp files. Closes: #71312
212 * Added some notes about dselect and offline usage. Closes: #66473, #38316
213 * Lock files on read only file systems are ignored w/ warning.
214 Closes: #61701
215 * apt-get update foo now gives an error! Closes: #42891
216 * Added test for shlibs on hurd. Closes: #71499
217 * Clarified apt-cache document. Closes: #71934
218 * DocBook SGML man pages and some improvements in the text..
219 * sigwinch thing. Closes: #72382
220 * Caching can be turned off by setting the cache file names blank.
221 * Ignores arches it does not know about when autocleaning. Closes: #72862
222 * New function in apt-config to return dirs, files, bools and integers.
223 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
224 complex cases involving OR groups and provides.
225 68754 describes confusing messages which are the result of this..
226 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
227 * Speeling mistake and return code for the 'wicked' resolver error
228 Closes: #72621, #75226, #77464
229 * Solved unable to upgrade libc6 from potato to woody due to 3 package
230 libc6 dependency loop problem.
231 * Leading sources.list spaces. Closes: #76010
232 * Removed a possible infinite loop while processing installations.
233 * Man page updates. Closes: #75411, #75560, #64292, #78469
234 * ReduceSourceList bug. Closes: #76027
235 * --only-source option. Closes: #76320
236 * Typos. Closes: #77812, #77999
237 * Different status messages. Closes: #76652, #78353
238 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
239 * OS detection an support for the new pseduo standard of os-arch for the
240 Architecture string. Also uses regexing.. Closes: #39227, #72349
241 * Various i18n stuff. Note that this still needs some i18n wizard
242 to do the last gettextization right. Closes: #62386
243 * Fixed a problem with some odd http servers/proxies that did not return
244 the content size in the header. Closes: #79878, #44379
245 * Little acquire bugs. Closes: #77029, #55820
246 * _POSIX_THREADS may not be defined to anything, just defined..
247 Closes: #78996
248 * Spelling of Ignore-Hold correctly. Closes: #78042
249 * Unlock the dpkg db if in download only mode. Closes: #84851
250 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
251 * Patch from BenC. Closes: #80810
252 * Single output of some names in lists. Closes: #80498, #43286
253 * Nice message for people who can't read syserror output. Closes: #84734
254 * OR search function. Closes: #82894
255 * User's guide updates. Closes: #82469
256 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
257 * Various CD bugs, again thanks to Greenbush
258 Closes: #80946, #76547, #71810, #70049, #69482
259 * Using potato debhelper. Closes: #57977
260 * I cannot self-terminate. Closes: #74928
261
262 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
263
264 apt (0.3.19) frozen unstable; urgency=low
265
266 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
267 Paul Wade.
268 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
269 * Fixed hardcoded path. Closes: #59743
270 * Fixed Jay's relative path bug
271 * Allowed source only CDs. Closes: #58952
272 * Space check is supressed if --print-uris is given. Closes: #58965
273 * Clarified the documenation examples for non-us. Closes: #58646
274 * Typo in the package description. Closes: #60230
275 * Man Page typo. Closes: #60347
276 * Typo in Algorithms.cc. Closes: #63577
277 * Evil dotty function in apt-cache for generating dependency graphs
278 with the as-yet-unpackaged GraphVis.
279 * Appears to have been fixed in Janurary.. Closes: #57981
280 * New config.guess/sub for the new archs. Closes: #60874
281 * Fixed error reporting for certain kinds of resolution failures.
282 Closes: #61327
283 * Made autoclean respect 'q' settings. Closes: #63023
284 * Fixed up the example sources.list. Closes: #63676
285 * Added DPkg::FlushSTDIN to control the flushing of stdin before
286 forking dpkg. Closes: #63991
287
288 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
289
290 apt (0.3.18) frozen unstable; urgency=low
291
292 * Changes in the postinst script. Closes: #56855, #57237
293 * Fixed bashism. Closes: #57216, #57335
294 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
295
296 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
297
298 apt (0.3.17) unstable; urgency=low
299
300 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
301 * Fixed the configuration parser to not blow up if ; is in the config
302 string
303 * Applied visual patch to dselect install script . Closes #55214
304 * Included the configure-index example
305 * Minimal CD swaps
306 * Library soname has increased
307 * Fixed default sources.list to have correct URLs for potato when it
308 becomes stable
309 * Added a message about erasing sources.list to dselect setup script
310 Closes: #55755
311 * No remove prompt if the archives dir has not changed. Closes: #55709
312 * Fixed inclusion of 2nd sample config file. Closes: #55374
313 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
314 Closes: #55991
315
316 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
317
318 apt (0.3.16) unstable; urgency=low
319
320 * Made --no-download work. Closes: #52993
321 * Now compiles on OpenBSD, Solaris and HP-UX
322 * Clarify segfault errors
323 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
324 * Fix for Joel's discovery of glibc removal behavoir.
325 * Fix for Ben Collins file: uri from slink upgrade.
326 * Fixed resume code in FTP. Closes: #54323
327 * Take more precautions to prevent the corruption Joey Hess saw.
328 * Fixed --no-list-cleanup
329 * RFC 2732 URI parsing ([] for hostnames).
330 * Typo in apt-cache man page. Closes: #54949
331
332 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
333
334 apt (0.3.15) unstable; urgency=low
335
336 * Added DSelect::WaitAfterDownload Closes: #49549
337 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
338 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
339 * Made -s and clean not do anything. Closes: #50238
340 * Problem with Protected packages and the new OR code.
341 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
342 * Remove doesn't require a package to be installable. Closes: #51175
343 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
344
345 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
346
347 apt (0.3.14) unstable; urgency=low
348
349 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
350 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
351 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
352 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
353 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
354 Closes: #45034, #45695, #46537
355 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
356 * Added APT::Clean-Installed option. Closes: #45973
357 * Moves the free space check to after the calculated size is printed.
358 Closes: #46639, #47498
359 * mipsel arch Closes: #47614
360 * Beautified URI printing to not include passwords Closes: #46857
361 * Fixed little problem with --no-download Closes: #47557
362 * Tweaked Dselect 'update' script to re-gen the avail file even in the
363 event of a failure Closes: #47112
364 * Retries for source archives too Closes: #47529
365 * Unmounts CDROMs iff it mounted them Closes: #45299
366 * Checks for the partial directories before doing downloads Closes: #47392
367 * no_proxy environment variable (http only!) Closes: #43476
368 * apt-cache showsrc Closes: #45799
369 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
370 * Regexs for install. Closes: #35304, #38835
371 * Dependency reports now show OR group relations
372 * Re-Install feature. Cloes: #46961, #37393, #38919
373 * Locks archive directory on clean (woops)
374 * Remove is not 'sticky'. Closes: #48392
375 * Slightly more accurate 'can not find package' message. Closes: #48311
376 * --trivial-only and --no-remove. Closes: #48518
377 * Increased the cache size. Closes: #47648
378 * Comment woopsie. Closes: #48789
379 * Removes existing links when linking sources. Closes: #48775
380 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
381 * Clearer usage message about 'source' Closes: #48858
382 * Immediate configure internal error Closes: #49062, #48884
383
384 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
385
386 apt (0.3.13) unstable; urgency=low
387
388 * Fix timestamp miss in FTP. Closes: #44363
389 * Fix sorting of Kept packages. Closes: #44377
390 * Fix Segfault for dselect-upgrade. Closes: #44436
391 * Fix handling of '/' for the dist name. Closes #43830
392 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
393 * Add commented-out deb-src URI to default sources.list file.
394
395 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
396
397 apt (0.3.12) unstable; urgency=low
398
399 * Fix for typo in the dhelp index. Closes: #40377
400 * Multiple media swap support
401 * Purge support. Closes: #33291, #40694
402 * Better handling of - remove notation. Closes: #41024
403 * Purge support. Closes: #33291, #40694
404 * Error code on failed update. Closes: #41053
405 * apt-cdrom adds entries for source directories. Closes: #41231
406 * Sorts the output of any list. Closes: #41107
407 * Fixes the looping problem. Closes: #41784, #42414, #44022
408 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
409 * More checks to keep the display sane. Particularly when fail-over is
410 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
411 * PThread lockup problem on certain sparc/m68k. Closes: #40628
412 * apt-cdrom understands .gz Package files too. Closes: #42779
413 * Spelling error in dselect method description. Closes: #43251
414 * Added security to the default source list. Closes: #43356
415
416 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
417
418 apt (0.3.11) unstable; urgency=low
419
420 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
421 * Fix for properly upgrading the system from perl 5.004 to 5.005
422
423 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
424
425 apt (0.3.9) unstable; urgency=low
426
427 * Spelling error in cachefile.cc. Closes: #39885
428 * Trailing slash in dselect install if you try to use the
429 default config file. Closes: #40011
430 * Simulate works for autoclean. Closes: #39141
431 * Fixed spelling errors. Closes: #39673
432 * Changed url parsing a bit. Closes: #40070, #40069
433 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
434
435 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
436
437 apt (0.3.7) unstable; urgency=low
438
439 * Fixed missing text in the apt-get(8) page. Closes: #37596
440 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
441 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
442 * Fixed handling of the -q option with not-entirely integer arguments
443 Closes: #37499
444 * Man page typo Closes: #37762
445 * Fixed parsing of the Source: line. Closes: #37679
446 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
447 * Added a check for an empty cache directory. Closes: #37963
448 * Return a failure code if -d is given and packages fail to download.
449 Closes: #38127
450 * Arranged for an ftp proxy specifing an http server to work. See the
451 important note in the sources.list man page.
452 * Accounted for resumed files in the cps calculation. Closes: #36787
453 * Deal with duplicate same version different packages. Closes: #30237
454 * Added --no-download. Closes: #38095
455 * Order of apt-cdrom dist detection. Closes: #38139
456 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
457 * IPv6 http support
458 * Suggests dpkg-dev for apt-get source. Closes: #38158
459 * Fixed typo in apt-get help. Closes: #38712
460 * Improved the error message in the case of broken held package. Closes: #38777
461 * Fixed handling of MD5 failures
462 * Documented list notation Closes: #39008
463 * Change the 'b' to 'B'. Closes: #39007
464
465 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
466
467 apt (0.3.6) unstable; urgency=low
468
469 * Note that 0.3.5 never made it out the door..
470 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
471 * Made APT print numbers in decimal. Closes: #35617, #37319
472 * Buffer munching fix for FTP. Closes: #35868
473 * Typo in sample config file. Closes: #35907
474 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
475 * Changed installed size counter to only count unpacked packages.
476 Closes: #36201
477 * apt-get source support. Closes: #23934, #27190
478 * Renames .debs that fail MD5 checking, provides automatic corruption
479 recovery. Closes: #35931
480 * Fixed autoconf verison. Closes: #37305
481 * Random Segfaulting. Closes: #37312, #37530
482 * Fixed apt-cache man page. Closes: #36904
483 * Added a newline to apt-cache showpkg. Closes: #36903
484
485 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
486
487 apt (0.3.4) unstable; urgency=low
488
489 * Release for Ben while he is out of town.
490 * Checked the size of partial files. Closes: #33705
491 * apt-get should not print progress on non-tty. Closes: #34944
492 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
493 * Applied cdrom patches from Torsten. Closes: #35140, #35141
494 * smbmounted cdrom fix. Closes: #35470
495 * Changed ie to eg. Closes: #35196
496
497 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
498
499 apt (0.3.3) unstable; urgency=low
500
501 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
502
503 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
504
505 apt (0.3.2) unstable; urgency=low
506
507 * Major release into unstable of v3
508 * These bugs have been fixed, explanations are in the bug system, read
509 the man pages as well..
510 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
511 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
512 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
513 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
514 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
515 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
516 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
517 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
518
519 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
520
521 apt (0.3.1) experimental; urgency=low
522
523 * Minor release of cvs version.
524 * Added virtual package libapt-pkgx.x
525
526 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
527
528 apt (0.3.0) experimental; urgency=low
529
530 * New experimental version.
531
532 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
533
534 apt (0.1.9) frozen unstable; urgency=low
535
536 * Return to the wacky numbering for when we build 0.1.8 for hamm
537 * Important bug related to APT on the Alpha fixed
538 * apt-get dist-upgrade problems fixed
539 * tiny patch for http method to fix an endless loop
540 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
541 libtool and add proper shared lib dependancies
542 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
543 in case an old libpkg is installed while building APT to prevent
544 spurious dependancies
545
546 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
547
548 apt (0.1.7) unstable; urgency=low
549
550 * New build with libstdc++2.9.
551 * Various fixes; read the Changelog.
552
553 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
554
555 apt (0.1.6) unstable; urgency=low
556
557 * Various fixes in the FTP method for error checking. Fixes: #26188.
558 * Spelling corrections in dselect method. Fixes: #25884
559 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
560 * No more bo releases: we're using a normal numbering system now.
561
562 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
563
564 apt (0.1.5) unstable; urgency=low
565
566 * Changed sources.list to point to 'unstable' by default, as
567 'frozen' no longer exists!
568
569 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
570
571 apt (0.1.3) unstable; urgency=low
572
573 * New upstreamish version.
574 * ftp method rewritten in C. Removes dependancies on all perl/perl
575 related modules. This fixes many of the ftp method bugs.
576
577 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
578
579 apt (0.1.1) unstable; urgency=low
580
581 * Release for unstable.
582
583 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
584
585 apt (0.1) unstable; urgency=low
586
587 * Kludge to fix problem in libnet-perl with illegal anonymous
588 FTP passwords.
589 * Moved to unstable; apt is in a useable state now.
590 * Fixed version numbering. From now on, numbering will be:
591 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
592 0.1.1 (release for unstable). Thanks, Manoj.
593
594 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
595
596 apt (0.0.17-1) experimental; urgency=low
597
598 * Fixed problem with libc6 version compare
599 * Scott's away for a while, so I'll be packaging apt for the time
600 being.
601
602 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
603
604 apt (0.0.16-1) experimental; urgency=low
605
606 * Modifications to make apt-get more friendly when backgrounded.
607 * Updated documentation.
608 * Updates to graphic widgets
609
610 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
611
612 apt (0.0.15-0.2bo) experimental; urgency=low
613
614 * Bo compilation
615 * Bob Hilliards crash
616
617 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
618
619 apt (0.0.15-0.1bo) experimental; urgency=low
620
621 * Bo compilation
622 * libstdc++272 patch
623
624 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
625
626 apt (0.0.15) experimental; urgency=low
627
628 * Clean up source tarball (no user-visible changes)
629
630 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
631
632 apt (0.0.14) experimental; urgency=low
633
634 * Updates in ordering code to make sure certain upgrades work correctly.
635 * Made dselect/setup understand ftp as well as http
636
637 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
638
639 apt (0.0.13-bo1) experimental; urgency=low
640
641 * Bo compilation
642
643 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
644
645 apt (0.0.13) experimental; urgency=low
646
647 * Remove hardcoded egcc from debian/rules (#21575)
648 * Fixes for ordering logic when system has a number of unpacked
649 but unconfigured packages installed.
650 * Spelling fix in dselect install method (#22556)
651
652 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
653
654 apt (0.0.12) experimental; urgency=low
655
656 * Fixed problems with package cache corruption.
657 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
658 earlier versions.
659 * Interface and documentation improvements.
660
661 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
662
663 apt (0.0.11) experimental; urgency=low
664
665 * Change dependancies to pre-depends since breaking your packaging tools
666 in the middle of an installation isn't very good.
667 * Bug fixes to ftp method and general apt-get code
668
669 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
670
671 apt (0.0.10) experimental; urgency=low
672
673 * Run "dpkg --configure -a" after an aborted dselect install
674 * Fixed problem with install looping
675 * Support for authenticating proxys: (note this isn't terribly secure)
676 http_proxy="http://user:pass@firewall:port/"
677 * Substitute $ARCH in sources.list
678 * Fixes in the resumption code for ftp
679
680 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
681
682 apt (0.0.9) experimental; urgency=low
683
684 * Added ftp support.
685 * Various other less visible bug fixes.
686 * Fixed problem with segfault when apt-get invoked in a non-existant
687 directory (Bug #21863)
688 * Bumped policy to 2.4.1
689
690 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
691
692 apt (0.0.8) experimental; urgency=low
693
694 * Fixed generated available file (Bug #21836)
695 * Added download ETA (Bug #21774).
696 * Fixed hardcoded ARCH (Bug #21751).
697 * Fixed check on http_proxy (Bug #21795).
698 * Added download speed indicator.
699
700 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
701
702 apt (0.0.7) experimental; urgency=low
703
704 * Remove libdeity and apt from package for now, since only apt-get and
705 apt-cache are actually useful right now.
706 * Clean up handling of package installation errors.
707 * Added timeout to http transfers (#21269)
708 * Updated setup for dselect/apt method.
709 * Updated man pages
710 * Long options (added in 0.0.6)
711
712 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
713
714 apt (0.0.6) experimental; urgency=low
715
716 * Spelling changes.
717 * Revamped download status display.
718 * Call apt-get clean after successful install in dselect.
719 * Added "apt-get clean" which deletes package files from /var/cache/apt
720
721 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
722
723 apt (0.0.5) experimental; urgency=low
724
725 * Ignore signals while dpkg is running so we don't leave dpkg running in
726 the background (#20804)
727 * Check Packages as well as Packages.gz for file URIs (#20784)
728 * Spelling cleanup (#20800)
729 * Added -m option to permit upgrade to go on in the case of a bad mirror.
730 This option may result in incomplete upgrades when used with -f.
731
732 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
733
734 apt (0.0.4) experimental; urgency=low
735
736 * New usage guide.
737 * Various documentation updates and cleanup.
738 * Added '-f' option to apt-get attempt to fix broken dependancies.
739
740 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
741
742 apt (0.0.3) experimental; urgency=low
743
744 * Added a shlibs.local file to prevent apt from depending on itself.
745 * Updates to how apt-get handles bad states in installed packages.
746 * Updated rules to make sure build works from a freshly checked out source
747 archive. Building from CVS needs libtool/automake/autoconf, builds from
748 the distributed source package should have no such dependancy.
749
750 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
751
752 apt (0.0.2) unstable; urgency=low
753
754 * Updates to apt-get and http binding for dselect method (apt).
755 * Updating version number from 0.0.1, which was released only on IRC.
756
757 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
758
759 apt (0.0.1) unstable; urgency=low
760
761 * Initial Release.
762
763 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500
764