]>
git.saurik.com Git - apt.git/blob - debian/apt.postinst
5 # summary of how this script can be called:
6 # * <postinst> `configure' <most-recently-configured-version>
7 # * <old-postinst> `abort-upgrade' <new version>
8 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
10 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
11 # <failed-install-package> <version> `removing'
12 # <conflicting-package> <version>
13 # for details, see http://www.debian.org/doc/debian-policy/ or
14 # the debian-policy package
18 if dpkg
--compare-versions "$2" lt
-nl 0.9.9.5; then
19 # we are using tmpfiles for both
20 rm -f /etc
/apt
/trustdb.gpg
21 # this removal was done unconditional since 0.8.15.3
22 SECRING
='/etc/apt/secring.gpg'
23 # test if secring is an empty normal file
24 if test -f $SECRING -a ! -s $SECRING; then
29 # ensure tighter permissons on the logs, see LP: #975199
30 if dpkg
--compare-versions "$2" lt
-nl 0.9.7.7; then
31 # ensure permissions are right
32 chmod -f 0640 /var
/log
/apt
/term.log
* || true
35 # create kernel autoremoval blacklist on update
36 if dpkg
--compare-versions "$2" lt
0.9.9.3; then
37 /etc
/kernel
/postinst.d
/apt
-auto-removal
41 abort
-upgrade|abort
-remove|abort
-deconfigure)
46 echo "postinst called with unknown argument \`$1'" >&2
51 # dh_installdeb will replace this with shell code automatically
52 # generated by other debhelper scripts.