]> git.saurik.com Git - apt.git/blob - debian/rules
* Move dh_makeshlibs ahead of dh_installdeb so that its...
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.54 2003/08/10 23:54:57 mdz Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
18 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19
20 # FOR AUTOCONF 2.52 AND NEWER ONLY
21 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
22 confflags += --build $(DEB_HOST_GNU_TYPE)
23 else
24 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
25 endif
26
27 # See below
28 -include build/environment.mak
29
30 # Default rule
31 build:
32
33 DEB_BUILD_PROG:=debuild -us -uc
34 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
35 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
36
37 # Determine the build directory to use
38 BASE=.
39 ifdef BUILD
40 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
41 else
42 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
43 endif
44 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
45 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
46 override BLD := $(BUILDX)
47
48 ifeq ($(words $(BLD)),0)
49 override BLD := ./build
50 endif
51
52 # Rebuild configure.in to have the correct version from the change log
53 ifneq ($(APT_DEBVER),$(APT_CONFVER))
54 .PHONY: configure.in
55 configure.in:
56 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
57 else
58 configure.in:
59 endif
60
61 # APT Programs in apt-utils
62 APT_UTILS=ftparchive sortpkgs extracttemplates
63
64 # Uncomment this to turn on verbose mode.
65 #export DH_VERBOSE=1
66
67 # Find the libapt-pkg major version for use in other control files
68 export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
69 export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
70
71 # Determine which package we should provide in the control files
72 LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
73 LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
74
75 debian/shlibs.local: apt-pkg/makefile
76 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
77 # one for the rest of the packages. This ensures that each package gets
78 # the right overrides..
79 rm -rf $@ $@.apt $@.apt-utils
80 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
81
82 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
83 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
84
85 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
86 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
87
88 build: build/build-stamp
89 build-doc: build/build-doc-stamp
90
91 # Note that this is unconditionally done first as part of loading environment.mak
92 # The true is needed to force make to reload environment.mak after running
93 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
94 build/environment.mak: build/configure-stamp
95 @true
96
97 configure: configure.in
98 build/configure-stamp: configure
99 dh_testdir
100 -mkdir build
101 cp COPYING debian/copyright
102 ifneq ($(wildcard /usr/share/misc/config.sub),)
103 cp -a /usr/share/misc/config.sub buildlib/config.sub
104 echo Updating buildlib/config.sub
105 endif
106 ifneq ($(wildcard /usr/share/misc/config.guess),)
107 cp -a /usr/share/misc/config.guess buildlib/config.guess
108 echo Updating buildlib/config.guess
109 endif
110 cd build && ../configure $(confflags)
111 touch $@
112
113 build/build-stamp: build/configure-stamp
114 # Add here commands to compile the package.
115 $(MAKE) binary
116 touch $@
117
118 build/build-doc-stamp: build/configure-stamp
119 # Add here commands to compile the package.
120 $(MAKE) doc
121 touch $@
122
123 clean:
124 dh_testdir
125 # dh_testroot
126 -$(MAKE) clean
127 -$(MAKE) distclean
128
129 rm -rf build
130
131 # Add here commands to clean up after the build process.
132 dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
133
134 binary-indep: apt-doc libapt-pkg-doc
135 # Build architecture-independent files here.
136 libapt-pkg-doc: build-doc debian/shlibs.local
137 dh_testdir -p$@
138 dh_testroot -p$@
139 dh_clean -p$@ -k
140 dh_installdirs -p$@
141 #
142 # libapt-pkg-doc install
143 #
144 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
145 $(BLD)/docs/files* $(BLD)/docs/method* \
146 doc/libapt-pkg2_to_3.txt doc/style.txt
147 dh_installexamples -p$@
148 # dh_installmenu -p$@
149 # dh_installinit -p$@
150 # dh_installcron -p$@
151 # dh_installman -p$@
152
153 # dh_undocumented -p$@
154 dh_installchangelogs -p$@
155 dh_strip -p$@
156 dh_compress -p$@
157 dh_fixperms -p$@
158 # dh_suidregister -p$@
159 dh_installdeb -p$@
160 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
161 dh_md5sums -p$@
162 dh_builddeb -p$@
163
164 apt-doc: build-doc
165 dh_testdir -p$@
166 dh_testroot -p$@
167 dh_clean -p$@ -k
168 #
169 # apt-doc install
170 #
171 # Copy the guides
172 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
173 $(BLD)/docs/offline.text $(BLD)/docs/offline.html
174 dh_installchangelogs -p$@
175 dh_compress -p$@
176 dh_fixperms -p$@
177 dh_installdeb -p$@
178 dh_gencontrol -p$@
179 dh_md5sums -p$@
180 dh_builddeb -p$@
181
182
183
184 # Build architecture-dependent files here.
185
186 binary-arch: apt libapt-pkg-dev apt-utils
187 apt: build debian/shlibs.local
188 dh_testdir -p$@
189 dh_testroot -p$@
190 dh_clean -p$@ -k
191 dh_installdirs -p$@ /usr/share/bug/$@
192 #
193 # apt install
194 #
195 cp $(BLD)/bin/apt-* debian/apt/usr/bin/
196
197 # Remove the bits that are in apt-utils
198 rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
199
200 # install the shared libs
201 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
202 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
203
204 cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
205
206 cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
207 cp -r $(BLD)/locale debian/apt/usr/share/
208
209 cp debian/bugscript debian/apt/usr/share/bug/apt/script
210
211 # head -n 500 ChangeLog > debian/ChangeLog
212
213 dh_installexamples -p$@ $(BLD)/docs/examples/*
214 dh_installman -p$@
215
216 dh_installdocs -p$@
217 dh_installchangelogs -p$@
218 dh_strip -p$@
219 dh_compress -p$@
220 dh_fixperms -p$@
221 dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
222 dh_installdeb -p$@
223 dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
224 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
225 dh_md5sums -p$@
226 dh_builddeb -p$@
227
228 libapt-pkg-dev: build debian/shlibs.local
229 dh_testdir -p$@
230 dh_testroot -p$@
231 dh_clean -p$@ -k
232 dh_installdirs -p$@
233 #
234 # libapt-pkg-dev install
235 #
236 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
237 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
238 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
239 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
240
241 dh_installdocs -p$@
242 # dh_installmenu -p$@
243 # dh_installinit -p$@
244 # dh_installcron -p$@
245 # dh_installman -p$@
246
247 dh_installchangelogs -p$@
248 dh_strip -p$@
249 dh_compress -p$@
250 dh_fixperms -p$@
251 # dh_suidregister -p$@
252 dh_installdeb -p$@
253 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
254 dh_md5sums -p$@
255 dh_builddeb -p$@
256
257 apt-utils: build debian/shlibs.local
258 dh_testdir -p$@
259 dh_testroot -p$@
260 dh_clean -p$@ -k
261 dh_installdirs -p$@
262
263 # install the shared libs
264 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
265 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
266
267 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
268 dh_installdocs -p$@
269
270 # Install the man pages..
271 dh_installman -p$@
272
273 dh_installchangelogs -p$@
274 dh_strip -p$@
275 dh_compress -p$@
276 dh_fixperms -p$@
277 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
278 dh_installdeb -p$@
279 LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
280 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
281 dh_md5sums -p$@
282 dh_builddeb -p$@
283
284 source diff:
285 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
286
287 # Update from CVS
288 l33ch: really-clean
289 cvs update
290 buildlib/mkChangeLog
291
292 # Update from CVS and then configure for build
293 super-l33ch: l33ch Makefile.in
294
295 configure:
296 $(MAKE) configure
297
298 l33ch-stamp: super-l33ch
299 touch $@
300
301 really-clean: clean
302 -find -name Makefile.in -print0 | xargs -0r rm -f
303 find -name ChangeLog | xargs rm -f
304 rm -f l33ch-stamp
305
306 binary: binary-indep binary-arch
307 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
308
309
310 # Done by the uploader.
311 #cvs update..
312 #edit debian/changelog
313 # configure.in has the version automatically updated now.
314 # edit configure.in
315 # debian/rules cvs-build
316
317 cvs-build:
318 rm -rf debian/cvs-build
319 cvs update
320 $(MAKE) startup
321 $(MAKE) doc
322 tar c --exclude CVS --exclude cvs-build --exclude '.#*' . |\
323 (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
324 (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
325
326 cvs-mkul:
327 -mkdir -p ../upload-$(APT_DEBVER)
328 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)