]> git.saurik.com Git - apt.git/blob - debian/rules
* Patch from Otavio Salvador to switch from dh_installm...
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.51 2003/08/02 19:51:02 mdz Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DH_COMPAT=2
18
19 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
20 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
21
22 # FOR AUTOCONF 2.52 AND NEWER ONLY
23 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
24 confflags += --build $(DEB_HOST_GNU_TYPE)
25 else
26 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
27 endif
28
29 # See below
30 -include build/environment.mak
31
32 # Default rule
33 build:
34
35 DEB_BUILD_PROG:=debuild -us -uc
36 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
37 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
38
39 # Determine the build directory to use
40 BASE=.
41 ifdef BUILD
42 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
43 else
44 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
45 endif
46 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
47 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
48 override BLD := $(BUILDX)
49
50 ifeq ($(words $(BLD)),0)
51 override BLD := ./build
52 endif
53
54 # Rebuild configure.in to have the correct version from the change log
55 ifneq ($(APT_DEBVER),$(APT_CONFVER))
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
59 else
60 configure.in:
61 endif
62
63 # APT Programs in apt-utils
64 APT_UTILS=ftparchive sortpkgs extracttemplates
65
66 # Uncomment this to turn on verbose mode.
67 #export DH_VERBOSE=1
68
69 # Find the libapt-pkg major version for use in other control files
70 export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
71 export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
72
73 # Determine which package we should provide in the control files
74 LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
75 LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
76
77 debian/shlibs.local: apt-pkg/makefile
78 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
79 # one for the rest of the packages. This ensures that each package gets
80 # the right overrides..
81 rm -rf $@ $@.apt $@.apt-utils
82 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
83
84 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
85 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
86
87 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
88 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
89
90 build: build/build-stamp
91 build-doc: build/build-doc-stamp
92
93 # Note that this is unconditionally done first as part of loading environment.mak
94 # The true is needed to force make to reload environment.mak after running
95 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
96 build/environment.mak: build/configure-stamp
97 @true
98
99 configure: configure.in
100 build/configure-stamp: configure
101 dh_testdir
102 -mkdir build
103 cp COPYING debian/copyright
104 ifneq ($(wildcard /usr/share/misc/config.sub),)
105 cp -a /usr/share/misc/config.sub buildlib/config.sub
106 echo Updating buildlib/config.sub
107 endif
108 ifneq ($(wildcard /usr/share/misc/config.guess),)
109 cp -a /usr/share/misc/config.guess buildlib/config.guess
110 echo Updating buildlib/config.guess
111 endif
112 cd build && ../configure $(confflags)
113 touch $@
114
115 build/build-stamp: build/configure-stamp
116 # Add here commands to compile the package.
117 $(MAKE) binary
118 touch $@
119
120 build/build-doc-stamp: build/configure-stamp
121 # Add here commands to compile the package.
122 $(MAKE) doc
123 touch $@
124
125 clean:
126 dh_testdir
127 # dh_testroot
128 -$(MAKE) clean
129 -$(MAKE) distclean
130
131 rm -rf build
132
133 # Add here commands to clean up after the build process.
134 dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
135
136 binary-indep: apt-doc libapt-pkg-doc
137 # Build architecture-independent files here.
138 libapt-pkg-doc: build-doc debian/shlibs.local
139 dh_testdir -p$@
140 dh_testroot -p$@
141 dh_clean -p$@ -k
142 dh_installdirs -p$@
143 #
144 # libapt-pkg-doc install
145 #
146 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
147 $(BLD)/docs/files* $(BLD)/docs/method* \
148 doc/libapt-pkg2_to_3.txt doc/style.txt
149 dh_installexamples -p$@
150 # dh_installmenu -p$@
151 # dh_installinit -p$@
152 # dh_installcron -p$@
153 # dh_installman -p$@
154
155 # dh_undocumented -p$@
156 dh_installchangelogs -p$@
157 dh_strip -p$@
158 dh_compress -p$@
159 dh_fixperms -p$@
160 # dh_suidregister -p$@
161 dh_installdeb -p$@
162 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
163 dh_md5sums -p$@
164 dh_builddeb -p$@
165
166 apt-doc: build-doc
167 dh_testdir -p$@
168 dh_testroot -p$@
169 dh_clean -p$@ -k
170 #
171 # apt-doc install
172 #
173 # Copy the guides
174 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
175 $(BLD)/docs/offline.text $(BLD)/docs/offline.html
176 dh_installchangelogs -p$@
177 dh_compress -p$@
178 dh_fixperms -p$@
179 dh_installdeb -p$@
180 dh_gencontrol -p$@
181 dh_md5sums -p$@
182 dh_builddeb -p$@
183
184
185
186 # Build architecture-dependent files here.
187
188 binary-arch: apt libapt-pkg-dev apt-utils
189 apt: build debian/shlibs.local
190 dh_testdir -p$@
191 dh_testroot -p$@
192 dh_clean -p$@ -k
193 dh_installdirs -p$@ /usr/share/bug/$@
194 #
195 # apt install
196 #
197 cp $(BLD)/bin/apt-* debian/apt/usr/bin/
198
199 # Remove the bits that are in apt-utils
200 rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
201
202 # install the shared libs
203 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
204 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
205
206 cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
207
208 cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
209 cp -r $(BLD)/locale debian/apt/usr/share/
210
211 cp debian/bugscript debian/apt/usr/share/bug/apt/script
212
213 # head -n 500 ChangeLog > debian/ChangeLog
214
215 dh_installexamples -p$@ $(BLD)/docs/examples/*
216 dh_installman -p$@
217
218 dh_installdocs -p$@
219 dh_installchangelogs -p$@
220 dh_strip -p$@
221 dh_compress -p$@
222 dh_fixperms -p$@
223 dh_installdeb -p$@
224 dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
225 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
226 dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
227 dh_md5sums -p$@
228 dh_builddeb -p$@
229
230 libapt-pkg-dev: build debian/shlibs.local
231 dh_testdir -p$@
232 dh_testroot -p$@
233 dh_clean -p$@ -k
234 dh_installdirs -p$@
235 #
236 # libapt-pkg-dev install
237 #
238 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
239 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
240 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
241 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
242
243 dh_installdocs -p$@
244 # dh_installmenu -p$@
245 # dh_installinit -p$@
246 # dh_installcron -p$@
247 # dh_installman -p$@
248
249 dh_installchangelogs -p$@
250 dh_strip -p$@
251 dh_compress -p$@
252 dh_fixperms -p$@
253 # dh_suidregister -p$@
254 dh_installdeb -p$@
255 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
256 dh_md5sums -p$@
257 dh_builddeb -p$@
258
259 apt-utils: build debian/shlibs.local
260 dh_testdir -p$@
261 dh_testroot -p$@
262 dh_clean -p$@ -k
263 dh_installdirs -p$@
264
265 # install the shared libs
266 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
267 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
268
269 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
270 dh_installdocs -p$@
271
272 # Install the man pages..
273 dh_installman -p$@
274
275 dh_installchangelogs -p$@
276 dh_strip -p$@
277 dh_compress -p$@
278 dh_fixperms -p$@
279 dh_installdeb -p$@
280 LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
281 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
282 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
283 dh_md5sums -p$@
284 dh_builddeb -p$@
285
286 source diff:
287 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
288
289 # Update from CVS
290 l33ch: really-clean
291 cvs update
292 buildlib/mkChangeLog
293
294 # Update from CVS and then configure for build
295 super-l33ch: l33ch Makefile.in
296
297 configure:
298 $(MAKE) configure
299
300 l33ch-stamp: super-l33ch
301 touch $@
302
303 really-clean: clean
304 -find -name Makefile.in -print0 | xargs -0r rm -f
305 find -name ChangeLog | xargs rm -f
306 rm -f l33ch-stamp
307
308 binary: binary-indep binary-arch
309 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
310
311
312 # Done by the uploader.
313 #cvs update..
314 #edit debian/changelog
315 # configure.in has the version automatically updated now.
316 # edit configure.in
317 # debian/rules cvs-build
318
319 cvs-build:
320 rm -rf debian/cvs-build
321 cvs update
322 $(MAKE) startup
323 $(MAKE) doc
324 tar c --exclude CVS --exclude cvs-build . |\
325 (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
326 (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
327
328 cvs-mkul:
329 -mkdir -p ../upload-$(APT_DEBVER)
330 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)