1 apt (0.5.6) unstable; urgency=low
3 * Adam Heath <doogie@debian.org>
4 - Fix segfault when handling /etc/apt/preferences. Closes: #192409.
5 * Matt Zimmerman <mdz@debian.org>
6 - Clean up some string handling, patch from Peter Lundkvist
7 <p.lundkvist@telia.com> (Closes: #192225)
8 - Don't fall off the end of the buffer when comparing versions.
9 Patch from Koblinger Egmont <egmont@uhulinux.hu> (Closes: #194327)
10 - Minor fixes to apt-ftparchive(1) (Closes: #118156)
11 - Fix typo in apt-ftparchive help text (Closes: #119072)
12 - Update config.guess, config.sub to latest versions
13 - Modify the description for apt-utils to reflect the fact that it is not
14 (any longer) infrequently used (Closes: #138045)
15 - Make setup script for dselect method more explicit about
16 overwriting sources.list (Closes: #151727)
20 apt (0.5.5.1) unstable; urgency=low
22 * Move the target of the example docs from doc to binary. Closes:
24 * Fix api breakage that broke apt-ftparchive and apt-cache dumpavail, by
25 backing out change that incorretly attempted to handle Package sections
26 larger than 32k. Closes: #192373
27 * Fix never-ending loop with apt-get install -V. Closes: #192355.
29 -- Adam Heath <doogie@debian.org> Mon, 19 May 2003 12:30:16 -0500
31 apt (0.5.5) unstable; urgency=low
33 * New deb version compare function, that has no integer limits, and
34 supports pre-versions using ~. Code ported from dpkg.
35 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
36 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
37 * "apt-get --arch-only build-dep" to install only architecture-
38 dependent build dependencies. Bump minor shared lib number to reflect
39 small change in BuildDepend API.
40 * APT::Build-Essential configuration option (defaults to "build-essential")
41 so that "apt-get build-dep" will ensure build essential packages are
42 installed prior to installing other build-dependencies. Closes: #148879
43 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
44 * /usr/doc reference in postinst. Closes: #126189
45 * Doc updates. Closes: #120689
46 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
48 * Print special message for EAI_AGAIN. Closes: #131397
49 * libapt-pkg-dev needs to bring in the apt-inst library if linking
50 is to work. Closes: #133943
51 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
52 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
53 #139994, #142955, #151654, #151834, #147611, #154268, #173971
54 * Fix possibility for tag file parsing to fail in some unlikely situations.
56 * Use std C++ names for some header files. Closes: #128741
57 * Do not check for free space if --no-download. Closes: #117856
58 * Actually implement or group handling for 'upgrade'. Closes: #133950
59 * "Internal Error, Couldn't configure pre-depend" is not actually an
60 internal error, it is a packaging error and now it says so, and
61 pinpoints the problem dependency. Closes: #155621
62 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
63 * Use usr/share/doc for dhelp. Closes: #115701
64 * --print-uris works with 'update'. Closes: #57070
65 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
67 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
69 * Allow an uninstalled package to be marked for removal on an install
70 line (meaning not to automatically install it), also fix some dodgy
71 handling of protected packages. Closes: #92287, #116011
72 * Fix errant prefix matching in version selection. Closes: #105968
73 * Ensure that all files needed to run APT as a user are readable and
74 ignore roots umask for these files. Closes: #108801
75 * Support larger config spaces. Closes: #111914
76 * 'apt-get update' no longer does 'Building Dependency Tree'.
77 * When matching regexs allways print a message. Change regex activation
78 charset. Closes: #147817
79 * Don't die if lines in sources.list are too long. Closes: #146846
80 * Show file name on apt-extracttemplate error messges. Closes: #151835
81 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
82 * Some highly unlikely memory faults. Closes: #155842
83 * C++ stuff for G++3.2. Closes: #162617, #165515,
84 * apt-config dumps sends to stdout not stderr now. Closes: #146294
85 * Fix segfault in FindAny when /i is used, and there is no default.
87 * Add s390x to archtable. Closese: #160992.
88 * Update config.sub/config.guess in cvs, and add support to debian/rules
89 to update them from /usr/share/misc if they exist. Closes: #155014
90 * Remove 'Sorry' from messages. Closes: #148824.
91 * Change wording of 'additional disk space usage' message. Closes:
93 * apt-extracttemplates now prepends the package name when extracting
94 files. Closes: #132776
95 * Add -n synonym for --names-only for apt-cache. Closes: #130689
96 * Display both current version and new version in apt-get -s. Closes:
98 * Add an options and timeout config item to ssh/rsh. Closes: #90654
99 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
100 * Change verbose logging output of apt-ftparchive to go to stderr,
101 instead of stdout. Also, errors that occur no longer go to stdout,
102 but stderr. Closes: #161592
103 * Test for timegm in configure. Closes: #165516.
104 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
105 support compliation on platforms where st_mtime is a macro. Closes:
107 * Check the currently mounted cdrom, to see if it's the one we are
108 interested in. Closes: #154602
109 * Refer to reportbug instead of bug in the man pages. Closes: #173745
110 * Link apt-inst to apt-pkg. Closes: #175055
111 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
113 * Fix > 300 col screen segfault. Closes: #176052
114 * Rebuild with gcc-3.2. Closes: #177752, #178008.
115 * Fix build-dep handling of | dependencies.
116 Closes: #98640, #145997, #158896, #172901
117 * Double default value of APT::Cache-Limit, until such time as it
118 can be made more dynamic. Closes: #178623.
119 * Report uris with '.gz' when there are errors. Closes: #178435.
120 * When installing build-deps, make sure the new version will
121 satisfy build requirements. Closes: #178121
122 * Split offline and guide documentation into apt-doc. This was done so
123 that binary-arch builds do not require documention deps. Note, that
124 apt-doc is not installed on upgrades.
125 * Use doc-base, instead of dhelp directly. Closes: #110389
126 * Change http message 'Waiting for file' to 'Waiting for headers'.
128 * Remove trailing lines on package lists in apt-get. Closes: #178736.
129 * Fix origin pins for file:// uris. Closes: #189014.
130 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
132 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
134 * Fix some typos in the apt-get manual. Closes: #163932.
135 * Apply patch from bug, to change frozen to testing, and then do it
136 everywhere else. Closes: #165085.
137 * Update es.po. Closes: #183111.
138 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
140 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
141 * Add option to apt-get to show versions of packages being
143 * Be quiet in apt.post{inst,rm}. Closes: #70685.
144 * apt-get now prints out suggested and recommended packages. Closes:
146 * Insert some newlines in the cdrom change media message. Closes:
148 * Add a rdepends command to apt-cache. Closes: #159864.
149 * When building the dpkg command line, allow for 8192 chars to be used,
150 instead of only 1024.
151 * APT::Immediate-Configure had inverted semantics(false meant it was
152 enabled). Closes: #173619.
153 * Fix status file parser so that if a record is larger than 32k, the
154 buffer size will be doubled, and the read attempted again. Closes:
157 -- Adam Heath <doogie@debian.org> Sun, 27 Apr 2003 01:23:12 -0500
159 apt (0.5.4) unstable; urgency=low
161 * M68k config.guess patch. Closes: #88913
162 * Bi-yearly test on OpenBSD and Solaris
163 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
164 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
166 * Various cosmetic code updates. Closes: #89066, #89066, #89152
167 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
169 * More patches from Alfredo for Vendors and more SHA-1 stuff
170 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
171 similar situations. Closes: #56708, #59432
172 * no_proxy and ftp. Closes: #89671
173 * Philippe Batailler's man page patches.
174 * Fix for display bug. Closes: #92033, #93652, #98468
175 * Use more than 16bits for the dep ID. Some people ran out..
176 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
177 #106911, #107395, #108968
178 * Reordered some things to make dante and FTP happier. Closes: #92757
179 * James R. Van Zandt's guide.sgml updates. Closes: #90027
180 * apt-ftparchive copes with no uncompressed package files + contents.
181 * French man pages from philippe batailler - well sort of. They
183 * run-parts. Closes: #94286
184 * 'apt-cache policy' preferences debug tool.
185 * Whatever. Closes: #89762
186 * libstdc++ and HURD. Closes: #92025
187 * More apt-utils verbage. Closes: #86954
188 * Fliped comparision operator. Closes: #94618
189 * Used the right copyright file. Closes: #65691
190 * Randolph's G++3 patches.
191 * Fixed no_proxy tokanizing. Closes: #100046
192 * Strip Config-Version when copying status to available. Closes: #97520
193 * Segfault with missing source files. Closes: #100325
194 * EINTR check. Closes: #102293
195 * Various changes to the locking metholodgy for --print-uris.
197 * Lame LD_LIBRARY_PATH thing. Closes: #98928
198 * apt-cache search searchs provide names too now. Closes: #98695
199 * Checksum and long lines problem. Closes: #106591
200 * .aptignr and empty files are just a warning. Closes: #97364
202 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
204 apt (0.5.3) unstable; urgency=low
206 * JoeyH's dpkg::preconfig not working. Closes: #88675
207 * Fixed apt override disparity
208 * Alfredo's SHA-1 and related patches
210 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
212 apt (0.5.2) unstable; urgency=low
214 * Fixed mention of /usr/doc in the long description
215 * JoeyH's downgrade bug -- don't use 0.5.1
216 * Doc bug. Closes: #88538
217 * Fault in building release strings. Closes: #88533
219 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
221 apt (0.5.1) unstable; urgency=low
223 * Fixed #82894 again, or should be and.
224 * Process the option string right. Closes: #86921
225 * Don't eat the last command for pipes. Closes: #86923
226 * Ignore .* for configuration directory processing. Closes: #86923
227 * Alfredo's no_proxy patch
228 * Documentation fixes. Closes: #87091
229 * JoeyH's double slash bug. Closes: #87266
230 * Unintitialized buffer and apt-ftparchive contents generation.
232 * Build-deps on virtual packages. Closes: #87639
233 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
234 libstdc++ version info in the library soname and in the package
235 provides. Closes: #87426
236 * Updated soname version to 0.3.2
237 * apt-extracttemplates moved from debconf into apt-utils
238 * s390 archtable entry. Closes: #88232
240 * Some instances where the status file can source a package in a
241 non-sensical way. Closes: #87390
242 * Work better if there are duplicate sources.list entries.
243 * Fixed the resetting of Dir with "dir {};". Closes: #87323
245 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
247 apt (0.5.0) unstable; urgency=low
249 * Fixed an obscure bug with missing final double new lines in
251 * Changed the apt-cdrom index copy routine to use the new section
253 * Added a package file sorter, apt-sortpkgs
254 * Parse obsolete Optional dependencies.
255 * Added Ben's rsh method. Closes: #57794
256 * Added IPv6 FTP support and better DNS rotation support.
257 * Include the server IP in error messages when using a DNS rotation.
259 * Made most of the byte counters into doubles to prevent 32bit overflow.
261 * HTTP Authorization. Closes: #61158
262 * Ability to parse and return source index build depends from Randolph.
263 * new 'apt-get build-dep' command from Randolph. Closes: #63982
264 * Added apt-ftparchive the all dancing all singing FTP archive
266 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
268 * Removed useless internal cruft including the xstatus file.
269 * Fixed config parser bugs. Closes: #67848, #71108
270 * Brain Damanged apt-get config options changed, does not change the command
271 line interface, except to allow --enable-* to undo a configuration
274 No-Download -> Download
275 No-Upgrade -> Upgrade
276 * Made this fix configable (DSelect::CheckDir) and default to disabled:
277 * No remove prompt if the archives dir has not changed. Closes: #55709
278 Because it is stupid in the case where no files were downloaded due to
279 a resumed-aborted install, or a full cache! Closes: #65952
280 * Obscure divide by zero problem. Closes: #64394
281 * Update sizetable for mips. Closes: #62288
282 * Fixed a bug with passive FTP connections
283 * Has sizetable entry for sparc64. Closes: #64869
284 * Escape special characters in the ::Label section of the cdroms.lst
285 * Created apt-utils and python-apt packages
286 * Due to the new policy engine, the available file may contain entries
287 from the status file. These are generated if the package is not obsolete
288 but the policy engine prohibits using the version from the package files.
289 They can be identified by the lack of a Filename field.
290 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
291 #36223, #33468, #22551
292 * Fixed deb-src line for non-us. Closes: #71501, #71601
293 * Fixes for G++ 2.96, s/friend/friend class/
294 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
295 * Confirmed fix for missing new line problem. Closes: #69386
296 * Fixed up dhelp files. Closes: #71312
297 * Added some notes about dselect and offline usage. Closes: #66473, #38316
298 * Lock files on read only file systems are ignored w/ warning.
300 * apt-get update foo now gives an error! Closes: #42891
301 * Added test for shlibs on hurd. Closes: #71499
302 * Clarified apt-cache document. Closes: #71934
303 * DocBook SGML man pages and some improvements in the text..
304 * sigwinch thing. Closes: #72382
305 * Caching can be turned off by setting the cache file names blank.
306 * Ignores arches it does not know about when autocleaning. Closes: #72862
307 * New function in apt-config to return dirs, files, bools and integers.
308 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
309 complex cases involving OR groups and provides.
310 68754 describes confusing messages which are the result of this..
311 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
312 * Speeling mistake and return code for the 'wicked' resolver error
313 Closes: #72621, #75226, #77464
314 * Solved unable to upgrade libc6 from potato to woody due to 3 package
315 libc6 dependency loop problem.
316 * Leading sources.list spaces. Closes: #76010
317 * Removed a possible infinite loop while processing installations.
318 * Man page updates. Closes: #75411, #75560, #64292, #78469
319 * ReduceSourceList bug. Closes: #76027
320 * --only-source option. Closes: #76320
321 * Typos. Closes: #77812, #77999
322 * Different status messages. Closes: #76652, #78353
323 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
324 * OS detection an support for the new pseduo standard of os-arch for the
325 Architecture string. Also uses regexing.. Closes: #39227, #72349
326 * Various i18n stuff. Note that this still needs some i18n wizard
327 to do the last gettextization right. Closes: #62386
328 * Fixed a problem with some odd http servers/proxies that did not return
329 the content size in the header. Closes: #79878, #44379
330 * Little acquire bugs. Closes: #77029, #55820
331 * _POSIX_THREADS may not be defined to anything, just defined..
333 * Spelling of Ignore-Hold correctly. Closes: #78042
334 * Unlock the dpkg db if in download only mode. Closes: #84851
335 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
336 * Patch from BenC. Closes: #80810
337 * Single output of some names in lists. Closes: #80498, #43286
338 * Nice message for people who can't read syserror output. Closes: #84734
339 * OR search function. Closes: #82894
340 * User's guide updates. Closes: #82469
341 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
342 * Various CD bugs, again thanks to Greenbush
343 Closes: #80946, #76547, #71810, #70049, #69482
344 * Using potato debhelper. Closes: #57977
345 * I cannot self-terminate. Closes: #74928
347 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
349 apt (0.3.19) frozen unstable; urgency=low
351 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
353 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
354 * Fixed hardcoded path. Closes: #59743
355 * Fixed Jay's relative path bug
356 * Allowed source only CDs. Closes: #58952
357 * Space check is supressed if --print-uris is given. Closes: #58965
358 * Clarified the documenation examples for non-us. Closes: #58646
359 * Typo in the package description. Closes: #60230
360 * Man Page typo. Closes: #60347
361 * Typo in Algorithms.cc. Closes: #63577
362 * Evil dotty function in apt-cache for generating dependency graphs
363 with the as-yet-unpackaged GraphVis.
364 * Appears to have been fixed in Janurary.. Closes: #57981
365 * New config.guess/sub for the new archs. Closes: #60874
366 * Fixed error reporting for certain kinds of resolution failures.
368 * Made autoclean respect 'q' settings. Closes: #63023
369 * Fixed up the example sources.list. Closes: #63676
370 * Added DPkg::FlushSTDIN to control the flushing of stdin before
371 forking dpkg. Closes: #63991
373 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
375 apt (0.3.18) frozen unstable; urgency=low
377 * Changes in the postinst script. Closes: #56855, #57237
378 * Fixed bashism. Closes: #57216, #57335
379 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
381 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
383 apt (0.3.17) unstable; urgency=low
385 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
386 * Fixed the configuration parser to not blow up if ; is in the config
388 * Applied visual patch to dselect install script . Closes #55214
389 * Included the configure-index example
391 * Library soname has increased
392 * Fixed default sources.list to have correct URLs for potato when it
394 * Added a message about erasing sources.list to dselect setup script
396 * No remove prompt if the archives dir has not changed. Closes: #55709
397 * Fixed inclusion of 2nd sample config file. Closes: #55374
398 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
401 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
403 apt (0.3.16) unstable; urgency=low
405 * Made --no-download work. Closes: #52993
406 * Now compiles on OpenBSD, Solaris and HP-UX
407 * Clarify segfault errors
408 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
409 * Fix for Joel's discovery of glibc removal behavoir.
410 * Fix for Ben Collins file: uri from slink upgrade.
411 * Fixed resume code in FTP. Closes: #54323
412 * Take more precautions to prevent the corruption Joey Hess saw.
413 * Fixed --no-list-cleanup
414 * RFC 2732 URI parsing ([] for hostnames).
415 * Typo in apt-cache man page. Closes: #54949
417 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
419 apt (0.3.15) unstable; urgency=low
421 * Added DSelect::WaitAfterDownload Closes: #49549
422 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
423 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
424 * Made -s and clean not do anything. Closes: #50238
425 * Problem with Protected packages and the new OR code.
426 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
427 * Remove doesn't require a package to be installable. Closes: #51175
428 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
430 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
432 apt (0.3.14) unstable; urgency=low
434 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
435 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
436 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
437 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
438 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
439 Closes: #45034, #45695, #46537
440 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
441 * Added APT::Clean-Installed option. Closes: #45973
442 * Moves the free space check to after the calculated size is printed.
443 Closes: #46639, #47498
444 * mipsel arch Closes: #47614
445 * Beautified URI printing to not include passwords Closes: #46857
446 * Fixed little problem with --no-download Closes: #47557
447 * Tweaked Dselect 'update' script to re-gen the avail file even in the
448 event of a failure Closes: #47112
449 * Retries for source archives too Closes: #47529
450 * Unmounts CDROMs iff it mounted them Closes: #45299
451 * Checks for the partial directories before doing downloads Closes: #47392
452 * no_proxy environment variable (http only!) Closes: #43476
453 * apt-cache showsrc Closes: #45799
454 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
455 * Regexs for install. Closes: #35304, #38835
456 * Dependency reports now show OR group relations
457 * Re-Install feature. Cloes: #46961, #37393, #38919
458 * Locks archive directory on clean (woops)
459 * Remove is not 'sticky'. Closes: #48392
460 * Slightly more accurate 'can not find package' message. Closes: #48311
461 * --trivial-only and --no-remove. Closes: #48518
462 * Increased the cache size. Closes: #47648
463 * Comment woopsie. Closes: #48789
464 * Removes existing links when linking sources. Closes: #48775
465 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
466 * Clearer usage message about 'source' Closes: #48858
467 * Immediate configure internal error Closes: #49062, #48884
469 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
471 apt (0.3.13) unstable; urgency=low
473 * Fix timestamp miss in FTP. Closes: #44363
474 * Fix sorting of Kept packages. Closes: #44377
475 * Fix Segfault for dselect-upgrade. Closes: #44436
476 * Fix handling of '/' for the dist name. Closes #43830
477 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
478 * Add commented-out deb-src URI to default sources.list file.
480 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
482 apt (0.3.12) unstable; urgency=low
484 * Fix for typo in the dhelp index. Closes: #40377
485 * Multiple media swap support
486 * Purge support. Closes: #33291, #40694
487 * Better handling of - remove notation. Closes: #41024
488 * Purge support. Closes: #33291, #40694
489 * Error code on failed update. Closes: #41053
490 * apt-cdrom adds entries for source directories. Closes: #41231
491 * Sorts the output of any list. Closes: #41107
492 * Fixes the looping problem. Closes: #41784, #42414, #44022
493 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
494 * More checks to keep the display sane. Particularly when fail-over is
495 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
496 * PThread lockup problem on certain sparc/m68k. Closes: #40628
497 * apt-cdrom understands .gz Package files too. Closes: #42779
498 * Spelling error in dselect method description. Closes: #43251
499 * Added security to the default source list. Closes: #43356
501 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
503 apt (0.3.11) unstable; urgency=low
505 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
506 * Fix for properly upgrading the system from perl 5.004 to 5.005
508 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
510 apt (0.3.9) unstable; urgency=low
512 * Spelling error in cachefile.cc. Closes: #39885
513 * Trailing slash in dselect install if you try to use the
514 default config file. Closes: #40011
515 * Simulate works for autoclean. Closes: #39141
516 * Fixed spelling errors. Closes: #39673
517 * Changed url parsing a bit. Closes: #40070, #40069
518 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
520 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
522 apt (0.3.7) unstable; urgency=low
524 * Fixed missing text in the apt-get(8) page. Closes: #37596
525 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
526 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
527 * Fixed handling of the -q option with not-entirely integer arguments
529 * Man page typo Closes: #37762
530 * Fixed parsing of the Source: line. Closes: #37679
531 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
532 * Added a check for an empty cache directory. Closes: #37963
533 * Return a failure code if -d is given and packages fail to download.
535 * Arranged for an ftp proxy specifing an http server to work. See the
536 important note in the sources.list man page.
537 * Accounted for resumed files in the cps calculation. Closes: #36787
538 * Deal with duplicate same version different packages. Closes: #30237
539 * Added --no-download. Closes: #38095
540 * Order of apt-cdrom dist detection. Closes: #38139
541 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
543 * Suggests dpkg-dev for apt-get source. Closes: #38158
544 * Fixed typo in apt-get help. Closes: #38712
545 * Improved the error message in the case of broken held package. Closes: #38777
546 * Fixed handling of MD5 failures
547 * Documented list notation Closes: #39008
548 * Change the 'b' to 'B'. Closes: #39007
550 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
552 apt (0.3.6) unstable; urgency=low
554 * Note that 0.3.5 never made it out the door..
555 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
556 * Made APT print numbers in decimal. Closes: #35617, #37319
557 * Buffer munching fix for FTP. Closes: #35868
558 * Typo in sample config file. Closes: #35907
559 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
560 * Changed installed size counter to only count unpacked packages.
562 * apt-get source support. Closes: #23934, #27190
563 * Renames .debs that fail MD5 checking, provides automatic corruption
564 recovery. Closes: #35931
565 * Fixed autoconf verison. Closes: #37305
566 * Random Segfaulting. Closes: #37312, #37530
567 * Fixed apt-cache man page. Closes: #36904
568 * Added a newline to apt-cache showpkg. Closes: #36903
570 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
572 apt (0.3.4) unstable; urgency=low
574 * Release for Ben while he is out of town.
575 * Checked the size of partial files. Closes: #33705
576 * apt-get should not print progress on non-tty. Closes: #34944
577 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
578 * Applied cdrom patches from Torsten. Closes: #35140, #35141
579 * smbmounted cdrom fix. Closes: #35470
580 * Changed ie to eg. Closes: #35196
582 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
584 apt (0.3.3) unstable; urgency=low
586 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
588 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
590 apt (0.3.2) unstable; urgency=low
592 * Major release into unstable of v3
593 * These bugs have been fixed, explanations are in the bug system, read
594 the man pages as well..
595 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
596 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
597 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
598 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
599 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
600 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
601 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
602 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
604 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
606 apt (0.3.1) experimental; urgency=low
608 * Minor release of cvs version.
609 * Added virtual package libapt-pkgx.x
611 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
613 apt (0.3.0) experimental; urgency=low
615 * New experimental version.
617 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
619 apt (0.1.9) frozen unstable; urgency=low
621 * Return to the wacky numbering for when we build 0.1.8 for hamm
622 * Important bug related to APT on the Alpha fixed
623 * apt-get dist-upgrade problems fixed
624 * tiny patch for http method to fix an endless loop
625 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
626 libtool and add proper shared lib dependancies
627 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
628 in case an old libpkg is installed while building APT to prevent
629 spurious dependancies
631 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
633 apt (0.1.7) unstable; urgency=low
635 * New build with libstdc++2.9.
636 * Various fixes; read the Changelog.
638 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
640 apt (0.1.6) unstable; urgency=low
642 * Various fixes in the FTP method for error checking. Fixes: #26188.
643 * Spelling corrections in dselect method. Fixes: #25884
644 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
645 * No more bo releases: we're using a normal numbering system now.
647 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
649 apt (0.1.5) unstable; urgency=low
651 * Changed sources.list to point to 'unstable' by default, as
652 'frozen' no longer exists!
654 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
656 apt (0.1.3) unstable; urgency=low
658 * New upstreamish version.
659 * ftp method rewritten in C. Removes dependancies on all perl/perl
660 related modules. This fixes many of the ftp method bugs.
662 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
664 apt (0.1.1) unstable; urgency=low
666 * Release for unstable.
668 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
670 apt (0.1) unstable; urgency=low
672 * Kludge to fix problem in libnet-perl with illegal anonymous
674 * Moved to unstable; apt is in a useable state now.
675 * Fixed version numbering. From now on, numbering will be:
676 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
677 0.1.1 (release for unstable). Thanks, Manoj.
679 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
681 apt (0.0.17-1) experimental; urgency=low
683 * Fixed problem with libc6 version compare
684 * Scott's away for a while, so I'll be packaging apt for the time
687 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
689 apt (0.0.16-1) experimental; urgency=low
691 * Modifications to make apt-get more friendly when backgrounded.
692 * Updated documentation.
693 * Updates to graphic widgets
695 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
697 apt (0.0.15-0.2bo) experimental; urgency=low
700 * Bob Hilliards crash
702 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
704 apt (0.0.15-0.1bo) experimental; urgency=low
709 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
711 apt (0.0.15) experimental; urgency=low
713 * Clean up source tarball (no user-visible changes)
715 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
717 apt (0.0.14) experimental; urgency=low
719 * Updates in ordering code to make sure certain upgrades work correctly.
720 * Made dselect/setup understand ftp as well as http
722 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
724 apt (0.0.13-bo1) experimental; urgency=low
728 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
730 apt (0.0.13) experimental; urgency=low
732 * Remove hardcoded egcc from debian/rules (#21575)
733 * Fixes for ordering logic when system has a number of unpacked
734 but unconfigured packages installed.
735 * Spelling fix in dselect install method (#22556)
737 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
739 apt (0.0.12) experimental; urgency=low
741 * Fixed problems with package cache corruption.
742 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
744 * Interface and documentation improvements.
746 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
748 apt (0.0.11) experimental; urgency=low
750 * Change dependancies to pre-depends since breaking your packaging tools
751 in the middle of an installation isn't very good.
752 * Bug fixes to ftp method and general apt-get code
754 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
756 apt (0.0.10) experimental; urgency=low
758 * Run "dpkg --configure -a" after an aborted dselect install
759 * Fixed problem with install looping
760 * Support for authenticating proxys: (note this isn't terribly secure)
761 http_proxy="http://user:pass@firewall:port/"
762 * Substitute $ARCH in sources.list
763 * Fixes in the resumption code for ftp
765 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
767 apt (0.0.9) experimental; urgency=low
770 * Various other less visible bug fixes.
771 * Fixed problem with segfault when apt-get invoked in a non-existant
772 directory (Bug #21863)
773 * Bumped policy to 2.4.1
775 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
777 apt (0.0.8) experimental; urgency=low
779 * Fixed generated available file (Bug #21836)
780 * Added download ETA (Bug #21774).
781 * Fixed hardcoded ARCH (Bug #21751).
782 * Fixed check on http_proxy (Bug #21795).
783 * Added download speed indicator.
785 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
787 apt (0.0.7) experimental; urgency=low
789 * Remove libdeity and apt from package for now, since only apt-get and
790 apt-cache are actually useful right now.
791 * Clean up handling of package installation errors.
792 * Added timeout to http transfers (#21269)
793 * Updated setup for dselect/apt method.
795 * Long options (added in 0.0.6)
797 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
799 apt (0.0.6) experimental; urgency=low
802 * Revamped download status display.
803 * Call apt-get clean after successful install in dselect.
804 * Added "apt-get clean" which deletes package files from /var/cache/apt
806 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
808 apt (0.0.5) experimental; urgency=low
810 * Ignore signals while dpkg is running so we don't leave dpkg running in
811 the background (#20804)
812 * Check Packages as well as Packages.gz for file URIs (#20784)
813 * Spelling cleanup (#20800)
814 * Added -m option to permit upgrade to go on in the case of a bad mirror.
815 This option may result in incomplete upgrades when used with -f.
817 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
819 apt (0.0.4) experimental; urgency=low
822 * Various documentation updates and cleanup.
823 * Added '-f' option to apt-get attempt to fix broken dependancies.
825 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
827 apt (0.0.3) experimental; urgency=low
829 * Added a shlibs.local file to prevent apt from depending on itself.
830 * Updates to how apt-get handles bad states in installed packages.
831 * Updated rules to make sure build works from a freshly checked out source
832 archive. Building from CVS needs libtool/automake/autoconf, builds from
833 the distributed source package should have no such dependancy.
835 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
837 apt (0.0.2) unstable; urgency=low
839 * Updates to apt-get and http binding for dselect method (apt).
840 * Updating version number from 0.0.1, which was released only on IRC.
842 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
844 apt (0.0.1) unstable; urgency=low
848 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500