2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
6 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
7 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
8 export DEB_HOST_MULTIARCH ?
= $(shell dpkg-architecture
-qDEB_HOST_MULTIARCH
)
10 # FOR AUTOCONF 2.52 AND NEWER ONLY
11 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
12 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
14 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
18 -include build
/environment.mak
20 ifneq (,$(shell which dpkg-buildflags
))
21 export CXXFLAGS
= $(shell dpkg-buildflags
--get CXXFLAGS
)
22 export LDFLAGS
= $(shell dpkg-buildflags
--get LDFLAGS
)
23 export CPPFLAGS
= $(shell dpkg-buildflags
--get CPPFLAGS
)
25 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
26 export CXXFLAGS
= -O0
-g
-Wall
28 export CXXFLAGS
= -O2
-g
-Wall
36 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
--preserve-envvar CCACHE_DIR
-us
-uc
$(DEB_BUILD_PROG_OPTS
)
38 # Determine the build directory to use
41 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
43 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
--machine
) $(BASE
)/build
45 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
46 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
47 override BLD
:= $(BUILDX
)
49 ifeq ($(words $(BLD
)),0)
50 override BLD
:= .
/build
53 # APT Programs in apt-utils
54 APT_UTILS
=ftparchive sortpkgs extracttemplates internal-solver
56 # Uncomment this to turn on verbose mode.
59 # Find the libapt-pkg major version for use in other control files
60 include buildlib
/libversion.mak
62 # Determine which library package names to use
63 LIBAPT_PKG
=libapt-pkg
$(LIBAPTPKG_MAJOR
)
64 LIBAPT_INST
=libapt-inst
$(LIBAPTINST_MAJOR
)
66 # do not fail as we are just experimenting with symbol files for now
67 export DPKG_GENSYMBOLS_CHECK_LEVEL
=0
69 build
: build
/build-stamp
70 build-doc
: build
/build-doc-stamp
72 # Note that this is unconditionally done first as part of loading environment.mak
73 # The true is needed to force make to reload environment.mak after running
74 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
75 build
/environment.mak
: build
/configure-stamp
78 configure
: configure.in
79 build
/configure-stamp
: configure
82 cp COPYING debian
/copyright
83 cd build
&& CXXFLAGS
="$(CXXFLAGS)" LDFLAGS
="$(LDFLAGS)" CPPFLAGS
="$(CPPFLAGS)" ..
/configure
$(confflags
)
86 build
/build-stamp
: build
/configure-stamp
87 # Add here commands to compile the package.
89 # compat symlink for the locale split
90 mkdir
-p build
/usr
/share
91 cd build
/usr
/share
&& ln
-f
-s ..
/..
/locale .
92 # compile and run tests
93 ifeq (,$(findstring nocheck
, $(DEB_BUILD_OPTIONS
)))
96 @echo
"Tests DISABLED"
100 build
/build-doc-stamp
: build
/configure-stamp
101 # Add here commands to compile the package.
108 [ ! -f Makefile
] ||
$(MAKE
) clean distclean
110 rm -f debian
/$(LIBAPT_PKG
).
install debian
/$(LIBAPT_INST
).
install \
111 debian
/libapt-pkg-dev.
install
113 debian
/%.
install: debian
/%.
install.in
114 sed
's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
116 binary-indep
: apt-doc libapt-pkg-doc
117 # Build architecture-independent files here.
118 libapt-pkg-doc
: build-doc
124 # libapt-pkg-doc install
126 dh_installdocs
-p
$@
$(BLD
)/docs
/design
* \
127 $(BLD
)/docs
/dpkg-tech
* \
129 $(BLD
)/docs
/method
* \
130 doc
/libapt-pkg2_to_3.txt \
132 $(BLD
)/doc
/doxygen
/html
133 dh_installexamples
-p
$@
135 dh_installchangelogs
-p
$@
152 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text \
153 $(BLD
)/docs
/guide
*.html \
154 $(BLD
)/docs
/offline
*.text \
155 $(BLD
)/docs
/offline
*.html
156 dh_installchangelogs
-p
$@
166 # Build architecture-dependent files here.
168 binary-arch
: $(LIBAPT_PKG
) $(LIBAPT_INST
) apt libapt-pkg-dev apt-utils apt-transport-https
169 apt_MANPAGES
= apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
178 cp debian
/apt.conf.autoremove debian
/$@
/etc
/apt
/apt.conf.d
/01autoremove
180 # make rosetta happy and remove pot files in po/ (but leave stuff
181 # in po/domains/* untouched) and cp *.po into each domain dir
185 dh_install
-p
$@
--sourcedir
=$(BLD
)
187 # Remove the bits that are in apt-utils
188 rm $(addprefix debian
/$@
/usr
/bin
/apt-
,$(APT_UTILS
) dump-solver
)
190 # https has its own package
191 rm debian
/$@
/usr
/lib
/apt
/methods
/https
193 # move the mirror failure script in place
194 #mv debian/$@/usr/bin/apt-report-mirror-failure \
195 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
199 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
200 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/%.
[158],$(apt_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt_MANPAGES
)))
203 dh_installchangelogs
-p
$@
204 dh_installlogrotate
-p
$@
214 libapt-pkg-dev
: build debian
/libapt-pkg-dev.
install
220 # libapt-pkg-dev install
222 dh_install
-p
$@
--sourcedir
=$(BLD
)
224 dh_installchangelogs
-p
$@
229 dh_gencontrol
-p
$@
-- -Vlibapt-pkg-name
=$(LIBAPT_PKG
) -Vlibapt-inst-name
=$(LIBAPT_INST
)
233 apt-utils_MANPAGES
= apt-sortpkgs apt-ftparchive apt-extracttemplates
240 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
241 cp
$(BLD
)/bin
/apt-dump-solver debian
/$@
/usr
/lib
/apt
/solvers
/dump
243 dh_install
-p
$@
--sourcedir
=$(BLD
)
246 dh_installexamples
-p
$@
248 # Install the man pages..
249 dh_installman
-p
$@
$(wildcard $(patsubst %,doc
/%.
[158],$(apt-utils_MANPAGES
)) $(patsubst %,doc
/*/%.
*.
[158],$(apt-utils_MANPAGES
)))
251 dh_installchangelogs
-p
$@
262 $(LIBAPT_PKG
): build debian
/$(LIBAPT_PKG
).
install
268 dh_install
-p
$@
--sourcedir
=$(BLD
)
270 dh_installchangelogs
-p
$@
281 $(LIBAPT_INST
): build debian
/$(LIBAPT_INST
).
install
287 dh_install
-p
$@
--sourcedir
=$(BLD
)
289 dh_installchangelogs
-p
$@
300 apt-transport-https
: build libapt-pkg-dev
306 dh_install
-p
$@
--sourcedir
=$(BLD
)
307 dh_installdocs
-p
$@ debian
/apt-transport-https.README
308 dh_installexamples
-p
$@
310 # Install the man pages..
313 dh_installchangelogs
-p
$@
327 -find .
-name Makefile.in
-print0 | xargs
--null
--no-run-if-empty
-- rm -f
328 find
-name ChangeLog | xargs
rm -f
331 binary
: binary-indep binary-arch
332 .PHONY
: build
clean binary-indep binary-arch binary