]> git.saurik.com Git - apt.git/blob - debian/rules
* build debian and ubuntu package from the same source
[apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
18 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19
20 # apt can be build from the same source on debian and ubuntu
21 DIST = $(shell lsb_release -i -s)
22
23 # FOR AUTOCONF 2.52 AND NEWER ONLY
24 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
25 confflags += --build $(DEB_HOST_GNU_TYPE)
26 else
27 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
28 endif
29
30 # See below
31 -include build/environment.mak
32
33 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
34 export CXXFLAGS = -O0 -g -Wall
35 else
36 export CXXFLAGS = -O2 -g -Wall
37 endif
38
39 # Default rule
40 build:
41
42 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
43 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
44 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
45 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
46
47 # Determine the build directory to use
48 BASE=.
49 ifdef BUILD
50 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
51 else
52 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
53 endif
54 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
55 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
56 override BLD := $(BUILDX)
57
58 ifeq ($(words $(BLD)),0)
59 override BLD := ./build
60 endif
61
62 # Rebuild configure.in to have the correct version from the change log
63 ifneq ($(APT_DEBVER),$(APT_CONFVER))
64 ifneq ($(APT_DEBVER),)
65 .PHONY: configure.in
66 configure.in:
67 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
68 endif
69 else
70 configure.in:
71 endif
72
73 # APT Programs in apt-utils
74 APT_UTILS=ftparchive sortpkgs extracttemplates
75
76 # Uncomment this to turn on verbose mode.
77 #export DH_VERBOSE=1
78
79 # Find the libapt-pkg major version for use in other control files
80 export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
81 export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
82
83 # Determine which package we should provide in the control files
84 LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
85 LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
86
87 debian/shlibs.local: apt-pkg/makefile
88 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
89 # one for the rest of the packages. This ensures that each package gets
90 # the right overrides..
91 rm -rf $@ $@.apt $@.apt-utils
92 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
93
94 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
95 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
96
97 echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
98 echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
99
100 build: build/build-stamp
101 build-doc: build/build-doc-stamp
102
103 # Note that this is unconditionally done first as part of loading environment.mak
104 # The true is needed to force make to reload environment.mak after running
105 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
106 build/environment.mak: build/configure-stamp
107 @true
108
109 configure: configure.in
110 build/configure-stamp: configure
111 dh_testdir
112 -mkdir build
113 cp COPYING debian/copyright
114 cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
115 touch $@
116
117 build/build-stamp: build/configure-stamp patch
118 # Add here commands to compile the package.
119 $(MAKE) binary
120 touch $@
121
122 build/build-doc-stamp: build/configure-stamp
123 # Add here commands to compile the package.
124 $(MAKE) doc
125 touch $@
126
127 clean: unpatch
128 dh_testdir
129 # dh_testroot
130 -$(MAKE) clean
131 -$(MAKE) distclean
132
133 rm -rf build
134
135 # Add here commands to clean up after the build process.
136 dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
137
138 binary-indep: apt-doc libapt-pkg-doc
139 # Build architecture-independent files here.
140 libapt-pkg-doc: build-doc debian/shlibs.local
141 dh_testdir -p$@
142 dh_testroot -p$@
143 dh_clean -p$@ -k
144 dh_installdirs -p$@
145 #
146 # libapt-pkg-doc install
147 #
148 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
149 $(BLD)/docs/files* $(BLD)/docs/method* \
150 doc/libapt-pkg2_to_3.txt doc/style.txt
151 dh_installexamples -p$@
152 # dh_installmenu -p$@
153 # dh_installinit -p$@
154 # dh_installcron -p$@
155 # dh_installman -p$@
156
157 # dh_undocumented -p$@
158 dh_installchangelogs -p$@
159 dh_strip -p$@
160 dh_compress -p$@
161 dh_fixperms -p$@
162 # dh_suidregister -p$@
163 dh_installdeb -p$@
164 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
165 dh_md5sums -p$@
166 dh_builddeb -p$@
167
168 apt-doc: build-doc
169 dh_testdir -p$@
170 dh_testroot -p$@
171 dh_clean -p$@ -k
172 #
173 # apt-doc install
174 #
175 # Copy the guides
176 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
177 $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
178 dh_installchangelogs -p$@
179 dh_compress -p$@
180 dh_fixperms -p$@
181 dh_installdeb -p$@
182 dh_gencontrol -p$@
183 dh_md5sums -p$@
184 dh_builddeb -p$@
185
186
187
188 # Build architecture-dependent files here.
189
190 binary-arch: apt libapt-pkg-dev apt-utils
191 apt: build debian/shlibs.local
192 dh_testdir -p$@
193 dh_testroot -p$@
194 dh_clean -p$@ -k
195 dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
196 #
197 # apt install
198 #
199 cp $(BLD)/bin/apt-* debian/$@/usr/bin/
200
201 # Remove the bits that are in apt-utils
202 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
203
204 # install the shared libs
205 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
206 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
207
208 cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
209
210 cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
211 cp -r $(BLD)/locale debian/$@/usr/share/
212
213 cp debian/bugscript debian/$@/usr/share/bug/apt/script
214
215 cp share/debian-archive.gpg debian/$@/usr/share/$@
216
217 # head -n 500 ChangeLog > debian/ChangeLog
218
219 dh_installexamples -p$@ $(BLD)/docs/examples/*
220 dh_installman -p$@
221 dh_installcron -p$@
222 dh_installdocs -p$@
223 dh_installchangelogs -p$@
224 dh_strip -p$@
225 dh_compress -p$@
226 dh_fixperms -p$@
227 dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
228 dh_installdeb -p$@
229 dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
230 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
231 dh_md5sums -p$@
232 dh_builddeb -p$@
233
234 libapt-pkg-dev: build debian/shlibs.local
235 dh_testdir -p$@
236 dh_testroot -p$@
237 dh_clean -p$@ -k
238 dh_installdirs -p$@
239 #
240 # libapt-pkg-dev install
241 #
242 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
243 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
244 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
245 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
246
247 dh_installdocs -p$@
248 # dh_installmenu -p$@
249 # dh_installinit -p$@
250 # dh_installcron -p$@
251 # dh_installman -p$@
252
253 dh_installchangelogs -p$@
254 dh_strip -p$@
255 dh_compress -p$@
256 dh_fixperms -p$@
257 # dh_suidregister -p$@
258 dh_installdeb -p$@
259 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
260 dh_md5sums -p$@
261 dh_builddeb -p$@
262
263 apt-utils: build debian/shlibs.local
264 dh_testdir -p$@
265 dh_testroot -p$@
266 dh_clean -p$@ -k
267 dh_installdirs -p$@
268
269 # install the shared libs
270 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
271 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
272
273 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
274 dh_installdocs -p$@
275
276 # Install the man pages..
277 dh_installman -p$@
278
279 dh_installchangelogs -p$@
280 dh_strip -p$@
281 dh_compress -p$@
282 dh_fixperms -p$@
283 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
284 dh_installdeb -p$@
285 dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
286 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
287 dh_md5sums -p$@
288 dh_builddeb -p$@
289
290 source diff:
291 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
292
293 # Update from CVS
294 l33ch: really-clean
295 cvs update
296 buildlib/mkChangeLog
297
298 # Update from CVS and then configure for build
299 super-l33ch: l33ch Makefile.in
300
301 configure:
302 $(MAKE) configure
303
304 l33ch-stamp: super-l33ch
305 touch $@
306
307 really-clean: clean
308 -find -name Makefile.in -print0 | xargs -0r rm -f
309 find -name ChangeLog | xargs rm -f
310 rm -f l33ch-stamp
311
312 binary: binary-indep binary-arch
313 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
314
315
316 # Done by the uploader.
317 #cvs update..
318 #edit debian/changelog
319 # configure.in has the version automatically updated now.
320 # edit configure.in
321 # debian/rules cvs-build
322
323 CVS_BUILDDIR=apt-$(APT_DEBVER)
324 CVS_ROOT=$(shell cat CVS/Root)
325 CVS_MODULE=$(shell cat CVS/Repository)
326 cvs-build:
327 rm -rf debian/cvs-build
328 mkdir -p debian/cvs-build
329 (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
330 $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
331 (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
332
333 cvs-mkul:
334 -mkdir -p ../upload-$(APT_DEBVER)
335 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
336
337 patch: patch-stamp
338 patch-stamp:
339 cp debian/patches/00list.$(DIST) debian/patches/00list
340 dpatch apply-all
341 touch patch-stamp
342
343 unpatch:
344 cp debian/patches/00list.$(DIST) debian/patches/00list
345 dpatch deapply-all
346 rm -rf patch-stamp debian/patched
347
348 arch-build:
349 rm -rf debian/arch-build
350 mkdir -p debian/arch-build/apt-$(APT_DEBVER)
351 baz inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
352 $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
353 (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))