2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.65 2004/04/30 04:37:47 mdz Exp $
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
17 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
18 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
20 # FOR AUTOCONF 2.52 AND NEWER ONLY
21 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
22 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
24 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
28 -include build
/environment.mak
30 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
31 export CXXFLAGS
= -O0
-g
-Wall
33 export CXXFLAGS
= -O2
-g
-Wall
39 DEB_BUILD_PROG
:=debuild
--preserve-envvar PATH
--preserve-envvar CCACHE_DIR
-us
-uc
40 APT_DEBVER
=$(shell dpkg-parsechangelog |sed
-n
-e
'/^Version:/s/^Version: //p')
41 APT_CONFVER
=$(shell sed
-n
-e
's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in
)
43 # Determine the build directory to use
46 BUILD_POSSIBLE
:= $(BUILD
) $(BASE
)/$(BUILD
)
48 BUILD_POSSIBLE
:= $(BASE
) $(BASE
)/build-
$(shell uname
-m
) $(BASE
)/build
50 BUILDX
:= $(foreach i
,$(BUILD_POSSIBLE
),$(wildcard $(i
)/environment.mak
*))
51 BUILDX
:= $(patsubst %/,%,$(firstword $(dir $(BUILDX
))))
52 override BLD
:= $(BUILDX
)
54 ifeq ($(words $(BLD
)),0)
55 override BLD
:= .
/build
58 # Rebuild configure.in to have the correct version from the change log
59 ifneq ($(APT_DEBVER
),$(APT_CONFVER
))
62 sed
-e
's/$(APT_CONFVER)/$(APT_DEBVER)/' $@
> $@.
$$$$ && mv
$@.
$$$$ $@
67 # APT Programs in apt-utils
68 APT_UTILS
=ftparchive sortpkgs extracttemplates
70 # Uncomment this to turn on verbose mode.
73 # Find the libapt-pkg major version for use in other control files
74 export LIBAPTPKG_MAJOR
:=$(shell egrep
'^MAJOR=' apt-pkg
/makefile |cut
-d
'=' -f
2)
75 export LIBAPTINST_MAJOR
:=$(shell egrep
'^MAJOR=' apt-inst
/makefile |cut
-d
'=' -f
2)
77 # Determine which package we should provide in the control files
78 LIBAPTPKG_PROVIDE
=libapt-pkg
$(GLIBC_VER
)$(LIBSTDCPP_VER
)-$(LIBAPTPKG_MAJOR
)
79 LIBAPTINST_PROVIDE
=libapt-inst
$(GLIBC_VER
)$(LIBSTDCPP_VER
)-$(LIBAPTINST_MAJOR
)
81 debian
/shlibs.local
: apt-pkg
/makefile
82 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
83 # one for the rest of the packages. This ensures that each package gets
84 # the right overrides..
85 rm -rf
$@
$@.apt
$@.apt-utils
86 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
88 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
89 echo
"libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
91 echo
"libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
92 echo
"libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
94 build
: build
/build-stamp
95 build-doc
: build
/build-doc-stamp
97 # Note that this is unconditionally done first as part of loading environment.mak
98 # The true is needed to force make to reload environment.mak after running
99 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
100 build
/environment.mak
: build
/configure-stamp
103 configure
: configure.in
104 build
/configure-stamp
: configure
107 cp COPYING debian
/copyright
108 cd build
&& CXXFLAGS
="$(confcxxflags)" ..
/configure
$(confflags
)
111 build
/build-stamp
: build
/configure-stamp
112 # Add here commands to compile the package.
116 build
/build-doc-stamp
: build
/configure-stamp
117 # Add here commands to compile the package.
129 # Add here commands to clean up after the build process.
130 dh_clean debian
/copyright debian
/shlibs.local debian
/shlibs.local.apt debian
/shlibs.local.apt-utils
132 binary-indep
: apt-doc libapt-pkg-doc
133 # Build architecture-independent files here.
134 libapt-pkg-doc
: build-doc debian
/shlibs.local
140 # libapt-pkg-doc install
142 dh_installdocs
-p
$@
$(BLD
)/docs
/cache
* $(BLD
)/docs
/design
* $(BLD
)/docs
/dpkg-tech
* \
143 $(BLD
)/docs
/files
* $(BLD
)/docs
/method
* \
144 doc
/libapt-pkg2_to_3.txt doc
/style.txt
145 dh_installexamples
-p
$@
146 # dh_installmenu -p$@
147 # dh_installinit -p$@
148 # dh_installcron -p$@
151 # dh_undocumented -p$@
152 dh_installchangelogs
-p
$@
156 # dh_suidregister -p$@
158 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
)
170 dh_installdocs
-p
$@
$(BLD
)/docs
/guide
*.text
$(BLD
)/docs
/guide
*.html \
171 $(BLD
)/docs
/offline.text
$(BLD
)/docs
/offline.html
172 dh_installchangelogs
-p
$@
182 # Build architecture-dependent files here.
184 binary-arch
: apt libapt-pkg-dev apt-utils
185 apt
: build debian
/shlibs.local
189 dh_installdirs
-p
$@
/usr
/share
/bug
/$@
193 cp
$(BLD
)/bin
/apt-
* debian
/apt
/usr
/bin
/
195 # Remove the bits that are in apt-utils
196 rm $(addprefix debian
/apt
/usr
/bin
/apt-
,$(APT_UTILS
))
198 # install the shared libs
199 find
$(BLD
)/bin
/ -type f
-name
"libapt-pkg*.so.*" -exec cp
-a
"{}" debian
/apt
/usr
/lib
/ \
;
200 find
$(BLD
)/bin
/ -type l
-name
"libapt-pkg*.so.*" -exec cp
-a
"{}" debian
/apt
/usr
/lib
/ \
;
202 cp
$(BLD
)/bin
/methods
/* debian
/apt
/usr
/lib
/apt
/methods
/
204 cp
$(BLD
)/scripts
/dselect
/* debian
/apt
/usr
/lib
/dpkg
/methods
/apt
/
205 cp
-r
$(BLD
)/locale debian
/apt
/usr
/share
/
207 cp debian
/bugscript debian
/apt
/usr
/share
/bug
/apt
/script
209 # head -n 500 ChangeLog > debian/ChangeLog
211 dh_installexamples
-p
$@
$(BLD
)/docs
/examples
/*
215 dh_installchangelogs
-p
$@
219 dh_makeshlibs
-p
$@
-m
$(LIBAPTPKG_MAJOR
) -V
'$(LIBAPTPKG_PROVIDE)'
221 dh_shlibdeps
-p
$@
-l
`pwd`/debian
/apt
/usr
/lib
-- -Ldebian
/shlibs.local.apt
222 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
)
226 libapt-pkg-dev
: build debian
/shlibs.local
232 # libapt-pkg-dev install
234 cp
-a
$(BLD
)/bin
/libapt-pkg
*.so debian
/libapt-pkg-dev
/usr
/lib
/
235 cp
-a
$(BLD
)/bin
/libapt-inst
*.so debian
/libapt-pkg-dev
/usr
/lib
/
236 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
237 cp
$(BLD
)/include/apt-pkg
/*.h debian
/libapt-pkg-dev
/usr
/include/apt-pkg
/
240 # dh_installmenu -p$@
241 # dh_installinit -p$@
242 # dh_installcron -p$@
245 dh_installchangelogs
-p
$@
249 # dh_suidregister -p$@
251 dh_gencontrol
-p
$@
-u
-Vlibapt-pkg
:provides
=$(LIBAPTPKG_PROVIDE
) -Vlibapt-inst
:provides
=$(LIBAPTINST_PROVIDE
)
255 apt-utils
: build debian
/shlibs.local
261 # install the shared libs
262 find
$(BLD
)/bin
/ -type f
-name
"libapt-inst*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
263 find
$(BLD
)/bin
/ -type l
-name
"libapt-inst*.so.*" -exec cp
-a
"{}" debian
/$@
/usr
/lib
/ \
;
265 cp
$(addprefix $(BLD
)/bin
/apt-
,$(APT_UTILS
)) debian
/$@
/usr
/bin
/
268 # Install the man pages..
271 dh_installchangelogs
-p
$@
275 dh_makeshlibs
-m
$(LIBAPTINST_MAJOR
) -V
'$(LIBAPTINST_PROVIDE)' -p
$@
277 dh_shlibdeps
-p
$@
-l
`pwd`/debian
/apt
/usr
/lib
:`pwd`/debian
/$@
/usr
/lib
-- -Ldebian
/shlibs.local.apt-utils
278 dh_gencontrol
-p
$@
-u
-Vlibapt-inst
:provides
=$(LIBAPTINST_PROVIDE
)
283 @echo
>&2 'source and diff are obsolete - use dpkg-source -b'; false
290 # Update from CVS and then configure for build
291 super-l33ch
: l33ch Makefile.in
296 l33ch-stamp
: super-l33ch
300 -find
-name Makefile.in
-print0 | xargs
-0r
rm -f
301 find
-name ChangeLog | xargs
rm -f
304 binary
: binary-indep binary-arch
305 .PHONY
: build
clean binary-indep binary-arch binary debian
/shlibs.local
308 # Done by the uploader.
310 #edit debian/changelog
311 # configure.in has the version automatically updated now.
313 # debian/rules cvs-build
316 rm -rf debian
/cvs-build
320 tar c
--exclude CVS
--exclude cvs-build
--exclude
'.#*' . |\
321 (mkdir
-p debian
/cvs-build
/apt-
$(APT_DEBVER
);cd debian
/cvs-build
/apt-
$(APT_DEBVER
);tar x
)
322 (cd debian
/cvs-build
/apt-
$(APT_DEBVER
);$(DEB_BUILD_PROG
))
325 -mkdir
-p ..
/upload-
$(APT_DEBVER
)
326 cp
`find debian/cvs-build -maxdepth 1 -type f` ..
/upload-
$(APT_DEBVER
)